- Home
- RFCs by Subject
- naming
naming
Naming and name resolution in general, not specific to one system
Within this page
naming subjects:
- DNS441 RFCs
- DANE11 RFCs
- DNS privacy20 RFCs
- DoH7 RFCs
- DoQ7 RFCs
- DoT2 RFCs
- oblivious DNS1 RFC
- DNS-SD9 RFCs
- DNS update3 RFCs
- DNS649 RFCs
- DNSSEC86 RFCs
- EDNS8 RFCs
- mDNS11 RFCs
- special-use domain names5 RFCs
- .onion2 RFCs
- domain registration116 RFCs
- ENUM33 RFCs
- handle system3 RFCs
- hostnames25 RFCs
- IDN24 RFCs
- service discovery9 RFCs
- SLP17 RFCs
- tel URI13 RFCs
- UUID5 RFCs
naming RFCs (29)
RFC 9586: IMAP Extension for Using and Returning Unique Identifiers (UIDs) Only
Experimental- A. Melnikov
- A. P. Achuthan
- V. Nagulakonda
- A. Singh
- L. Alves
- May 2024
- IETF publication
- Applications and Real-Time Area
Abstract
The UIDONLY extension to the Internet Message Access Protocol (RFCs 3501 and 9051) allows clients to enable a mode in which information about mailbox changes is returned using only Unique Identifiers (UIDs). Message numbers are not returned in responses and cannot be used in requests once this extension is enabled. This helps both clients and servers to reduce resource usage required to maintain a map between message numbers and UIDs.
This document defines an experimental IMAP extension.
Abstract
The UIDONLY extension to the Internet Message Access Protocol (RFCs 3501 and 9051) allows clients to enable a mode in which information about mailbox changes is returned using only Unique Identifiers (UIDs). Message numbers are not returned in responses and cannot be used in requests once this extension is enabled. This helps both clients and servers to reduce resource usage required to maintain a map between message numbers and UIDs.
This document defines an experimental IMAP extension.
RFC 9236: Architectural Considerations of Information-Centric Networking (ICN) Using a Name Resolution Service
Informational- J. Hong
- T. You
- V. Kafle
- April 2022
- IRTF publication
Abstract
This document describes architectural considerations and implications related to the use of a Name Resolution Service (NRS) in Information-Centric Networking (ICN). It explains how the ICN architecture can change when an NRS is utilized and how its use influences the ICN routing system. This document is a product of the Information-Centric Networking Research Group (ICNRG).
Abstract
This document describes architectural considerations and implications related to the use of a Name Resolution Service (NRS) in Information-Centric Networking (ICN). It explains how the ICN architecture can change when an NRS is utilized and how its use influences the ICN routing system. This document is a product of the Information-Centric Networking Research Group (ICNRG).
RFC 9138: Design Considerations for Name Resolution Service in Information-Centric Networking (ICN)
Informational- J. Hong
- T. You
- L. Dong
- C. Westphal
- B. Ohlman
- December 2021
- IRTF publication
Abstract
This document provides the functionalities and design considerations for a Name Resolution Service (NRS) in Information-Centric Networking (ICN). The purpose of an NRS in ICN is to translate an object name into some other information such as a locator, another name, etc. in order to forward the object request. This document is a product of the Information-Centric Networking Research Group (ICNRG).
Abstract
This document provides the functionalities and design considerations for a Name Resolution Service (NRS) in Information-Centric Networking (ICN). The purpose of an NRS in ICN is to translate an object name into some other information such as a locator, another name, etc. in order to forward the object request. This document is a product of the Information-Centric Networking Research Group (ICNRG).
RFC 8917: The LoST-Validation Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag
Proposed Standard- R. Gellens
- B. Rosen
- October 2020
- IETF publication
- General Area
Abstract
This document adds the 'LoST-Validation' service tag to the Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag IANA registry. This tag can appear in a Naming Authority Pointer (NAPTR) Domain Name System (DNS) record to assist clients of the Location-to-Service Translation (LoST) Protocol in identifying LoST servers designated for location validation. This tag and the information about its use update RFC 5222, which enables the explicit discovery of a server that supports location validation.
Abstract
This document adds the 'LoST-Validation' service tag to the Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service Tag IANA registry. This tag can appear in a Naming Authority Pointer (NAPTR) Domain Name System (DNS) record to assist clients of the Location-to-Service Translation (LoST) Protocol in identifying LoST servers designated for location validation. This tag and the information about its use update RFC 5222, which enables the explicit discovery of a server that supports location validation.
RFC 7631: TLV Naming in the Mobile Ad Hoc Network (MANET) Generalized Packet/Message Format
Proposed Standard- C. Dearlove
- T. Clausen
- September 2015
- IETF publication
- Routing Area
Abstract
This document reorganizes the naming of already-allocated TLV (type- length-value) types and type extensions in the "Mobile Ad hoc NETwork (MANET) Parameters" registries defined by RFC 5444 to use names appropriately. It has no consequences in terms of any protocol implementation.
This document also updates the Expert Review guidelines in RFC 5444, so as to establish a policy for consistent naming of future TLV type and type extension allocations. It makes no other changes to RFC 5444.
Abstract
This document reorganizes the naming of already-allocated TLV (type- length-value) types and type extensions in the "Mobile Ad hoc NETwork (MANET) Parameters" registries defined by RFC 5444 to use names appropriately. It has no consequences in terms of any protocol implementation.
This document also updates the Expert Review guidelines in RFC 5444, so as to establish a policy for consistent naming of future TLV type and type extension allocations. It makes no other changes to RFC 5444.
RFC 6920: Naming Things with Hashes
Proposed Standard- S. Farrell
- D. Kutscher
- C. Dannewitz
- B. Ohlman
- A. Keranen
- P. Hallam-Baker
- April 2013
- IETF publication
- General Area
Abstract
This document defines a set of ways to identify a thing (a digital object in this case) using the output from a hash function. It specifies a new URI scheme for this purpose, a way to map these to HTTP URLs, and binary and human-speakable formats for these names. The various formats are designed to support, but not require, a strong link to the referenced object, such that the referenced object may be authenticated to the same degree as the reference to it. The reason for this work is to standardise current uses of hash outputs in URLs and to support new information-centric applications and other uses of hash outputs in protocols.
Abstract
This document defines a set of ways to identify a thing (a digital object in this case) using the output from a hash function. It specifies a new URI scheme for this purpose, a way to map these to HTTP URLs, and binary and human-speakable formats for these names. The various formats are designed to support, but not require, a strong link to the referenced object, such that the referenced object may be authenticated to the same degree as the reference to it. The reason for this work is to standardise current uses of hash outputs in URLs and to support new information-centric applications and other uses of hash outputs in protocols.
RFC 6680: Generic Security Service Application Programming Interface (GSS-API) Naming Extensions
Proposed Standard- N. Williams
- L. Johansson
- S. Hartman
- S. Josefsson
- August 2012
- IETF publication
- Security Area
Abstract
The Generic Security Service Application Programming Interface (GSS-API) provides a simple naming architecture that supports name-based authorization. This document introduces new APIs that extend the GSS-API naming model to support name attribute transfer between GSS-API peers.
Abstract
The Generic Security Service Application Programming Interface (GSS-API) provides a simple naming architecture that supports name-based authorization. This document introduces new APIs that extend the GSS-API naming model to support name attribute transfer between GSS-API peers.
RFC 6408: Diameter Straightforward-Naming Authority Pointer (S-NAPTR) Usage
Proposed Standard- M. Jones
- J. Korhonen
- L. Morand
- November 2011
- IETF publication
- Operations and Management Area
Abstract
The Diameter base protocol specifies mechanisms whereby a given realm may advertise Diameter nodes and the supported transport protocol. However, these mechanisms do not reveal the Diameter applications that each node supports. A peer outside the realm would have to perform a Diameter capability exchange with every node until it discovers one that supports the required application. This document updates RFC 3588, "Diameter Base Protocol", and describes an improvement using an extended format for the Straightforward-Naming Authority Pointer (S-NAPTR) application service tag that allows for discovery of the supported applications without doing Diameter capability exchange beforehand. [STANDARDS-TRACK]
Abstract
The Diameter base protocol specifies mechanisms whereby a given realm may advertise Diameter nodes and the supported transport protocol. However, these mechanisms do not reveal the Diameter applications that each node supports. A peer outside the realm would have to perform a Diameter capability exchange with every node until it discovers one that supports the required application. This document updates RFC 3588, "Diameter Base Protocol", and describes an improvement using an extended format for the Straightforward-Naming Authority Pointer (S-NAPTR) application service tag that allows for discovery of the supported applications without doing Diameter capability exchange beforehand. [STANDARDS-TRACK]
RFC 6111: Additional Kerberos Naming Constraints
Proposed Standard- L. Zhu
- April 2011
- IETF publication
- Security Area
Abstract
This document defines new naming constraints for well-known Kerberos principal names and well-known Kerberos realm names. [STANDARDS- TRACK]
Abstract
This document defines new naming constraints for well-known Kerberos principal names and well-known Kerberos realm names. [STANDARDS- TRACK]
RFC 4768: Desired Enhancements to Generic Security Services Application Program Interface (GSS-API) Version 3 Naming
Informational- S. Hartman
- December 2006
- IETF publication
- Security Area
Abstract
The Generic Security Services API (GSS-API) provides a naming architecture that supports name-based authorization. GSS-API authenticates two named parties to each other. Names can be stored on access control lists (ACLs) to make authorization decisions. Advances in security mechanisms and the way implementers wish to use GSS-API require this model to be extended for the next version of GSS-API. As people move within an organization or change their names, the name authenticated by GSS-API may change. Using some sort of constant identifier would make ACLs more stable. Some mechanisms, such as public-key mechanisms, do not have a single name to be used across all environments. Other mechanisms, such as Kerberos, may include group membership or role information as part of authentication. This document motivates extensions to GSS-API naming and describes the extensions under discussion. This memo provides information for the Internet community.
Abstract
The Generic Security Services API (GSS-API) provides a naming architecture that supports name-based authorization. GSS-API authenticates two named parties to each other. Names can be stored on access control lists (ACLs) to make authorization decisions. Advances in security mechanisms and the way implementers wish to use GSS-API require this model to be extended for the next version of GSS-API. As people move within an organization or change their names, the name authenticated by GSS-API may change. Using some sort of constant identifier would make ACLs more stable. Some mechanisms, such as public-key mechanisms, do not have a single name to be used across all environments. Other mechanisms, such as Kerberos, may include group membership or role information as part of authentication. This document motivates extensions to GSS-API naming and describes the extensions under discussion. This memo provides information for the Internet community.
RFC 3980: T11 Network Address Authority (NAA) Naming Format for iSCSI Node Names
Proposed Standard- M. Krueger
- M. Chadalapaka
- R. Elliott
- February 2005
- IETF publication
- Transport Area
Abstract
Internet Small Computer Systems Interface (iSCSI) is a SCSI transport protocol that maps the SCSI family of protocols onto TCP/IP. This document defines an additional iSCSI node name type format to enable use of the "Network Address Authority" (NAA) worldwide naming format defined by the InterNational Committee for Information Technology Standards (INCITS) T11 - Fibre Channel (FC) protocols and used by Serial Attached SCSI (SAS). This document updates RFC 3720. [STANDARDS-TRACK]
Obsoleted by RFC 7143
Abstract
Internet Small Computer Systems Interface (iSCSI) is a SCSI transport protocol that maps the SCSI family of protocols onto TCP/IP. This document defines an additional iSCSI node name type format to enable use of the "Network Address Authority" (NAA) worldwide naming format defined by the InterNational Committee for Information Technology Standards (INCITS) T11 - Fibre Channel (FC) protocols and used by Serial Attached SCSI (SAS). This document updates RFC 3720. [STANDARDS-TRACK]
RFC 3721: Internet Small Computer Systems Interface (iSCSI) Naming and Discovery
Informational- M. Bakke
- J. Hafner
- J. Hufferd
- K. Voruganti
- M. Krueger
- April 2004
- IETF publication
- Transport Area
Abstract
This document provides examples of the Internet Small Computer Systems Interface (iSCSI; or SCSI over TCP) name construction and discussion of discovery of iSCSI resources (targets) by iSCSI initiators. This document complements the iSCSI protocol document. Flexibility is the key guiding principle behind this document. That is, an effort has been made to satisfy the needs of both small isolated environments, as well as large environments requiring secure/scalable solutions. This memo provides information for the Internet community.
Abstract
This document provides examples of the Internet Small Computer Systems Interface (iSCSI; or SCSI over TCP) name construction and discussion of discovery of iSCSI resources (targets) by iSCSI initiators. This document complements the iSCSI protocol document. Flexibility is the key guiding principle behind this document. That is, an effort has been made to satisfy the needs of both small isolated environments, as well as large environments requiring secure/scalable solutions. This memo provides information for the Internet community.
RFC 3367: Common Name Resolution Protocol (CNRP)
Proposed Standard- N. Popp
- M. Mealling
- M. Moseley
- September 2002
- Legacy publication
Abstract
People often refer to things in the real world by a common name or
phrase, e.g., a trade name, company name, or a book title. These
names are sometimes easier for people to remember and type than
URLs. Furthermore, because of the limited syntax of URLs, companies
and individuals are finding that the ones that might be most
reasonable for their resources are being used elsewhere and so are
unavailable. For the purposes of this document, a 'common name' is a
word or a phrase, without imposed syntactic structure, that may be
associated with a resource.
Abstract
People often refer to things in the real world by a common name or
phrase, e.g., a trade name, company name, or a book title. These
names are sometimes easier for people to remember and type than
URLs. Furthermore, because of the limited syntax of URLs, companies
and individuals are finding that the ones that might be most
reasonable for their resources are being used elsewhere and so are
unavailable. For the purposes of this document, a 'common name' is a
word or a phrase, without imposed syntactic structure, that may be
associated with a resource.
RFC 3368: The 'go' URI Scheme for the Common Name Resolution Protocol
Proposed Standard- M. Mealling
- August 2002
- Legacy publication
Abstract
This document defines a URI scheme, 'go:' to be used with the Common
Name Resolution Protocol. Specifically it lays out the syntactic
components and how those components are used by URI Resolution to
find the available transports for a CNRP service. Care should be
taken with several of the URI components because, while they may look
like components found in other URI schemes, they often do not act
like them. The 'go' scheme has more in common with the location
independent 'news' scheme than any other URI scheme.
Abstract
This document defines a URI scheme, 'go:' to be used with the Common
Name Resolution Protocol. Specifically it lays out the syntactic
components and how those components are used by URI Resolution to
find the available transports for a CNRP service. Care should be
taken with several of the URI components because, while they may look
like components found in other URI schemes, they often do not act
like them. The 'go' scheme has more in common with the location
independent 'news' scheme than any other URI scheme.
RFC 2972: Context and Goals for Common Name Resolution
Informational- N. Popp
- M. Mealling
- L. Masinter
- K. Sollins
- October 2000
- Legacy publication
Abstract
This document establishes the context and goals for a Common Name Resolution Protocol. This memo provides information for the Internet community.
Abstract
This document establishes the context and goals for a Common Name Resolution Protocol. This memo provides information for the Internet community.
RFC 2377: Naming Plan for Internet Directory-Enabled Applications
Informational- A. Grimstad
- R. Huber
- S. Sataluri
- M. Wahl
- September 1998
- IETF publication
- Applications Area
Abstract
Application of the conventional X.500 approach to naming has heretofore, in the experience of the authors, proven to be an obstacle to the wide deployment of directory-enabled applications on the Internet. We propose a new directory naming plan that leverages the strengths of the most popular and successful Internet naming schemes for naming objects in a hierarchical directory. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
Abstract
Application of the conventional X.500 approach to naming has heretofore, in the experience of the authors, proven to be an obstacle to the wide deployment of directory-enabled applications on the Internet. We propose a new directory naming plan that leverages the strengths of the most popular and successful Internet naming schemes for naming objects in a hierarchical directory. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
RFC 2276: Architectural Principles of Uniform Resource Name Resolution
Informational- K. Sollins
- January 1998
- IETF publication
- Applications Area
Abstract
This document addresses the issues of the discovery of URN (Uniform Resource Name) resolver services that in turn will directly translate URNs into URLs (Uniform Resource Locators) and URCs (Uniform Resource Characteristics). This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
Abstract
This document addresses the issues of the discovery of URN (Uniform Resource Name) resolver services that in turn will directly translate URNs into URLs (Uniform Resource Locators) and URCs (Uniform Resource Characteristics). This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
RFC 2120: Managing the X.500 Root Naming Context
Experimental- D. Chadwick
- March 1997
- IETF publication
- Applications Area
Abstract
This document describes the use of 1993 ISO X.500 Standard protocols for managing the root context. Whilst the ASN.1 is compatible with that of the X.500 Standard, the actual settings of the parameters are supplementary to that of the X.500 Standard. This memo defines an Experimental Protocol for the Internet community.
Abstract
This document describes the use of 1993 ISO X.500 Standard protocols for managing the root context. Whilst the ASN.1 is compatible with that of the X.500 Standard, the actual settings of the parameters are supplementary to that of the X.500 Standard. This memo defines an Experimental Protocol for the Internet community.
RFC 1617: Naming and Structuring Guidelines for X.500 Directory Pilots
Informational- P. Barker
- S. Kille
- T. Lenggenhager
- May 1994
- Legacy publication
Abstract
This document defines a number of naming and structuring guidelines focused on White Pages usage. Alignment to these guidelines is recommended for directory pilots. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document defines a number of naming and structuring guidelines focused on White Pages usage. Alignment to these guidelines is recommended for directory pilots. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1562: Naming Guidelines for the AARNet X.500 Directory Service
Informational- G. Michaelson
- M. Prior
- December 1993
- Legacy publication
Abstract
This document is an AARNet (Australian Academic and Research Network) Engineering Note (AEN-001). AARNet Engineering Notes are engineering documents of the AARNet Engineering Working Group, and record current or proposed operational practices related to the provision of Internetworking services within Australia, and AARNet in particular. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document is an AARNet (Australian Academic and Research Network) Engineering Note (AEN-001). AARNet Engineering Notes are engineering documents of the AARNet Engineering Working Group, and record current or proposed operational practices related to the provision of Internetworking services within Australia, and AARNet in particular. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1498: On the Naming and Binding of Network Destinations
Informational- J. Saltzer
- August 1993
- Legacy publication
Abstract
This brief paper offers a perspective on the subject of names of destinations in data communication networks. It suggests two ideas: First, it is helpful to distinguish among four different kinds of objects that may be named as the destination of a packet in a network. Second, the operating system concept of binding is a useful way to describe the relations among the four kinds of objects. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
This brief paper offers a perspective on the subject of names of destinations in data communication networks. It suggests two ideas: First, it is helpful to distinguish among four different kinds of objects that may be named as the destination of a packet in a network. Second, the operating system concept of binding is a useful way to describe the relations among the four kinds of objects. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1484: Using the OSI Directory to achieve User Friendly Naming (OSI-DS 24 (v1.2))
Historic- S. Hardcastle-Kille
- July 1993
- IETF publication
- Applications Area
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet standard.
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet standard.
RFC 1439: The Uniqueness of Unique Identifiers
Informational- C. Finseth
- March 1993
- Legacy publication
Abstract
This RFC provides information that may be useful when selecting a method to use for assigning unique identifiers to people. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
This RFC provides information that may be useful when selecting a method to use for assigning unique identifiers to people. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1384: Naming Guidelines for Directory Pilots
Informational- P. Barker
- S.E. Hardcastle-Kille
- January 1993
- IETF publication
- Applications Area
Abstract
This document defines a number of naming guidelines. Alignment to these guidelines is recommended for directory pilots. This memo provides information for the Internet community. It does not specify an Internet standard.
Obsoleted by RFC 1617
Abstract
This document defines a number of naming guidelines. Alignment to these guidelines is recommended for directory pilots. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1255: A Naming Scheme for c=US
Informational- The North American Directory Forum
- September 1991
- Legacy publication
Abstract
This memo documents the NADF's agreement as to how entries are named in the public portions of the North American Directory. This memo provides information for the Internet community. It does not specify an Internet standard.
Obsoleted by RFC 1417
Abstract
This memo documents the NADF's agreement as to how entries are named in the public portions of the North American Directory. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1218: Naming scheme for c=US
Informational- North American Directory Forum
- April 1991
- Legacy publication
Abstract
This RFC is a near-verbatim copy of a document, known as NADF-123, which has been produced by the North American Directory Forum (NADF). As a part of its charter, the NADF must reach agreement as to how entries are named in the public portions of the North American Directory. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
This RFC is a near-verbatim copy of a document, known as NADF-123, which has been produced by the North American Directory Forum (NADF). As a part of its charter, the NADF must reach agreement as to how entries are named in the public portions of the North American Directory. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 819: The Domain Naming Convention for Internet User Applications
Unknown- Z. Su
- J. Postel
- August 1982
- Legacy publication
Abstract
This RFC is an attempt to clarify the generalization of the Domain Naming Convention, the Internet Naming Convention, and to explore the implications of its adoption for Internet name service and user applications.
Abstract
This RFC is an attempt to clarify the generalization of the Domain Naming Convention, the Internet Naming Convention, and to explore the implications of its adoption for Internet name service and user applications.
RFC 757: Suggested solution to the naming, addressing, and delivery problem for ARPANET message systems
Unknown- D.P. Deutsch
- September 1979
- Legacy publication
RFC 506: FTP command naming problem
Unknown- M.A. Padlipsky
- June 1973
- Legacy publication
Subscribe to naming
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.