EPP

EPP (Extensible Provisioning Protocol) for registry objects

EPP RFCs (56)

Display RFCs as
  • RFC 10037: Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • Proposed Standard
  • RFC 9873: Additional Email Address Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 9877: Registration Data Access Protocol (RDAP) Extension for Geofeed Data

    Proposed Standard
  • RFC 9874: BCP 244: Best Practices for Deletion of Domain and Host Objects in the Extensible Provisioning Protocol (EPP)

    Best Current Practice
  • RFC 9803: Extensible Provisioning Protocol (EPP) Mapping for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • RFC 9560: Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID Connect

    Proposed Standard
  • Proposed Standard
  • RFC 9537: Redacted Fields in the Registration Data Access Protocol (RDAP) Response

    Proposed Standard
  • RFC 9224: STD 95: Finding the Authoritative Registration Data Access Protocol (RDAP) Service

    Internet Standard
  • RFC 9154: Extensible Provisioning Protocol (EPP) Secure Authorization Information for Transfer

    Proposed Standard
  • RFC 9167: Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 9095: Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for Strict Bundling Registration

    Informational
  • RFC 9082: STD 95: Registration Data Access Protocol (RDAP) Query Format

    Internet Standard
  • RFC 9083: STD 95: JSON Responses for the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 9038: Extensible Provisioning Protocol (EPP) Unhandled Namespaces

    Proposed Standard
  • RFC 9022: Domain Name Registration Data (DNRD) Objects Mapping

    Proposed Standard
  • RFC 8982: Registration Data Access Protocol (RDAP) Partial Response

    Proposed Standard
  • RFC 8977: Registration Data Access Protocol (RDAP) Query Parameters for Result Sorting and Paging

    Proposed Standard
  • RFC 8909: Registry Data Escrow Specification

    Proposed Standard
  • RFC 8807: Login Security Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8748: Registry Fee Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8590: Change Poll Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8544: Organization Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8543: Extensible Provisioning Protocol (EPP) Organization Mapping

    Proposed Standard
  • RFC 8495: Allocation Token Extension for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8521: BCP 221: Registration Data Access Protocol (RDAP) Object Tagging

    Best Current Practice
  • RFC 8334: Launch Phase Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8063: Key Relay Mapping for the Extensible Provisioning Protocol

    Proposed Standard
  • RFC 8056: Extensible Provisioning Protocol (EPP) and Registration Data Access Protocol (RDAP) Status Mapping

    Proposed Standard
  • RFC 7848: Mark and Signed Mark Objects Mapping

    Proposed Standard
  • RFC 7451: Extension Registry for the Extensible Provisioning Protocol

    Informational
  • RFC 5910: Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 5730: STD 69: Extensible Provisioning Protocol (EPP)

    Internet Standard
  • RFC 5731: STD 69: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Internet Standard
  • RFC 5732: STD 69: Extensible Provisioning Protocol (EPP) Host Mapping

    Internet Standard
  • RFC 5733: STD 69: Extensible Provisioning Protocol (EPP) Contact Mapping

    Internet Standard
  • RFC 5734: STD 69: Extensible Provisioning Protocol (EPP) Transport over TCP

    Internet Standard
  • RFC 5076: ENUM Validation Information Mapping for the Extensible Provisioning Protocol

    Proposed Standard
  • RFC 4930: Extensible Provisioning Protocol (EPP)

    Draft Standard

    Obsoleted by RFC 5730

  • RFC 4931: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Draft Standard

    Obsoleted by RFC 5731

  • RFC 4932: Extensible Provisioning Protocol (EPP) Host Mapping

    Draft Standard

    Obsoleted by RFC 5732

  • RFC 4933: Extensible Provisioning Protocol (EPP) Contact Mapping

    Draft Standard

    Obsoleted by RFC 5733

  • RFC 4934: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Draft Standard

    Obsoleted by RFC 5734

  • RFC 4310: Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard

    Obsoleted by RFC 5910

  • RFC 4114: E.164 Number Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 3915: Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 3730: Extensible Provisioning Protocol (EPP)

    Proposed Standard

    Obsoleted by RFC 4930

  • RFC 3731: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Proposed Standard

    Obsoleted by RFC 4931

  • RFC 3732: Extensible Provisioning Protocol (EPP) Host Mapping

    Proposed Standard

    Obsoleted by RFC 4932

  • RFC 3733: Extensible Provisioning Protocol (EPP) Contact Mapping

    Proposed Standard

    Obsoleted by RFC 4933

  • RFC 3734: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Proposed Standard

    Obsoleted by RFC 4934

  • RFC 3735: Guidelines for Extending the Extensible Provisioning Protocol (EPP)

    Informational
  • RFC 3632: VeriSign Registry Registrar Protocol (RRP) Version 2.0.0

    Informational
  • RFC 3375: Generic Registry-Registrar Protocol Requirements

    Informational
  • RFC 2832: NSI Registry Registrar Protocol (RRP) Version 1.1.0

    Informational

Subscribe to EPP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.