DNS

DNS (Domain Name System): protocol, resource records, resolver and server behaviour, operations

DNS subjects:

DNS RFCs (298)

Display RFCs as
  • RFC 10037: Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • RFC 10001: BCP 91: Operational Guidelines for DNS Transport in Mixed IPv4/IPv6 Environments

    Best Current Practice
  • RFC 10023: The "_for-sale" Underscored and Globally Scoped DNS Node Name

    Informational
  • RFC 9953: DNS over CoAP (DoC)

    Proposed Standard
  • RFC 9848: Bootstrapping TLS Encrypted ClientHello with DNS Service Bindings

    Proposed Standard
  • RFC 9886: DRIP Entity Tags (DETs) in the Domain Name System

    Proposed Standard
  • RFC 9803: Extensible Provisioning Protocol (EPP) Mapping for DNS Time-to-Live (TTL) Values

    Proposed Standard
  • RFC 9609: BCP 209: Initializing a DNS Resolver with Priming Queries

    Best Current Practice
  • RFC 9715: IP Fragmentation Avoidance in DNS over UDP

    Informational
  • RFC 9660: The DNS Zone Version (ZONEVERSION) Option

    Proposed Standard
  • RFC 9619: In the DNS, QDCOUNT Is (Usually) One

    Proposed Standard
  • RFC 9567: DNS Error Reporting

    Proposed Standard
  • RFC 9499: BCP 219: DNS Terminology

    Best Current Practice
  • RFC 9540: Discovery of Oblivious Services via Service Binding Records

    Proposed Standard
  • RFC 9526: Simple Provisioning of Public Names for Residential Networks

    Experimental
  • RFC 9527: DHCPv6 Options for the Homenet Naming Authority

    Proposed Standard
  • RFC 9520: Negative Caching of DNS Resolution Failures

    Proposed Standard
  • RFC 9498: The GNU Name System

    Informational
  • RFC 9460: Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)

    Proposed Standard
  • RFC 9471: DNS Glue Requirements in Referral Responses

    Proposed Standard
  • RFC 9476: The .alt Special-Use Top-Level Domain

    Proposed Standard
  • RFC 9432: DNS Catalog Zones

    Proposed Standard
  • RFC 9121: Deprecating Infrastructure "int" Domains

    Informational
  • Informational
  • RFC 9224: STD 95: Finding the Authoritative Registration Data Access Protocol (RDAP) Service

    Internet Standard
  • RFC 9233: Internationalized Domain Names for Applications 2008 (IDNA2008) and Unicode 12.0.0

    Proposed Standard
  • RFC 9210: BCP 235: DNS Transport over TCP - Operational Requirements

    Best Current Practice
  • RFC 9199: Considerations for Large Authoritative DNS Server Operators

    Informational
  • RFC 9156: DNS Query Name Minimisation to Improve Privacy

    Proposed Standard
  • RFC 9120: Nameservers for the Address and Routing Parameter Area ("arpa") Domain

    Informational
  • RFC 9108: YANG Types for DNS Classes and Resource Record Types

    Proposed Standard
  • RFC 9095: Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for Strict Bundling Registration

    Informational
  • RFC 9022: Domain Name Registration Data (DNRD) Objects Mapping

    Proposed Standard
  • RFC 9018: Interoperable Domain Name System (DNS) Server Cookies

    Proposed Standard
  • RFC 8945: STD 93: Secret Key Transaction Authentication for DNS (TSIG)

    Internet Standard
  • RFC 8914: Extended DNS Errors

    Proposed Standard
  • RFC 8906: BCP 231: A Common Operational Problem in DNS Servers: Failure to Communicate

    Best Current Practice
  • RFC 8904: DNS Whitelist (DNSWL) Email Authentication Method Extension

    Informational
  • RFC 8801: Discovering Provisioning Domain Names and Data

    Proposed Standard
  • RFC 8764: Apple's DNS Long-Lived Queries Protocol

    Informational
  • RFC 8806: Running a Root Server Local to a Resolver

    Informational
  • RFC 8777: DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery

    Proposed Standard
  • RFC 8753: Internationalized Domain Names for Applications (IDNA) Review for New Unicode Versions

    Proposed Standard
  • RFC 8767: Serving Stale Data to Improve DNS Resiliency

    Proposed Standard
  • RFC 8659: DNS Certification Authority Authorization (CAA) Resource Record

    Proposed Standard
  • RFC 8618: Compacted-DNS (C-DNS): A Format for DNS Packet Capture

    Proposed Standard
  • RFC 8598: Split DNS Configuration for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 8552: BCP 222: Scoped Interpretation of DNS Resource Records through "Underscored" Naming of Attribute Leaves

    Best Current Practice
  • RFC 8553: BCP 222: DNS Attrleaf Changes: Fixing Specifications That Use Underscored Node Names

    Best Current Practice
  • RFC 8490: DNS Stateful Operations

    Proposed Standard
  • RFC 8482: Providing Minimal-Sized Responses to DNS Queries That Have QTYPE=ANY

    Proposed Standard
  • RFC 8499: DNS Terminology

    Best Current Practice

    Obsoleted by RFC 9499

  • RFC 8501: Reverse DNS in IPv6 for Internet Service Providers

    Informational
  • RFC 8427: Representing DNS Messages in JSON

    Informational
  • RFC 8334: Launch Phase Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 8324: DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?

    Informational
  • RFC 8305: Happy Eyeballs Version 2: Better Connectivity Using Concurrency

    Proposed Standard
  • RFC 8106: IPv6 Router Advertisement Options for DNS Configuration

    Proposed Standard
  • RFC 8109: Initializing a DNS Resolver with Priming Queries

    Best Current Practice

    Obsoleted by RFC 9609

  • RFC 8020: NXDOMAIN: There Really Is Nothing Underneath

    Proposed Standard
  • RFC 8005: Host Identity Protocol (HIP) Domain Name System (DNS) Extension

    Proposed Standard
  • RFC 7975: Request Routing Redirection Interface for Content Delivery Network (CDN) Interconnection

    Proposed Standard
  • RFC 7984: Locating Session Initiation Protocol (SIP) Servers in a Dual-Stack IP Network

    Proposed Standard
  • RFC 7873: Domain Name System (DNS) Cookies

    Proposed Standard
  • RFC 7793: BCP 163: Adding 100.64.0.0/10 Prefixes to the IPv4 Locally-Served DNS Zones Registry

    Best Current Practice
  • RFC 7816: DNS Query Name Minimisation to Improve Privacy

    Experimental

    Obsoleted by RFC 9156

  • RFC 7754: Technical Considerations for Internet Service Blocking and Filtering

    Informational
  • RFC 7766: DNS Transport over TCP - Implementation Requirements

    Proposed Standard
  • RFC 7745: XML Schemas for Reverse DNS Management

    Informational
  • RFC 7719: DNS Terminology

    Informational

    Obsoleted by RFC 8499

  • RFC 7720: BCP 40: DNS Root Name Service Protocol and Deployment Requirements

    Best Current Practice
  • RFC 7706: Decreasing Access Time to Root Servers by Running One on Loopback

    Informational

    Obsoleted by RFC 8806

  • RFC 7712: Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 7585: Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)

    Experimental
  • RFC 7505: A "Null MX" No Service Resource Record for Domains That Accept No Mail

    Proposed Standard
  • RFC 7553: The Uniform Resource Identifier (URI) DNS Resource Record

    Informational
  • RFC 7534: AS112 Nameserver Operations

    Informational
  • RFC 7535: AS112 Redirection Using DNAME

    Informational
  • RFC 7477: Child-to-Parent Synchronization in DNS

    Proposed Standard
  • RFC 7479: Using Ed25519 in SSHFP Resource Records

    Informational
  • RFC 7393: Using the Port Control Protocol (PCP) to Update Dynamic DNS

    Informational
  • RFC 7304: A Method for Mitigating Namespace Collisions

    Informational
  • RFC 7216: Location Information Server (LIS) Discovery Using IP Addresses and Reverse DNS

    Proposed Standard
  • RFC 7085: Top-Level Domains That Are Already Dotless

    Informational
  • RFC 7043: Resource Records for EUI-48 and EUI-64 Addresses in the DNS

    Informational
  • RFC 6950: Architectural Considerations on Application Features in the DNS

    Informational
  • RFC 6927: Variants in Second-Level Names Registered in Top-Level Domains

    Informational
  • RFC 6895: BCP 42: Domain Name System (DNS) IANA Considerations

    Best Current Practice
  • RFC 6912: Principles for Unicode Code Point Inclusion in Labels in the DNS

    Informational
  • RFC 6731: Improved Recursive DNS Server Selection for Multi-Interfaced Nodes

    Proposed Standard
  • RFC 6742: DNS Resource Records for the Identifier-Locator Network Protocol (ILNP)

    Experimental
  • RFC 6641: Using DNS SRV to Specify a Global File Namespace with NFS Version 4

    Proposed Standard
  • RFC 6672: DNAME Redirection in the DNS

    Proposed Standard
  • RFC 6594: Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource Records

    Proposed Standard
  • RFC 6535: Dual-Stack Hosts Using "Bump-in-the-Host" (BIH)

    Proposed Standard
  • RFC 6471: Overview of Best Email DNS-Based List (DNSBL) Operational Practices

    Informational
  • RFC 6440: The EAP Re-authentication Protocol (ERP) Local Domain Name DHCPv6 Option

    Proposed Standard
  • RFC 6418: Multiple Interfaces and Provisioning Domains Problem Statement

    Informational
  • RFC 6452: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA) - Unicode 6.0

    Proposed Standard
  • RFC 6382: BCP 169: Unique Origin Autonomous System Numbers (ASNs) per Node for Globally Anycasted Services

    Best Current Practice
  • RFC 6303: BCP 163: Locally Served DNS Zones

    Best Current Practice
  • RFC 6304: AS112 Nameserver Operations

    Informational

    Obsoleted by RFC 7534

  • RFC 6305: I'm Being Attacked by PRISONER.IANA.ORG!

    Informational
  • RFC 6168: Requirements for Management of Name Servers for the DNS

    Informational
  • RFC 6186: Use of SRV Records for Locating Email Submission/Access Services

    Proposed Standard
  • RFC 6195: Domain Name System (DNS) IANA Considerations

    Best Current Practice

    Obsoleted by RFC 6895

  • RFC 6116: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)

    Proposed Standard
  • RFC 6117: IANA Registration of Enumservices: Guide, Template, and IANA Considerations

    Proposed Standard
  • RFC 6118: Update of Legacy IANA Registrations of Enumservices

    Proposed Standard
  • RFC 6055: IAB Thoughts on Encodings for Internationalized Domain Names

    Informational
  • RFC 6097: Local Mobility Anchor (LMA) Discovery for Proxy Mobile IPv6

    Informational
  • RFC 6106: IPv6 Router Advertisement Options for DNS Configuration

    Proposed Standard

    Obsoleted by RFC 8106

  • RFC 5992: Internationalized Domain Names Registration and Administration Guidelines for European Languages Using Cyrillic

    Informational
  • RFC 5895: Mapping Characters for Internationalized Domain Names in Applications (IDNA) 2008

    Informational
  • RFC 5966: DNS Transport over TCP - Implementation Requirements

    Proposed Standard

    Obsoleted by RFC 7766

  • RFC 5890: Internationalized Domain Names for Applications (IDNA): Definitions and Document Framework

    Proposed Standard
  • RFC 5891: Internationalized Domain Names in Applications (IDNA): Protocol

    Proposed Standard
  • RFC 5892: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)

    Proposed Standard
  • RFC 5893: Right-to-Left Scripts for Internationalized Domain Names for Applications (IDNA)

    Proposed Standard
  • RFC 5894: Internationalized Domain Names for Applications (IDNA): Background, Explanation, and Rationale

    Informational
  • RFC 5936: DNS Zone Transfer Protocol (AXFR)

    Proposed Standard
  • RFC 5855: BCP 155: Nameservers for IPv4 and IPv6 Reverse Zones

    Best Current Practice
  • RFC 5864: DNS SRV Resource Records for AFS

    Proposed Standard
  • RFC 5782: DNS Blacklists and Whitelists

    Informational
  • RFC 5564: Linguistic Guidelines for the Use of the Arabic Language in Internet Domains

    Informational
  • RFC 5679: Locating IEEE 802.21 Mobility Services Using DNS

    Proposed Standard
  • RFC 5731: STD 69: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Internet Standard
  • RFC 5625: BCP 152: DNS Proxy Implementation Guidelines

    Best Current Practice
  • RFC 5507: Design Choices When Expanding the DNS

    Informational
  • RFC 5526: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application for Infrastructure ENUM

    Informational
  • RFC 5509: Internet Assigned Numbers Authority (IANA) Registration of Instant Messaging and Presence DNS SRV RRs for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5483: ENUM Implementation Issues and Experiences

    Informational
  • RFC 5452: Measures for Making DNS More Resilient against Forged Answers

    Proposed Standard
  • RFC 5395: Domain Name System (DNS) IANA Considerations

    Best Current Practice

    Obsoleted by RFC 6195

  • RFC 5358: BCP 140: Preventing Use of Recursive Nameservers in Reflector Attacks

    Best Current Practice
  • RFC 5346: Operational Requirements for ENUM-Based Softswitch Use

    Informational
  • RFC 5205: Host Identity Protocol (HIP) Domain Name System (DNS) Extensions

    Experimental

    Obsoleted by RFC 8005

  • RFC 5158: 6to4 Reverse DNS Delegation Specification

    Informational
  • RFC 5076: ENUM Validation Information Mapping for the Extensible Provisioning Protocol

    Proposed Standard
  • RFC 5006: IPv6 Router Advertisement Option for DNS Configuration

    Experimental

    Obsoleted by RFC 6106

  • RFC 5001: DNS Name Server Identifier (NSID) Option

    Proposed Standard
  • RFC 4892: Requirements for a Mechanism Identifying a Name Server Instance

    Informational
  • RFC 4931: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Draft Standard

    Obsoleted by RFC 5731

  • RFC 4870: Domain-Based Email Authentication Using Public Keys Advertised in the DNS (DomainKeys)

    Historic

    Obsoleted by RFC 4871

  • RFC 4848: Domain-Based Application Service Location Using URIs and the Dynamic Delegation Discovery Service (DDDS)

    Proposed Standard
  • Informational
  • RFC 4759: The ENUM Dip Indicator Parameter for the "tel" URI

    Proposed Standard
  • RFC 4697: BCP 123: Observed DNS Resolution Misbehavior

    Best Current Practice
  • RFC 4701: A DNS Resource Record (RR) for Encoding Dynamic Host Configuration Protocol (DHCP) Information (DHCID RR)

    Proposed Standard
  • RFC 4702: The Dynamic Host Configuration Protocol (DHCP) Client Fully Qualified Domain Name (FQDN) Option

    Proposed Standard
  • RFC 4703: Resolution of Fully Qualified Domain Name (FQDN) Conflicts among Dynamic Host Configuration Protocol (DHCP) Clients

    Proposed Standard
  • RFC 4704: The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Client Fully Qualified Domain Name (FQDN) Option

    Proposed Standard
  • RFC 4713: Registration and Administration Recommendations for Chinese Domain Names

    Informational
  • RFC 4690: Review and Recommendations for Internationalized Domain Names (IDNs)

    Informational
  • RFC 4635: HMAC SHA (Hashed Message Authentication Code, Secure Hash Algorithm) TSIG Algorithm Identifiers

    Proposed Standard

    Obsoleted by RFC 8945

  • RFC 4592: The Role of Wildcards in the Domain Name System

    Proposed Standard
  • RFC 4501: Domain Name System Uniform Resource Identifiers

    Proposed Standard
  • RFC 4472: Operational Considerations and Issues with IPv6 DNS

    Informational
  • RFC 4438: Fibre-Channel Name Server MIB

    Proposed Standard
  • RFC 4398: Storing Certificates in the Domain Name System (DNS)

    Proposed Standard
  • RFC 4339: IPv6 Host Configuration of DNS Server Information Approaches

    Informational
  • RFC 4367: What's in a Name: False Assumptions about DNS Names

    Informational
  • RFC 4386: Internet X.509 Public Key Infrastructure Repository Locator Service

    Experimental
  • RFC 4343: Domain Name System (DNS) Case Insensitivity Clarification

    Proposed Standard
  • RFC 4355: IANA Registration for Enumservices email, fax, mms, ems, and sms

    Proposed Standard
  • RFC 4290: Suggested Practices for Registration of Internationalized Domain Names (IDN)

    Informational
  • RFC 4322: Opportunistic Encryption using the Internet Key Exchange (IKE)

    Informational
  • RFC 4143: Facsimile Using Internet Mail (IFAX) Service of ENUM

    Proposed Standard
  • RFC 4185: National and Local Characters for DNS Top Level Domain (TLD) Names

    Informational
  • RFC 4183: A Suggested Scheme for DNS Resolution of Networks and Gateways

    Informational
  • RFC 4159: BCP 109: Deprecation of "ip6.int"

    Best Current Practice
  • RFC 4074: Common Misbehavior Against DNS Queries for IPv6 Addresses

    Informational
  • RFC 4095: Attaching Meaning to Solicitation Class Keywords

    Proposed Standard
  • RFC 4018: Finding Internet Small Computer Systems Interface (iSCSI) Targets and Name Servers by Using Service Location Protocol version 2 (SLPv2)

    Proposed Standard
  • RFC 4027: Domain Name System Media Types

    Informational
  • RFC 4025: A Method for Storing IPsec Keying Material in DNS

    Proposed Standard
  • RFC 3958: Domain-Based Application Service Location Using SRV RRs and the Dynamic Delegation Discovery Service (DDDS)

    Proposed Standard
  • RFC 3898: Network Information Service (NIS) Configuration Options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard
  • RFC 3915: Domain Registry Grace Period Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 3901: BCP 91: DNS IPv6 Transport Operational Guidelines

    Best Current Practice

    Obsoleted by RFC 10001

  • RFC 3833: Threat Analysis of the Domain Name System (DNS)

    Informational
  • RFC 3832: Remote Service Discovery in the Service Location Protocol (SLP) via DNS SRV

    Experimental
  • RFC 3761: The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)

    Proposed Standard

    Obsoleted by RFC 6116, RFC 6117

  • RFC 3743: Joint Engineering Team (JET) Guidelines for Internationalized Domain Names (IDN) Registration and Administration for Chinese, Japanese, and Korean

    Informational
  • RFC 3731: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Proposed Standard

    Obsoleted by RFC 4931

  • RFC 3681: BCP 80: Delegation of E.F.F.3.IP6.ARPA

    Best Current Practice
  • RFC 3658: Delegation Signer (DS) Resource Record (RR)

    Proposed Standard

    Obsoleted by RFC 4033, RFC 4034, RFC 4035

  • RFC 3646: DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard
  • RFC 3655: Redefinition of DNS Authenticated Data (AD) bit

    Proposed Standard

    Obsoleted by RFC 4033, RFC 4034, RFC 4035

  • RFC 3645: Generic Security Service Algorithm for Secret Key Transaction Authentication for DNS (GSS-TSIG)

    Proposed Standard
  • RFC 3596: STD 88: DNS Extensions to Support IP Version 6

    Internet Standard
  • RFC 3597: Handling of Unknown DNS Resource Record (RR) Types

    Proposed Standard
  • RFC 3490: Internationalizing Domain Names in Applications (IDNA)

    Proposed Standard

    Obsoleted by RFC 5890, RFC 5891

  • RFC 3491: Nameprep: A Stringprep Profile for Internationalized Domain Names (IDN)

    Proposed Standard

    Obsoleted by RFC 5891

  • RFC 3492: Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)

    Proposed Standard
  • RFC 3467: Role of the Domain Name System (DNS)

    Informational
  • RFC 3445: Limiting the Scope of the KEY Resource Record (RR)

    Proposed Standard

    Obsoleted by RFC 4033, RFC 4034, RFC 4035

  • RFC 3425: Obsoleting IQUERY

    Proposed Standard
  • RFC 3397: Dynamic Host Configuration Protocol (DHCP) Domain Search Option

    Proposed Standard
  • RFC 3401: Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDS

    Informational
  • RFC 3402: Dynamic Delegation Discovery System (DDDS) Part Two: The Algorithm

    Proposed Standard
  • RFC 3403: Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) Database

    Proposed Standard
  • RFC 3404: Dynamic Delegation Discovery System (DDDS) Part Four: The Uniform Resource Identifiers (URI)

    Proposed Standard
  • RFC 3405: BCP 65: Dynamic Delegation Discovery System (DDDS) Part Five: URI.ARPA Assignment Procedures

    Best Current Practice
  • RFC 3375: Generic Registry-Registrar Protocol Requirements

    Informational
  • RFC 3363: Representing Internet Protocol version 6 (IPv6) Addresses in the Domain Name System (DNS)

    Informational
  • RFC 3364: Tradeoffs in Domain Name System (DNS) Support for Internet Protocol version 6 (IPv6)

    Informational
  • RFC 3254: Definitions for talking about directories

    Informational
  • RFC 3258: Distributing Authoritative Name Servers via Shared Unicast Addresses

    Informational
  • RFC 3197: Applicability Statement for DNS MIB Extensions

    Informational
  • RFC 3172: BCP 52: Management Guidelines & Operational Requirements for the Address and Routing Parameter Area Domain ("arpa")

    Best Current Practice
  • RFC 3152: BCP 49: Delegation of IP6.ARPA

    Best Current Practice

    Obsoleted by RFC 3596

  • RFC 3123: A DNS RR Type for Lists of Address Prefixes (APL RR)

    Experimental
  • RFC 3110: RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)

    Proposed Standard
  • RFC 3088: OpenLDAP Root Service An experimental LDAP referral service

    Experimental
  • RFC 3071: Reflections on the DNS, RFC 1591, and Categories of Domains

    Informational
  • RFC 3026: Liaison to IETF/ISOC on ENUM

    Informational
  • RFC 2915: The Naming Authority Pointer (NAPTR) DNS Resource Record

    Proposed Standard

    Obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404

  • RFC 2916: E.164 number and DNS

    Proposed Standard

    Obsoleted by RFC 3761

  • RFC 2929: Domain Name System (DNS) IANA Considerations

    Best Current Practice

    Obsoleted by RFC 5395

  • RFC 2930: Secret Key Establishment for DNS (TKEY RR)

    Proposed Standard
  • RFC 2931: DNS Request and Transaction Signatures ( SIG(0)s )

    Proposed Standard
  • RFC 2901: FYI 37: Guide to Administrative Procedures of the Internet Infrastructure

    Informational
  • RFC 2874: DNS Extensions to Support IPv6 Address Aggregation and Renumbering

    Historic
  • RFC 2870: Root Name Server Operational Requirements

    Best Current Practice

    Obsoleted by RFC 7720

  • RFC 2825: A Tangled Web: Issues of I18N, Domain Names, and the Other Internet protocols

    Informational
  • RFC 2826: IAB Technical Comment on the Unique DNS Root

    Informational
  • RFC 2845: Secret Key Transaction Authentication for DNS (TSIG)

    Proposed Standard

    Obsoleted by RFC 8945

  • RFC 2782: A DNS RR for specifying the location of services (DNS SRV)

    Proposed Standard
  • RFC 2694: DNS extensions to Network Address Translators (DNS_ALG)

    Informational
  • RFC 2671: Extension Mechanisms for DNS (EDNS0)

    Proposed Standard

    Obsoleted by RFC 6891

  • RFC 2672: Non-Terminal DNS Name Redirection

    Proposed Standard

    Obsoleted by RFC 6672

  • RFC 2673: Binary Labels in the Domain Name System

    Historic

    Obsoleted by RFC 6891

  • RFC 2606: BCP 32: Reserved Top Level DNS Names

    Best Current Practice
  • RFC 2517: Building Directories from DNS: Experiences from WWWSeeker

    Informational
  • RFC 2378: The CCSO Nameserver (Ph) Architecture

    Informational
  • RFC 2345: Domain Names and Company Name Retrieval

    Experimental
  • Informational
  • RFC 2308: Negative Caching of DNS Queries (DNS NCACHE)

    Proposed Standard
  • RFC 2317: BCP 20: Classless IN-ADDR.ARPA delegation

    Best Current Practice
  • RFC 2163: Using the Internet DNS to Distribute MIXER Conformant Global Address Mapping (MCGAM)

    Proposed Standard
  • RFC 2247: Using Domains in LDAP/X.500 Distinguished Names

    Proposed Standard
  • RFC 2230: Key Exchange Delegation Record for the DNS

    Informational
  • Informational

    Obsoleted by RFC 2352

  • RFC 2242: NetWare/IP Domain Name and Information

    Proposed Standard
  • RFC 2219: BCP 17: Use of DNS Aliases for Network Services

    Best Current Practice
  • RFC 2181: Clarifications to the DNS Specification

    Proposed Standard
  • RFC 2182: BCP 16: Selection and Operation of Secondary DNS Servers

    Best Current Practice
  • RFC 2168: Resolution of Uniform Resource Identifiers using the Domain Name System

    Experimental

    Obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404

  • RFC 2146: U.S. Government Internet Domain Names

    Informational
  • RFC 2010: Operational Criteria for Root Name Servers

    Informational

    Obsoleted by RFC 2870

  • RFC 2052: A DNS RR for specifying the location of services (DNS SRV)

    Experimental

    Obsoleted by RFC 2782

  • RFC 1982: Serial Number Arithmetic

    Proposed Standard
  • RFC 1995: Incremental Zone Transfer in DNS

    Proposed Standard
  • RFC 1996: A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY)

    Proposed Standard
  • RFC 1912: Common DNS Operational and Configuration Errors

    Informational
  • RFC 1876: A Means for Expressing Location Information in the Domain Name System

    Experimental
  • RFC 1877: PPP Internet Protocol Control Protocol Extensions for Name Server Addresses

    Informational
  • RFC 1886: DNS Extensions to support IP version 6

    Proposed Standard

    Obsoleted by RFC 3596

  • RFC 1816: U.S. Government Internet Domain Names

    Informational

    Obsoleted by RFC 2146

  • RFC 1811: U.S. Government Internet Domain Names

    Informational

    Obsoleted by RFC 1816

  • RFC 1788: ICMP Domain Name Messages

    Historic

    Obsoleted by RFC 6918

  • RFC 1794: DNS Support for Load Balancing

    Informational
  • RFC 1712: DNS Encoding of Geographical Location

    Experimental
  • RFC 1713: FYI 27: Tools for DNS debugging

    Informational
  • RFC 1706: DNS NSAP Resource Records

    Historic
  • RFC 1664: Using the Internet DNS to Distribute RFC1327 Mail Address Mapping Tables

    Experimental

    Obsoleted by RFC 2163

  • RFC 1637: DNS NSAP Resource Records

    Experimental

    Obsoleted by RFC 1706

  • RFC 1611: DNS Server MIB Extensions

    Historic
  • RFC 1612: DNS Resolver MIB Extensions

    Historic
  • RFC 1591: Domain Name System Structure and Delegation

    Informational
  • RFC 1535: A Security Problem and Proposed Correction With Widely Deployed DNS Software

    Informational
  • RFC 1536: Common DNS Implementation Errors and Suggested Fixes

    Informational
  • RFC 1537: Common DNS Data File Configuration Errors

    Informational

    Obsoleted by RFC 1912

  • RFC 1480: The US Domain

    Informational
  • RFC 1464: Using the Domain Name System To Store Arbitrary String Attributes

    Experimental
  • RFC 1394: Relationship of Telex Answerback Codes to Internet Domains

    Informational
  • RFC 1401: Correspondence between the IAB and DISA on the use of DNS

    Informational
  • RFC 1383: An Experiment in DNS Based IP Routing

    Experimental
  • RFC 1386: The US Domain

    Informational

    Obsoleted by RFC 1480

  • RFC 1348: DNS NSAP RRs

    Experimental

    Obsoleted by RFC 1637

  • RFC 1296: Internet Growth (1981-1991)

    Informational
  • RFC 1183: New DNS RR Definitions

    Experimental
  • RFC 1101: DNS encoding of network names and other types

    Unknown
  • RFC 1032: Domain administrators guide

    Unknown
  • RFC 1033: Domain Administrators Operations Guide

    Unknown
  • RFC 1034: STD 13: Domain names - concepts and facilities

    Internet Standard
  • RFC 1035: STD 13: Domain names - implementation and specification

    Internet Standard
  • RFC 973: Domain system changes and observations

    Unknown

    Obsoleted by RFC 1034, RFC 1035

  • RFC 974: STD 10: Mail routing and the domain system

    Historic

    Obsoleted by RFC 2821

  • RFC 953: Hostname Server

    Historic
  • RFC 920: Domain requirements

    Unknown
  • RFC 921: Domain name system implementation schedule - revised

    Unknown
  • RFC 897: Domain name system implementation schedule

    Unknown
  • RFC 881: Domain names plan and schedule

    Unknown
  • RFC 882: Domain names: Concepts and facilities

    Unknown

    Obsoleted by RFC 1034, RFC 1035

  • RFC 883: Domain names: Implementation specification

    Unknown

    Obsoleted by RFC 1034, RFC 1035

  • RFC 756: NIC name server - a datagram-based information utility

    Unknown

Subscribe to DNS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.