MPLS

MPLS (Multiprotocol Label Switching): architecture, encapsulation, operations

MPLS subjects:

MPLS RFCs (226)

Display RFCs as
  • RFC 9994: MPLS Network Action (MNA) Sub-Stack Specification Including In-Stack Network Actions and Data

    Proposed Standard
  • RFC 9961: MPLS Segment Routing Point-to-Multipoint (P2MP) Policy Ping

    Proposed Standard
  • RFC 9902: A YANG Data Model for IS-IS Segment Routing over the MPLS Data Plane

    Proposed Standard
  • RFC 9903: A YANG Data Model for OSPF Segment Routing over the MPLS Data Plane

    Proposed Standard
  • RFC 9889: A Realization of Network Slices for 5G Networks Using Current IP/MPLS Technologies

    Informational
  • Proposed Standard
  • RFC 9884: Label Switched Path Ping for Segment Routing Path Segment Identifier with MPLS Data Plane

    Proposed Standard
  • RFC 9860: Multicast-Only Fast Reroute (MoFRR) Based on Topology Independent Loop-Free Alternate (TI-LFA) Fast Reroute

    Informational
  • RFC 9789: MPLS Network Actions (MNAs) Framework

    Informational
  • RFC 9790: IANA Registry and Processing Recommendations for the First Nibble Following a Label Stack

    Proposed Standard
  • RFC 9791: Use Cases for MPLS Network Action Indicators and Ancillary Data

    Informational
  • RFC 9780: Bidirectional Forwarding Detection (BFD) for Multipoint Networks over Point-to-Multipoint MPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 9779: Performance Measurement for Segment Routing Networks with the MPLS Data Plane

    Proposed Standard
  • RFC 9705: Refresh-Interval Independent RSVP Fast Reroute Facility Protection

    Proposed Standard
  • RFC 9714: Encapsulation for MPLS Performance Measurement with the Alternate-Marking Method

    Proposed Standard
  • RFC 9716: Mechanisms for MPLS Ping and Traceroute Procedures in Inter-Domain Segment Routing Networks

    Proposed Standard
  • RFC 9717: A Routing Architecture for Satellite Networks

    Informational
  • RFC 9702: YANG Data Model for Maximum Segment Identifier (SID) Depth (MSD) Types and MPLS MSD

    Proposed Standard
  • RFC 9703: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) Egress Peer Engineering (EPE) Segment Identifiers (SIDs) with MPLS Data Plane

    Proposed Standard
  • RFC 9655: Egress Validation in Label Switched Path Ping and Traceroute Mechanisms

    Proposed Standard
  • RFC 9613: Requirements for Solutions that Support MPLS Network Actions (MNAs)

    Informational
  • RFC 9612: Bidirectional Forwarding Detection (BFD) Reverse Path for MPLS Label Switched Paths (LSPs)

    Experimental
  • RFC 9571: Extension of RFC 6374-Based Performance Measurement Using Synonymous Flow Labels

    Proposed Standard
  • RFC 9570: Deprecating the Use of Router Alert in LSP Ping

    Proposed Standard
  • RFC 9566: Deterministic Networking (DetNet) Packet Replication, Elimination, and Ordering Functions (PREOF) via MPLS over UDP/IP

    Informational
  • RFC 9546: Operations, Administration, and Maintenance (OAM) for Deterministic Networking (DetNet) with the MPLS Data Plane

    Proposed Standard
  • RFC 9545: Path Segment Identifier in MPLS-Based Segment Routing Networks

    Proposed Standard
  • RFC 9489: Label Switched Path (LSP) Ping Mechanisms for EVPN and Provider Backbone Bridging EVPN (PBB-EVPN)

    Proposed Standard
  • RFC 9491: Integration of the Network Service Header (NSH) and Segment Routing for Service Function Chaining (SFC)

    Proposed Standard
  • RFC 9359: Echo Request/Reply for Enabled In Situ OAM (IOAM) Capabilities

    Proposed Standard
  • RFC 9358: Path Computation Element Communication Protocol (PCEP) Extensions for Establishing Relationships between Sets of Label Switched Paths and Virtual Networks

    Proposed Standard
  • RFC 9357: Label Switched Path (LSP) Object Flag Extension for Stateful PCE

    Proposed Standard
  • RFC 9256: Segment Routing Policy Architecture

    Proposed Standard
  • RFC 9214: OSPFv3 Code Point for MPLS LSP Ping

    Proposed Standard
  • RFC 9160: Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 9056: Deterministic Networking (DetNet) Data Plane: IP over MPLS

    Proposed Standard
  • Proposed Standard
  • RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry

    Proposed Standard
  • RFC 9059: Path Computation Element Communication Protocol (PCEP) Extensions for Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 9024: Deterministic Networking (DetNet) Data Plane: IEEE 802.1 Time-Sensitive Networking over MPLS

    Proposed Standard
  • RFC 9037: Deterministic Networking (DetNet) Data Plane: MPLS over IEEE 802.1 Time-Sensitive Networking (TSN)

    Informational
  • RFC 9020: YANG Data Model for Segment Routing

    Proposed Standard
  • RFC 9025: Deterministic Networking (DetNet) Data Plane: MPLS over UDP/IP

    Proposed Standard
  • RFC 9017: Special-Purpose Label Terminology

    Proposed Standard
  • RFC 9005: Path Computation Element Communication Protocol (PCEP) Extension for Associating Policies and Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8957: Synonymous Flow Label Framework

    Proposed Standard
  • RFC 8964: Deterministic Networking (DetNet) Data Plane: MPLS

    Proposed Standard
  • RFC 8960: A YANG Data Model for MPLS Base

    Proposed Standard
  • RFC 8934: PCE Communication Protocol (PCEP) Extensions for Label Switched Path (LSP) Scheduling with Stateful PCE

    Proposed Standard
  • RFC 8800: Path Computation Element Communication Protocol (PCEP) Extension for Label Switched Path (LSP) Diversity Constraint Signaling

    Proposed Standard
  • RFC 8796: RSVP-TE Summary Fast Reroute Extensions for Label Switched Path (LSP) Tunnels

    Proposed Standard
  • RFC 8745: Path Computation Element Communication Protocol (PCEP) Extensions for Associating Working and Protection Label Switched Paths (LSPs) with Stateful PCE

    Proposed Standard
  • RFC 8741: Ability for a Stateful Path Computation Element (PCE) to Request and Obtain Control of a Label Switched Path (LSP)

    Proposed Standard
  • RFC 8733: Path Computation Element Communication Protocol (PCEP) Extensions for MPLS-TE Label Switched Path (LSP) Auto-Bandwidth Adjustment with Stateful PCE

    Proposed Standard
  • RFC 8697: Path Computation Element Communication Protocol (PCEP) Extensions for Establishing Relationships between Sets of Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8690: Clarification of Segment ID Sub-TLV Length for RFC 8287

    Proposed Standard
  • RFC 8660: Segment Routing with the MPLS Data Plane

    Proposed Standard
  • RFC 8662: Entropy Label for Source Packet Routing in Networking (SPRING) Tunnels

    Proposed Standard
  • RFC 8663: MPLS Segment Routing over IP

    Proposed Standard
  • RFC 8665: OSPF Extensions for Segment Routing

    Proposed Standard
  • RFC 8666: OSPFv3 Extensions for Segment Routing

    Proposed Standard
  • RFC 8667: IS-IS Extensions for Segment Routing

    Proposed Standard
  • RFC 8669: Segment Routing Prefix Segment Identifier Extensions for BGP

    Proposed Standard
  • RFC 8679: MPLS Egress Protection Framework

    Proposed Standard
  • RFC 8687: OSPF Routing with Cross-Address Family Traffic Engineering Tunnels

    Proposed Standard
  • RFC 8623: Stateful Path Computation Element (PCE) Protocol Extensions for Usage with Point-to-Multipoint TE Label Switched Paths (LSPs)

    Proposed Standard
  • Proposed Standard
  • RFC 8595: An MPLS-Based Forwarding Plane for Service Function Chaining

    Proposed Standard
  • RFC 8596: MPLS Transport Encapsulation for the Service Function Chaining (SFC) Network Service Header (NSH)

    Informational
  • RFC 8577: Signaling RSVP-TE Tunnels on a Shared MPLS Forwarding Plane

    Proposed Standard
  • RFC 8537: Updates to the Fast Reroute Procedures for Co-routed Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8502: L2L3 VPN Multicast MIB

    Proposed Standard
  • RFC 8503: BGP/MPLS Layer 3 VPN Multicast Management Information Base

    Proposed Standard
  • RFC 8424: Extensions to RSVP-TE for Label Switched Path (LSP) Ingress Fast Reroute (FRR) Protection

    Experimental
  • RFC 8426: Recommendations for RSVP-TE and Segment Routing (SR) Label Switched Path (LSP) Coexistence

    Informational
  • RFC 8403: A Scalable and Topology-Aware MPLS Data-Plane Monitoring System

    Informational
  • RFC 8413: Framework for Scheduled Use of Resources

    Informational
  • Informational
  • RFC 8400: Extensions to RSVP-TE for Label Switched Path (LSP) Egress Protection

    Proposed Standard
  • RFC 8388: Usage and Applicability of BGP MPLS-Based Ethernet VPN

    Informational
  • Proposed Standard
  • RFC 8372: MPLS Flow Identification Considerations

    Informational
  • RFC 8296: Encapsulation for Bit Index Explicit Replication (BIER) in MPLS and Non-MPLS Networks

    Proposed Standard
  • RFC 8287: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes

    Proposed Standard
  • RFC 8306: Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched Paths

    Proposed Standard
  • RFC 8277: Using BGP to Bind MPLS Labels to Address Prefixes

    Proposed Standard
  • RFC 8232: Optimizations of Label Switched Path State Synchronization Procedures for a Stateful PCE

    Proposed Standard
  • RFC 8233: Extensions to the Path Computation Element Communication Protocol (PCEP) to Compute Service-Aware Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8169: Residence Time Measurement in MPLS Networks

    Proposed Standard
  • RFC 8149: RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures

    Proposed Standard
  • RFC 8100: Diffserv-Interconnection Classes and Practice

    Informational
  • RFC 7876: UDP Return Path for Packet Loss and Delay Measurement for MPLS Networks

    Proposed Standard
  • RFC 7881: Seamless Bidirectional Forwarding Detection (S-BFD) for IPv4, IPv6, and MPLS

    Proposed Standard
  • RFC 7900: Extranet Multicast in BGP/IP MPLS VPNs

    Proposed Standard
  • RFC 7823: Performance-Based Path Selection for Explicitly Routed Label Switched Paths (LSPs) Using TE Metric Extensions

    Informational
  • RFC 7814: Virtual Subnet: A BGP/MPLS IP VPN-Based Subnet Extension Solution

    Informational
  • RFC 7726: Clarifying Procedures for Establishing BFD Sessions for MPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 7746: Label Switched Path (LSP) Self-Ping

    Proposed Standard
  • RFC 7737: Label Switched Path (LSP) Ping and Traceroute Reply Mode Simplification

    Proposed Standard
  • RFC 7743: Relayed Echo Reply Mechanism for Label Switched Path (LSP) Ping

    Proposed Standard
  • RFC 7625: Architecture of an IP/MPLS Network with Hardened Pipes

    Informational
  • RFC 7555: Proxy MPLS Echo Request

    Proposed Standard
  • RFC 7524: Inter-Area Point-to-Multipoint (P2MP) Segmented Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 7551: RSVP-TE Extensions for Associated Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 7537: IANA Registries for LSP Ping Code Points

    Proposed Standard

    Obsoleted by RFC 8029

  • RFC 7506: IPv6 Router Alert Option for MPLS Operations, Administration, and Maintenance (OAM)

    Historic
  • RFC 7510: Encapsulating MPLS in UDP

    Proposed Standard
  • RFC 7432: BGP MPLS-Based Ethernet VPN

    Proposed Standard
  • RFC 7447: Deprecation of BGP Entropy Label Capability Attribute

    Proposed Standard
  • RFC 7394: Definition of Time to Live TLV for LSP-Ping Mechanisms

    Proposed Standard
  • RFC 7387: A Framework for Ethernet Tree (E-Tree) Service over a Multiprotocol Label Switching (MPLS) Network

    Informational
  • RFC 7334: PCE-Based Computation Procedure to Compute Shortest Constrained Point-to-Multipoint (P2MP) Inter-Domain Traffic Engineering Label Switched Paths

    Experimental
  • RFC 7308: Extended Administrative Groups in MPLS Traffic Engineering (MPLS-TE)

    Proposed Standard
  • RFC 7297: IP Connectivity Provisioning Profile (CPP)

    Informational
  • RFC 7289: Carrier-Grade NAT (CGN) Deployment with BGP/MPLS IP VPNs

    Informational
  • RFC 7212: MPLS Generic Associated Channel (G-ACh) Advertisement Protocol

    Proposed Standard
  • RFC 7274: Allocating and Retiring Special-Purpose MPLS Labels

    Proposed Standard
  • RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry

    Proposed Standard
  • RFC 7226: Requirements for Advanced Multipath in MPLS Networks

    Informational
  • RFC 7152: Requirements for Metro Ethernet Forum (MEF) Ethernet-Tree (E-Tree) Support in Layer 2 Virtual Private Network (L2VPN)

    Informational
  • RFC 7110: Return Path Specified Label Switched Path (LSP) Ping

    Proposed Standard
  • RFC 7054: Addressing Requirements and Design Considerations for Per-Interface Maintenance Entity Group Intermediate Points (MIPs)

    Informational
  • RFC 7024: Virtual Hub-and-Spoke in BGP/MPLS VPNs

    Proposed Standard
  • RFC 6981: A Framework for IP and MPLS Fast Reroute Using Not-Via Addresses

    Informational
  • RFC 6894: Methodology for Benchmarking MPLS Traffic Engineered (MPLS-TE) Fast Reroute Protection

    Informational
  • RFC 6790: The Use of Entropy Labels in MPLS Forwarding

    Proposed Standard
  • RFC 6669: An Overview of the Operations, Administration, and Maintenance (OAM) Toolset for MPLS-Based Transport Networks

    Informational
  • RFC 6565: OSPFv3 as a Provider Edge to Customer Edge (PE-CE) Routing Protocol

    Proposed Standard
  • RFC 6601: Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS Networks

    Experimental
  • RFC 6511: Non-Penultimate Hop Popping Behavior and Out-of-Band Mapping for RSVP-TE Label Switched Paths

    Proposed Standard
  • RFC 6513: Multicast in MPLS/BGP IP VPNs

    Proposed Standard
  • RFC 6514: BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNs

    Proposed Standard
  • RFC 6425: Detecting Data-Plane Failures in Point-to-Multipoint MPLS - Extensions to LSP Ping

    Proposed Standard
  • RFC 6427: MPLS Fault Management Operations, Administration, and Maintenance (OAM)

    Proposed Standard
  • RFC 6445: Multiprotocol Label Switching (MPLS) Traffic Engineering Management Information Base for Fast Reroute

    Proposed Standard
  • RFC 6424: Mechanism for Performing Label Switched Path Ping (LSP Ping) over MPLS Tunnels

    Proposed Standard

    Obsoleted by RFC 8029

  • RFC 6368: Internal BGP as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 6371: Operations, Administration, and Maintenance Framework for MPLS-Based Transport Networks

    Informational
  • RFC 6374: Packet Loss and Delay Measurement for MPLS Networks

    Proposed Standard
  • RFC 6375: A Packet Loss and Delay Measurement Profile for MPLS-Based Transport Networks

    Informational
  • RFC 6178: Label Edge Router Forwarding of IPv4 Option Packets

    Proposed Standard
  • RFC 6037: Cisco Systems' Solution for Multicast in BGP/MPLS IP VPNs

    Historic
  • RFC 6006: Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched Paths

    Proposed Standard

    Obsoleted by RFC 8306

  • RFC 5884: Bidirectional Forwarding Detection (BFD) for MPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 5824: Requirements for Supporting Customer Resource ReSerVation Protocol (RSVP) and RSVP Traffic Engineering (RSVP-TE) over a BGP/MPLS IP-VPN

    Informational
  • RFC 5711: Node Behavior upon Originating and Receiving Resource Reservation Protocol (RSVP) Path Error Messages

    Proposed Standard
  • RFC 5712: MPLS Traffic Engineering Soft Preemption

    Proposed Standard
  • RFC 5714: IP Fast Reroute Framework

    Informational
  • RFC 5715: A Framework for Loop-Free Convergence

    Informational
  • RFC 5695: MPLS Forwarding Benchmarking Methodology for IP Flows

    Informational
  • RFC 5441: A Backward-Recursive PCE-Based Computation (BRPC) Procedure to Compute Shortest Constrained Inter-Domain Traffic Engineering Label Switched Paths

    Proposed Standard
  • RFC 5462: Multiprotocol Label Switching (MPLS) Label Stack Entry: "EXP" Field Renamed to "Traffic Class" Field

    Proposed Standard
  • RFC 5439: An Analysis of Scaling Issues in MPLS-TE Core Networks

    Informational
  • Proposed Standard
  • RFC 5331: MPLS Upstream Label Assignment and Context-Specific Label Space

    Proposed Standard
  • RFC 5332: MPLS Multicast Encapsulations

    Proposed Standard
  • RFC 5129: Explicit Congestion Marking in MPLS

    Proposed Standard
  • RFC 4950: ICMP Extensions for Multiprotocol Label Switching

    Proposed Standard
  • RFC 4928: BCP 128: Avoiding Equal Cost Multipath Treatment in MPLS Networks

    Best Current Practice
  • RFC 4905: Encapsulation Methods for Transport of Layer 2 Frames over MPLS Networks

    Historic
  • RFC 4901: Protocol Extensions for Header Compression over MPLS

    Proposed Standard
  • RFC 4875: Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 4859: Codepoint Registry for the Flags Field in the Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Session Attribute Object

    Informational
  • RFC 4829: Label Switched Path (LSP) Preemption Policies for MPLS Traffic Engineering

    Informational
  • RFC 4817: Encapsulation of MPLS over Layer 2 Tunneling Protocol Version 3

    Proposed Standard
  • RFC 4804: Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE Tunnels

    Proposed Standard
  • RFC 4798: Connecting IPv6 Islands over IPv4 MPLS Using IPv6 Provider Edge Routers (6PE)

    Proposed Standard
  • RFC 4797: Use of Provider Edge to Provider Edge (PE-PE) Generic Routing Encapsulation (GRE) or IP in BGP/MPLS IP Virtual Private Networks

    Informational
  • RFC 4781: Graceful Restart Mechanism for BGP with MPLS

    Proposed Standard
  • RFC 4684: Constrained Route Distribution for Border Gateway Protocol/MultiProtocol Label Switching (BGP/MPLS) Internet Protocol (IP) Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4687: Operations and Management (OAM) Requirements for Point-to-Multipoint MPLS Networks

    Informational
  • RFC 4659: BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPN

    Proposed Standard
  • Proposed Standard
  • RFC 4577: OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4561: Definition of a Record Route Object (RRO) Node-Id Sub-Object

    Proposed Standard
  • RFC 4461: Signaling Requirements for Point-to-Multipoint Traffic-Engineered MPLS Label Switched Paths (LSPs)

    Informational
  • RFC 4420: Encoding of Attributes for Multiprotocol Label Switching (MPLS) Label Switched Path (LSP) Establishment Using Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)

    Proposed Standard

    Obsoleted by RFC 5420

  • RFC 4382: MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base

    Proposed Standard
  • RFC 4364: BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4365: Applicability Statement for BGP/MPLS IP Virtual Private Networks (VPNs)

    Informational
  • RFC 4377: Operations and Management (OAM) Requirements for Multi-Protocol Label Switched (MPLS) Networks

    Informational
  • RFC 4378: A Framework for Multi-Protocol Label Switching (MPLS) Operations and Management (OAM)

    Informational
  • RFC 4379: Detecting Multi-Protocol Label Switched (MPLS) Data Plane Failures

    Proposed Standard

    Obsoleted by RFC 8029

  • RFC 4381: Analysis of the Security of BGP/MPLS IP Virtual Private Networks (VPNs)

    Informational
  • RFC 4368: Multiprotocol Label Switching (MPLS) Label-Controlled Asynchronous Transfer Mode (ATM) and Frame-Relay Management Interface Definition

    Proposed Standard
  • Proposed Standard
  • RFC 4221: Multiprotocol Label Switching (MPLS) Management Overview

    Informational
  • RFC 4216: MPLS Inter-Autonomous System (AS) Traffic Engineering (TE) Requirements

    Informational
  • RFC 4247: Requirements for Header Compression over MPLS

    Informational
  • RFC 4182: Removing a Restriction on the use of MPLS Explicit NULL

    Proposed Standard
  • RFC 4124: Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering

    Proposed Standard
  • RFC 4125: Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4126: Max Allocation with Reservation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering & Performance Comparisons

    Experimental
  • RFC 4127: Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4128: Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance Evaluation

    Informational
  • RFC 4105: Requirements for Inter-Area MPLS Traffic Engineering

    Informational
  • RFC 4090: Fast Reroute Extensions to RSVP-TE for LSP Tunnels

    Proposed Standard
  • RFC 4023: Encapsulating MPLS in IP or Generic Routing Encapsulation (GRE)

    Proposed Standard
  • RFC 3919: Remote Network Monitoring (RMON) Protocol Identifiers for IPv6 and Multi Protocol Label Switching (MPLS)

    Informational
  • RFC 3812: Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB)

    Proposed Standard
  • RFC 3813: Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB)

    Proposed Standard
  • RFC 3814: Multiprotocol Label Switching (MPLS) Forwarding Equivalence Class To Next Hop Label Forwarding Entry (FEC-To-NHLFE) Management Information Base (MIB)

    Proposed Standard
  • RFC 3811: Definitions of Textual Conventions (TCs) for Multiprotocol Label Switching (MPLS) Management

    Proposed Standard
  • RFC 3785: BCP 87: Use of Interior Gateway Protocol (IGP) Metric as a second MPLS Traffic Engineering (TE) Metric

    Best Current Practice
  • RFC 3564: Requirements for Support of Differentiated Services-aware MPLS Traffic Engineering

    Informational
  • RFC 3496: Protocol Extension for Support of Asynchronous Transfer Mode (ATM) Service Class-aware Multiprotocol Label Switching (MPLS) Traffic Engineering

    Informational
  • RFC 3469: Framework for Multi-Protocol Label Switching (MPLS)-based Recovery

    Informational
  • Proposed Standard
  • RFC 3443: Time To Live (TTL) Processing in Multi-Protocol Label Switching (MPLS) Networks

    Proposed Standard
  • RFC 3429: Assignment of the 'OAM Alert Label' for Multiprotocol Label Switching Architecture (MPLS) Operation and Maintenance (OAM) Functions

    Informational
  • RFC 3353: Overview of IP Multicast in a Multi-Protocol Label Switching (MPLS) Environment

    Informational
  • RFC 3346: Applicability Statement for Traffic Engineering with MPLS

    Informational
  • RFC 3270: Multi-Protocol Label Switching (MPLS) Support of Differentiated Services

    Proposed Standard
  • RFC 3209: RSVP-TE: Extensions to RSVP for LSP Tunnels

    Proposed Standard
  • RFC 3210: Applicability Statement for Extensions to RSVP for LSP-Tunnels

    Informational
  • RFC 3107: Carrying Label Information in BGP-4

    Proposed Standard

    Obsoleted by RFC 8277

  • RFC 3063: MPLS Loop Prevention Mechanism

    Experimental
  • RFC 3031: Multiprotocol Label Switching Architecture

    Proposed Standard
  • RFC 3032: MPLS Label Stack Encoding

    Proposed Standard
  • RFC 3033: The Assignment of the Information Field and Protocol Identifier in the Q.2941 Generic Identifier and Q.2957 User-to-user Signaling for the Internet Protocol

    Proposed Standard
  • RFC 3034: Use of Label Switching on Frame Relay Networks Specification

    Proposed Standard
  • RFC 2917: A Core MPLS IP VPN Architecture

    Informational
  • RFC 2702: Requirements for Traffic Engineering Over MPLS

    Informational
  • RFC 2547: BGP/MPLS VPNs

    Informational

    Obsoleted by RFC 4364

  • RFC 2430: A Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

    Informational

Subscribe to MPLS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.