GMPLS

GMPLS (Generalized Multiprotocol Label Switching): generalized MPLS and optical/transport network control

GMPLS RFCs (172)

Display RFCs as
  • RFC 9730: Interworking of GMPLS Control and Centralized Controller Systems

    Informational
  • RFC 9656: A YANG Data Model for Microwave Topology

    Proposed Standard
  • RFC 9504: Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE Usage in GMPLS-Controlled Networks

    Proposed Standard
  • RFC 9376: Applicability of GMPLS for beyond 100 Gbit/s Optical Transport Network

    Informational
  • RFC 9346: IS-IS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 9270: GMPLS Signaling Extensions for Shared Mesh Protection

    Proposed Standard
  • RFC 9093: A YANG Data Model for Layer 0 Types

    Proposed Standard
  • RFC 9094: A YANG Data Model for Wavelength Switched Optical Networks (WSONs)

    Proposed Standard
  • RFC 8779: Path Computation Element Communication Protocol (PCEP) Extensions for GMPLS

    Proposed Standard
  • RFC 8780: The Path Computation Element Communication Protocol (PCEP) Extension for Wavelength Switched Optical Network (WSON) Routing and Wavelength Assignment (RWA)

    Proposed Standard
  • RFC 8694: Applicability of the Path Computation Element to Inter-area and Inter-AS MPLS and GMPLS Traffic Engineering

    Informational
  • RFC 8632: A YANG Data Model for Alarm Management

    Proposed Standard
  • RFC 8625: Ethernet Traffic Parameters with Availability Information

    Proposed Standard
  • Proposed Standard
  • RFC 8432: A Framework for Management and Control of Microwave and Millimeter Wave Interface Parameters

    Informational
  • RFC 8363: GMPLS OSPF-TE Extensions in Support of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

    Proposed Standard
  • Proposed Standard
  • RFC 8282: Extensions to the Path Computation Element Communication Protocol (PCEP) for Inter-Layer MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 8271: Updates to the Resource Reservation Protocol for Fast Reroute of Traffic Engineering GMPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8258: Generalized SCSI: A Generic Structure for Interface Switching Capability Descriptor (ISCD) Switching Capability Specific Information (SCSI)

    Proposed Standard
  • RFC 8131: RSVP-TE Signaling Procedure for End-to-End GMPLS Restoration and Resource Sharing

    Informational
  • RFC 8024: Multi-Chassis Passive Optical Network (MC-PON) Protection in MPLS

    Proposed Standard
  • RFC 7963: RSVP-TE Extension for Additional Signal Types in G.709 Optical Transport Networks (OTNs)

    Informational
  • RFC 7892: IANA Allocation Procedures for the GMPLS OTN Signal Type Registry

    Proposed Standard
  • RFC 7792: RSVP-TE Signaling Extensions in Support of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

    Proposed Standard
  • RFC 7698: Framework and Requirements for GMPLS-Based Control of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

    Informational
  • RFC 7699: Generalized Labels for the Flexi-Grid in Lambda Switch Capable (LSC) Label Switching Routers

    Proposed Standard
  • RFC 7688: GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

    Proposed Standard
  • RFC 7689: Signaling Extensions for Wavelength Switched Optical Networks

    Proposed Standard
  • RFC 7709: Requirements for Very Fast Setup of GMPLS Label Switched Paths (LSPs)

    Informational
  • RFC 7570: Label Switched Path (LSP) Attribute in the Explicit Route Object (ERO)

    Proposed Standard
  • RFC 7571: GMPLS RSVP-TE Extensions for Lock Instruct and Loopback

    Proposed Standard
  • RFC 7579: General Network Element Constraint Encoding for GMPLS-Controlled Networks

    Proposed Standard
  • RFC 7580: OSPF-TE Extensions for General Network Element Constraints

    Proposed Standard
  • RFC 7581: Routing and Wavelength Assignment Information Encoding for Wavelength Switched Optical Networks

    Proposed Standard
  • RFC 7487: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using RSVP-TE

    Proposed Standard
  • RFC 7446: Routing and Wavelength Assignment Information Model for Wavelength Switched Optical Networks

    Informational
  • RFC 7449: Path Computation Element Communication Protocol (PCEP) Requirements for Wavelength Switched Optical Network (WSON) Routing and Wavelength Assignment

    Informational
  • RFC 7369: GMPLS RSVP-TE Extensions for Ethernet Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 7260: GMPLS RSVP-TE Extensions for Operations, Administration, and Maintenance (OAM) Configuration

    Proposed Standard
  • RFC 7271: MPLS Transport Profile (MPLS-TP) Linear Protection to Match the Operational Expectations of Synchronous Digital Hierarchy, Optical Transport Network, and Ethernet Transport Network Operators

    Proposed Standard
  • RFC 7138: Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

    Proposed Standard
  • RFC 7139: GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport Networks

    Proposed Standard
  • RFC 7096: Evaluation of Existing GMPLS Encoding against G.709v3 Optical Transport Networks (OTNs)

    Informational
  • RFC 7062: Framework for GMPLS and PCE Control of G.709 Optical Transport Networks

    Informational
  • RFC 7074: Revised Definition of the GMPLS Switching Capability and Type Fields

    Proposed Standard
  • RFC 7025: Requirements for GMPLS Applications of PCE

    Informational
  • RFC 6934: Applicability of the Access Node Control Mechanism to Broadband Networks Based on Passive Optical Networks (PONs)

    Informational
  • Proposed Standard
  • RFC 6825: Traffic Engineering Database Management Information Base in Support of MPLS-TE/GMPLS

    Proposed Standard
  • RFC 6827: Automatically Switched Optical Network (ASON) Routing for OSPFv2 Protocols

    Proposed Standard
  • RFC 6805: The Application of the Path Computation Element Architecture to the Determination of a Sequence of Domains in MPLS and GMPLS

    Informational
  • RFC 6777: Label Switched Path (LSP) Data Path Delay Metrics in Generalized MPLS and MPLS Traffic Engineering (MPLS-TE) Networks

    Proposed Standard
  • RFC 6780: RSVP ASSOCIATION Object Extensions

    Proposed Standard
  • RFC 6689: Usage of the RSVP ASSOCIATION Object

    Informational
  • RFC 6566: A Framework for the Control of Wavelength Switched Optical Networks (WSONs) with Impairments

    Informational
  • RFC 6510: Resource Reservation Protocol (RSVP) Message Formats for Label Switched Path (LSP) Attributes Objects

    Proposed Standard
  • RFC 6457: PCC-PCE Communication and PCE Discovery Requirements for Inter-Layer Traffic Engineering

    Informational
  • RFC 6456: Multi-Segment Pseudowires in Passive Optical Networks

    Informational
  • RFC 6383: Advice on When It Is Safe to Start Sending Data on Label Switched Paths Established Using RSVP-TE

    Informational
  • RFC 6387: GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 6373: MPLS Transport Profile (MPLS-TP) Control Plane Framework

    Informational
  • Proposed Standard
  • RFC 6240: Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation over Packet (CEP) MIB Using SMIv2

    Proposed Standard
  • RFC 6163: Framework for GMPLS and Path Computation Element (PCE) Control of Wavelength Switched Optical Networks (WSONs)

    Informational
  • RFC 6205: Generalized Labels for Lambda-Switch-Capable (LSC) Label Switching Routers

    Proposed Standard
  • RFC 6060: Generalized Multiprotocol Label Switching (GMPLS) Control of Ethernet Provider Backbone Traffic Engineering (PBB-TE)

    Proposed Standard
  • RFC 6107: Procedures for Dynamically Signaled Hierarchical Label Switched Paths

    Proposed Standard
  • RFC 6001: Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)

    Proposed Standard
  • RFC 6002: Generalized MPLS (GMPLS) Data Channel Switching Capable (DCSC) and Channel Set Label Extensions

    Proposed Standard
  • RFC 6003: Ethernet Traffic Parameters

    Proposed Standard
  • RFC 6004: Generalized MPLS (GMPLS) Support for Metro Ethernet Forum and G.8011 Ethernet Service Switching

    Proposed Standard
  • RFC 6005: Generalized MPLS (GMPLS) Support for Metro Ethernet Forum and G.8011 User Network Interface (UNI)

    Proposed Standard
  • RFC 5920: Security Framework for MPLS and GMPLS Networks

    Informational
  • RFC 5862: Path Computation Clients (PCC) - Path Computation Element (PCE) Requirements for Point-to-Multipoint MPLS-TE

    Informational
  • RFC 5817: Graceful Shutdown in MPLS and Generalized MPLS Traffic Engineering Networks

    Informational
  • Proposed Standard
  • RFC 5852: RSVP-TE Signaling Extension for LSP Handover from the Management Plane to the Control Plane in a GMPLS-Enabled Transport Network

    Proposed Standard
  • RFC 5828: Generalized Multiprotocol Label Switching (GMPLS) Ethernet Label Switching Architecture and Framework

    Informational
  • RFC 5787: OSPFv2 Routing Protocols Extensions for Automatically Switched Optical Network (ASON) Routing

    Experimental

    Obsoleted by RFC 6827

  • RFC 5814: Label Switched Path (LSP) Dynamic Provisioning Performance Metrics in Generalized MPLS Networks

    Proposed Standard
  • RFC 5710: PathErr Message Triggered MPLS and GMPLS LSP Reroutes

    Proposed Standard
  • RFC 5671: Applicability of the Path Computation Element (PCE) to Point-to-Multipoint (P2MP) MPLS and GMPLS Traffic Engineering (TE)

    Informational
  • RFC 5623: Framework for PCE-Based Inter-Layer MPLS and GMPLS Traffic Engineering

    Informational
  • RFC 5553: Resource Reservation Protocol (RSVP) Extensions for Path Key Support

    Proposed Standard
  • RFC 5521: Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions

    Proposed Standard
  • RFC 5493: Requirements for the Conversion between Permanent Connections and Switched Connections in a Generalized Multiprotocol Label Switching (GMPLS) Network

    Informational
  • RFC 5495: Description of the Resource Reservation Protocol - Traffic-Engineered (RSVP-TE) Graceful Restart Procedures

    Informational
  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

    Proposed Standard
  • RFC 5467: GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)

    Experimental

    Obsoleted by RFC 6387

  • RFC 5317: Joint Working Team (JWT) Report on MPLS Architectural Considerations for a Transport Profile

    Informational
  • RFC 5420: Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)

    Proposed Standard
  • RFC 5392: OSPF Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 5316: ISIS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard

    Obsoleted by RFC 9346

  • RFC 5376: Inter-AS Requirements for the Path Computation Element Communication Protocol (PCECP)

    Informational
  • RFC 5307: IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • RFC 5339: Evaluation of Existing GMPLS Protocols against Multi-Layer and Multi-Region Networks (MLN/MRN)

    Informational
  • RFC 5298: Analysis of Inter-Domain Label Switched Path (LSP) Recovery

    Informational
  • RFC 5212: Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)

    Informational
  • RFC 5253: Applicability Statement for Layer 1 Virtual Private Network (L1VPN) Basic Mode

    Informational
  • RFC 5145: Framework for MPLS-TE to GMPLS Migration

    Informational
  • RFC 5146: Interworking Requirements to Support Operation of MPLS-TE over GMPLS Networks

    Informational
  • RFC 5150: Label Switched Path Stitching with Generalized Multiprotocol Label Switching Traffic Engineering (GMPLS TE)

    Proposed Standard
  • RFC 5151: Inter-Domain MPLS and GMPLS Traffic Engineering -- Resource Reservation Protocol-Traffic Engineering (RSVP-TE) Extensions

    Proposed Standard
  • RFC 5152: A Per-Domain Path Computation Method for Establishing Inter-Domain Traffic Engineering (TE) Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 5143: Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation Service over MPLS (CEM) Encapsulation

    Historic

    Obsoleted by RFC 4842

  • RFC 5073: IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node Capabilities

    Proposed Standard
  • RFC 5063: Extensions to GMPLS Resource Reservation Protocol (RSVP) Graceful Restart

    Proposed Standard
  • RFC 4990: Use of Addresses in Generalized Multiprotocol Label Switching (GMPLS) Networks

    Informational
  • RFC 4974: Generalized MPLS (GMPLS) RSVP-TE Signaling Extensions in Support of Calls

    Proposed Standard
  • RFC 4972: Routing Extensions for Discovery of Multiprotocol (MPLS) Label Switch Router (LSR) Traffic Engineering (TE) Mesh Membership

    Proposed Standard
  • RFC 4920: Crankback Signaling Extensions for MPLS and GMPLS RSVP-TE

    Proposed Standard
  • RFC 4837: Managed Objects of Ethernet Passive Optical Networks (EPON)

    Proposed Standard
  • RFC 4927: Path Computation Element Communication Protocol (PCECP) Specific Requirements for Inter-Area MPLS and GMPLS Traffic Engineering

    Informational
  • RFC 4929: BCP 129: Change Process for Multiprotocol Label Switching (MPLS) and Generalized MPLS (GMPLS) Protocols and Procedures

    Best Current Practice
  • RFC 4906: Transport of Layer 2 Frames Over MPLS

    Historic
  • RFC 4872: RSVP-TE Extensions in Support of End-to-End Generalized Multi-Protocol Label Switching (GMPLS) Recovery

    Proposed Standard
  • RFC 4873: GMPLS Segment Recovery

    Proposed Standard
  • RFC 4842: Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation over Packet (CEP)

    Proposed Standard
  • RFC 4874: Exclude Routes - Extension to Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)

    Proposed Standard
  • RFC 4801: Definitions of Textual Conventions for Generalized Multiprotocol Label Switching (GMPLS) Management

    Proposed Standard
  • RFC 4802: Generalized Multiprotocol Label Switching (GMPLS) Traffic Engineering Management Information Base

    Proposed Standard
  • RFC 4803: Generalized Multiprotocol Label Switching (GMPLS) Label Switching Router (LSR) Management Information Base

    Proposed Standard
  • RFC 4783: GMPLS - Communication of Alarm Information

    Proposed Standard
  • RFC 4726: A Framework for Inter-Domain Multiprotocol Label Switching Traffic Engineering

    Informational
  • RFC 4736: Reoptimization of Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Loosely Routed Label Switched Path (LSP)

    Informational
  • RFC 4652: Evaluation of Existing Routing Protocols against Automatic Switched Optical Network (ASON) Routing Requirements

    Informational
  • Proposed Standard
  • RFC 4606: Generalized Multi-Protocol Label Switching (GMPLS) Extensions for Synchronous Optical Network (SONET) and Synchronous Digital Hierarchy (SDH) Control

    Proposed Standard
  • RFC 4558: Node-ID Based Resource Reservation Protocol (RSVP) Hello: A Clarification Statement

    Proposed Standard
  • RFC 4426: Generalized Multi-Protocol Label Switching (GMPLS) Recovery Functional Specification

    Proposed Standard
  • RFC 4427: Recovery (Protection and Restoration) Terminology for Generalized Multi-Protocol Label Switching (GMPLS)

    Informational
  • RFC 4428: Analysis of Generalized Multi-Protocol Label Switching (GMPLS)-based Recovery Mechanisms (including Protection and Restoration)

    Informational
  • Informational
  • RFC 4397: A Lexicography for the Interpretation of Generalized Multiprotocol Label Switching (GMPLS) Terminology within the Context of the ITU-T's Automatically Switched Optical Network (ASON) Architecture

    Informational
  • Proposed Standard

    Obsoleted by RFC 4631

  • RFC 4328: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control

    Proposed Standard
  • RFC 4257: Framework for Generalized Multi-Protocol Label Switching (GMPLS)-based Control of Synchronous Digital Hierarchy/Synchronous Optical Networking (SDH/SONET) Networks

    Informational
  • RFC 4258: Requirements for Generalized Multi-Protocol Label Switching (GMPLS) Routing for the Automatically Switched Optical Network (ASON)

    Informational
  • RFC 4197: Requirements for Edge-to-Edge Emulation of Time Division Multiplexed (TDM) Circuits over Packet Switching Networks

    Informational
  • Proposed Standard
  • Proposed Standard
  • RFC 4202: Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • RFC 4203: OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • Proposed Standard
  • RFC 4205: Intermediate System to Intermediate System (IS-IS) Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Informational

    Obsoleted by RFC 5307

  • RFC 4206: Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)

    Proposed Standard
  • Proposed Standard
  • RFC 4208: Generalized Multiprotocol Label Switching (GMPLS) User-Network Interface (UNI): Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Support for the Overlay Model

    Proposed Standard
  • RFC 4139: Requirements for Generalized MPLS (GMPLS) Signaling Usage and Extensions for Automatically Switched Optical Network (ASON)

    Informational
  • RFC 4054: Impairments and Other Constraints on Optical Layer Routing

    Informational
  • RFC 4003: GMPLS Signaling Procedure for Egress Control

    Proposed Standard
  • RFC 3945: Generalized Multi-Protocol Label Switching (GMPLS) Architecture

    Proposed Standard
  • RFC 3946: Generalized Multi-Protocol Label Switching (GMPLS) Extensions for Synchronous Optical Network (SONET) and Synchronous Digital Hierarchy (SDH) Control

    Proposed Standard

    Obsoleted by RFC 4606

  • RFC 3717: IP over Optical Networks: A Framework

    Informational
  • RFC 3604: Requirements for Adding Optical Support to the General Switch Management Protocol version 3 (GSMPv3)

    Informational
  • RFC 3609: Tracing Requirements for Generic Tunnels

    Informational
  • RFC 3591: Definitions of Managed Objects for the Optical Interface Type

    Proposed Standard
  • RFC 3592: Definitions of Managed Objects for the Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Interface Type

    Draft Standard
  • RFC 3572: Internet Protocol Version 6 over MAPOS (Multiple Access Protocol Over SONET/SDH)

    Informational
  • RFC 3474: Documentation of IANA assignments for Generalized MultiProtocol Label Switching (GMPLS) Resource Reservation Protocol - Traffic Engineering (RSVP-TE) Usage and Extensions for Automatically Switched Optical Network (ASON)

    Informational
  • RFC 3475: Documentation of IANA assignments for Constraint-Based LSP setup using LDP (CR-LDP) Extensions for Automatic Switched Optical Network (ASON)

    Informational
  • RFC 3476: Documentation of IANA Assignments for Label Distribution Protocol (LDP), Resource ReSerVation Protocol (RSVP), and Resource ReSerVation Protocol-Traffic Engineering (RSVP-TE) Extensions for Optical UNI Signaling

    Informational
  • RFC 3498: Definitions of Managed Objects for Synchronous Optical Network (SONET) Linear Automatic Protection Switching (APS) Architectures

    Proposed Standard
  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description

    Proposed Standard
  • RFC 3472: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Constraint-based Routed Label Distribution Protocol (CR-LDP) Extensions

    Proposed Standard
  • RFC 3473: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Extensions

    Proposed Standard
  • RFC 3422: Forwarding Media Access Control (MAC) Frames over Multiple Access Protocol over Synchronous Optical Network/Synchronous Digital Hierarchy (MAPOS)

    Informational
  • RFC 3255: Extending Point-to-Point Protocol (PPP) over Synchronous Optical NETwork/Synchronous Digital Hierarchy (SONET/SDH) with virtual concatenation, high order and low order payloads

    Proposed Standard
  • Experimental
  • RFC 2615: PPP over SONET/SDH

    Proposed Standard
  • RFC 1619: PPP over SONET/SDH

    Proposed Standard

    Obsoleted by RFC 2615

Subscribe to GMPLS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.