addressing

Addressing: IP address architecture, allocation and use

addressing subjects:

addressing RFCs (100)

Display RFCs as
  • RFC 9812: BCP 242: Clarification of IPv6 Address Allocation Policy

    Best Current Practice
  • RFC 9602: Segment Routing over IPv6 (SRv6) Segment Identifiers in the IPv6 Addressing Architecture

    Informational
  • RFC 8994: An Autonomic Control Plane (ACP)

    Proposed Standard
  • RFC 7871: Client Subnet in DNS Queries

    Informational
  • RFC 7814: Virtual Subnet: A BGP/MPLS IP VPN-Based Subnet Extension Solution

    Informational
  • RFC 7600: IPv4 Residual Deployment via IPv6 - A Stateless Solution (4rd)

    Experimental
  • RFC 7421: Analysis of the 64-bit Boundary in IPv6 Addressing

    Informational
  • Informational
  • RFC 7213: MPLS Transport Profile (MPLS-TP) Next-Hop Ethernet Addressing

    Proposed Standard
  • RFC 7054: Addressing Requirements and Design Considerations for Per-Interface Maintenance Entity Group Intermediate Points (MIPs)

    Informational
  • RFC 6964: Operational Guidance for IPv6 Deployment in IPv4 Sites Using the Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Informational
  • RFC 6751: Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)

    Experimental
  • RFC 6752: Issues with Private IP Addressing in the Internet

    Informational
  • RFC 6598: BCP 153: IANA-Reserved IPv4 Prefix for Shared Address Space

    Best Current Practice
  • RFC 6319: Issues Associated with Designating Additional Private IPv4 Address Space

    Informational
  • RFC 6306: Hierarchical IPv4 Framework

    Experimental
  • RFC 6254: Request to Move RFC 2754 to Historic Status

    Informational
  • RFC 6227: Design Goals for Scalable Internet Routing

    Informational
  • Proposed Standard
  • RFC 6177: BCP 157: IPv6 Address Assignment to End Sites

    Best Current Practice
  • RFC 6179: The Internet Routing Overlay Network (IRON)

    Experimental
  • RFC 6139: Routing and Addressing in Networks with Global Enterprise Recursion (RANGER) Scenarios

    Informational
  • RFC 6052: IPv6 Addressing of IPv4/IPv6 Translators

    Proposed Standard
  • RFC 5889: IP Addressing Model in Ad Hoc Networks

    Informational
  • Proposed Standard
  • RFC 5579: Transmission of IPv4 Packets over Intra-Site Automatic Tunnel Addressing Protocol (ISATAP) Interfaces

    Informational
  • RFC 5720: Routing and Addressing in Networks with Global Enterprise Recursion (RANGER)

    Informational
  • RFC 5684: Unintended Consequences of NAT Deployments with Overlapping Address Space

    Informational
  • RFC 5658: Addressing Record-Route Issues in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5393: Addressing an Amplification Vulnerability in Session Initiation Protocol (SIP) Forking Proxies

    Proposed Standard
  • RFC 5375: IPv6 Unicast Address Assignment Considerations

    Informational
  • RFC 5210: A Source Address Validation Architecture (SAVA) Testbed and Deployment Experience

    Experimental
  • RFC 5157: IPv6 Implications for Network Scanning

    Informational

    Obsoleted by RFC 7707

  • RFC 5214: Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Informational
  • RFC 5233: Sieve Email Filtering: Subaddress Extension

    Proposed Standard
  • RFC 4984: Report from the IAB Workshop on Routing and Addressing

    Informational
  • RFC 4944: Transmission of IPv6 Packets over IEEE 802.15.4 Networks

    Proposed Standard
  • Informational
  • RFC 4320: Actions Addressing Identified Issues with the Session Initiation Protocol's (SIP) Non-INVITE Transaction

    Proposed Standard
  • RFC 4238: Voice Message Routing Service

    Proposed Standard
  • RFC 4214: Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

    Experimental

    Obsoleted by RFC 5214

  • RFC 4147: Proposed Changes to the Format of the IANA IPv6 Registry

    Informational
  • Proposed Standard
  • RFC 4007: IPv6 Scoped Address Architecture

    Proposed Standard
  • RFC 3804: Voice Profile for Internet Mail (VPIM) Addressing

    Proposed Standard
  • RFC 3701: 6bone (IPv6 Testing Address Allocation) Phaseout

    Informational
  • RFC 3598: Sieve Email Filtering -- Subaddress Extension

    Proposed Standard

    Obsoleted by RFC 5233

  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

    Proposed Standard
  • RFC 3531: A Flexible Method for Managing the Assignment of Bits of an IPv6 Address Block

    Informational
  • RFC 3194: The H-Density Ratio for Address Assignment Efficiency An Update on the H ratio

    Informational
  • RFC 3102: Realm Specific IP: Framework

    Experimental
  • RFC 3104: RSIP Support for End-to-end IPsec

    Experimental
  • RFC 3105: Finding an RSIP Server with SLP

    Experimental
  • RFC 3177: IAB/IESG Recommendations on IPv6 Address Allocations to Sites

    Informational

    Obsoleted by RFC 6177

  • RFC 3069: VLAN Aggregation for Efficient IP Address Allocation

    Informational
  • RFC 2901: FYI 37: Guide to Administrative Procedures of the Internet Infrastructure

    Informational
  • RFC 2814: SBM (Subnet Bandwidth Manager): A Protocol for RSVP-based Admission Control over IEEE 802-style networks

    Proposed Standard
  • RFC 2644: BCP 34: Changing the Default for Directed Broadcasts in Routers

    Best Current Practice
  • RFC 2471: IPv6 Testing Address Allocation

    Historic

    Obsoleted by RFC 3701

  • RFC 2175: MAPOS 16 - Multiple Access Protocol over SONET/SDH with 16 Bit Addressing

    Informational
  • RFC 2101: IPv4 Address Behaviour Today

    Informational
  • RFC 2103: Mobility Support for Nimrod : Challenges and Solution Approaches

    Informational
  • RFC 2009: GPS-Based Addressing and Routing

    Experimental
  • RFC 2050: Internet Registry IP Allocation Guidelines

    Historic

    Obsoleted by RFC 7020

  • RFC 1955: New Scheme for Internet Routing and Addressing (ENCAPS) for IPNG

    Informational
  • RFC 1879: Class A Subnet Experiment Results and Recommendations

    Informational
  • RFC 1897: IPv6 Testing Address Allocation

    Experimental

    Obsoleted by RFC 2471

  • RFC 1878: Variable Length Subnet Table For IPv4

    Historic
  • RFC 1881: IPv6 Address Allocation Management

    Informational
  • RFC 1884: IP Version 6 Addressing Architecture

    Historic

    Obsoleted by RFC 2373

  • RFC 1887: An Architecture for IPv6 Unicast Address Allocation

    Informational
  • RFC 1860: Variable Length Subnet Table For IPv4

    Informational

    Obsoleted by RFC 1878

  • RFC 1814: Unique Addresses are Good

    Informational
  • RFC 1797: Class A Subnet Experiment

    Experimental
  • RFC 1744: Observations on the Management of the Internet Address Space

    Informational
  • RFC 1753: IPng Technical Requirements Of the Nimrod Routing and Addressing Architecture

    Informational
  • RFC 1715: The H Ratio for Address Assignment Efficiency

    Informational
  • RFC 1597: Address Allocation for Private Internets

    Informational

    Obsoleted by RFC 1918

  • RFC 1380: IESG Deliberations on Routing and Addressing

    Informational
  • RFC 1385: EIP: The Extended Internet Protocol

    Historic

    Obsoleted by RFC 6814

  • RFC 1366: Guidelines for Management of IP Address Space

    Informational

    Obsoleted by RFC 1466

  • RFC 1367: Schedule for IP Address Space Management Guidelines

    Informational

    Obsoleted by RFC 1467

  • RFC 1375: Suggestion for New Classes of IP Addresses

    Informational
  • RFC 1347: TCP and UDP with Bigger Addresses (TUBA), A Simple Proposal for Internet Addressing and Routing

    Historic
  • RFC 1335: A Two-Tier Address Structure for the Internet: A Solution to the Problem of Address Space Exhaustion

    Informational
  • RFC 1219: On the assignment of subnet numbers

    Informational
  • RFC 1027: Using ARP to implement transparent subnet gateways

    Unknown
  • RFC 982: Guidelines for the specification of the structure of the Domain Specific Part (DSP) of the ISO standard NSAP address

    Unknown
  • RFC 950: STD 5: Internet Standard Subnetting Procedure

    Internet Standard
  • RFC 947: Multi-network broadcasting within the Internet

    Unknown
  • RFC 940: Toward an Internet standard scheme for subnetting

    Unknown
  • RFC 941: Addendum to the network service definition covering network layer addressing

    Unknown
  • RFC 936: Another Internet subnet addressing scheme

    Unknown
  • RFC 932: Subnetwork addressing scheme

    Unknown
  • RFC 917: Internet subnets

    Unknown
  • RFC 919: STD 5: Broadcasting Internet Datagrams

    Internet Standard
  • RFC 922: STD 5: Broadcasting Internet datagrams in the presence of subnets

    Internet Standard
  • RFC 887: Resource Location Protocol

    Experimental
  • RFC 824: CRONUS Virtual Local Network

    Unknown
  • RFC 730: Extensible field addressing

    Unknown

Subscribe to addressing

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.