CIDR

CIDR (Classless Inter-Domain Routing) and aggregation

CIDR RFCs (17)

Display RFCs as
  • RFC 7608: BCP 198: IPv6 Prefix Length Recommendation for Forwarding

    Best Current Practice
  • RFC 4632: BCP 122: Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan

    Best Current Practice
  • RFC 2519: A Framework for Inter-Domain Route Aggregation

    Informational
  • RFC 2008: BCP 7: Implications of Various Address Allocation Policies for Internet Routing

    Best Current Practice
  • RFC 2036: Observations on the use of Components of the Class A Address Space within the Internet

    Historic
  • RFC 1917: BCP 4: An Appeal to the Internet Community to Return Unused IP Networks (Prefixes) to the IANA

    Best Current Practice
  • RFC 1918: BCP 5: Address Allocation for Private Internets

    Best Current Practice
  • RFC 1817: CIDR and Classful Routing

    Historic
  • RFC 1517: Applicability Statement for the Implementation of Classless Inter-Domain Routing (CIDR)

    Historic
  • RFC 1518: An Architecture for IP Address Allocation with CIDR

    Historic
  • RFC 1519: Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy

    Proposed Standard

    Obsoleted by RFC 4632

  • RFC 1520: Exchanging Routing Information Across Provider Boundaries in the CIDR Environment

    Historic
  • RFC 1467: Status of CIDR Deployment in the Internet

    Historic
  • RFC 1481: IAB Recommendation for an Intermediate Strategy to Address the Issue of Scaling

    Historic
  • RFC 1482: Aggregation Support in the NSFNET Policy-Based Routing Database

    Historic
  • RFC 1466: Guidelines for Management of IP Address Space

    Informational

    Obsoleted by RFC 2050

  • RFC 1338: Supernetting: an Address Assignment and Aggregation Strategy

    Informational

    Obsoleted by RFC 1519

Subscribe to CIDR

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.