SNMP

SNMP (Simple Network Management Protocol) framework and security

SNMP subjects:

SNMP RFCs (72)

Display RFCs as
  • RFC 7860: HMAC-SHA-2 Authentication Protocols in User-Based Security Model (USM) for SNMPv3

    Proposed Standard
  • RFC 7630: HMAC-SHA-2 Authentication Protocols in the User-based Security Model (USM) for SNMPv3

    Proposed Standard

    Obsoleted by RFC 7860

  • RFC 7407: A YANG Data Model for SNMP Configuration

    Proposed Standard
  • RFC 7241: The IEEE 802/IETF Relationship

    Informational
  • RFC 5675: Mapping Simple Network Management Protocol (SNMP) Notifications to SYSLOG Messages

    Proposed Standard
  • RFC 5608: Remote Authentication Dial-In User Service (RADIUS) Usage for Simple Network Management Protocol (SNMP) Transport Models

    Proposed Standard
  • RFC 5607: Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) Management

    Proposed Standard
  • RFC 5591: STD 78: Transport Security Model for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 5592: Secure Shell Transport Model for the Simple Network Management Protocol (SNMP)

    Proposed Standard
  • RFC 5345: Simple Network Management Protocol (SNMP) Traffic Measurements and Trace Exchange Formats

    Informational
  • RFC 5343: STD 78: Simple Network Management Protocol (SNMP) Context EngineID Discovery

    Internet Standard
  • RFC 4789: Simple Network Management Protocol (SNMP) over IEEE 802 Networks

    Proposed Standard
  • RFC 4441: The IEEE 802/IETF Relationship

    Informational

    Obsoleted by RFC 7241

  • RFC 4097: Middlebox Communications (MIDCOM) Protocol Evaluation

    Informational
  • RFC 4088: Uniform Resource Identifier (URI) Scheme for the Simple Network Management Protocol (SNMP)

    Proposed Standard
  • RFC 3780: SMIng - Next Generation Structure of Management Information

    Experimental
  • RFC 3781: Next Generation Structure of Management Information (SMIng) Mappings to the Simple Network Management Protocol (SNMP)

    Experimental
  • RFC 3512: Configuring Networks and Devices with Simple Network Management Protocol (SNMP)

    Informational
  • RFC 3410: Introduction and Applicability Statements for Internet-Standard Management Framework

    Informational
  • RFC 3411: STD 62: An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks

    Internet Standard
  • RFC 3412: STD 62: Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 3413: STD 62: Simple Network Management Protocol (SNMP) Applications

    Internet Standard
  • RFC 3430: Simple Network Management Protocol Over Transmission Control Protocol Transport Mapping

    Experimental
  • RFC 2962: An SNMP Application Level Gateway for Payload Address Translation

    Informational
  • RFC 2856: Textual Conventions for Additional High Capacity Data Types

    Proposed Standard
  • RFC 2570: Introduction to Version 3 of the Internet-standard Network Management Framework

    Informational

    Obsoleted by RFC 3410

  • RFC 2571: An Architecture for Describing SNMP Management Frameworks

    Draft Standard

    Obsoleted by RFC 3411

  • RFC 2572: Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)

    Draft Standard

    Obsoleted by RFC 3412

  • RFC 2573: SNMP Applications

    Draft Standard

    Obsoleted by RFC 3413

  • RFC 2261: An Architecture for Describing SNMP Management Frameworks

    Proposed Standard

    Obsoleted by RFC 2271

  • RFC 2262: Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 2272

  • RFC 2263: SNMPv3 Applications

    Proposed Standard

    Obsoleted by RFC 2273

  • RFC 2264: User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)

    Proposed Standard

    Obsoleted by RFC 2274

  • RFC 2265: View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 2275

  • RFC 2271: An Architecture for Describing SNMP Management Frameworks

    Proposed Standard

    Obsoleted by RFC 2571

  • RFC 2272: Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 2572

  • RFC 2273: SNMPv3 Applications

    Proposed Standard

    Obsoleted by RFC 2573

  • RFC 2274: User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)

    Proposed Standard

    Obsoleted by RFC 2574

  • RFC 2275: View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 2575

  • RFC 2089: V2ToV1 Mapping SNMPv2 onto SNMPv1 within a bi-lingual SNMP agent

    Informational

    Obsoleted by RFC 2576

  • RFC 1909: An Administrative Infrastructure for SNMPv2

    Historic
  • RFC 1910: User-based Security Model for SNMPv2

    Historic
  • RFC 1901: Introduction to Community-based SNMPv2

    Historic
  • RFC 1902: Structure of Management Information for Version 2 of the Simple Network Management Protocol (SNMPv2)

    Draft Standard

    Obsoleted by RFC 2578

  • RFC 1903: Textual Conventions for Version 2 of the Simple Network Management Protocol (SNMPv2)

    Draft Standard

    Obsoleted by RFC 2579

  • RFC 1904: Conformance Statements for Version 2 of the Simple Network Management Protocol (SNMPv2)

    Draft Standard

    Obsoleted by RFC 2580

  • RFC 1592: Simple Network Management Protocol Distributed Protocol Interface Version 2.0

    Experimental
  • RFC 1503: Algorithms for Automating Administration in SNMPv2 Managers

    Informational
  • RFC 1441: Introduction to version 2 of the Internet-standard Network Management Framework

    Historic
  • RFC 1443: Textual Conventions for version 2 of the Simple Network Management Protocol (SNMPv2)

    Proposed Standard

    Obsoleted by RFC 1903

  • RFC 1444: Conformance Statements for version 2 of the Simple Network Management Protocol (SNMPv2)

    Proposed Standard

    Obsoleted by RFC 1904

  • RFC 1445: Administrative Model for version 2 of the Simple Network Management Protocol (SNMPv2)

    Historic
  • RFC 1446: Security Protocols for version 2 of the Simple Network Management Protocol (SNMPv2)

    Historic
  • RFC 1448: Protocol Operations for version 2 of the Simple Network Management Protocol (SNMPv2)

    Proposed Standard

    Obsoleted by RFC 1905

  • RFC 1449: Transport Mappings for version 2 of the Simple Network Management Protocol (SNMPv2)

    Proposed Standard

    Obsoleted by RFC 1906

  • RFC 1452: Coexistence between version 1 and version 2 of the Internet-standard Network Management Framework

    Proposed Standard

    Obsoleted by RFC 1908

  • RFC 1418: SNMP over OSI

    Historic
  • RFC 1419: SNMP over AppleTalk

    Historic
  • RFC 1420: SNMP over IPX

    Proposed Standard
  • RFC 1351: SNMP Administrative Model

    Historic
  • RFC 1352: SNMP Security Protocols

    Historic
  • RFC 1298: SNMP over IPX

    Informational

    Obsoleted by RFC 1420

  • RFC 1270: SNMP Communications Services

    Informational
  • RFC 1224: Techniques for managing asynchronously generated alerts

    Experimental
  • RFC 1228: SNMP-DPI: Simple Network Management Protocol Distributed Program Interface

    Experimental

    Obsoleted by RFC 1592

  • RFC 1215: Convention for defining traps for use with the SNMP

    Informational
  • RFC 1187: Bulk Table Retrieval with the SNMP

    Experimental
  • RFC 1161: SNMP over OSI

    Experimental

    Obsoleted by RFC 1418

  • RFC 1157: Simple Network Management Protocol (SNMP)

    Historic
  • RFC 1098: Simple Network Management Protocol (SNMP)

    Unknown

    Obsoleted by RFC 1157

  • RFC 1089: SNMP over Ethernet

    Unknown

    Obsoleted by RFC 4789

  • RFC 1067: Simple Network Management Protocol

    Unknown

    Obsoleted by RFC 1098

Subscribe to SNMP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.