SMTP

SMTP (Simple Mail Transfer Protocol) and mail relaying/submission

SMTP RFCs (129)

Display RFCs as
  • RFC 10022: IMAP UIDBATCHES Extension

    Proposed Standard
  • RFC 9979: Registration of Further IMAP/JMAP Keywords and Mailbox Name Attributes

    Informational
  • RFC 9422: The LIMITS SMTP Service Extension

    Proposed Standard
  • RFC 8997: Deprecation of TLS 1.1 for Email Submission and Access

    Proposed Standard
  • RFC 8689: SMTP Require TLS Option

    Proposed Standard
  • RFC 8460: SMTP TLS Reporting

    Proposed Standard
  • RFC 8461: SMTP MTA Strict Transport Security (MTA-STS)

    Proposed Standard
  • RFC 8314: Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access

    Proposed Standard
  • RFC 7960: Interoperability Issues between Domain-based Message Authentication, Reporting, and Conformance (DMARC) and Indirect Email Flows

    Informational
  • Proposed Standard
  • RFC 7672: SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)

    Proposed Standard
  • RFC 7504: SMTP 521 and 556 Reply Codes

    Proposed Standard
  • RFC 7293: The Require-Recipient-Valid-Since Header Field and SMTP Service Extension

    Proposed Standard
  • RFC 7103: Advice for Safe Handling of Malformed Messages

    Informational
  • RFC 6758: Tunneling of SMTP Message Transfer Priorities

    Informational
  • RFC 6710: Simple Mail Transfer Protocol Extension for Message Transfer Priorities

    Proposed Standard
  • RFC 6647: Email Greylisting: An Applicability Statement for SMTP

    Proposed Standard
  • RFC 6530: Overview and Framework for Internationalized Email

    Proposed Standard
  • RFC 6531: SMTP Extension for Internationalized Email

    Proposed Standard
  • RFC 6409: STD 72: Message Submission for Mail

    Internet Standard
  • RFC 6186: Use of SRV Records for Locating Email Submission/Access Services

    Proposed Standard
  • RFC 6152: STD 71: SMTP Service Extension for 8-bit MIME Transport

    Internet Standard
  • RFC 6009: Sieve Email Filtering: Delivery Status Notifications and Deliver-By Extensions

    Proposed Standard
  • RFC 5784: Sieve Email Filtering: Sieves and Display Directives in XML

    Proposed Standard
  • RFC 5616: Streaming Internet Messaging Attachments

    Informational
  • RFC 5550: The Internet Email to Support Diverse Service Environments (Lemonade) Profile

    Proposed Standard
  • RFC 5551: Lemonade Notifications Architecture

    Informational
  • RFC 5617: DomainKeys Identified Mail (DKIM) Author Domain Signing Practices (ADSP)

    Historic
  • RFC 5598: Internet Mail Architecture

    Informational
  • RFC 5524: Extended URLFETCH for Binary and Converted Parts

    Proposed Standard
  • RFC 5423: Internet Message Store Events

    Proposed Standard
  • RFC 5429: Sieve Email Filtering: Reject and Extended Reject Extensions

    Proposed Standard
  • RFC 5442: LEMONADE Architecture - Supporting Open Mobile Alliance (OMA) Mobile Email (MEM) Using Internet Mail

    Informational
  • RFC 5463: Sieve Email Filtering: Ihave Extension

    Proposed Standard
  • RFC 5465: The IMAP NOTIFY Extension

    Proposed Standard
  • RFC 5466: IMAP4 Extension for Named Searches (Filters)

    Proposed Standard
  • RFC 5383: BCP 143: Deployment Considerations for Lemonade-Compliant Mobile Email

    Best Current Practice
  • RFC 5321: Simple Mail Transfer Protocol

    Draft Standard
  • RFC 5336: SMTP Extension for Internationalized Email Addresses

    Experimental

    Obsoleted by RFC 6531

  • RFC 5337: Internationalized Delivery Status and Disposition Notifications

    Experimental

    Obsoleted by RFC 6533

  • RFC 5259: Internet Message Access Protocol - CONVERT Extension

    Proposed Standard
  • RFC 5260: Sieve Email Filtering: Date and Index Extensions

    Proposed Standard
  • RFC 5248: BCP 138: A Registry for SMTP Enhanced Mail System Status Codes

    Best Current Practice
  • RFC 5162: IMAP4 Extensions for Quick Mailbox Resynchronization

    Proposed Standard

    Obsoleted by RFC 7162

  • RFC 5092: IMAP URL Scheme

    Proposed Standard
  • RFC 5068: BCP 134: Email Submission Operations: Access and Accountability Requirements

    Best Current Practice
  • RFC 5032: WITHIN Search Extension to the IMAP Protocol

    Proposed Standard
  • RFC 4978: The IMAP COMPRESS Extension

    Proposed Standard
  • RFC 4952: Overview and Framework for Internationalized Email

    Informational

    Obsoleted by RFC 6530

  • RFC 4954: SMTP Service Extension for Authentication

    Proposed Standard
  • RFC 4865: SMTP Submission Service Extension for Future Message Release

    Proposed Standard
  • RFC 4902: Integrity, Privacy, and Security in Open Pluggable Edge Services (OPES) for SMTP

    Informational
  • RFC 4550: Internet Email to Support Diverse Service Environments (Lemonade) Profile

    Proposed Standard

    Obsoleted by RFC 5550

  • RFC 4467: Internet Message Access Protocol (IMAP) - URLAUTH Extension

    Proposed Standard
  • RFC 4468: Message Submission BURL Extension

    Proposed Standard
  • RFC 4496: Open Pluggable Edge Services (OPES) SMTP Use Cases

    Informational
  • RFC 4405: SMTP Service Extension for Indicating the Responsible Submitter of an E-Mail Message

    Historic
  • RFC 4406: Sender ID: Authenticating E-Mail

    Historic
  • RFC 4409: Message Submission for Mail

    Draft Standard

    Obsoleted by RFC 6409

  • RFC 4469: Internet Message Access Protocol (IMAP) CATENATE Extension

    Proposed Standard
  • RFC 4416: Goals for Internet Messaging to Support Diverse Service Environments

    Informational
  • RFC 4356: Mapping Between the Multimedia Messaging Service (MMS) and Internet Mail

    Proposed Standard
  • RFC 4141: SMTP and MIME Extensions for Content Conversion

    Proposed Standard
  • RFC 4130: MIME-Based Secure Peer-to-Peer Business Data Interchange Using HTTP, Applicability Statement 2 (AS2)

    Proposed Standard
  • RFC 4095: Attaching Meaning to Solicitation Class Keywords

    Proposed Standard
  • RFC 3974: SMTP Operational Experience in Mixed IPv4/v6 Environments

    Informational
  • RFC 3885: SMTP Service Extension for Message Tracking

    Proposed Standard
  • RFC 3886: An Extensible Message Format for Message Tracking Responses

    Proposed Standard
  • RFC 3887: Message Tracking Query Protocol

    Proposed Standard
  • RFC 3888: Message Tracking Model and Requirements

    Informational
  • RFC 3865: A No Soliciting Simple Mail Transfer Protocol (SMTP) Service Extension

    Proposed Standard
  • RFC 3848: ESMTP and LMTP Transmission Types Registration

    Draft Standard
  • RFC 3461: Simple Mail Transfer Protocol (SMTP) Service Extension for Delivery Status Notifications (DSNs)

    Draft Standard
  • RFC 3463: Enhanced Mail System Status Codes

    Draft Standard
  • RFC 3207: SMTP Service Extension for Secure SMTP over Transport Layer Security

    Proposed Standard
  • RFC 2821: Simple Mail Transfer Protocol

    Proposed Standard

    Obsoleted by RFC 5321

  • RFC 2822: Internet Message Format

    Proposed Standard

    Obsoleted by RFC 5322

  • RFC 3030: SMTP Service Extensions for Transmission of Large and Binary MIME Messages

    Proposed Standard
  • RFC 2920: STD 60: SMTP Service Extension for Command Pipelining

    Internet Standard
  • RFC 2852: Deliver By SMTP Service Extension

    Proposed Standard
  • RFC 2788: Network Services Monitoring MIB

    Proposed Standard
  • RFC 2789: Mail Monitoring MIB

    Proposed Standard
  • RFC 2645: ON-DEMAND MAIL RELAY (ODMR) SMTP with Dynamic IP Addresses

    Proposed Standard
  • RFC 2605: Directory Server Monitoring MIB

    Proposed Standard
  • RFC 2554: SMTP Service Extension for Authentication

    Proposed Standard

    Obsoleted by RFC 4954

  • RFC 2505: BCP 30: Anti-Spam Recommendations for SMTP MTAs

    Best Current Practice
  • RFC 2524: Neda's Efficient Mail Submission and Delivery (EMSD) Protocol Specification Version 1.3

    Informational
  • RFC 2487: SMTP Service Extension for Secure SMTP over TLS

    Proposed Standard

    Obsoleted by RFC 3207

  • RFC 2476: Message Submission

    Proposed Standard

    Obsoleted by RFC 4409

  • RFC 2442: The Batch SMTP Media Type

    Informational
  • RFC 2248: Network Services Monitoring MIB

    Proposed Standard

    Obsoleted by RFC 2788

  • RFC 2249: Mail Monitoring MIB

    Proposed Standard

    Obsoleted by RFC 2789

  • RFC 2234: Augmented BNF for Syntax Specifications: ABNF

    Proposed Standard

    Obsoleted by RFC 4234

  • RFC 2197: SMTP Service Extension for Command Pipelining

    Draft Standard

    Obsoleted by RFC 2920

  • RFC 2076: Common Internet Message Headers

    Informational
  • RFC 2017: Definition of the URL MIME External-Body Access-Type

    Proposed Standard
  • RFC 2033: Local Mail Transfer Protocol

    Informational
  • RFC 2034: SMTP Service Extension for Returning Enhanced Error Codes

    Proposed Standard
  • RFC 1985: SMTP Service Extension for Remote Message Queue Starting

    Proposed Standard
  • RFC 1911: Voice Profile for Internet Mail

    Experimental

    Obsoleted by RFC 2421, RFC 2422, RFC 2423

  • RFC 1891: SMTP Service Extension for Delivery Status Notifications

    Proposed Standard

    Obsoleted by RFC 3461

  • RFC 1892: The Multipart/Report Content Type for the Reporting of Mail System Administrative Messages

    Proposed Standard

    Obsoleted by RFC 3462

  • RFC 1893: Enhanced Mail System Status Codes

    Proposed Standard

    Obsoleted by RFC 3463

  • RFC 1894: An Extensible Message Format for Delivery Status Notifications

    Proposed Standard

    Obsoleted by RFC 3464

  • RFC 1869: STD 10: SMTP Service Extensions

    Internet Standard

    Obsoleted by RFC 2821

  • RFC 1870: STD 10: SMTP Service Extension for Message Size Declaration

    Internet Standard
  • RFC 1854: SMTP Service Extension for Command Pipelining

    Proposed Standard

    Obsoleted by RFC 2197

  • RFC 1845: SMTP Service Extension for Checkpoint/Restart

    Experimental
  • RFC 1846: SMTP 521 Reply Code

    Experimental
  • RFC 1830: SMTP Service Extensions for Transmission of Large and Binary MIME Messages

    Experimental

    Obsoleted by RFC 3030

  • RFC 1844: Multimedia E-mail (MIME) User Agent Checklist

    Informational
  • RFC 1651: SMTP Service Extensions

    Draft Standard

    Obsoleted by RFC 1869

  • RFC 1652: SMTP Service Extension for 8bit-MIMEtransport

    Draft Standard

    Obsoleted by RFC 6152

  • RFC 1653: SMTP Service Extension for Message Size Declaration

    Draft Standard

    Obsoleted by RFC 1870

  • RFC 1565: Network Services Monitoring MIB

    Proposed Standard

    Obsoleted by RFC 2248

  • RFC 1566: Mail Monitoring MIB

    Proposed Standard

    Obsoleted by RFC 2249, RFC 2789

  • RFC 1567: X.500 Directory Monitoring MIB

    Proposed Standard

    Obsoleted by RFC 2605

  • RFC 1425: SMTP Service Extensions

    Proposed Standard

    Obsoleted by RFC 1651

  • RFC 1426: SMTP Service Extension for 8bit-MIMEtransport

    Proposed Standard

    Obsoleted by RFC 1652

  • RFC 1427: SMTP Service Extension for Message Size Declaration

    Proposed Standard

    Obsoleted by RFC 1653

  • RFC 1428: Transition of Internet Mail from Just-Send-8 to 8bit-SMTP/MIME

    Informational
  • RFC 1405: Mapping between X.400(1984/1988) and Mail-11 (DECnet mail)

    Experimental

    Obsoleted by RFC 2162

  • RFC 1168: Intermail and Commercial Mail Relay services

    Informational
  • RFC 1090: SMTP on X.25

    Unknown
  • RFC 1047: Duplicate messages and SMTP

    Unknown
  • RFC 876: Survey of SMTP implementations

    Unknown
  • RFC 847: Summary of Smallberg surveys

    Unknown
  • RFC 821: STD 10: Simple Mail Transfer Protocol

    Internet Standard

    Obsoleted by RFC 2821

  • RFC 788: Simple Mail Transfer Protocol

    Unknown

    Obsoleted by RFC 821

Subscribe to SMTP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.