Sieve

Sieve email filtering language

Sieve RFCs (61)

Display RFCs as
  • RFC 9755: IMAP Support for UTF-8

    Proposed Standard
  • RFC 9738: IMAP MESSAGELIMIT Extension

    Experimental
  • RFC 9698: The JMAPACCESS Extension for IMAP

    Proposed Standard
  • RFC 9671: Sieve Email Filtering: Extension for Processing Calendar Attachments

    Proposed Standard
  • RFC 9661: The JSON Meta Application Protocol (JMAP) for Sieve Scripts

    Proposed Standard
  • RFC 9585: IMAP Response Code for Command Progress Notifications

    Proposed Standard
  • RFC 9590: IMAP Extension for Returning Mailbox METADATA in Extended LIS

    Proposed Standard
  • RFC 9586: IMAP Extension for Using and Returning Unique Identifiers (UIDs) Only

    Experimental
  • RFC 9122: IANA Registry for Sieve Actions

    Proposed Standard
  • RFC 9394: IMAP PARTIAL Extension for Paged SEARCH and FETCH

    Proposed Standard
  • RFC 9208: IMAP QUOTA Extension

    Proposed Standard
  • RFC 9051: Internet Message Access Protocol (IMAP) - Version 4rev2

    Proposed Standard
  • RFC 9042: Sieve Email Filtering: Delivery by MAILBOXID

    Proposed Standard
  • RFC 8970: IMAP4 Extension: Message Preview Generation

    Proposed Standard
  • RFC 8579: Sieve Email Filtering: Delivering to Special-Use Mailboxes

    Proposed Standard
  • RFC 8580: Sieve Extension: File Carbon Copy (FCC)

    Proposed Standard
  • RFC 8508: IMAP REPLACE Extension

    Proposed Standard
  • RFC 8514: Internet Message Access Protocol (IMAP) - SAVEDATE Extension

    Proposed Standard
  • RFC 8474: IMAP Extension for Object Identifiers

    Proposed Standard
  • RFC 8457: IMAP "$Important" Keyword and "\Important" Special-Use Attribute

    Proposed Standard
  • RFC 8437: IMAP UNAUTHENTICATE Extension for Connection Reuse

    Proposed Standard
  • RFC 8438: IMAP Extension for STATUS=SIZE

    Proposed Standard
  • RFC 8440: IMAP4 Extension for Returning MYRIGHTS Information in Extended LIST

    Proposed Standard
  • RFC 7352: Sieve Email Filtering: Detecting Duplicate Deliveries

    Proposed Standard
  • RFC 6785: Support for Internet Message Access Protocol (IMAP) Events in Sieve

    Proposed Standard
  • RFC 6609: Sieve Email Filtering: Include Extension

    Proposed Standard
  • RFC 6558: Sieve Extension for Converting Messages before Delivery

    Proposed Standard
  • RFC 6468: Sieve Notification Mechanism: SIP MESSAGE

    Proposed Standard
  • RFC 6131: Sieve Vacation Extension: "Seconds" Parameter

    Proposed Standard
  • RFC 6132: Sieve Notification Using Presence Information

    Proposed Standard
  • RFC 6133: Sieve Email Filtering: Use of Presence Information with Auto-Responder Functionality

    Informational
  • RFC 6134: Sieve Extension: Externally Stored Lists

    Proposed Standard
  • RFC 6009: Sieve Email Filtering: Delivery Status Notifications and Deliver-By Extensions

    Proposed Standard
  • RFC 5804: A Protocol for Remotely Managing Sieve Scripts

    Proposed Standard
  • RFC 5784: Sieve Email Filtering: Sieves and Display Directives in XML

    Proposed Standard
  • RFC 5703: Sieve Email Filtering: MIME Part Tests, Iteration, Extraction, Replacement, and Enclosure

    Proposed Standard
  • RFC 5550: The Internet Email to Support Diverse Service Environments (Lemonade) Profile

    Proposed Standard
  • RFC 5598: Internet Mail Architecture

    Informational
  • RFC 5490: The Sieve Mail-Filtering Language -- Extensions for Checking Mailbox Status and Accessing Mailbox Metadata

    Proposed Standard
  • RFC 5429: Sieve Email Filtering: Reject and Extended Reject Extensions

    Proposed Standard
  • RFC 5463: Sieve Email Filtering: Ihave Extension

    Proposed Standard
  • RFC 5435: Sieve Email Filtering: Extension for Notifications

    Proposed Standard
  • RFC 5436: Sieve Notification Mechanism: mailto

    Proposed Standard
  • RFC 5437: Sieve Notification Mechanism: Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 5293: Sieve Email Filtering: Editheader Extension

    Proposed Standard
  • RFC 5260: Sieve Email Filtering: Date and Index Extensions

    Proposed Standard
  • RFC 5183: Sieve Email Filtering: Environment Extension

    Proposed Standard
  • RFC 5173: Sieve Email Filtering: Body Extension

    Proposed Standard
  • RFC 5228: Sieve: An Email Filtering Language

    Proposed Standard
  • RFC 5229: Sieve Email Filtering: Variables Extension

    Proposed Standard
  • RFC 5230: Sieve Email Filtering: Vacation Extension

    Proposed Standard
  • RFC 5231: Sieve Email Filtering: Relational Extension

    Proposed Standard
  • RFC 5232: Sieve Email Filtering: Imap4flags Extension

    Proposed Standard
  • RFC 5233: Sieve Email Filtering: Subaddress Extension

    Proposed Standard
  • RFC 5235: Sieve Email Filtering: Spamtest and Virustest Extensions

    Proposed Standard
  • RFC 5068: BCP 134: Email Submission Operations: Access and Accountability Requirements

    Best Current Practice
  • RFC 3894: Sieve Extension: Copying Without Side Effects

    Proposed Standard
  • RFC 3685: SIEVE Email Filtering: Spamtest and VirusTest Extensions

    Proposed Standard

    Obsoleted by RFC 5235

  • RFC 3598: Sieve Email Filtering -- Subaddress Extension

    Proposed Standard

    Obsoleted by RFC 5233

  • RFC 3431: Sieve Extension: Relational Tests

    Proposed Standard

    Obsoleted by RFC 5231

  • RFC 3028: Sieve: A Mail Filtering Language

    Proposed Standard

    Obsoleted by RFC 5228, RFC 5429

Subscribe to Sieve

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.