OSI
OSI (Open Systems Interconnection) network-layer protocols and coexistence with IP
Within this page
OSI subjects:
- CLNP11 RFCs
OSI RFCs (45)
RFC 9134: RTP Payload Format for ISO/IEC 21122 (JPEG XS)
Proposed Standard- T. Bruylants
- A. Descampe
- C. Damman
- T. Richter
- October 2021
- IETF publication
- Web and Internet Transport
Abstract
This document specifies a Real-Time Transport Protocol (RTP) payload format to be used for transporting video encoded with JPEG XS (ISO/IEC 21122). JPEG XS is a low-latency, lightweight image coding system. Compared to an uncompressed video use case, it allows higher resolutions and video frame rates while offering visually lossless quality, reduced power consumption, and encoding-decoding latency confined to a fraction of a video frame.
Abstract
This document specifies a Real-Time Transport Protocol (RTP) payload format to be used for transporting video encoded with JPEG XS (ISO/IEC 21122). JPEG XS is a low-latency, lightweight image coding system. Compared to an uncompressed video use case, it allows higher resolutions and video frame rates while offering visually lossless quality, reduced power consumption, and encoding-decoding latency confined to a fraction of a video frame.
RFC 5458: Security Requirements for the Unidirectional Lightweight Encapsulation (ULE) Protocol
Informational- H. Cruickshank
- P. Pillai
- M. Noisternig
- S. Iyengar
- March 2009
- IETF publication
- Applications Area
Abstract
The MPEG-2 standard defined by ISO 13818-1 supports a range of transmission methods for a variety of services. This document provides a threat analysis and derives the security requirements when using the Transport Stream, TS, to support an Internet network-layer using Unidirectional Lightweight Encapsulation (ULE) defined in RFC 4326. The document also provides the motivation for link-layer security for a ULE Stream. A ULE Stream may be used to send IPv4 packets, IPv6 packets, and other Protocol Data Units (PDUs) to an arbitrarily large number of Receivers supporting unicast and/or multicast transmission.
The analysis also describes applicability to the Generic Stream Encapsulation (GSE) defined by the Digital Video Broadcasting (DVB) Project. This memo provides information for the Internet community.
Abstract
The MPEG-2 standard defined by ISO 13818-1 supports a range of transmission methods for a variety of services. This document provides a threat analysis and derives the security requirements when using the Transport Stream, TS, to support an Internet network-layer using Unidirectional Lightweight Encapsulation (ULE) defined in RFC 4326. The document also provides the motivation for link-layer security for a ULE Stream. A ULE Stream may be used to send IPv4 packets, IPv6 packets, and other Protocol Data Units (PDUs) to an arbitrarily large number of Receivers supporting unicast and/or multicast transmission.
The analysis also describes applicability to the Generic Stream Encapsulation (GSE) defined by the Digital Video Broadcasting (DVB) Project. This memo provides information for the Internet community.
RFC 5308: Routing IPv6 with IS-IS
Proposed Standard- C. Hopps
- October 2008
- IETF publication
- Routing Area
Abstract
This document specifies a method for exchanging IPv6 routing information using the IS-IS routing protocol. The described method utilizes two new TLVs: a reachability TLV and an interface address TLV to distribute the necessary IPv6 information throughout a routing domain. Using this method, one can route IPv6 along with IPv4 and OSI using a single intra-domain routing protocol. [STANDARDS-TRACK]
Abstract
This document specifies a method for exchanging IPv6 routing information using the IS-IS routing protocol. The described method utilizes two new TLVs: a reachability TLV and an interface address TLV to distribute the necessary IPv6 information throughout a routing domain. Using this method, one can route IPv6 along with IPv4 and OSI using a single intra-domain routing protocol. [STANDARDS-TRACK]
RFC 4330: Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSI
Informational- D. Mills
- January 2006
- Independent Stream publication
Abstract
This memorandum describes the Simple Network Time Protocol Version 4 (SNTPv4), which is a subset of the Network Time Protocol (NTP) used to synchronize computer clocks in the Internet. SNTPv4 can be used when the ultimate performance of a full NTP implementation based on RFC 1305 is neither needed nor justified. When operating with current and previous NTP and SNTP versions, SNTPv4 requires no changes to the specifications or known implementations, but rather clarifies certain design features that allow operation in a simple, stateless remote-procedure call (RPC) mode with accuracy and reliability expectations similar to the UDP/TIME protocol described in RFC 868.
This memorandum obsoletes RFC 1769, which describes SNTP Version 3 (SNTPv3), and RFC 2030, which describes SNTPv4. Its purpose is to correct certain inconsistencies in the previous documents and to clarify header formats and protocol operations for NTPv3 (IPv4) and SNTPv4 (IPv4, IPv6, and OSI), which are also used for SNTP. A further purpose is to provide guidance for home and business client implementations for routers and other consumer devices to protect the server population from abuse. A working knowledge of the NTPv3 specification, RFC 1305, is not required for an implementation of SNTP. This memo provides information for the Internet community.
Obsoleted by RFC 5905
Abstract
This memorandum describes the Simple Network Time Protocol Version 4 (SNTPv4), which is a subset of the Network Time Protocol (NTP) used to synchronize computer clocks in the Internet. SNTPv4 can be used when the ultimate performance of a full NTP implementation based on RFC 1305 is neither needed nor justified. When operating with current and previous NTP and SNTP versions, SNTPv4 requires no changes to the specifications or known implementations, but rather clarifies certain design features that allow operation in a simple, stateless remote-procedure call (RPC) mode with accuracy and reliability expectations similar to the UDP/TIME protocol described in RFC 868.
This memorandum obsoletes RFC 1769, which describes SNTP Version 3 (SNTPv3), and RFC 2030, which describes SNTPv4. Its purpose is to correct certain inconsistencies in the previous documents and to clarify header formats and protocol operations for NTPv3 (IPv4) and SNTPv4 (IPv4, IPv6, and OSI), which are also used for SNTP. A further purpose is to provide guidance for home and business client implementations for routers and other consumer devices to protect the server population from abuse. A working knowledge of the NTPv3 specification, RFC 1305, is not required for an implementation of SNTP. This memo provides information for the Internet community.
RFC 3563: Cooperative Agreement Between the ISOC/IETF and ISO/IEC Joint Technical Committee 1/Sub Committee 6 (JTC1/SC6) on IS-IS Routing Protocol Development
Informational- A. Zinin
- July 2003
- IETF publication
Abstract
This document contains the text of the agreement signed between ISOC/IETF and ISO/IEC JTC1/SC6 regarding cooperative development of the IS-IS routing protocol. The agreement includes definitions of the related work scopes for the two organizations, request for creation and maintenance of an IS-IS registry by IANA, as well as collaboration guidelines. This memo provides information for the Internet community.
Abstract
This document contains the text of the agreement signed between ISOC/IETF and ISO/IEC JTC1/SC6 regarding cooperative development of the IS-IS routing protocol. The agreement includes definitions of the related work scopes for the two organizations, request for creation and maintenance of an IS-IS registry by IANA, as well as collaboration guidelines. This memo provides information for the Internet community.
RFC 3359: Reserved Type, Length and Value (TLV) Codepoints in Intermediate System to Intermediate System
Informational- T. Przygienda
- August 2002
- IETF publication
- Routing Area
Abstract
This draft describes implementation codepoints within
IS-IS [ISO90 , Cal90a , Cal90b ] used today by several ISPs for
routing within their clouds. IS-IS is an interior gateway routing
protocol developed originally by OSI and used with IP extensions as
IGP. This draft summarizes all TLV codepoints that are being used by
the protocol and its pending extensions.
Abstract
This draft describes implementation codepoints within
IS-IS [ISO90 , Cal90a , Cal90b ] used today by several ISPs for
routing within their clouds. IS-IS is an interior gateway routing
protocol developed originally by OSI and used with IP extensions as
IGP. This draft summarizes all TLV codepoints that are being used by
the protocol and its pending extensions.
RFC 2556: OSI connectionless transport services on top of UDP Applicability Statement for Historic Status
Informational- S. Bradner
- March 1999
- Legacy publication
Abstract
RFC 1240, "OSI connectionless transport services on top of UDP", was published as a Proposed Standard in June 1991 but at this time there do not seem to be any implementations which follow RFC 1240. In addition there is a growing concern over using UDP-based transport protocols in environments where congestion is a possibility This memo provides information for the Internet community.
Abstract
RFC 1240, "OSI connectionless transport services on top of UDP", was published as a Proposed Standard in June 1991 but at this time there do not seem to be any implementations which follow RFC 1240. In addition there is a growing concern over using UDP-based transport protocols in environments where congestion is a possibility This memo provides information for the Internet community.
RFC 2503: MIME Types for Use with the ISO ILL Protocol
Informational- R. Moulton
- M. Needleman
- February 1999
- Legacy publication
Abstract
This memorandum describes a set of MIME types for use with the ISO Interlibrary Loan Protocol (ISO 10160/10161). This memo provides information for the Internet community.
Abstract
This memorandum describes a set of MIME types for use with the ISO Interlibrary Loan Protocol (ISO 10160/10161). This memo provides information for the Internet community.
RFC 2237: Japanese Character Encoding for Internet Messages
Informational- K. Tamaru
- November 1997
- Legacy publication
Abstract
This memo defines an encoding scheme for the Japanese Characters, describes "ISO-2022-JP-1", which is used in electronic mail [RFC-822], and network news [RFC 1036]. Also this memo provides a listing of the Japanese Character Set that can be used in this encoding scheme. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
Abstract
This memo defines an encoding scheme for the Japanese Characters, describes "ISO-2022-JP-1", which is used in electronic mail [RFC-822], and network news [RFC 1036]. Also this memo provides a listing of the Japanese Character Set that can be used in this encoding scheme. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
RFC 2126: ISO Transport Service on top of TCP (ITOT)
Proposed Standard- Y. Pouffary
- A. Young
- March 1997
- Legacy publication
Abstract
This document is a revision to STD35, RFC1006. This document describes the mechanism to allow ISO Transport Services to run over TCP over IPv4 or IPv6. It also defines a number of new features, which are not provided in RFC1006. [STANDARDS-TRACK]
Abstract
This document is a revision to STD35, RFC1006. This document describes the mechanism to allow ISO Transport Services to run over TCP over IPv4 or IPv6. It also defines a number of new features, which are not provided in RFC1006. [STANDARDS-TRACK]
RFC 2030: Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSI
Informational- D. Mills
- October 1996
- Legacy publication
Abstract
This memorandum describes the Simple Network Time Protocol (SNTP) Version 4, which is an adaptation of the Network Time Protocol (NTP) used to synchronize computer clocks in the Internet. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Obsoleted by RFC 4330
Abstract
This memorandum describes the Simple Network Time Protocol (SNTP) Version 4, which is an adaptation of the Network Time Protocol (NTP) used to synchronize computer clocks in the Internet. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1888: OSI NSAPs and IPv6
Historic- J. Bound
- B. Carpenter
- D. Harrington
- J. Houldsworth
- A. Lloyd
- August 1996
- IETF publication
- Internet Area
Abstract
This document recommends that network implementors who have planned or deployed an OSI NSAP addressing plan, and who wish to deploy or transition to IPv6, should redesign a native IPv6 addressing plan to meet their needs. This memo defines an Experimental Protocol for the Internet community.
Obsoleted by RFC 4048
Abstract
This document recommends that network implementors who have planned or deployed an OSI NSAP addressing plan, and who wish to deploy or transition to IPv6, should redesign a native IPv6 addressing plan to meet their needs. This memo defines an Experimental Protocol for the Internet community.
RFC 1859: ISO Transport Class 2 Non-use of Explicit Flow Control over TCP RFC1006 extension
Informational- Y. Pouffary
- October 1995
- Legacy publication
Abstract
This document is an extension to STD35, RFC1006, a standard for the Internet community. The document does not duplicate the protocol definitions contained in RFC1006 and in International Standard ISO 8073. It supplements that information with the description of how to implement ISO Transport Class 2 Non-use of Explicit Flow Control on top of TCP. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document is an extension to STD35, RFC1006, a standard for the Internet community. The document does not duplicate the protocol definitions contained in RFC1006 and in International Standard ISO 8073. It supplements that information with the description of how to implement ISO Transport Class 2 Non-use of Explicit Flow Control on top of TCP. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1781: Using the OSI Directory to Achieve User Friendly Naming
Historic- S. Kille
- March 1995
- IETF publication
- Applications Area
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. [STANDARDS-TRACK]
Obsoleted by RFC 3494
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. [STANDARDS-TRACK]
RFC 1698: Octet Sequences for Upper-Layer OSI to Support Basic Communications Applications
Informational- P. Furniss
- October 1994
- IETF publication
- OSI Integration Area
Abstract
This document states particular octet sequences that comprise the OSI upper-layer protocols (Session, Presentation and ACSE) when used to support applications with "basic communications requirements". This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document states particular octet sequences that comprise the OSI upper-layer protocols (Session, Presentation and ACSE) when used to support applications with "basic communications requirements". This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1706: DNS NSAP Resource Records
Historic- B. Manning
- R. Colella
- October 1994
- Legacy publication
Abstract
This document defines the format of one new Resource Record (RR) for the DNS for domain name-to-NSAP mapping. The RR may be used with any NSAP address format. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document defines the format of one new Resource Record (RR) for the DNS for domain name-to-NSAP mapping. The RR may be used with any NSAP address format. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1637: DNS NSAP Resource Records
Experimental- B. Manning
- R. Colella
- June 1994
- Legacy publication
Abstract
This document defines the format of one new Resource Record (RR) for the DNS for domain name-to-NSAP mapping. This memo defines an Experimental Protocol for the Internet community.
Obsoleted by RFC 1706
Abstract
This document defines the format of one new Resource Record (RR) for the DNS for domain name-to-NSAP mapping. This memo defines an Experimental Protocol for the Internet community.
RFC 1564: DSA Metrics (OSI-DS 34 (v3))
Informational- P. Barker
- R. Hedberg
- January 1994
- IETF publication
- Applications Area
Abstract
This document defines a set of criteria by which a DSA implementation may be judged. Particular issues covered include conformance to standards; performance; demonstrated interoperability. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document defines a set of criteria by which a DSA implementation may be judged. Particular issues covered include conformance to standards; performance; demonstrated interoperability. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1484: Using the OSI Directory to achieve User Friendly Naming (OSI-DS 24 (v1.2))
Historic- S. Hardcastle-Kille
- July 1993
- IETF publication
- Applications Area
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet standard.
Abstract
This proposal sets out some conventions for representing names in a friendly manner, and shows how this can be used to achieve really friendly naming. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet standard.
RFC 1485: A String Representation of Distinguished Names (OSI-DS 23 (v5))
Historic- S. Hardcastle-Kille
- July 1993
- IETF publication
- Applications Area
Abstract
When a distinguished name is communicated between to users not using a directory protocol (e.g., in a mail message), there is a need to have a user-oriented string representation of distinguished name. [STANDARDS-TRACK]
Abstract
When a distinguished name is communicated between to users not using a directory protocol (e.g., in a mail message), there is a need to have a user-oriented string representation of distinguished name. [STANDARDS-TRACK]
RFC 1418: SNMP over OSI
Historic- M. Rose
- March 1993
- IETF publication
- Network Management Area
Abstract
This memo addresses some concerns by defining a framework for running the SNMP in an environment which supports the OSI connectionless-mode transport service. [STANDARDS-TRACK]
Abstract
This memo addresses some concerns by defining a framework for running the SNMP in an environment which supports the OSI connectionless-mode transport service. [STANDARDS-TRACK]
RFC 1431: DUA Metrics (OSI-DS 33 (v2))
Informational- P. Barker
- February 1993
- IETF publication
- Applications Area
Abstract
This document defines a set of criteria by which a DUA implementation, or more precisely a Directory user interface, may be judged. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
This document defines a set of criteria by which a DUA implementation, or more precisely a Directory user interface, may be judged. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1415: FTP-FTAM Gateway Specification
Historic- J. Mindel
- R. Slaski
- January 1993
- Legacy publication
Abstract
This memo describes a dual protocol stack application layer gateway that performs protocol translation, in an interactive environment, between the FTP and FTAM file transfer protocols. [STANDARDS-TRACK]
Abstract
This memo describes a dual protocol stack application layer gateway that performs protocol translation, in an interactive environment, between the FTP and FTAM file transfer protocols. [STANDARDS-TRACK]
RFC 1377: The PPP OSI Network Layer Control Protocol (OSINLCP)
Proposed Standard- D. Katz
- November 1992
- IETF publication
- Internet Area
Abstract
This document defines the NCP for establishing and configuring OSI Network Layer Protocols. [STANDARDS-TRACK]
Abstract
This document defines the NCP for establishing and configuring OSI Network Layer Protocols. [STANDARDS-TRACK]
RFC 1330: Recommendations for the Phase I Deployment of OSI Directory Services (X.500) and OSI Message Handling Services (X.400) within the ESNET Community
Informational- ESCC X.500/X.400 Task Force
- ESnet Site Coordinating Comittee (ESCC)
- Energy Sciences Network (ESnet)
- May 1992
- Legacy publication
Abstract
This RFC is a near verbatim copy of the whitepaper produced by the ESnet Site Coordinating Committee's X.500/X.400 Task Force. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
This RFC is a near verbatim copy of the whitepaper produced by the ESnet Site Coordinating Committee's X.500/X.400 Task Force. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1283: SNMP over OSI
Experimental- M. Rose
- December 1991
- IETF publication
- Network Management Area
Abstract
This memo describes mappings from the SNMP onto both the COTS and the CLTS. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet Standard.
Obsoleted by RFC 1418
Abstract
This memo describes mappings from the SNMP onto both the COTS and the CLTS. This memo defines an Experimental Protocol for the Internet community. It does not specify an Internet Standard.
RFC 1277: Encoding Network Addresses to Support Operation over Non-OSI Lower Layers
Proposed Standard- S.E. Hardcastle-Kille
- November 1991
- IETF publication
- Applications Area
Abstract
This document defines a new network address format, and rules for using some existing network address formats. [STANDARDS-TRACK]
Abstract
This document defines a new network address format, and rules for using some existing network address formats. [STANDARDS-TRACK]
RFC 1278: A string encoding of Presentation Address
Informational- S.E. Hardcastle-Kille
- November 1991
- IETF publication
- Applications Area
Abstract
There are a number of environments where a simple string encoding of Presentation Address is desirable. This specification defines such a representation. This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
There are a number of environments where a simple string encoding of Presentation Address is desirable. This specification defines such a representation. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1237: Guidelines for OSI NSAP Allocation in the Internet
Proposed Standard- R. Colella
- E. Gardner
- R. Callon
- July 1991
- IETF publication
- OSI Integration Area
Abstract
This paper provides guidelines for allocating NSAPs in the Internet.[STANDARDS-TRACK]
Obsoleted by RFC 1629
Abstract
This paper provides guidelines for allocating NSAPs in the Internet.[STANDARDS-TRACK]
RFC 1240: OSI connectionless transport services on top of UDP: Version 1
Historic- C. Shue
- W. Haggerty
- K. Dobbins
- June 1991
- Legacy publication
Abstract
This document describes a protocol for running OSI Connectionless service on UDP. [STANDARDS-TRACK]
Abstract
This document describes a protocol for running OSI Connectionless service on UDP. [STANDARDS-TRACK]
RFC 1223: OSI CLNS and LLC1 protocols on Network Systems HYPERchannel
Informational- J.M. Halpern
- May 1991
- Legacy publication
Abstract
The intent of this document is to provide a complete discussion of the protocols and techniques used to transmit OSI CLNS and LLC1 datagrams (and any associated higher level protocols) on Network Systems Corporation's HYPERchannel equipment.This memo provides information for the Internet community. It does not specify an Internet standard.
Abstract
The intent of this document is to provide a complete discussion of the protocols and techniques used to transmit OSI CLNS and LLC1 datagrams (and any associated higher level protocols) on Network Systems Corporation's HYPERchannel equipment.This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1214: OSI internet management: Management Information Base
Historic- L. LaBarre
- April 1991
- IETF publication
- Network Management Area
Abstract
This RFC documents a MIB for use with CMIP, either over pure OSI stacks or with the CMIP over TCP specification. It redefines objects comprised by the second revision of the Management Information Base for Network Management of TCP/IP-based internets: MIB-II so as to conform to the OSI structure of management information. [STANDARDS-TRACK]
Abstract
This RFC documents a MIB for use with CMIP, either over pure OSI stacks or with the CMIP over TCP specification. It redefines objects comprised by the second revision of the Management Information Base for Network Management of TCP/IP-based internets: MIB-II so as to conform to the OSI structure of management information. [STANDARDS-TRACK]
RFC 1195: Use of OSI IS-IS for routing in TCP/IP and dual environments
Proposed Standard- R. Callon
- December 1990
- Legacy publication
Abstract
This memo specifies an integrated routing protocol, based on the OSI Intra-Domain IS-IS Routing Protocol, which may be used as an interior gateway protocol (IGP) to support TCP/IP as well as OSI. This allows a single routing protocol to be used to support pure IP environments, pure OSI environments, and dual environments. This specification was developed by the IS-IS working group of the Internet Engineering Task Force. [STANDARDS-TRACK]
Abstract
This memo specifies an integrated routing protocol, based on the OSI Intra-Domain IS-IS Routing Protocol, which may be used as an interior gateway protocol (IGP) to support TCP/IP as well as OSI. This allows a single routing protocol to be used to support pure IP environments, pure OSI environments, and dual environments. This specification was developed by the IS-IS working group of the Internet Engineering Task Force. [STANDARDS-TRACK]
RFC 1161: SNMP over OSI
Experimental- M.T. Rose
- June 1990
- Legacy publication
Abstract
This memo defines an experimental means for running the Simple Network Management Protocol (SNMP) over OSI transports. This memo does not specify a standard for the Internet community,
Obsoleted by RFC 1418
Abstract
This memo defines an experimental means for running the Simple Network Management Protocol (SNMP) over OSI transports. This memo does not specify a standard for the Internet community,
RFC 1165: Network Time Protocol (NTP) over the OSI Remote Operations Service
Experimental- J. Crowcroft
- J.P. Onions
- June 1990
- Legacy publication
Abstract
This memo suggests an Experimental Protocol for the OSI and Internet communities. Hosts in either community, and in particular those on both are encouraged to experiment with this mechanism.
Abstract
This memo suggests an Experimental Protocol for the OSI and Internet communities. Hosts in either community, and in particular those on both are encouraged to experiment with this mechanism.
RFC 1142: OSI IS-IS Intra-domain Routing Protocol
Historic- D. Oran
- February 1990
- Legacy publication
Abstract
This RFC is a republication of ISO DP 10589 as a service to the Internet community. This is not an Internet standard.
Obsoleted by RFC 7142
Abstract
This RFC is a republication of ISO DP 10589 as a service to the Internet community. This is not an Internet standard.
RFC 1139: Echo function for ISO 8473
Proposed Standard- R.A. Hagens
- January 1990
- IETF publication
- OSI Integration Area
Abstract
This memo defines an echo function for the connection-less network layer protocol. Two mechanisms are introduced that may be used to implement the echo function. The first mechanism is recommended as an interim solution for the Internet community. The second mechanism will be progressed to the ANSI X3S3.3 working group for consideration as a work item. When an ISO standard is adopted that provides functionality similar to that described by this memo, then this memo will become obsolete and superceded by the ISO standard. This memo is not intended to compete with an ISO standard. [STANDARDS-TRACK]
Abstract
This memo defines an echo function for the connection-less network layer protocol. Two mechanisms are introduced that may be used to implement the echo function. The first mechanism is recommended as an interim solution for the Internet community. The second mechanism will be progressed to the ANSI X3S3.3 working group for consideration as a work item. When an ISO standard is adopted that provides functionality similar to that described by this memo, then this memo will become obsolete and superceded by the ISO standard. This memo is not intended to compete with an ISO standard. [STANDARDS-TRACK]
RFC 1070: Use of the Internet as a subnetwork for experimentation with the OSI network layer
Unknown- R.A. Hagens
- N.E. Hall
- M.T. Rose
- February 1989
- Legacy publication
Abstract
This RFC proposes a scenario for experimentation with the International Organization for Standardization (ISO) Open Systems Interconnection (OSI) network layer protocols over the Internet and requests discussion and suggestions for improvements to this scenario. This RFC also proposes the creation of an experimental OSI internet. To participate in the experimental OSI internet, a system must abide by the agreements set forth in this RFC.
Abstract
This RFC proposes a scenario for experimentation with the International Organization for Standardization (ISO) Open Systems Interconnection (OSI) network layer protocols over the Internet and requests discussion and suggestions for improvements to this scenario. This RFC also proposes the creation of an experimental OSI internet. To participate in the experimental OSI internet, a system must abide by the agreements set forth in this RFC.
RFC 1085: ISO presentation services on top of TCP/IP based internets
Unknown- M.T. Rose
- December 1988
- Legacy publication
Abstract
RFC 1006 describes a mechanism for providing the ISO transport service on top of TCP/IP. Once this method is applied, one may implement "real" ISO applications on top of TCP/IP-based internets, by simply implementing OSI session, presentation, and application services on top of the transport service access point which is provided on top of the TCP. Although straight-forward, there are some environments in which the richness provided by the OSI application layer is desired, but it is nonetheless impractical to implement the underlying OSI infrastructure (i.e., the presentation, session, and transport services on top of the TCP). This memo describes an approach for providing "stream-lined" support of OSI application services on top of TCP/IP-based internets for such constrained environments. This memo proposes a standard for the Internet community.
Abstract
RFC 1006 describes a mechanism for providing the ISO transport service on top of TCP/IP. Once this method is applied, one may implement "real" ISO applications on top of TCP/IP-based internets, by simply implementing OSI session, presentation, and application services on top of the transport service access point which is provided on top of the TCP. Although straight-forward, there are some environments in which the richness provided by the OSI application layer is desired, but it is nonetheless impractical to implement the underlying OSI infrastructure (i.e., the presentation, session, and transport services on top of the TCP). This memo describes an approach for providing "stream-lined" support of OSI application services on top of TCP/IP-based internets for such constrained environments. This memo proposes a standard for the Internet community.
RFC 1007: Military supplement to the ISO Transport Protocol
Unknown- W. McCoy
- June 1987
- Legacy publication
Abstract
This document supplements the Transport Service and Protocol of the International Standards Organization (ISO), IS 8072 and IS 8073, respectively, and their formal descriptions by providing conventions, option selections and parameter values. This RFC is being distributed to members of the Internet community in order to solicit comments on the Draft Military Supplement. While this document may not be directly relevant to the research problems of the Internet, it may be of some interest to a number of researchers and implementors.
Abstract
This document supplements the Transport Service and Protocol of the International Standards Organization (ISO), IS 8072 and IS 8073, respectively, and their formal descriptions by providing conventions, option selections and parameter values. This RFC is being distributed to members of the Internet community in order to solicit comments on the Draft Military Supplement. While this document may not be directly relevant to the research problems of the Internet, it may be of some interest to a number of researchers and implementors.
RFC 1008: Implementation guide for the ISO Transport Protocol
Unknown- W. McCoy
- June 1987
- Legacy publication
Abstract
This RFC is being distributed to members of the Internet community in order to solicit comments on the Implementors Guide. While this document may not be directly relevant to the research problems of the Internet, it may be of some interest to a number of researchers and implementors.
Abstract
This RFC is being distributed to members of the Internet community in order to solicit comments on the Implementors Guide. While this document may not be directly relevant to the research problems of the Internet, it may be of some interest to a number of researchers and implementors.
RFC 1006: STD 35: ISO Transport Service on top of the TCP Version: 3
Internet Standard- M.T. Rose
- D.E. Cass
- May 1987
- Legacy publication
Abstract
This memo specifies a standard for the Internet community. Hosts on the Internet that choose to implement ISO transport services on top of the TCP are expected to adopt and implement this standard. TCP port 102 is reserved for hosts which implement this standard. This memo specifies version 3 of the protocol and supersedes RFC-983. Changes between the protocol is described in RFC-983 and this memo are minor, but unfortunately incompatible.
Abstract
This memo specifies a standard for the Internet community. Hosts on the Internet that choose to implement ISO transport services on top of the TCP are expected to adopt and implement this standard. TCP port 102 is reserved for hosts which implement this standard. This memo specifies version 3 of the protocol and supersedes RFC-983. Changes between the protocol is described in RFC-983 and this memo are minor, but unfortunately incompatible.
RFC 983: ISO transport arrives on top of the TCP
Unknown- D.E. Cass
- M.T. Rose
- April 1986
- Legacy publication
Abstract
This memo describes a proposed protocol standard for the ARPA Internet community. The CCITT and the ISO have defined various session, presentation, and application recommendations which have been adopted by the international community and numerous vendors. To the largest extent possible, it is desirable to offer these higher level services directly in the ARPA Internet, without disrupting existing facilities. This permits users to develop expertise with ISO and CCITT applications which previously were not available in the ARPA Internet. The intention is that hosts in the ARPA-Internet that choose to implement ISO TSAP services on top of the TCP be expected to adopt and implement this standard. Suggestions for improvement are encouraged.
Obsoleted by RFC 1006
Abstract
This memo describes a proposed protocol standard for the ARPA Internet community. The CCITT and the ISO have defined various session, presentation, and application recommendations which have been adopted by the international community and numerous vendors. To the largest extent possible, it is desirable to offer these higher level services directly in the ARPA Internet, without disrupting existing facilities. This permits users to develop expertise with ISO and CCITT applications which previously were not available in the ARPA Internet. The intention is that hosts in the ARPA-Internet that choose to implement ISO TSAP services on top of the TCP be expected to adopt and implement this standard. Suggestions for improvement are encouraged.
RFC 905: ISO Transport Protocol specification ISO DP 8073
Unknown- ISO
- April 1984
- Legacy publication
Abstract
This is the current specification of the ISO Transport Protocol. This document is the text of ISO/TC97/SC16/N1576 as corrected by ISO/TC97/SC16/N1695. This is the specification currently being voted on in ISO as a Draft International Standard (DIS). This document is distributed as an RFC for your information only, it does not specify a standard for the ARPA-Internet or DARPA research community. Our thanks to Alex McKenzie of BBN for making this online version available. Please note the size of this document, the file contains 258,729 characters.
Abstract
This is the current specification of the ISO Transport Protocol. This document is the text of ISO/TC97/SC16/N1576 as corrected by ISO/TC97/SC16/N1695. This is the specification currently being voted on in ISO as a Draft International Standard (DIS). This document is distributed as an RFC for your information only, it does not specify a standard for the ARPA-Internet or DARPA research community. Our thanks to Alex McKenzie of BBN for making this online version available. Please note the size of this document, the file contains 258,729 characters.
RFC 892: ISO Transport Protocol specification
Unknown- International Organization for Standardization
- December 1983
- Legacy publication
Abstract
This is a draft version of the transport protocol being standardized by the ISO. This version also appeared in the ACM SIGCOMM Computer Communication Review (V.12, N.3-4) July-October 1982. This version is now out of date.
Obsoleted by RFC 905
Abstract
This is a draft version of the transport protocol being standardized by the ISO. This version also appeared in the ACM SIGCOMM Computer Communication Review (V.12, N.3-4) July-October 1982. This version is now out of date.
Subscribe to OSI
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.