NTP

NTP (Network Time Protocol)

NTP RFCs (40)

Display RFCs as
  • RFC 10030: Network Time Protocol (NTP) over the Precision Time Protocol (PTP)

    Proposed Standard
  • RFC 9760: Enterprise Profile for the Precision Time Protocol with Mixed Multicast and Unicast Messages

    Proposed Standard
  • RFC 9769: NTP Interleaved Modes

    Proposed Standard
  • RFC 9748: Updating the NTP Registries

    Proposed Standard
  • RFC 9616: Delay-Based Metric Extension for the Babel Routing Protocol

    Proposed Standard
  • RFC 9581: Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

    Proposed Standard
  • RFC 9523: A Secure Selection and Filtering Mechanism for the Network Time Protocol with Khronos

    Informational
  • RFC 9327: Control Messages Protocol for Use with Network Time Protocol Version 4

    Historic
  • RFC 9249: A YANG Data Model for NTP

    Proposed Standard
  • RFC 9109: Network Time Protocol Version 4: Port Randomization

    Proposed Standard
  • RFC 8915: Network Time Security for the Network Time Protocol

    Proposed Standard
  • RFC 8877: Guidelines for Defining Packet Timestamps

    Informational
  • RFC 8633: BCP 223: Network Time Protocol Best Current Practices

    Best Current Practice
  • RFC 8573: Message Authentication Code for the Network Time Protocol

    Proposed Standard
  • RFC 8575: YANG Data Model for the Precision Time Protocol (PTP)

    Proposed Standard
  • RFC 8173: Precision Time Protocol Version 2 (PTPv2) Management Information Base

    Proposed Standard
  • RFC 8039: Multipath Time Synchronization

    Experimental
  • RFC 7821: UDP Checksum Complement in the Network Time Protocol (NTP)

    Experimental
  • RFC 7822: Network Time Protocol Version 4 (NTPv4) Extension Fields

    Proposed Standard
  • RFC 7384: Security Requirements of Time Protocols in Packet Switched Networks

    Informational
  • RFC 7164: RTP and Leap Seconds

    Proposed Standard
  • RFC 5905: Network Time Protocol Version 4: Protocol and Algorithms Specification

    Proposed Standard
  • RFC 5906: Network Time Protocol Version 4: Autokey Specification

    Informational
  • RFC 5907: Definitions of Managed Objects for Network Time Protocol Version 4 (NTPv4)

    Proposed Standard
  • RFC 5908: Network Time Protocol (NTP) Server Option for DHCPv6

    Proposed Standard
  • RFC 4330: Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSI

    Informational

    Obsoleted by RFC 5905

  • RFC 4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6

    Proposed Standard
  • RFC 2783: Pulse-Per-Second API for UNIX-like Operating Systems, Version 1.0

    Informational
  • RFC 2030: Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSI

    Informational

    Obsoleted by RFC 4330

  • RFC 1769: Simple Network Time Protocol (SNTP)

    Informational

    Obsoleted by RFC 2030, RFC 4330

  • RFC 1708: NTP PICS PROFORMA - For the Network Time Protocol Version 3

    Informational
  • RFC 1589: A Kernel Model for Precision Timekeeping

    Informational
  • RFC 1361: Simple Network Time Protocol (SNTP)

    Informational

    Obsoleted by RFC 1769

  • RFC 1305: Network Time Protocol (Version 3) Specification, Implementation and Analysis

    Historic

    Obsoleted by RFC 5905

  • RFC 1165: Network Time Protocol (NTP) over the OSI Remote Operations Service

    Experimental
  • RFC 1128: Measured performance of the Network Time Protocol in the Internet system

    Unknown
  • RFC 1129: Internet Time Synchronization: The Network Time Protocol

    Informational
  • RFC 1119: Network Time Protocol (version 2) specification and implementation

    Historic

    Obsoleted by RFC 1305

  • RFC 1059: Network Time Protocol (version 1) specification and implementation

    Unknown

    Obsoleted by RFC 1119, RFC 1305

  • RFC 958: Network Time Protocol (NTP)

    Unknown

    Obsoleted by RFC 1059, RFC 1119, RFC 1305

Subscribe to NTP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.