multicast

IP multicast routing, group membership and deployment

multicast subjects:

multicast RFCs (121)

Display RFCs as
  • RFC 9760: Enterprise Profile for the Precision Time Protocol with Mixed Multicast and Unicast Messages

    Proposed Standard
  • RFC 9685: Listener Subscription for IPv6 Neighbor Discovery Multicast and Anycast Addresses

    Proposed Standard
  • RFC 9625: EVPN Optimized Inter-Subnet Multicast (OISM) Forwarding

    Proposed Standard
  • RFC 9630: Multicast On-Path Telemetry Using In Situ Operations, Administration, and Maintenance (IOAM)

    Proposed Standard
  • RFC 9572: Updates to EVPN Broadcast, Unknown Unicast, or Multicast (BUM) Procedures

    Proposed Standard
  • RFC 9467: Relaxed Packet Counter Verification for Babel MAC Authentication

    Proposed Standard
  • RFC 9119: Multicast Considerations over IEEE 802 Wireless Media

    Informational
  • Proposed Standard
  • RFC 8494: Multicast Email (MULE) over Allied Communications Publication (ACP) 142

    Informational
  • RFC 8386: Privacy Considerations for Protocols Relying on IP Broadcast or Multicast

    Informational
  • RFC 8378: Signal-Free Locator/ID Separation Protocol (LISP) Multicast

    Experimental
  • Proposed Standard
  • RFC 8293: A Framework for Multicast in Network Virtualization over Layer 3

    Informational
  • RFC 7985: Security Threats to Simplified Multicast Forwarding (SMF)

    Informational
  • Proposed Standard
  • RFC 7902: Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags

    Proposed Standard
  • RFC 7774: Multicast Protocol for Low-Power and Lossy Networks (MPL) Parameter Configuration Option for DHCPv6

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 7731: Multicast Protocol for Low-Power and Lossy Networks (MPL)

    Proposed Standard
  • RFC 7732: Forwarder Policy for Multicast with Admin-Local Scope in the Multicast Protocol for Low-Power and Lossy Networks (MPL)

    Informational
  • RFC 7678: Attribute-Value Pairs for Provisioning Customer Equipment Supporting IPv4-Over-IPv6 Transitional Solutions

    Proposed Standard
  • RFC 7431: Multicast-Only Fast Reroute

    Informational
  • RFC 7438: Multipoint LDP (mLDP) In-Band Signaling with Wildcards

    Proposed Standard
  • RFC 7390: Group Communication for the Constrained Application Protocol (CoAP)

    Experimental
  • RFC 7367: Definition of Managed Objects for the Mobile Ad Hoc Network (MANET) Simplified Multicast Framework Relay Set Process

    Experimental
  • RFC 7385: IANA Registry for P-Multicast Service Interface (PMSI) Tunnel Type Code Points

    Proposed Standard
  • RFC 7371: Updates to the IPv6 Multicast Addressing Architecture

    Proposed Standard
  • RFC 7346: IPv6 Multicast Address Scopes

    Proposed Standard
  • RFC 7256: Multicast Control Extensions for the Access Node Control Protocol (ANCP)

    Proposed Standard
  • RFC 7287: Mobile Multicast Sender Support in Proxy Mobile IPv6 (PMIPv6) Domains

    Experimental
  • Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 7780

  • RFC 7161: Proxy Mobile IPv6 (PMIPv6) Multicast Handover Optimization by the Subscription Information Acquisition through the LMA (SIAL)

    Experimental
  • RFC 7117: Multicast in Virtual Private LAN Service (VPLS)

    Proposed Standard
  • RFC 7046: A Common API for Transparent Hybrid Multicast

    Experimental
  • RFC 7019: Application-Layer Multicast Extensions to REsource LOcation And Discovery (RELOAD)

    Experimental
  • RFC 6831: The Locator/ID Separation Protocol (LISP) for Multicast Environments

    Experimental
  • RFC 6676: Multicast Addresses for Documentation

    Informational
  • RFC 6659: Considerations for Deploying the Rapid Acquisition of Multicast RTP Sessions (RAMS) Method

    Informational
  • RFC 6621: Simplified Multicast Forwarding

    Experimental
  • RFC 6348: Requirements for Point-to-Multipoint Extensions to the Label Distribution Protocol

    Historic
  • RFC 6284: Port Mapping between Unicast and Multicast RTP Sessions

    Proposed Standard
  • RFC 6219: The China Education and Research Network (CERNET) IVI Translation Design and Deployment for the IPv4/IPv6 Coexistence and Transition

    Informational
  • RFC 6085: Address Mapping of IPv6 Multicast Packets on Ethernet

    Proposed Standard
  • RFC 6064: SDP and RTSP Extensions Defined for 3GPP Packet-Switched Streaming Service and Multimedia Broadcast/Multicast Service

    Informational
  • RFC 6034: Unicast-Prefix-Based IPv4 Multicast Addresses

    Proposed Standard
  • RFC 5851: Framework and Requirements for an Access Node Control Mechanism in Broadband Multi-Service Networks

    Informational
  • RFC 5771: BCP 51: IANA Guidelines for IPv4 Multicast Address Assignments

    Best Current Practice
  • RFC 5644: IP Performance Metrics (IPPM): Spatial and Multicast

    Proposed Standard
  • RFC 5332: MPLS Multicast Encapsulations

    Proposed Standard
  • RFC 5135: BCP 135: IP Multicast Requirements for a Network Address Translator (NAT) and a Network Address Port Translator (NAPT)

    Best Current Practice
  • RFC 5110: Overview of the Internet Multicast Routing Architecture

    Informational
  • RFC 5132: IP Multicast MIB

    Proposed Standard
  • RFC 5058: Explicit Multicast (Xcast) Concepts and Options

    Experimental
  • RFC 4629: RTP Payload Format for ITU-T Rec. H.263 Video

    Proposed Standard
  • Informational
  • RFC 4566: SDP: Session Description Protocol

    Proposed Standard

    Obsoleted by RFC 8866

  • RFC 4473: Requirements for Internet Media Guides (IMGs)

    Informational
  • Proposed Standard
  • RFC 4291: IP Version 6 Addressing Architecture

    Draft Standard
  • RFC 4363: Definitions of Managed Objects for Bridges with Traffic Classes, Multicast Filtering, and Virtual LAN Extensions

    Proposed Standard
  • RFC 4280: Dynamic Host Configuration Protocol (DHCP) Options for Broadcast and Multicast Control Servers

    Proposed Standard
  • RFC 4045: Extensions to Support Efficient Carrying of Multicast Traffic in Layer-2 Tunneling Protocol (L2TP)

    Experimental
  • RFC 3956: Embedding the Rendezvous Point (RP) Address in an IPv6 Multicast Address

    Proposed Standard
  • RFC 3918: Methodology for IP Multicast Benchmarking

    Informational
  • RFC 3754: IP Multicast in Differentiated Services (DS) Networks

    Informational
  • RFC 3513: Internet Protocol Version 6 (IPv6) Addressing Architecture

    Proposed Standard

    Obsoleted by RFC 4291

  • RFC 3488: Cisco Systems Router-port Group Management Protocol (RGMP)

    Informational
  • RFC 3306: Unicast-Prefix-based IPv6 Multicast Addresses

    Proposed Standard
  • RFC 3353: Overview of IP Multicast in a Multi-Protocol Label Switching (MPLS) Environment

    Informational
  • RFC 3264: An Offer/Answer Model with Session Description Protocol (SDP)

    Proposed Standard
  • RFC 3292: General Switch Management Protocol (GSMP) V3

    Proposed Standard
  • RFC 3259: A Message Bus for Local Coordination

    Informational
  • RFC 3170: IP Multicast Applications: Challenges and Solutions

    Informational
  • RFC 3180: BCP 53: GLOP Addressing in 233/8

    Best Current Practice
  • RFC 3171: IANA Guidelines for IPv4 Multicast Address Assignments

    Best Current Practice

    Obsoleted by RFC 5771

  • RFC 3138: Extended Assignments in 233/8

    Informational

    Obsoleted by RFC 5771

  • RFC 2991: Multipath Issues in Unicast and Multicast Next-Hop Selection

    Informational
  • RFC 2932: IPv4 Multicast Routing MIB

    Proposed Standard

    Obsoleted by RFC 5132

  • RFC 2770: GLOP Addressing in 233/8

    Experimental

    Obsoleted by RFC 3180

  • RFC 2776: Multicast-Scope Zone Announcement Protocol (MZAP)

    Historic
  • RFC 2729: Taxonomy of Communication Requirements for Large-scale Multicast Applications

    Informational
  • RFC 2734: IPv4 over IEEE 1394

    Proposed Standard
  • RFC 2715: Interoperability Rules for Multicast Routing Protocols

    Informational
  • RFC 2674: Definitions of Managed Objects for Bridges with Traffic Classes, Multicast Filtering and Virtual LAN Extensions

    Proposed Standard

    Obsoleted by RFC 4363

  • RFC 2602: ILMI-Based Server Discovery for MARS

    Proposed Standard
  • RFC 2627: Key Management for Multicast: Issues and Architectures

    Informational
  • RFC 2588: IP Multicast and Firewalls

    Informational
  • RFC 2502: Limitations of Internet Protocol Suite for Distributed Simulation the Large Multicast Environment

    Informational
  • RFC 2490: A Simulation Model for IP Multicast with RSVP

    Informational
  • RFC 2429: RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+)

    Proposed Standard

    Obsoleted by RFC 4629

  • RFC 2431: RTP Payload Format for BT.656 Video Encoding

    Proposed Standard
  • RFC 2432: Terminology for IP Multicast Benchmarking

    Informational
  • RFC 2417: Definitions of Managed Objects for Multicast over UNI 3.0/3.1 based ATM Networks

    Proposed Standard
  • RFC 2365: BCP 23: Administratively Scoped IP Multicast

    Best Current Practice
  • RFC 2366: Definitions of Managed Objects for Multicast over UNI 3.0/3.1 based ATM Networks

    Proposed Standard

    Obsoleted by RFC 2417

  • RFC 2373: IP Version 6 Addressing Architecture

    Proposed Standard

    Obsoleted by RFC 3513

  • RFC 2375: IPv6 Multicast Address Assignments

    Informational
  • RFC 2327: SDP: Session Description Protocol

    Proposed Standard

    Obsoleted by RFC 4566

  • RFC 2269: Using the MARS Model in non-ATM NBMA Networks

    Informational
  • RFC 2189: Core Based Trees (CBT version 2) Multicast Routing -- Protocol Specification --

    Historic
  • RFC 2191: VENUS - Very Extensive Non-Unicast Service

    Informational
  • RFC 2201: Core Based Trees (CBT) Multicast Routing Architecture

    Historic
  • RFC 2205: Resource ReSerVation Protocol (RSVP) -- Version 1 Functional Specification

    Proposed Standard
  • RFC 2149: Multicast Server Architectures for MARS-based ATM multicasting

    Informational
  • RFC 2121: Issues affecting MARS Cluster Size

    Informational
  • RFC 2090: TFTP Multicast Option

    Experimental
  • RFC 2102: Multicast Support for Nimrod : Requirements and Solution Approaches

    Informational
  • RFC 2022: Support for Multicast over UNI 3.0/3.1 based ATM Networks

    Proposed Standard
  • RFC 1949: Scalable Multicast Key Distribution

    Experimental
  • RFC 1585: MOSPF: Analysis and Experience

    Informational
  • RFC 1469: IP Multicast over Token-Ring Local Area Networks

    Historic
  • RFC 1458: Requirements for Multicast Protocols

    Informational
  • RFC 1301: Multicast Transport Protocol

    Informational
  • RFC 1075: Distance Vector Multicast Routing Protocol

    Experimental
  • RFC 1054: Host extensions for IP multicasting

    Unknown

    Obsoleted by RFC 1112

  • RFC 1045: VMTP: Versatile Message Transaction Protocol: Protocol specification

    Experimental
  • RFC 992: On communication support for fault tolerant process groups

    Unknown
  • RFC 988: Host extensions for IP multicasting

    Unknown

    Obsoleted by RFC 1054, RFC 1112

  • RFC 966: Host groups: A multicast extension to the Internet Protocol

    Unknown

    Obsoleted by RFC 988

Subscribe to multicast

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.