Mobile IPv6

Mobile IPv6

Mobile IPv6 RFCs (91)

Display RFCs as
  • RFC 8818: Distributed Mobility Anchoring

    Informational
  • RFC 8885: Proxy Mobile IPv6 Extensions for Distributed Mobility Management

    Experimental
  • RFC 8371: Mobile Node Identifier Types for MIPv6

    Proposed Standard
  • RFC 8278: Mobile Access Gateway (MAG) Multipath Options

    Proposed Standard
  • RFC 8191: Home Network Prefix Renumbering in Proxy Mobile IPv6 (PMIPv6)

    Proposed Standard
  • RFC 7839: Access-Network-Identifier Option in DHCP

    Proposed Standard
  • RFC 7864: Proxy Mobile IPv6 Extensions to Support Flow Mobility

    Proposed Standard
  • RFC 7563: Extensions to the Proxy Mobile IPv6 (PMIPv6) Access Network Identifier Option

    Proposed Standard
  • RFC 7561: Mapping Quality of Service (QoS) Procedures of Proxy Mobile IPv6 (PMIPv6) and WLAN

    Informational
  • RFC 7411: Multicast Listener Extensions for Mobile IPv6 (MIPv6) and Proxy Mobile IPv6 (PMIPv6) Fast Handovers

    Experimental
  • RFC 7389: Separation of Control and User Plane for Proxy Mobile IPv6

    Proposed Standard
  • RFC 7287: Mobile Multicast Sender Support in Proxy Mobile IPv6 (PMIPv6) Domains

    Experimental
  • RFC 7222: Quality-of-Service Option for Proxy Mobile IPv6

    Proposed Standard
  • RFC 7156: Diameter Support for Proxy Mobile IPv6 Localized Routing

    Proposed Standard
  • RFC 7161: Proxy Mobile IPv6 (PMIPv6) Multicast Handover Optimization by the Subscription Information Acquisition through the LMA (SIAL)

    Experimental
  • RFC 7148: Prefix Delegation Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 7109: Flow Bindings Initiated by Home Agents for Mobile IPv6

    Experimental
  • RFC 7077: Update Notifications for Proxy Mobile IPv6

    Proposed Standard
  • RFC 7028: Multicast Mobility Routing Optimizations for Proxy Mobile IPv6

    Experimental
  • RFC 6909: IPv4 Traffic Offload Selector Option for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6757: Access Network Identifier (ANI) Option for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6705: Localized Routing for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6572: RADIUS Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6618: Mobile IPv6 Security Framework Using Transport Layer Security for Communication between the Mobile Node and Home Agent

    Experimental
  • RFC 6543: Reserved IPv6 Interface Identifier for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6602: Bulk Binding Update Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6610: DHCP Options for Home Information Discovery in Mobile IPv6 (MIPv6)

    Proposed Standard
  • RFC 6611: Mobile IPv6 (MIPv6) Bootstrapping for the Integrated Scenario

    Proposed Standard
  • Informational
  • RFC 6475: Proxy Mobile IPv6 Management Information Base

    Proposed Standard
  • RFC 6463: Runtime Local Mobility Anchor (LMA) Assignment Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6496: Secure Proxy ND Support for SEcure Neighbor Discovery (SEND)

    Experimental
  • RFC 6276: DHCPv6 Prefix Delegation for Network Mobility (NEMO)

    Proposed Standard
  • RFC 6275: Mobility Support in IPv6

    Proposed Standard
  • RFC 6279: Proxy Mobile IPv6 (PMIPv6) Localized Routing Problem Statement

    Informational
  • RFC 6224: Base Deployment for Multicast Listener Support in Proxy Mobile IPv6 (PMIPv6) Domains

    Informational
  • RFC 6058: Transient Binding for Proxy Mobile IPv6

    Experimental
  • RFC 6097: Local Mobility Anchor (LMA) Discovery for Proxy Mobile IPv6

    Informational
  • RFC 6088: Traffic Selectors for Flow Bindings

    Proposed Standard
  • RFC 6089: Flow Bindings in Mobile IPv6 and Network Mobility (NEMO) Basic Support

    Proposed Standard
  • RFC 5949: Fast Handovers for Proxy Mobile IPv6

    Proposed Standard
  • RFC 5846: Binding Revocation for IPv6 Mobility

    Proposed Standard
  • RFC 5847: Heartbeat Mechanism for Proxy Mobile IPv6

    Proposed Standard
  • RFC 5845: Generic Routing Encapsulation (GRE) Key Option for Proxy Mobile IPv6

    Proposed Standard
  • RFC 5844: IPv4 Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 5779: Diameter Proxy Mobile IPv6: Mobile Access Gateway and Local Mobility Anchor Interaction with Diameter Server

    Proposed Standard
  • RFC 5757: Multicast Mobility in Mobile IP Version 6 (MIPv6): Problem Statement and Brief Survey

    Informational
  • RFC 5726: Mobile IPv6 Location Privacy Solutions

    Experimental
  • RFC 5778: Diameter Mobile IPv6: Support for Home Agent to Diameter Server Interaction

    Proposed Standard
  • RFC 5677: IEEE 802.21 Mobility Services Framework Design (MSFD)

    Proposed Standard
  • RFC 5678: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Options for IEEE 802.21 Mobility Services (MoS) Discovery

    Proposed Standard
  • RFC 5679: Locating IEEE 802.21 Mobility Services Using DNS

    Proposed Standard
  • RFC 5522: Network Mobility Route Optimization Requirements for Operational Use in Aeronautics and Space Exploration Mobile Networks

    Informational
  • RFC 5648: Multiple Care-of Addresses Registration

    Proposed Standard
  • RFC 5637: Authentication, Authorization, and Accounting (AAA) Goals for Mobile IPv6

    Informational
  • RFC 5568: Mobile IPv6 Fast Handovers

    Proposed Standard
  • RFC 5555: Mobile IPv6 Support for Dual Stack Hosts and Routers

    Proposed Standard
  • RFC 5488: Network Mobility (NEMO) Management Information Base

    Proposed Standard
  • RFC 5447: Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction

    Proposed Standard
  • RFC 5419: Why the Authentication Data Suboption is Needed for Mobile IPv6 (MIPv6)

    Informational
  • RFC 5380: Hierarchical Mobile IPv6 (HMIPv6) Mobility Management

    Proposed Standard
  • RFC 5213: Proxy Mobile IPv6

    Proposed Standard
  • RFC 5268: Mobile IPv6 Fast Handovers

    Proposed Standard

    Obsoleted by RFC 5568

  • RFC 5269: Distributing a Symmetric Fast Mobile IPv6 (FMIPv6) Handover Key Using SEcure Neighbor Discovery (SEND)

    Proposed Standard
  • RFC 5270: Mobile IPv6 Fast Handovers over IEEE 802.16e Networks

    Informational
  • RFC 5271: Mobile IPv6 Fast Handovers for 3G CDMA Networks

    Informational
  • RFC 5164: Mobility Services Transport: Problem Statement

    Informational
  • RFC 5149: Service Selection for Mobile IPv6

    Informational
  • RFC 5142: Mobility Header Home Agent Switch Message

    Proposed Standard
  • RFC 5094: Mobile IPv6 Vendor Specific Option

    Proposed Standard
  • RFC 5096: Mobile IPv6 Experimental Messages

    Proposed Standard
  • RFC 5026: Mobile IPv6 Bootstrapping in Split Scenario

    Proposed Standard
  • RFC 4977: Problem Statement: Dual Stack Mobility

    Informational
  • RFC 4882: IP Address Location Privacy and Mobile IPv6: Problem Statement

    Informational
  • RFC 4866: Enhanced Route Optimization for Mobile IPv6

    Proposed Standard
  • RFC 4877: Mobile IPv6 Operation with IKEv2 and the Revised IPsec Architecture

    Proposed Standard
  • RFC 4651: A Taxonomy and Analysis of Enhancements to Mobile IPv6 Route Optimization

    Informational
  • RFC 4640: Problem Statement for bootstrapping Mobile IPv6 (MIPv6)

    Informational
  • RFC 4584: Extension to Sockets API for Mobile IPv6

    Informational
  • RFC 4449: Securing Mobile IPv6 Route Optimization Using a Static Shared Key

    Proposed Standard
  • RFC 4487: Mobile IPv6 and Firewalls: Problem Statement

    Informational
  • RFC 4295: Mobile IPv6 Management Information Base

    Proposed Standard
  • RFC 4285: Authentication Protocol for Mobile IPv6

    Informational
  • RFC 4225: Mobile IP Version 6 Route Optimization Security Design Background

    Informational
  • RFC 4283: Mobile Node Identifier Option for Mobile IPv6 (MIPv6)

    Proposed Standard
  • RFC 4260: Mobile IPv6 Fast Handovers for 802.11 Networks

    Informational
  • RFC 4140: Hierarchical Mobile IPv6 Mobility Management (HMIPv6)

    Experimental

    Obsoleted by RFC 5380

  • RFC 4068: Fast Handovers for Mobile IPv6

    Experimental

    Obsoleted by RFC 5268

  • RFC 3963: Network Mobility (NEMO) Basic Support Protocol

    Proposed Standard
  • RFC 3775: Mobility Support in IPv6

    Proposed Standard

    Obsoleted by RFC 6275

  • RFC 3776: Using IPsec to Protect Mobile IPv6 Signaling Between Mobile Nodes and Home Agents

    Proposed Standard

Subscribe to Mobile IPv6

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.