IP mobility

IP-layer host and network mobility (Mobile IP and its successors)

IP mobility subjects:

IP mobility RFCs (49)

Display RFCs as
  • RFC 9721: Extended Mobility Procedures for Ethernet VPN Integrated Routing and Bridging (EVPN-IRB)

    Proposed Standard
  • RFC 9433: Segment Routing over IPv6 for the Mobile User Plane

    Informational
  • RFC 8653: On-Demand Mobility Management

    Informational
  • RFC 8127: Mobile Access Gateway Configuration Parameters Controlled by the Local Mobility Anchor

    Proposed Standard
  • RFC 8016: Mobility with Traversal Using Relays around NAT (TURN)

    Proposed Standard
  • RFC 7429: Distributed Mobility Management: Current Practices and Gap Analysis

    Informational
  • RFC 7333: Requirements for Distributed Mobility Management

    Informational
  • RFC 6636: Tuning the Behavior of the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) for Routers in Mobile and Wireless Networks

    Informational
  • RFC 6301: A Survey of Mobility Support in the Internet

    Informational
  • RFC 6059: Simple Procedures for Detecting Network Attachment in IPv6

    Proposed Standard
  • RFC 5631: Session Initiation Protocol (SIP) Session Mobility

    Informational
  • RFC 5446: Service Selection for Mobile IPv4

    Informational
  • RFC 5184: Unified Layer 2 (L2) Abstractions for Layer 3 (L3)-Driven Fast Handover

    Experimental
  • Informational
  • RFC 4784: Verizon Wireless Dynamic Mobile IP Key Update for cdma2000(R) Networks

    Informational
  • RFC 4621: Design of the IKEv2 Mobility and Multihoming (MOBIKE) Protocol

    Informational
  • RFC 4555: IKEv2 Mobility and Multihoming Protocol (MOBIKE)

    Proposed Standard
  • RFC 4332: Cisco's Mobile IPv4 Host Configuration Extensions

    Informational
  • RFC 4135: Goals of Detecting Network Attachment in IPv6

    Informational
  • RFC 4004: Diameter Mobile IPv4 Application

    Proposed Standard
  • RFC 4065: Instructions for Seamoby and Experimental Mobility Protocol IANA Allocations

    Experimental
  • RFC 4066: Candidate Access Router Discovery (CARD)

    Experimental
  • RFC 4067: Context Transfer Protocol (CXTP)

    Experimental
  • Informational
  • RFC 3588: Diameter Base Protocol

    Proposed Standard

    Obsoleted by RFC 6733

  • RFC 3583: Requirements of a Quality of Service (QoS) Solution for Mobile IP

    Informational
  • RFC 3543: Registration Revocation in Mobile IPv4

    Proposed Standard
  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

    Proposed Standard
  • RFC 3374: Problem Description: Reasons For Performing Context Transfers Between Nodes in an IP Access Network

    Informational
  • RFC 3344: IP Mobility Support for IPv4

    Proposed Standard

    Obsoleted by RFC 5944

  • RFC 3220: IP Mobility Support for IPv4

    Proposed Standard

    Obsoleted by RFC 3344

  • RFC 3154: Requirements and Functional Architecture for an IP Host Alerting Protocol

    Informational
  • RFC 3132: Dormant Mode Host Alerting ("IP Paging") Problem Statement

    Informational
  • RFC 3115: Mobile IP Vendor/Organization-Specific Extensions

    Proposed Standard
  • RFC 3025: Mobile IP Vendor/Organization-Specific Extensions

    Proposed Standard

    Obsoleted by RFC 3115

  • RFC 3024: Reverse Tunneling for Mobile IP, revised

    Proposed Standard
  • RFC 3012: Mobile IPv4 Challenge/Response Extensions

    Proposed Standard

    Obsoleted by RFC 4721

  • RFC 2977: Mobile IP Authentication, Authorization, and Accounting Requirements

    Informational
  • RFC 2794: Mobile IP Network Access Identifier Extension for IPv4

    Proposed Standard
  • RFC 2356: Sun's SKIP Firewall Traversal for Mobile IP

    Informational
  • RFC 2344: Reverse Tunneling for Mobile IP

    Proposed Standard

    Obsoleted by RFC 3024

  • RFC 2290: Mobile-IPv4 Configuration Option for PPP IPCP

    Proposed Standard
  • RFC 2103: Mobility Support for Nimrod : Challenges and Solution Approaches

    Informational
  • RFC 2002: IP Mobility Support

    Proposed Standard

    Obsoleted by RFC 3220

  • RFC 2003: IP Encapsulation within IP

    Proposed Standard
  • RFC 2004: Minimal Encapsulation within IP

    Proposed Standard
  • RFC 2005: Applicability Statement for IP Mobility Support

    Proposed Standard
  • RFC 2006: The Definitions of Managed Objects for IP Mobility Support using SMIv2

    Proposed Standard
  • RFC 1688: IPng Mobility Considerations

    Informational

Subscribe to IP mobility

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.