message format

Internet message format: headers, addressing, disposition

message format RFCs (43)

Display RFCs as
  • RFC 9477: Complaint Feedback Loop Address Header

    Experimental
  • RFC 9228: Delivered-To Email Header Field

    Experimental
  • RFC 8601: Message Header Field for Indicating Message Authentication Status

    Proposed Standard
  • RFC 8098: STD 85: Message Disposition Notification

    Internet Standard
  • RFC 8058: Signaling One-Click Functionality for List Email Headers

    Proposed Standard
  • RFC 7912: Message Authorizing Email Header Field and Its Use for the Draft and Release Procedure

    Informational
  • RFC 7601: Message Header Field for Indicating Message Authentication Status

    Proposed Standard

    Obsoleted by RFC 8601

  • RFC 7259: The Jabber-ID Header Field

    Informational
  • RFC 7001: Message Header Field for Indicating Message Authentication Status

    Proposed Standard

    Obsoleted by RFC 7601

  • RFC 6854: Update to Internet Message Format to Allow Group Syntax in the "From:" and "Sender:" Header Fields

    Proposed Standard
  • RFC 6532: Internationalized Email Headers

    Proposed Standard
  • RFC 5451: Message Header Field for Indicating Message Authentication Status

    Proposed Standard

    Obsoleted by RFC 7001

  • RFC 5322: Internet Message Format

    Draft Standard
  • RFC 5335: Internationalized Email Headers

    Experimental

    Obsoleted by RFC 6532

  • RFC 5064: The Archived-At Message Header Field

    Proposed Standard
  • RFC 5068: BCP 134: Email Submission Operations: Access and Accountability Requirements

    Best Current Practice
  • RFC 3864: BCP 90: Registration Procedures for Message Header Fields

    Best Current Practice
  • RFC 3865: A No Soliciting Simple Mail Transfer Protocol (SMTP) Service Extension

    Proposed Standard
  • RFC 3282: Content Language Headers

    Draft Standard
  • RFC 2821: Simple Mail Transfer Protocol

    Proposed Standard

    Obsoleted by RFC 5321

  • RFC 2822: Internet Message Format

    Proposed Standard

    Obsoleted by RFC 5322

  • RFC 2369: The Use of URLs as Meta-Syntax for Core Mail List Commands and their Transport through Message Header Fields

    Proposed Standard
  • RFC 2298: An Extensible Message Format for Message Disposition Notifications

    Proposed Standard

    Obsoleted by RFC 3798

  • RFC 2234: Augmented BNF for Syntax Specifications: ABNF

    Proposed Standard

    Obsoleted by RFC 4234

  • RFC 2076: Common Internet Message Headers

    Informational
  • RFC 2047: MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII Text

    Draft Standard
  • RFC 1891: SMTP Service Extension for Delivery Status Notifications

    Proposed Standard

    Obsoleted by RFC 3461

  • RFC 1892: The Multipart/Report Content Type for the Reporting of Mail System Administrative Messages

    Proposed Standard

    Obsoleted by RFC 3462

  • RFC 1893: Enhanced Mail System Status Codes

    Proposed Standard

    Obsoleted by RFC 3463

  • RFC 1894: An Extensible Message Format for Delivery Status Notifications

    Proposed Standard

    Obsoleted by RFC 3464

  • RFC 1522: MIME (Multipurpose Internet Mail Extensions) Part Two: Message Header Extensions for Non-ASCII Text

    Draft Standard

    Obsoleted by RFC 2045, RFC 2046, RFC 2047, RFC 2048, RFC 2049

  • RFC 1505: Encoding Header Field for Internet Messages

    Experimental
  • RFC 1342: Representation of Non-ASCII Text in Internet Message Headers

    Proposed Standard

    Obsoleted by RFC 1522

  • RFC 1153: Digest message format

    Experimental
  • RFC 1154: Encoding header field for internet messages

    Experimental

    Obsoleted by RFC 1505

  • RFC 934: Proposed standard for message encapsulation

    Unknown
  • RFC 886: Proposed standard for message header munging

    Unknown
  • RFC 841: Specification for message format for Computer Based Message Systems

    Unknown
  • RFC 822: STD 11: STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGES

    Internet Standard

    Obsoleted by RFC 2822

  • RFC 806: Proposed Federal Information Processing Standard: Specification for message format for computer based message systems

    Unknown

    Obsoleted by RFC 841

  • RFC 733: Standard for the format of ARPA network text messages

    Unknown

    Obsoleted by RFC 822

  • RFC 724: Proposed official standard for the format of ARPA Network messages

    Unknown

    Obsoleted by RFC 733

  • RFC 561: Standardizing Network Mail Headers

    Unknown

Subscribe to message format

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.