JSON

JSON (JavaScript Object Notation) and JSON-based formats

JSON subjects:

JSON RFCs (78)

Display RFCs as
  • RFC 9982: JSContact Version 2.0: A JSON Representation of Contact Data

    Proposed Standard
  • RFC 9964: ML-DSA for JSON Object Signing and Encryption (JOSE) and CBOR Object Signing and Encryption (COSE)

    Proposed Standard
  • RFC 9901: Selective Disclosure for JSON Web Tokens

    Proposed Standard
  • RFC 9864: Fully-Specified Algorithms for JSON Object Signing and Encryption (JOSE) and CBOR Object Signing and Encryption (COSE)

    Proposed Standard
  • RFC 9728: OAuth 2.0 Protected Resource Metadata

    Proposed Standard
  • RFC 9749: Use of Voluntary Application Server Identification (VAPID) in JSON Meta Application Protocol (JMAP) Web Push

    Proposed Standard
  • RFC 9701: JSON Web Token (JWT) Response for OAuth Token Introspection

    Proposed Standard
  • RFC 9610: JSON Meta Application Protocol (JMAP) for Contacts

    Proposed Standard
  • RFC 9670: JSON Meta Application Protocol (JMAP) Sharing

    Proposed Standard
  • RFC 9661: The JSON Meta Application Protocol (JMAP) for Sieve Scripts

    Proposed Standard
  • RFC 9553: JSContact: A JSON Representation of Contact Data

    Proposed Standard
  • RFC 9555: JSContact: Converting from and to vCard

    Proposed Standard
  • RFC 9404: JSON Meta Application Protocol (JMAP) Blob Management Extension

    Proposed Standard
  • RFC 9439: Application-Layer Traffic Optimization (ALTO) Performance Cost Metrics

    Proposed Standard
  • RFC 9457: Problem Details for HTTP APIs

    Proposed Standard
  • RFC 9425: JSON Meta Application Protocol (JMAP) for Quotas

    Proposed Standard
  • RFC 9321: Signature Validation Token

    Informational
  • RFC 9278: JWK Thumbprint URI

    Proposed Standard
  • Proposed Standard
  • RFC 9219: S/MIME Signature Verification Extension to the JSON Meta Application Protocol (JMAP)

    Proposed Standard
  • RFC 9068: JSON Web Token (JWT) Profile for OAuth 2.0 Access Tokens

    Proposed Standard
  • RFC 9118: Enhanced JSON Web Token (JWT) Claim Constraints for Secure Telephone Identity Revisited (STIR) Certificates

    Proposed Standard
  • RFC 9101: The OAuth 2.0 Authorization Framework: JWT-Secured Authorization Request (JAR)

    Proposed Standard
  • RFC 8984: JSCalendar: A JSON Representation of Calendar Data

    Proposed Standard
  • RFC 9083: STD 95: JSON Responses for the Registration Data Access Protocol (RDAP)

    Internet Standard
  • RFC 9007: Handling Message Disposition Notification with the JSON Meta Application Protocol (JMAP)

    Proposed Standard
  • RFC 8949: STD 94: Concise Binary Object Representation (CBOR)

    Internet Standard
  • RFC 8935: Push-Based Security Event Token (SET) Delivery Using HTTP

    Proposed Standard
  • RFC 8936: Poll-Based Security Event Token (SET) Delivery Using HTTP

    Proposed Standard
  • RFC 8927: JSON Type Definition

    Experimental
  • RFC 8887: A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocket

    Proposed Standard
  • RFC 8812: CBOR Object Signing and Encryption (COSE) and JSON Object Signing and Encryption (JOSE) Registrations for Web Authentication (WebAuthn) Algorithms

    Proposed Standard
  • RFC 8727: JSON Binding of the Incident Object Description Exchange Format

    Proposed Standard
  • RFC 8785: JSON Canonicalization Scheme (JCS)

    Informational
  • RFC 8705: OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access Tokens

    Proposed Standard
  • RFC 8746: Concise Binary Object Representation (CBOR) Tags for Typed Arrays

    Proposed Standard
  • RFC 8725: BCP 225: JSON Web Token Best Current Practices

    Best Current Practice
  • RFC 8742: Concise Binary Object Representation (CBOR) Sequences

    Proposed Standard
  • RFC 8693: OAuth 2.0 Token Exchange

    Proposed Standard
  • RFC 8621: The JSON Meta Application Protocol (JMAP) for Mail

    Proposed Standard
  • RFC 8620: The JSON Meta Application Protocol (JMAP)

    Proposed Standard
  • RFC 8610: Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures

    Proposed Standard
  • RFC 8443: Personal Assertion Token (PASSporT) Extension for Resource Priority Authorization

    Proposed Standard
  • RFC 8427: Representing DNS Messages in JSON

    Informational
  • RFC 8417: Security Event Token (SET)

    Proposed Standard
  • RFC 8414: OAuth 2.0 Authorization Server Metadata

    Proposed Standard
  • RFC 8392: CBOR Web Token (CWT)

    Proposed Standard
  • RFC 8259: STD 90: The JavaScript Object Notation (JSON) Data Interchange Format

    Internet Standard
  • RFC 8091: A Media Type Structured Syntax Suffix for JSON Text Sequences

    Informational
  • RFC 8037: CFRG Elliptic Curve Diffie-Hellman (ECDH) and Signatures in JSON Object Signing and Encryption (JOSE)

    Proposed Standard
  • RFC 7951: JSON Encoding of Data Modeled with YANG

    Proposed Standard
  • RFC 7800: Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)

    Proposed Standard
  • RFC 7807: Problem Details for HTTP APIs

    Proposed Standard

    Obsoleted by RFC 9457

  • RFC 7797: JSON Web Signature (JWS) Unencoded Payload Option

    Proposed Standard
  • RFC 7638: JSON Web Key (JWK) Thumbprint

    Proposed Standard
  • RFC 7515: JSON Web Signature (JWS)

    Proposed Standard
  • RFC 7516: JSON Web Encryption (JWE)

    Proposed Standard
  • RFC 7517: JSON Web Key (JWK)

    Proposed Standard
  • RFC 7518: JSON Web Algorithms (JWA)

    Proposed Standard
  • RFC 7519: JSON Web Token (JWT)

    Proposed Standard
  • RFC 7520: Examples of Protecting Content Using JSON Object Signing and Encryption (JOSE)

    Informational
  • RFC 7523: JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization Grants

    Proposed Standard
  • RFC 7483: JSON Responses for the Registration Data Access Protocol (RDAP)

    Proposed Standard

    Obsoleted by RFC 9083

  • RFC 7484: Finding the Authoritative Registration Data (RDAP) Service

    Proposed Standard

    Obsoleted by RFC 9224

  • RFC 7493: The I-JSON Message Format

    Proposed Standard
  • RFC 7464: JavaScript Object Notation (JSON) Text Sequences

    Proposed Standard
  • RFC 7396: JSON Merge Patch

    Proposed Standard
  • RFC 7386: JSON Merge Patch

    Proposed Standard

    Obsoleted by RFC 7396

  • RFC 7265: jCal: The JSON Format for iCalendar

    Proposed Standard
  • RFC 7165: Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)

    Informational
  • RFC 7159: The JavaScript Object Notation (JSON) Data Interchange Format

    Proposed Standard

    Obsoleted by RFC 8259

  • RFC 7158: The JavaScript Object Notation (JSON) Data Interchange Format

    Proposed Standard

    Obsoleted by RFC 7159

  • RFC 7095: jCard: The JSON Format for vCard

    Proposed Standard
  • RFC 7049: Concise Binary Object Representation (CBOR)

    Proposed Standard

    Obsoleted by RFC 8949

  • RFC 7033: WebFinger

    Proposed Standard
  • RFC 6901: JavaScript Object Notation (JSON) Pointer

    Proposed Standard
  • RFC 6902: JavaScript Object Notation (JSON) Patch

    Proposed Standard
  • RFC 4627: The application/json Media Type for JavaScript Object Notation (JSON)

    Informational

    Obsoleted by RFC 7159

Subscribe to JSON

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.