IPFIX

IPFIX (IP Flow Information Export) and packet sampling

IPFIX subjects:

IPFIX RFCs (48)

Display RFCs as
  • RFC 9951: Export of Delay Performance Metrics in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 9870: Export of UDP Options Information in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 9740: New IPFIX Information Elements for TCP Options and IPv6 Extension Headers

    Proposed Standard
  • RFC 9710: Simple Fixes to the IP Flow Information Export (IPFIX) Entities IANA Registry

    Proposed Standard
  • RFC 9565: An Update to the tcpControlBits IP Flow Information Export (IPFIX) Information Element

    Proposed Standard
  • RFC 9487: Export of Segment Routing over IPv6 Information in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 9160: Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 8549: Export of BGP Community Information in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 8158: IP Flow Information Export (IPFIX) Information Elements for Logging NAT Events

    Proposed Standard
  • RFC 8038: Exporting MIB Variables Using the IP Flow Information Export (IPFIX) Protocol

    Proposed Standard
  • RFC 7373: Textual Representation of IP Flow Information Export (IPFIX) Abstract Data Types

    Proposed Standard
  • RFC 7270: Cisco-Specific Information Elements Reused in IP Flow Information Export (IPFIX)

    Informational
  • RFC 7119: Operation of the IP Flow Information Export (IPFIX) Protocol on IPFIX Mediators

    Proposed Standard
  • RFC 7125: Revision of the tcpControlBits IP Flow Information Export (IPFIX) Information Element

    Informational

    Obsoleted by RFC 9565

  • RFC 7011: STD 77: Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow Information

    Internet Standard
  • RFC 7012: Information Model for IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 7013: BCP 184: Guidelines for Authors and Reviewers of IP Flow Information Export (IPFIX) Information Elements

    Best Current Practice
  • RFC 7014: Flow Selection Techniques

    Proposed Standard
  • RFC 7015: Flow Aggregation for the IP Flow Information Export (IPFIX) Protocol

    Proposed Standard
  • RFC 6759: Cisco Systems Export of Application Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 6645: IP Flow Information Accounting and Export Benchmarking Methodology

    Informational
  • RFC 6615: Definitions of Managed Objects for IP Flow Information Export

    Proposed Standard
  • RFC 6526: IP Flow Information Export (IPFIX) Per Stream Control Transmission Protocol (SCTP) Stream

    Proposed Standard
  • RFC 6313: Export of Structured Data in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 6235: IP Flow Anonymization Support

    Experimental
  • RFC 6183: IP Flow Information Export (IPFIX) Mediation: Framework

    Informational
  • RFC 5982: IP Flow Information Export (IPFIX) Mediation: Problem Statement

    Informational
  • RFC 5815: Definitions of Managed Objects for IP Flow Information Export

    Proposed Standard

    Obsoleted by RFC 6615

  • RFC 5655: Specification of the IP Flow Information Export (IPFIX) File Format

    Proposed Standard
  • RFC 5610: Exporting Type Information for IP Flow Information Export (IPFIX) Information Elements

    Proposed Standard
  • RFC 5470: Architecture for IP Flow Information Export

    Informational
  • RFC 5471: Guidelines for IP Flow Information Export (IPFIX) Testing

    Informational
  • RFC 5153: IP Flow Information Export (IPFIX) Implementation Guidelines

    Informational
  • RFC 5101: Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow Information

    Proposed Standard

    Obsoleted by RFC 7011

  • RFC 5102: Information Model for IP Flow Information Export

    Proposed Standard

    Obsoleted by RFC 7012

  • RFC 5103: Bidirectional Flow Export Using IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 3954: Cisco Systems NetFlow Services Export Version 9

    Informational
  • RFC 3955: Evaluation of Candidate Protocols for IP Flow Information Export (IPFIX)

    Informational
  • RFC 3917: Requirements for IP Flow Information Export (IPFIX)

    Informational
  • RFC 3423: XACCT's Common Reliable Accounting for Network Element (CRANE) Protocol Specification Version 1.0

    Informational
  • RFC 2720: Traffic Flow Measurement: Meter MIB

    Proposed Standard
  • RFC 2721: RTFM: Applicability Statement

    Informational
  • RFC 2722: Traffic Flow Measurement: Architecture

    Informational
  • RFC 2723: SRL: A Language for Describing Traffic Flows and Specifying Actions for Flow Groups

    Informational
  • RFC 2724: RTFM: New Attributes for Traffic Flow Measurement

    Experimental
  • RFC 2123: Traffic Flow Measurement: Experiences with NeTraMet

    Informational
  • RFC 2063: Traffic Flow Measurement: Architecture

    Experimental

    Obsoleted by RFC 2722

  • RFC 2064: Traffic Flow Measurement: Meter MIB

    Experimental

    Obsoleted by RFC 2720

Subscribe to IPFIX

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.