- Home
- RFCs by Subject
- network management
- energy management
energy management
Energy monitoring and management of networked devices
Within this page
energy management RFCs (7)
RFC 7603: Energy Management (EMAN) Applicability Statement
Proposed Standard- B. Schoening
- M. Chandramouli
- B. Nordman
- August 2015
- IETF publication
- Operations and Management Area
Abstract
The objective of Energy Management (EMAN) is to provide an energy management framework for networked devices. This document presents the applicability of the EMAN information model in a variety of scenarios with cases and target devices. These use cases are useful for identifying requirements for the framework and MIBs. Further, we describe the relationship of the EMAN framework to other relevant energy monitoring standards and architectures.
Abstract
The objective of Energy Management (EMAN) is to provide an energy management framework for networked devices. This document presents the applicability of the EMAN information model in a variety of scenarios with cases and target devices. These use cases are useful for identifying requirements for the framework and MIBs. Further, we describe the relationship of the EMAN framework to other relevant energy monitoring standards and architectures.
RFC 7577: Definition of Managed Objects for Battery Monitoring
Proposed Standard- J. Quittek
- R. Winter
- T. Dietz
- July 2015
- IETF publication
- Operations and Management Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it defines managed objects that provide information on the status of batteries in managed devices.
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it defines managed objects that provide information on the status of batteries in managed devices.
RFC 7460: Monitoring and Control MIB for Power and Energy
Proposed Standard- M. Chandramouli
- B. Claise
- B. Schoening
- J. Quittek
- T. Dietz
- March 2015
- IETF publication
- Operations and Management Area
Abstract
This document defines a subset of the Management Information Base (MIB) for power and energy monitoring of devices.
Abstract
This document defines a subset of the Management Information Base (MIB) for power and energy monitoring of devices.
RFC 7461: Energy Object Context MIB
Proposed Standard- J. Parello
- B. Claise
- M. Chandramouli
- March 2015
- IETF publication
- Operations and Management Area
Abstract
This document defines a subset of a Management Information Base (MIB) for energy management of devices. The module addresses device identification, context information, and the energy relationships between devices.
Abstract
This document defines a subset of a Management Information Base (MIB) for energy management of devices. The module addresses device identification, context information, and the energy relationships between devices.
RFC 7326: Energy Management Framework
Informational- J. Parello
- B. Claise
- B. Schoening
- J. Quittek
- September 2014
- IETF publication
- Operations and Management Area
Abstract
This document defines a framework for Energy Management (EMAN) for devices and device components within, or connected to, communication networks. The framework presents a physical reference model and information model. The information model consists of an Energy Management Domain as a set of Energy Objects. Each Energy Object can be attributed with identity, classification, and context. Energy Objects can be monitored and controlled with respect to power, Power State, energy, demand, Power Attributes, and battery. Additionally, the framework models relationships and capabilities between Energy Objects.
Abstract
This document defines a framework for Energy Management (EMAN) for devices and device components within, or connected to, communication networks. The framework presents a physical reference model and information model. The information model consists of an Energy Management Domain as a set of Energy Objects. Each Energy Object can be attributed with identity, classification, and context. Energy Objects can be monitored and controlled with respect to power, Power State, energy, demand, Power Attributes, and battery. Additionally, the framework models relationships and capabilities between Energy Objects.
RFC 6988: Requirements for Energy Management
Informational- J. Quittek
- M. Chandramouli
- R. Winter
- T. Dietz
- B. Claise
- September 2013
- IETF publication
- Operations and Management Area
Abstract
This document defines requirements for standards specifications for Energy Management. The requirements defined in this document are concerned with monitoring functions as well as control functions. Monitoring functions include identifying energy-managed devices and their components, as well as monitoring their Power States, Power Inlets, Power Outlets, actual power, Power Attributes, received energy, provided energy, and contained batteries. Control functions include such functions as controlling power supply and Power State of energy-managed devices and their components.
This document does not specify the features that must be implemented by compliant implementations but rather lists features that must be supported by standards for Energy Management.
Abstract
This document defines requirements for standards specifications for Energy Management. The requirements defined in this document are concerned with monitoring functions as well as control functions. Monitoring functions include identifying energy-managed devices and their components, as well as monitoring their Power States, Power Inlets, Power Outlets, actual power, Power Attributes, received energy, provided energy, and contained batteries. Control functions include such functions as controlling power supply and Power State of energy-managed devices and their components.
This document does not specify the features that must be implemented by compliant implementations but rather lists features that must be supported by standards for Energy Management.
RFC 6933: Entity MIB (Version 4)
Proposed Standard- A. Bierman
- D. Romascanu
- J. Quittek
- M. Chandramouli
- May 2013
- IETF publication
- Operations and Management Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects used for managing multiple logical and physical entities managed by a single Simple Network Management Protocol (SNMP) agent. This document specifies version 4 of the Entity MIB. This memo obsoletes version 3 of the Entity MIB module published as RFC 4133.
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. In particular, it describes managed objects used for managing multiple logical and physical entities managed by a single Simple Network Management Protocol (SNMP) agent. This document specifies version 4 of the Entity MIB. This memo obsoletes version 3 of the Entity MIB module published as RFC 4133.
Subscribe to energy management
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.