DHCPv6

DHCPv6 (Dynamic Host Configuration Protocol for IPv6): DHCP for IPv6

DHCPv6 RFCs (74)

Display RFCs as
  • RFC 10038: Distributing the Segment Routing over IPv6 (SRv6) Locator Using DHCPv6

    Proposed Standard
  • RFC 9928: DHCPv4 over DHCPv6 with Relay Agent Support

    Proposed Standard
  • RFC 9915: STD 102: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Internet Standard
  • RFC 9898: Neighbor Discovery Considerations in IPv6 Deployments

    Informational
  • RFC 9818: DHCPv6 Prefix Delegation on IPv6 Customer Edge (CE) Routers in LANs

    Informational
  • RFC 9762: Using Router Advertisements to Signal the Availability of DHCPv6 Prefix Delegation to Clients

    Proposed Standard
  • RFC 9686: Registering Self-Generated IPv6 Addresses Using DHCPv6

    Proposed Standard
  • RFC 9663: Using DHCPv6 Prefix Delegation (DHCPv6-PD) to Allocate Unique IPv6 Prefixes per Client in Large Broadcast Networks

    Informational
  • RFC 9527: DHCPv6 Options for the Homenet Naming Authority

    Proposed Standard
  • RFC 9243: A YANG Data Model for DHCPv6 Configuration

    Proposed Standard
  • RFC 9096: BCP 234: Improving the Reaction of Customer Edge Routers to IPv6 Renumbering Events

    Best Current Practice
  • RFC 8987: DHCPv6 Prefix Delegating Relay Requirements

    Proposed Standard
  • Proposed Standard
  • RFC 8948: Structured Local Address Plan (SLAP) Quadrant Selection Option for DHCPv6

    Proposed Standard
  • RFC 8539: Softwire Provisioning Using DHCPv4 over DHCPv6

    Proposed Standard
  • RFC 8415: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard

    Obsoleted by RFC 9915

  • RFC 8156: DHCPv6 Failover Protocol

    Proposed Standard
  • RFC 8168: DHCPv6 Prefix-Length Hint Issues

    Proposed Standard
  • RFC 8115: DHCPv6 Option for IPv4-Embedded Multicast and Unicast IPv6 Prefixes

    Proposed Standard
  • RFC 8026: Unified IPv4-in-IPv6 Softwire Customer Premises Equipment (CPE): A DHCPv6-Based Prioritization Mechanism

    Proposed Standard
  • RFC 7969: Customizing DHCP Configuration on the Basis of Network Topology

    Informational
  • RFC 7943: A Method for Generating Semantically Opaque Interface Identifiers (IIDs) with the Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Informational
  • RFC 7934: BCP 204: Host Address Availability Recommendations

    Best Current Practice
  • RFC 7839: Access-Network-Identifier Option in DHCP

    Proposed Standard
  • RFC 7824: Privacy Considerations for DHCPv6

    Informational
  • RFC 7844: Anonymity Profiles for DHCP Clients

    Proposed Standard
  • RFC 7774: Multicast Protocol for Low-Power and Lossy Networks (MPL) Parameter Configuration Option for DHCPv6

    Proposed Standard
  • RFC 7653: DHCPv6 Active Leasequery

    Proposed Standard
  • RFC 7610: BCP 199: DHCPv6-Shield: Protecting against Rogue DHCPv6 Servers

    Best Current Practice
  • RFC 7598: DHCPv6 Options for Configuration of Softwire Address and Port-Mapped Clients

    Proposed Standard
  • RFC 7550: Issues and Recommendations with Multiple Stateful DHCPv6 Options

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 7341: DHCPv4-over-DHCPv6 (DHCP 4o6) Transport

    Proposed Standard
  • RFC 7283: Handling Unknown DHCPv6 Messages

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 7227: BCP 187: Guidelines for Creating New DHCPv6 Options

    Best Current Practice
  • RFC 7078: Distributing Address Selection Policy Using DHCPv6

    Proposed Standard
  • RFC 7037: RADIUS Option for the DHCPv6 Relay Agent

    Proposed Standard
  • RFC 7031: DHCPv6 Failover Requirements

    Informational
  • RFC 6977: Triggering DHCPv6 Reconfiguration from Relay Agents

    Proposed Standard
  • Proposed Standard
  • RFC 6853: BCP 180: DHCPv6 Redundancy Deployment Considerations

    Best Current Practice
  • RFC 6784: Kerberos Options for DHCPv6

    Proposed Standard
  • RFC 6644: Rebind Capability in DHCPv6 Reconfigure Messages

    Proposed Standard
  • RFC 6653: DHCPv6 Prefix Delegation in Long-Term Evolution (LTE) Networks

    Informational
  • RFC 6603: Prefix Exclude Option for DHCPv6-based Prefix Delegation

    Proposed Standard
  • RFC 6607: Virtual Subnet Selection Options for DHCPv4 and DHCPv6

    Proposed Standard
  • RFC 6422: Relay-Supplied DHCP Options

    Proposed Standard
  • RFC 6440: The EAP Re-authentication Protocol (ERP) Local Domain Name DHCPv6 Option

    Proposed Standard
  • RFC 6355: Definition of the UUID-Based DHCPv6 Unique Identifier (DUID-UUID)

    Proposed Standard
  • RFC 6334: Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Option for Dual-Stack Lite

    Proposed Standard
  • RFC 6276: DHCPv6 Prefix Delegation for Network Mobility (NEMO)

    Proposed Standard
  • RFC 6221: Lightweight DHCPv6 Relay Agent

    Proposed Standard
  • RFC 6153: DHCPv4 and DHCPv6 Options for Access Network Discovery and Selection Function (ANDSF) Discovery

    Proposed Standard
  • RFC 6059: Simple Procedures for Detecting Network Attachment in IPv6

    Proposed Standard
  • RFC 6011: Session Initiation Protocol (SIP) User Agent Configuration

    Informational
  • RFC 5970: DHCPv6 Options for Network Boot

    Proposed Standard
  • RFC 5908: Network Time Protocol (NTP) Server Option for DHCPv6

    Proposed Standard
  • RFC 5678: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Options for IEEE 802.21 Mobility Services (MoS) Discovery

    Proposed Standard
  • RFC 5460: DHCPv6 Bulk Leasequery

    Proposed Standard
  • RFC 4994: DHCPv6 Relay Agent Echo Request Option

    Proposed Standard
  • RFC 5007: DHCPv6 Leasequery

    Proposed Standard
  • RFC 4776: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Option for Civic Addresses Configuration Information

    Proposed Standard
  • RFC 4676: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Option for Civic Addresses Configuration Information

    Proposed Standard

    Obsoleted by RFC 4776

  • RFC 4704: The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Client Fully Qualified Domain Name (FQDN) Option

    Proposed Standard
  • RFC 4649: Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Relay Agent Remote-ID Option

    Proposed Standard
  • RFC 4580: Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Relay Agent Subscriber-ID Option

    Proposed Standard
  • RFC 4339: IPv6 Host Configuration of DNS Server Information Approaches

    Informational
  • RFC 4361: Node-specific Client Identifiers for Dynamic Host Configuration Protocol Version Four (DHCPv4)

    Proposed Standard
  • RFC 4242: Information Refresh Time Option for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6

    Proposed Standard
  • RFC 4076: Renumbering Requirements for Stateless Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Informational
  • RFC 3898: Network Information Service (NIS) Configuration Options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard
  • RFC 3646: DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard
  • RFC 3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 3319: Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiation Protocol (SIP) Servers

    Proposed Standard

Subscribe to DHCPv6

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.