DHCP

DHCP (Dynamic Host Configuration Protocol)

DHCP subjects:

DHCP RFCs (94)

Display RFCs as
  • RFC 9463: DHCP and Router Advertisement Options for the Discovery of Network-designated Resolvers (DNR)

    Proposed Standard
  • RFC 9445: RADIUS Extensions for DHCP-Configured Services

    Proposed Standard
  • RFC 8925: IPv6-Only Preferred Option for DHCPv4

    Proposed Standard
  • RFC 8910: Captive-Portal Identification in DHCP and Router Advertisements (RAs)

    Proposed Standard
  • RFC 8801: Discovering Provisioning Domain Names and Data

    Proposed Standard
  • RFC 8357: Generalized UDP Source Port for DHCP Relay

    Proposed Standard
  • Proposed Standard
  • RFC 8213: Security of Messages Exchanged between Servers and Relay Agents

    Proposed Standard
  • RFC 8074: Source Address Validation Improvement (SAVI) for Mixed Address Assignment Methods Scenario

    Proposed Standard
  • RFC 7819: Privacy Considerations for DHCP

    Informational
  • RFC 7724: Active DHCPv4 Lease Query

    Proposed Standard
  • RFC 7710: Captive-Portal Identification Using DHCP or Router Advertisements (RAs)

    Proposed Standard

    Obsoleted by RFC 8910

  • RFC 7618: Dynamic Allocation of Shared IPv4 Addresses

    Proposed Standard
  • RFC 7513: Source Address Validation Improvement (SAVI) Solution for DHCP

    Proposed Standard
  • RFC 7291: DHCP Options for the Port Control Protocol (PCP)

    Proposed Standard
  • RFC 7083: Modification to Default Values of SOL_MAX_RT and INF_MAX_RT

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 6925: The DHCPv4 Relay Agent Identifier Sub-Option

    Proposed Standard
  • RFC 6926: DHCPv4 Bulk Leasequery

    Proposed Standard
  • RFC 6842: Client Identifier Option in DHCP Server Replies

    Proposed Standard
  • RFC 6704: Forcerenew Nonce Authentication

    Proposed Standard
  • RFC 6656: Description of Cisco Systems' Subnet Allocation Option for DHCPv4

    Informational
  • RFC 6610: DHCP Options for Home Information Discovery in Mobile IPv6 (MIPv6)

    Proposed Standard
  • RFC 6418: Multiple Interfaces and Provisioning Domains Problem Statement

    Informational
  • RFC 6225: Dynamic Host Configuration Protocol Options for Coordinate-Based Location Configuration Information

    Proposed Standard
  • RFC 6148: DHCPv4 Lease Query by Relay Agent Remote ID

    Proposed Standard
  • RFC 5505: Principles of Internet Host Configuration

    Informational
  • RFC 5417: Control And Provisioning of Wireless Access Points (CAPWAP) Access Controller DHCP Option

    Proposed Standard
  • RFC 5223: Discovering Location-to-Service Translation (LoST) Servers Using the Dynamic Host Configuration Protocol (DHCP)

    Proposed Standard
  • RFC 5192: DHCP Options for Protocol for Carrying Authentication for Network Access (PANA) Authentication Agents

    Proposed Standard
  • RFC 5107: DHCP Server Identifier Override Suboption

    Proposed Standard
  • RFC 5071: Dynamic Host Configuration Protocol Options Used by PXELINUX

    Informational
  • RFC 5010: The Dynamic Host Configuration Protocol Version 4 (DHCPv4) Relay Agent Flags Suboption

    Proposed Standard
  • RFC 4833: Timezone Options for DHCP

    Proposed Standard
  • RFC 4578: Dynamic Host Configuration Protocol (DHCP) Options for the Intel Preboot eXecution Environment (PXE)

    Informational
  • RFC 4701: A DNS Resource Record (RR) for Encoding Dynamic Host Configuration Protocol (DHCP) Information (DHCID RR)

    Proposed Standard
  • RFC 4702: The Dynamic Host Configuration Protocol (DHCP) Client Fully Qualified Domain Name (FQDN) Option

    Proposed Standard
  • RFC 4703: Resolution of Fully Qualified Domain Name (FQDN) Conflicts among Dynamic Host Configuration Protocol (DHCP) Clients

    Proposed Standard
  • RFC 4562: MAC-Forced Forwarding: A Method for Subscriber Separation on an Ethernet Access Network

    Informational
  • RFC 4477: Dynamic Host Configuration Protocol (DHCP): IPv4 and IPv6 Dual-Stack Issues

    Informational
  • RFC 4390: Dynamic Host Configuration Protocol (DHCP) over InfiniBand

    Proposed Standard
  • RFC 4436: Detecting Network Attachment in IPv4 (DNAv4)

    Proposed Standard
  • RFC 4388: Dynamic Host Configuration Protocol (DHCP) Leasequery

    Proposed Standard
  • RFC 4332: Cisco's Mobile IPv4 Host Configuration Extensions

    Informational
  • RFC 4243: Vendor-Specific Information Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Option

    Proposed Standard
  • RFC 4280: Dynamic Host Configuration Protocol (DHCP) Options for Broadcast and Multicast Control Servers

    Proposed Standard
  • RFC 4174: The IPv4 Dynamic Host Configuration Protocol (DHCP) Option for the Internet Storage Name Service

    Proposed Standard
  • RFC 4030: The Authentication Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Option

    Proposed Standard
  • RFC 4039: Rapid Commit Option for the Dynamic Host Configuration Protocol version 4 (DHCPv4)

    Proposed Standard
  • RFC 3993: Subscriber-ID Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Option

    Proposed Standard
  • RFC 4014: Remote Authentication Dial-In User Service (RADIUS) Attributes Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Information Option

    Proposed Standard
  • RFC 3942: Reclassifying Dynamic Host Configuration Protocol version 4 (DHCPv4) Options

    Proposed Standard
  • RFC 3925: Vendor-Identifying Vendor Options for Dynamic Host Configuration Protocol version 4 (DHCPv4)

    Proposed Standard
  • RFC 3825: Dynamic Host Configuration Protocol Option for Coordinate-based Location Configuration Information

    Proposed Standard

    Obsoleted by RFC 6225

  • RFC 3736: Stateless Dynamic Host Configuration Protocol (DHCP) Service for IPv6

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 3679: Unused Dynamic Host Configuration Protocol (DHCP) Option Codes

    Informational
  • RFC 3634: Key Distribution Center (KDC) Server Address Sub-option for the Dynamic Host Configuration Protocol (DHCP) CableLabs Client Configuration (CCC) Option

    Proposed Standard
  • RFC 3633: IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6

    Proposed Standard

    Obsoleted by RFC 8415

  • RFC 3594: PacketCable Security Ticket Control Sub-Option for the DHCP CableLabs Client Configuration (CCC) Option

    Proposed Standard
  • Proposed Standard
  • RFC 3495: Dynamic Host Configuration Protocol (DHCP) Option for CableLabs Client Configuration

    Proposed Standard
  • RFC 3456: Dynamic Host Configuration Protocol (DHCPv4) Configuration of IPsec Tunnel Mode

    Proposed Standard
  • RFC 3442: The Classless Static Route Option for Dynamic Host Configuration Protocol (DHCP) version 4

    Proposed Standard
  • RFC 3396: Encoding Long Options in the Dynamic Host Configuration Protocol (DHCPv4)

    Proposed Standard
  • RFC 3397: Dynamic Host Configuration Protocol (DHCP) Domain Search Option

    Proposed Standard
  • RFC 3361: Dynamic Host Configuration Protocol (DHCP-for-IPv4) Option for Session Initiation Protocol (SIP) Servers

    Proposed Standard
  • RFC 3256: The DOCSIS (Data-Over-Cable Service Interface Specifications) Device Class DHCP (Dynamic Host Configuration Protocol) Relay Agent Information Sub-option

    Proposed Standard
  • RFC 3203: DHCP reconfigure extension

    Proposed Standard
  • RFC 3118: Authentication for DHCP Messages

    Proposed Standard
  • RFC 3074: DHC Load Balancing Algorithm

    Proposed Standard
  • RFC 3046: DHCP Relay Agent Information Option

    Proposed Standard
  • RFC 3004: The User Class Option for DHCP

    Proposed Standard
  • RFC 3011: The IPv4 Subnet Selection Option for DHCP

    Proposed Standard
  • RFC 2937: The Name Service Search Option for DHCP

    Proposed Standard
  • RFC 2939: BCP 43: Procedures and IANA Guidelines for Definition of New DHCP Options and Message Types

    Best Current Practice
  • RFC 2855: DHCP for IEEE 1394

    Proposed Standard
  • RFC 2610: DHCP Options for Service Location Protocol

    Proposed Standard
  • RFC 2563: DHCP Option to Disable Stateless Auto-Configuration in IPv4 Clients

    Proposed Standard
  • RFC 2485: DHCP Option for The Open Group's User Authentication Protocol

    Proposed Standard
  • RFC 2489: BCP 29: Procedure for Defining New DHCP Options

    Best Current Practice

    Obsoleted by RFC 2939

  • RFC 2241: DHCP Options for Novell Directory Services

    Proposed Standard
  • RFC 2242: NetWare/IP Domain Name and Information

    Proposed Standard
  • RFC 2131: Dynamic Host Configuration Protocol

    Draft Standard
  • RFC 2132: DHCP Options and BOOTP Vendor Extensions

    Draft Standard
  • RFC 1531: Dynamic Host Configuration Protocol

    Proposed Standard

    Obsoleted by RFC 1541

  • RFC 1532: Clarifications and Extensions for the Bootstrap Protocol

    Proposed Standard

    Obsoleted by RFC 1542

  • RFC 1533: DHCP Options and BOOTP Vendor Extensions

    Proposed Standard

    Obsoleted by RFC 2132

  • RFC 1534: Interoperation Between DHCP and BOOTP

    Draft Standard
  • RFC 1541: Dynamic Host Configuration Protocol

    Proposed Standard

    Obsoleted by RFC 2131

  • RFC 1542: Clarifications and Extensions for the Bootstrap Protocol

    Draft Standard
  • RFC 1497: BOOTP Vendor Information Extensions

    Draft Standard

    Obsoleted by RFC 1533

  • RFC 1395: BOOTP Vendor Information Extensions

    Draft Standard

    Obsoleted by RFC 1497, RFC 1533

  • RFC 1084: BOOTP vendor information extensions

    Unknown

    Obsoleted by RFC 1395, RFC 1497, RFC 1533

  • RFC 1048: BOOTP vendor information extensions

    Unknown

    Obsoleted by RFC 1084, RFC 1395, RFC 1497, RFC 1533

  • RFC 951: Bootstrap Protocol

    Draft Standard

Subscribe to DHCP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.