CBOR

CBOR (Concise Binary Object Representation)

CBOR subjects:

CBOR RFCs (38)

Display RFCs as
  • RFC 9997: YANG-CBOR: Allocating SID Ranges for Private Enterprise Number (PEN) Holders

    Proposed Standard
  • RFC 9995: CBOR Object Signing and Encryption (COSE) Hash Envelope

    Proposed Standard
  • RFC 9942: CBOR Object Signing and Encryption (COSE) Receipts

    Proposed Standard
  • RFC 9964: ML-DSA for JSON Object Signing and Encryption (JOSE) and CBOR Object Signing and Encryption (COSE)

    Proposed Standard
  • RFC 9921: CBOR Object Signing and Encryption (COSE) Header Parameter for Timestamp Tokens as Defined in RFC 3161

    Proposed Standard
  • RFC 9864: Fully-Specified Algorithms for JSON Object Signing and Encryption (JOSE) and CBOR Object Signing and Encryption (COSE)

    Proposed Standard
  • RFC 9711: The Entity Attestation Token (EAT)

    Proposed Standard
  • RFC 9679: CBOR Object Signing and Encryption (COSE) Key Thumbprint

    Proposed Standard
  • RFC 9581: Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

    Proposed Standard
  • RFC 9595: YANG Schema Item iDentifier (YANG SID)

    Proposed Standard
  • RFC 9597: CBOR Web Token (CWT) Claims in COSE Headers

    Proposed Standard
  • RFC 9596: CBOR Object Signing and Encryption (COSE) "typ" (type) Header Parameter

    Proposed Standard
  • RFC 9542: BCP 141: IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 Parameters

    Best Current Practice
  • RFC 9459: CBOR Object Signing and Encryption (COSE): AES-CTR and AES-CBC

    Proposed Standard
  • RFC 9360: CBOR Object Signing and Encryption (COSE): Header Parameters for Carrying and Referencing X.509 Certificates

    Proposed Standard
  • RFC 9338: STD 96: CBOR Object Signing and Encryption (COSE): Countersignatures

    Internet Standard
  • RFC 9290: Concise Problem Details for Constrained Application Protocol (CoAP) APIs

    Proposed Standard
  • RFC 9052: STD 96: CBOR Object Signing and Encryption (COSE): Structures and Process

    Internet Standard
  • RFC 9053: CBOR Object Signing and Encryption (COSE): Initial Algorithms

    Informational
  • RFC 9054: CBOR Object Signing and Encryption (COSE): Hash Algorithms

    Informational
  • RFC 9277: On Stable Storage for Items in Concise Binary Object Representation (CBOR)

    Proposed Standard
  • RFC 9254: Encoding of Data Modeled with YANG in the Concise Binary Object Representation (CBOR)

    Proposed Standard
  • RFC 9164: Concise Binary Object Representation (CBOR) Tags for IPv4 and IPv6 Addresses and Prefixes

    Proposed Standard
  • RFC 9090: Concise Binary Object Representation (CBOR) Tags for Object Identifiers

    Proposed Standard
  • RFC 9021: Use of the Walnut Digital Signature Algorithm with CBOR Object Signing and Encryption (COSE)

    Informational
  • RFC 8949: STD 94: Concise Binary Object Representation (CBOR)

    Internet Standard
  • RFC 8943: Concise Binary Object Representation (CBOR) Tags for Date

    Proposed Standard
  • RFC 8812: CBOR Object Signing and Encryption (COSE) and JSON Object Signing and Encryption (JOSE) Registrations for Web Authentication (WebAuthn) Algorithms

    Proposed Standard
  • RFC 8727: JSON Binding of the Incident Object Description Exchange Format

    Proposed Standard
  • RFC 8778: Use of the HSS/LMS Hash-Based Signature Algorithm with CBOR Object Signing and Encryption (COSE)

    Proposed Standard
  • RFC 8769: Cryptographic Message Syntax (CMS) Content Types for Concise Binary Object Representation (CBOR)

    Informational
  • RFC 8747: Proof-of-Possession Key Semantics for CBOR Web Tokens (CWTs)

    Proposed Standard
  • RFC 8746: Concise Binary Object Representation (CBOR) Tags for Typed Arrays

    Proposed Standard
  • RFC 8742: Concise Binary Object Representation (CBOR) Sequences

    Proposed Standard
  • RFC 8392: CBOR Web Token (CWT)

    Proposed Standard
  • RFC 8230: Using RSA Algorithms with CBOR Object Signing and Encryption (COSE) Messages

    Proposed Standard
  • RFC 8152: CBOR Object Signing and Encryption (COSE)

    Proposed Standard

    Obsoleted by RFC 9052, RFC 9053

  • RFC 7049: Concise Binary Object Representation (CBOR)

    Proposed Standard

    Obsoleted by RFC 8949

Subscribe to CBOR

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.