ASN.1

ASN.1 (Abstract Syntax Notation One) modules and encoding rules

ASN.1 RFCs (28)

Display RFCs as
  • RFC 9169: New ASN.1 Modules for the Evidence Record Syntax (ERS)

    Informational
  • RFC 9090: Concise Binary Object Representation (CBOR) Tags for Object Identifiers

    Proposed Standard
  • RFC 8951: Clarification of Enrollment over Secure Transport (EST): Transfer Encodings and ASN.1

    Proposed Standard
  • RFC 8410: Algorithm Identifiers for Ed25519, Ed448, X25519, and X448 for Use in the Internet X.509 Public Key Infrastructure

    Proposed Standard
  • RFC 6268: Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)

    Informational
  • RFC 6025: ASN.1 Translation

    Informational
  • RFC 6019: BinaryTime: An Alternate Format for Representing Date and Time in ASN.1

    Proposed Standard
  • RFC 5911: New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME

    Informational
  • RFC 5912: New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)

    Informational
  • RFC 5480: Elliptic Curve Cryptography Subject Public Key Information

    Proposed Standard
  • RFC 4910: Robust XML Encoding Rules (RXER) for Abstract Syntax Notation One (ASN.1)

    Experimental
  • RFC 4911: Encoding Instructions for the Robust XML Encoding Rules (RXER)

    Experimental
  • RFC 4912: Abstract Syntax Notation X (ASN.X)

    Experimental
  • RFC 4913: Abstract Syntax Notation X (ASN.X) Representation of Encoding Instructions for the Generic String Encoding Rules (GSER)

    Experimental
  • RFC 4914: Abstract Syntax Notation X (ASN.X) Representation of Encoding Instructions for the XML Encoding Rules (XER)

    Experimental
  • RFC 4792: Encoding Instructions for the Generic String Encoding Rules (GSER)

    Proposed Standard
  • RFC 4510: Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map

    Proposed Standard
  • RFC 4514: Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished Names

    Proposed Standard
  • RFC 4515: Lightweight Directory Access Protocol (LDAP): String Representation of Search Filters

    Proposed Standard
  • RFC 4055: Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile

    Proposed Standard
  • RFC 4049: BinaryTime: An Alternate Format for Representing Date and Time in ASN.1

    Experimental

    Obsoleted by RFC 6019

  • RFC 3727: ASN.1 Module Definition for the LDAP and X.500 Component Matching Rules

    Proposed Standard
  • RFC 3641: Generic String Encoding Rules (GSER) for ASN.1 Types

    Proposed Standard
  • RFC 3642: Common Elements of Generic String Encoding Rules (GSER) Encodings

    Informational
  • RFC 3279: Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile

    Proposed Standard
  • RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4514

  • RFC 2254: The String Representation of LDAP Search Filters

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4515

  • RFC 1278: A string encoding of Presentation Address

    Informational

Subscribe to ASN.1

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.