XMPP

XMPP (Extensible Messaging and Presence Protocol)

XMPP RFCs (32)

Display RFCs as
  • RFC 8600: Using Extensible Messaging and Presence Protocol (XMPP) for Security Information Exchange

    Proposed Standard
  • RFC 8284: Lightweight Directory Access Protocol (LDAP) Schema for Supporting the Extensible Messaging and Presence Protocol (XMPP) in White Pages

    Informational
  • RFC 8266: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard
  • RFC 8048: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Presence

    Proposed Standard
  • RFC 7700: Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames

    Proposed Standard

    Obsoleted by RFC 8266

  • RFC 7702: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Groupchat

    Proposed Standard
  • RFC 7711: PKIX over Secure HTTP (POSH)

    Proposed Standard
  • RFC 7712: Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 7649: The Jabber Scribe Role at IETF Meetings

    Historic
  • RFC 7622: Extensible Messaging and Presence Protocol (XMPP): Address Format

    Proposed Standard
  • RFC 7590: Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 7572: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Instant Messaging

    Proposed Standard
  • RFC 7573: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): One-to-One Text Chat Sessions

    Proposed Standard
  • RFC 7395: An Extensible Messaging and Presence Protocol (XMPP) Subprotocol for WebSocket

    Proposed Standard
  • RFC 7340: Secure Telephone Identity Problem Statement and Requirements

    Informational
  • RFC 7247: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Architecture, Addresses, and Error Handling

    Proposed Standard
  • RFC 7248: Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Presence

    Proposed Standard

    Obsoleted by RFC 8048

  • RFC 7259: The Jabber-ID Header Field

    Informational
  • RFC 7165: Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)

    Informational
  • RFC 7081: CUSAX: Combined Use of the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP)

    Informational
  • RFC 6120: Extensible Messaging and Presence Protocol (XMPP): Core

    Proposed Standard
  • RFC 6121: Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and Presence

    Proposed Standard
  • RFC 6122: Extensible Messaging and Presence Protocol (XMPP): Address Format

    Proposed Standard

    Obsoleted by RFC 7622

  • RFC 5437: Sieve Notification Mechanism: Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 5122: Internationalized Resource Identifiers (IRIs) and Uniform Resource Identifiers (URIs) for the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 4979: IANA Registration for Enumservice 'XMPP'

    Proposed Standard
  • RFC 4854: A Uniform Resource Name (URN) Namespace for Extensions to the Extensible Messaging and Presence Protocol (XMPP)

    Informational
  • RFC 4622: Internationalized Resource Identifiers (IRIs) and Uniform Resource Identifiers (URIs) for the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard

    Obsoleted by RFC 5122

  • RFC 3920: Extensible Messaging and Presence Protocol (XMPP): Core

    Proposed Standard

    Obsoleted by RFC 6120

  • RFC 3921: Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and Presence

    Proposed Standard

    Obsoleted by RFC 6121

  • RFC 3922: Mapping the Extensible Messaging and Presence Protocol (XMPP) to Common Presence and Instant Messaging (CPIM)

    Proposed Standard
  • RFC 3923: End-to-End Signing and Object Encryption for the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard

Subscribe to XMPP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.