- Home
- RFCs by Subject
- security
- XML signatures
XML signatures
XML digital signatures and encryption
Within this page
XML signatures RFCs (10)
RFC 9231: Additional XML Security Uniform Resource Identifiers (URIs)
Proposed Standard- D. Eastlake 3rd
- July 2022
- IETF publication
- General Area
Abstract
This document updates and corrects the IANA "XML Security URIs" registry that lists URIs intended for use with XML digital signatures, encryption, canonicalization, and key management. These URIs identify algorithms and types of information. This document also obsoletes and corrects three errata against RFC 6931.
Abstract
This document updates and corrects the IANA "XML Security URIs" registry that lists URIs intended for use with XML digital signatures, encryption, canonicalization, and key management. These URIs identify algorithms and types of information. This document also obsoletes and corrects three errata against RFC 6931.
RFC 6283: Extensible Markup Language Evidence Record Syntax (XMLERS)
Proposed Standard- A. Jerman Blazic
- S. Saljic
- T. Gondrom
- July 2011
- IETF publication
- Applications Area
Abstract
In many scenarios, users must be able to demonstrate the (time of) existence, integrity, and validity of data including signed data for long or undetermined periods of time. This document specifies XML syntax and processing rules for creating evidence for long-term non- repudiation of existence and integrity of data. The Extensible Markup Language Evidence Record Syntax XMLERS provides alternative syntax and processing rules to the ASN.1 (Abstract Syntax Notation One) ERS (Evidence Record Syntax) (RFC 4998) syntax by using XML. [STANDARDS-TRACK]
Abstract
In many scenarios, users must be able to demonstrate the (time of) existence, integrity, and validity of data including signed data for long or undetermined periods of time. This document specifies XML syntax and processing rules for creating evidence for long-term non- repudiation of existence and integrity of data. The Extensible Markup Language Evidence Record Syntax XMLERS provides alternative syntax and processing rules to the ASN.1 (Abstract Syntax Notation One) ERS (Evidence Record Syntax) (RFC 4998) syntax by using XML. [STANDARDS-TRACK]
RFC 4050: Using the Elliptic Curve Signature Algorithm (ECDSA) for XML Digital Signatures
Informational- S. Blake-Wilson
- G. Karlinger
- T. Kobayashi
- Y. Wang
- April 2005
- Independent Stream publication
Abstract
This document specifies how to use Elliptic Curve Digital Signature Algorithm (ECDSA) with XML Signatures. The mechanism specified provides integrity, message authentication, and/or signer authentication services for data of any type, whether located within the XML that includes the signature or included by reference. This memo provides information for the Internet community.
Abstract
This document specifies how to use Elliptic Curve Digital Signature Algorithm (ECDSA) with XML Signatures. The mechanism specified provides integrity, message authentication, and/or signer authentication services for data of any type, whether located within the XML that includes the signature or included by reference. This memo provides information for the Internet community.
RFC 4051: Additional XML Security Uniform Resource Identifiers (URIs)
Proposed Standard- D. Eastlake 3rd
- April 2005
- IETF publication
Abstract
A number of Uniform Resource Identifiers (URIs) intended for use with XML Digital Signatures, Encryption, and Canonicalization are defined. These URIs identify algorithms and types of keying information. [STANDARDS-TRACK]
Obsoleted by RFC 6931
Abstract
A number of Uniform Resource Identifiers (URIs) intended for use with XML Digital Signatures, Encryption, and Canonicalization are defined. These URIs identify algorithms and types of keying information. [STANDARDS-TRACK]
RFC 3741: Exclusive XML Canonicalization, Version 1.0
Informational- J. Boyer
- D. Eastlake 3rd
- J. Reagle
- March 2004
- IETF publication
- Security Area
Abstract
Canonical XML specifies a standard serialization of XML that, when applied to a subdocument, includes the subdocument's ancestor context including all of the namespace declarations and attributes in the "xml:" namespace. However, some applications require a method which, to the extent practical, excludes ancestor context from a canonicalized subdocument. For example, one might require a digital signature over an XML payload (subdocument) in an XML message that will not break when that subdocument is removed from its original message and/or inserted into a different context. This requirement is satisfied by Exclusive XML Canonicalization. This memo provides information for the Internet community.
Abstract
Canonical XML specifies a standard serialization of XML that, when applied to a subdocument, includes the subdocument's ancestor context including all of the namespace declarations and attributes in the "xml:" namespace. However, some applications require a method which, to the extent practical, excludes ancestor context from a canonicalized subdocument. For example, one might require a digital signature over an XML payload (subdocument) in an XML message that will not break when that subdocument is removed from its original message and/or inserted into a different context. This requirement is satisfied by Exclusive XML Canonicalization. This memo provides information for the Internet community.
RFC 3653: XML-Signature XPath Filter 2.0
Informational- J. Boyer
- M. Hughes
- J. Reagle
- December 2003
- IETF publication
- Security Area
Abstract
XML Signature recommends a standard means for specifying information content to be digitally signed and for representing the resulting digital signatures in XML. Some applications require the ability to specify a subset of a given XML document as the information content to be signed. The XML Signature specification meets this requirement with the XPath transform. However, this transform can be difficult to implement efficiently with existing technologies. This specification defines a new XML Signature transform to facilitate the development of efficient document subsetting implementations that interoperate under similar performance profiles. This document is the W3C XML Signature XPath-Filter 2.0 Recommendation. This document has been reviewed by W3C Members and other interested parties and has been endorsed by the Director as a W3C Recommendation. It is a stable document and may be used as reference material or cited as a normative reference from another document. W3C's role in making the Recommendation is to draw attention to the specification and to promote its widespread deployment. This enhances the functionality and interoperability of the Web.
Abstract
XML Signature recommends a standard means for specifying information content to be digitally signed and for representing the resulting digital signatures in XML. Some applications require the ability to specify a subset of a given XML document as the information content to be signed. The XML Signature specification meets this requirement with the XPath transform. However, this transform can be difficult to implement efficiently with existing technologies. This specification defines a new XML Signature transform to facilitate the development of efficient document subsetting implementations that interoperate under similar performance profiles. This document is the W3C XML Signature XPath-Filter 2.0 Recommendation. This document has been reviewed by W3C Members and other interested parties and has been endorsed by the Director as a W3C Recommendation. It is a stable document and may be used as reference material or cited as a normative reference from another document. W3C's role in making the Recommendation is to draw attention to the specification and to promote its widespread deployment. This enhances the functionality and interoperability of the Web.
RFC 3275: (Extensible Markup Language) XML-Signature Syntax and Processing
Draft Standard- D. Eastlake 3rd
- J. Reagle
- D. Solo
- March 2002
- IETF publication
- Security Area
Abstract
This document specifies XML (Extensible Markup Language) digital signature processing rules and syntax. [STANDARDS-TRACK]
Abstract
This document specifies XML (Extensible Markup Language) digital signature processing rules and syntax. [STANDARDS-TRACK]
RFC 3075: XML-Signature Syntax and Processing
Proposed Standard- D. Eastlake 3rd
- J. Reagle
- D. Solo
- March 2001
- IETF publication
- Security Area
Abstract
This document specifies XML (Extensible Markup Language) digital signature processing rules and syntax. [STANDARDS-TRACK]
Obsoleted by RFC 3275
Abstract
This document specifies XML (Extensible Markup Language) digital signature processing rules and syntax. [STANDARDS-TRACK]
RFC 3076: Canonical XML Version 1.0
Informational- J. Boyer
- March 2001
- IETF publication
- Security Area
Abstract
This specification describes a method for generating a physical representation, the canonical form, of an XML document that accounts for the permissible changes. This memo provides information for the Internet community.
Abstract
This specification describes a method for generating a physical representation, the canonical form, of an XML document that accounts for the permissible changes. This memo provides information for the Internet community.
RFC 2807: XML Signature Requirements
Informational- J. Reagle
- July 2000
- IETF publication
- Security Area
Abstract
This document lists the design principles, scope, and requirements for the XML Digital Signature specification. It includes requirements as they relate to the signature syntax, data model, format, cryptographic processing, and external requirements and coordination. This memo provides information for the Internet community.
Abstract
This document lists the design principles, scope, and requirements for the XML Digital Signature specification. It includes requirements as they relate to the signature syntax, data model, format, cryptographic processing, and external requirements and coordination. This memo provides information for the Internet community.
Subscribe to XML signatures
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.