- Home
- RFCs by Subject
- web
- WebSocket
WebSocket
The WebSocket protocol
Within this page
WebSocket RFCs (12)
RFC 8857: The WebSocket Protocol as a Transport for the Binary Floor Control Protocol (BFCP)
Proposed Standard- V. Pascual
- A. Román
- S. Cazeaux
- G. Salgueiro
- R. Ravindranath
- January 2021
- IETF publication
- Applications and Real-Time Area
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers. This document specifies the use of Binary Floor Control Protocol (BFCP) as a new WebSocket subprotocol enabling a reliable transport mechanism between BFCP entities in new scenarios.
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers. This document specifies the use of Binary Floor Control Protocol (BFCP) as a new WebSocket subprotocol enabling a reliable transport mechanism between BFCP entities in new scenarios.
RFC 8887: A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocket
Proposed Standard- K. Murchison
- August 2020
- IETF publication
- Applications and Real-Time Area
Abstract
This document defines a binding for the JSON Meta Application Protocol (JMAP) over a WebSocket transport layer. The WebSocket binding for JMAP provides higher performance than the current HTTP binding for JMAP.
Abstract
This document defines a binding for the JSON Meta Application Protocol (JMAP) over a WebSocket transport layer. The WebSocket binding for JMAP provides higher performance than the current HTTP binding for JMAP.
RFC 8307: Well-Known URIs for the WebSocket Protocol
Proposed Standard- C. Bormann
- January 2018
- IETF publication
Abstract
RFC 5785 defines a path prefix, "/.well-known/", that can be used by well-known URIs. It was specifically defined for the "http" and "https" URI schemes. The present memo formally updates RFC 6455, which defines the URI schemes defined for the WebSocket Protocol, to extend the use of these well-known URIs to those URI schemes.
Abstract
RFC 5785 defines a path prefix, "/.well-known/", that can be used by well-known URIs. It was specifically defined for the "http" and "https" URI schemes. The present memo formally updates RFC 6455, which defines the URI schemes defined for the WebSocket Protocol, to extend the use of these well-known URIs to those URI schemes.
RFC 8124: The Session Description Protocol (SDP) WebSocket Connection URI Attribute
Proposed Standard- R. Ravindranath
- G. Salgueiro
- March 2017
- IETF publication
- Applications and Real-Time Area
Abstract
The WebSocket protocol enables bidirectional real-time communication between clients and servers in web-based applications. This document specifies extensions to Session Description Protocol (SDP) for application protocols using WebSocket as a transport.
Abstract
The WebSocket protocol enables bidirectional real-time communication between clients and servers in web-based applications. This document specifies extensions to Session Description Protocol (SDP) for application protocols using WebSocket as a transport.
RFC 7977: The WebSocket Protocol as a Transport for the Message Session Relay Protocol (MSRP)
Proposed Standard- P. Dunkley
- G. Llewellyn
- V. Pascual
- G. Salgueiro
- R. Ravindranath
- September 2016
- IETF publication
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers in situations where direct access to TCP and UDP is not available (for example, from within JavaScript in a web browser). This document specifies a new WebSocket subprotocol as a reliable transport mechanism between Message Session Relay Protocol (MSRP) clients and relays to enable usage of MSRP in new scenarios. This document normatively updates RFCs 4975 and 4976.
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers in situations where direct access to TCP and UDP is not available (for example, from within JavaScript in a web browser). This document specifies a new WebSocket subprotocol as a reliable transport mechanism between Message Session Relay Protocol (MSRP) clients and relays to enable usage of MSRP in new scenarios. This document normatively updates RFCs 4975 and 4976.
RFC 7936: Clarifying Registry Procedures for the WebSocket Subprotocol Name Registry
Proposed Standard- T. Hardie
- July 2016
- IETF publication
Abstract
This document clarifies the instructions to IANA for the subprotocol registry set up for WebSockets in RFC 6455.
Abstract
This document clarifies the instructions to IANA for the subprotocol registry set up for WebSockets in RFC 6455.
RFC 7692: Compression Extensions for WebSocket
Proposed Standard- T. Yoshino
- December 2015
- IETF publication
- Applications and Real-Time Area
Abstract
This document defines a framework for creating WebSocket extensions that add compression functionality to the WebSocket Protocol. An extension based on this framework compresses the payload data portion of WebSocket data messages on a per-message basis using parameters negotiated during the opening handshake. This framework provides a general method for applying a compression algorithm to the contents of WebSocket messages. Each compression algorithm has to be defined in a document defining the extension by specifying the parameter negotiation and the payload transformation algorithm in detail. This document also specifies one specific compression extension using the DEFLATE algorithm.
Abstract
This document defines a framework for creating WebSocket extensions that add compression functionality to the WebSocket Protocol. An extension based on this framework compresses the payload data portion of WebSocket data messages on a per-message basis using parameters negotiated during the opening handshake. This framework provides a general method for applying a compression algorithm to the contents of WebSocket messages. Each compression algorithm has to be defined in a document defining the extension by specifying the parameter negotiation and the payload transformation algorithm in detail. This document also specifies one specific compression extension using the DEFLATE algorithm.
RFC 7478: Web Real-Time Communication Use Cases and Requirements
Informational- C. Holmberg
- S. Hakansson
- G. Eriksson
- March 2015
- IETF publication
- Web and Internet Transport
Abstract
This document describes web-based real-time communication use cases. Requirements on the browser functionality are derived from the use cases.
This document was developed in an initial phase of the work with rather minor updates at later stages. It has not really served as a tool in deciding features or scope for the WG's efforts so far. It is being published to record the early conclusions of the WG. It will not be used as a set of rigid guidelines that specifications and implementations will be held to in the future.
Abstract
This document describes web-based real-time communication use cases. Requirements on the browser functionality are derived from the use cases.
This document was developed in an initial phase of the work with rather minor updates at later stages. It has not really served as a tool in deciding features or scope for the WG's efforts so far. It is being published to record the early conclusions of the WG. It will not be used as a set of rigid guidelines that specifications and implementations will be held to in the future.
RFC 7395: An Extensible Messaging and Presence Protocol (XMPP) Subprotocol for WebSocket
Proposed Standard- L. Stout
- J. Moffitt
- E. Cestari
- October 2014
- IETF publication
- Applications and Real-Time Area
Abstract
This document defines a binding for the Extensible Messaging and Presence Protocol (XMPP) over a WebSocket transport layer. A WebSocket binding for XMPP provides higher performance than the current HTTP binding for XMPP.
Abstract
This document defines a binding for the Extensible Messaging and Presence Protocol (XMPP) over a WebSocket transport layer. A WebSocket binding for XMPP provides higher performance than the current HTTP binding for XMPP.
RFC 7355: Indicating WebSocket Protocol as a Transport in the Session Initiation Protocol (SIP) Common Log Format (CLF)
Informational- G. Salgueiro
- V. Pascual
- A. Roman
- S. Garcia
- September 2014
- IETF publication
Abstract
RFC 7118 specifies a WebSocket subprotocol as a reliable real-time transport mechanism between Session Initiation Protocol (SIP) entities to enable usage of SIP in web-oriented deployments. This document updates the SIP Common Log Format (CLF), defined in RFC 6873, with a new "Transport Flag" for such SIP WebSocket transport.
Abstract
RFC 7118 specifies a WebSocket subprotocol as a reliable real-time transport mechanism between Session Initiation Protocol (SIP) entities to enable usage of SIP in web-oriented deployments. This document updates the SIP Common Log Format (CLF), defined in RFC 6873, with a new "Transport Flag" for such SIP WebSocket transport.
RFC 7118: The WebSocket Protocol as a Transport for the Session Initiation Protocol (SIP)
Proposed Standard- I. Baz Castillo
- J. Millan Villegas
- V. Pascual
- January 2014
- IETF publication
- Applications and Real-Time Area
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers in web-based applications. This document specifies a WebSocket subprotocol as a reliable transport mechanism between Session Initiation Protocol (SIP) entities to enable use of SIP in web-oriented deployments.
Abstract
The WebSocket protocol enables two-way real-time communication between clients and servers in web-based applications. This document specifies a WebSocket subprotocol as a reliable transport mechanism between Session Initiation Protocol (SIP) entities to enable use of SIP in web-oriented deployments.
RFC 6455: The WebSocket Protocol
Proposed Standard- I. Fette
- A. Melnikov
- December 2011
- IETF publication
- Applications and Real-Time Area
Abstract
The WebSocket Protocol enables two-way communication between a client running untrusted code in a controlled environment to a remote host that has opted-in to communications from that code. The security model used for this is the origin-based security model commonly used by web browsers. The protocol consists of an opening handshake followed by basic message framing, layered over TCP. The goal of this technology is to provide a mechanism for browser-based applications that need two-way communication with servers that does not rely on opening multiple HTTP connections (e.g., using XMLHttpRequest or <iframe>s and long polling). [STANDARDS-TRACK]
Abstract
The WebSocket Protocol enables two-way communication between a client running untrusted code in a controlled environment to a remote host that has opted-in to communications from that code. The security model used for this is the origin-based security model commonly used by web browsers. The protocol consists of an opening handshake followed by basic message framing, layered over TCP. The goal of this technology is to provide a mechanism for browser-based applications that need two-way communication with servers that does not rely on opening multiple HTTP connections (e.g., using XMLHttpRequest or <iframe>s and long polling). [STANDARDS-TRACK]
Subscribe to WebSocket
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.