UDP

UDP (User Datagram Protocol) and its usage guidelines

UDP subjects:

UDP RFCs (70)

Display RFCs as
  • RFC 9984: YANG Groupings for UDP Clients and UDP Servers

    Proposed Standard
  • RFC 9946: The UDP Speed Test Protocol (UDPSTP) for One-Way IP Capacity Metric Measurement

    Proposed Standard
  • RFC 9868: Transport Options for UDP

    Proposed Standard
  • RFC 9869: Datagram Packetization Layer Path MTU Discovery (DPLPMTUD) for UDP Options

    Proposed Standard
  • RFC 9870: Export of UDP Options Information in IP Flow Information Export (IPFIX)

    Proposed Standard
  • RFC 9715: IP Fragmentation Avoidance in DNS over UDP

    Informational
  • RFC 9566: Deterministic Networking (DetNet) Packet Replication, Elimination, and Ordering Functions (PREOF) via MPLS over UDP/IP

    Informational
  • RFC 9484: Proxying IP in HTTP

    Proposed Standard
  • RFC 9363: A YANG Data Model for Static Context Header Compression (SCHC)

    Proposed Standard
  • RFC 9298: Proxying UDP in HTTP

    Proposed Standard
  • RFC 8999: Version-Independent Properties of QUIC

    Proposed Standard
  • RFC 9000: QUIC: A UDP-Based Multiplexed and Secure Transport

    Proposed Standard
  • RFC 9025: Deterministic Networking (DetNet) Data Plane: MPLS over UDP/IP

    Proposed Standard
  • RFC 9011: Static Context Header Compression and Fragmentation (SCHC) over LoRaWAN

    Proposed Standard
  • RFC 8899: Packetization Layer Path MTU Discovery for Datagram Transports

    Proposed Standard
  • RFC 8724: SCHC: Generic Framework for Static Context Header Compression and Fragmentation

    Proposed Standard
  • RFC 8663: MPLS Segment Routing over IP

    Proposed Standard
  • RFC 8517: An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator Perspective

    Informational
  • RFC 8357: Generalized UDP Source Port for DHCP Relay

    Proposed Standard
  • RFC 8084: BCP 208: Network Transport Circuit Breakers

    Best Current Practice
  • RFC 8085: BCP 145: UDP Usage Guidelines

    Best Current Practice
  • RFC 8086: GRE-in-UDP Encapsulation

    Proposed Standard
  • RFC 7876: UDP Return Path for Packet Loss and Delay Measurement for MPLS Networks

    Proposed Standard
  • RFC 7820: UDP Checksum Complement in the One-Way Active Measurement Protocol (OWAMP) and Two-Way Active Measurement Protocol (TWAMP)

    Experimental
  • RFC 7821: UDP Checksum Complement in the Network Time Protocol (NTP)

    Experimental
  • RFC 7663: Report from the IAB Workshop on Stack Evolution in a Middlebox Internet (SEMI)

    Informational
  • RFC 7604: Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)

    Informational
  • RFC 7605: BCP 165: Recommendations on Using Assigned Transport Port Numbers

    Best Current Practice
  • RFC 7510: Encapsulating MPLS in UDP

    Proposed Standard
  • RFC 7345: UDP Transport Layer (UDPTL) over Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 6951: UDP Encapsulation of Stream Control Transmission Protocol (SCTP) Packets for End-Host to End-Host Communication

    Proposed Standard
  • RFC 6935: IPv6 and UDP Checksums for Tunneled Packets

    Proposed Standard
  • RFC 6936: Applicability Statement for the Use of IPv6 UDP Datagrams with Zero Checksums

    Proposed Standard
  • RFC 6812: Cisco Service-Level Assurance Protocol

    Informational
  • RFC 6773: DCCP-UDP: A Datagram Congestion Control Protocol UDP Encapsulation for NAT Traversal

    Proposed Standard
  • RFC 6679: Explicit Congestion Notification (ECN) for RTP over UDP

    Proposed Standard
  • RFC 6633: Deprecation of ICMP Source Quench Messages

    Proposed Standard
  • RFC 5456: IAX: Inter-Asterisk eXchange Version 2

    Informational
  • RFC 5426: Transmission of Syslog Messages over UDP

    Proposed Standard
  • RFC 5405: Unicast UDP Usage Guidelines for Application Designers

    Best Current Practice

    Obsoleted by RFC 8085

  • RFC 4993: A Lightweight UDP Transfer Protocol for the Internet Registry Information Service

    Proposed Standard
  • RFC 4815: RObust Header Compression (ROHC): Corrections and Clarifications to RFC 3095

    Proposed Standard
  • RFC 4787: BCP 127: Network Address Translation (NAT) Behavioral Requirements for Unicast UDP

    Best Current Practice
  • RFC 4727: Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers

    Proposed Standard
  • RFC 4445: A Proposed Media Delivery Index (MDI)

    Informational
  • RFC 4380: Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)

    Proposed Standard
  • Proposed Standard
  • RFC 4113: Management Information Base for the User Datagram Protocol (UDP)

    Proposed Standard
  • RFC 3948: UDP Encapsulation of IPsec ESP Packets

    Proposed Standard
  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

    Proposed Standard
  • RFC 3489: STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)

    Proposed Standard

    Obsoleted by RFC 5389

  • RFC 3409: Lower Layer Guidelines for Robust RTP/UDP/IP Header Compression

    Informational
  • Proposed Standard

    Obsoleted by RFC 4362

  • RFC 3243: RObust Header Compression (ROHC): Requirements and Assumptions for 0-byte IP/UDP/RTP Compression

    Informational
  • RFC 3257: Stream Control Transmission Protocol Applicability Statement

    Informational
  • RFC 3095: RObust Header Compression (ROHC): Framework and four profiles: RTP, UDP, ESP, and uncompressed

    Proposed Standard
  • RFC 3096: Requirements for robust IP/UDP/RTP header compression

    Informational
  • RFC 2556: OSI connectionless transport services on top of UDP Applicability Statement for Historic Status

    Informational
  • Proposed Standard
  • RFC 2454: IP Version 6 Management Information Base for the User Datagram Protocol

    Historic

    Obsoleted by RFC 4113, RFC 8096

  • RFC 2354: Options for Repair of Streaming Media

    Informational
  • RFC 2147: TCP and UDP over IPv6 Jumbograms

    Proposed Standard

    Obsoleted by RFC 2675

  • RFC 2013: SNMPv2 Management Information Base for the User Datagram Protocol using SMIv2

    Proposed Standard

    Obsoleted by RFC 4113

  • RFC 1936: Implementing the Internet Checksum in Hardware

    Informational
  • RFC 1791: TCP And UDP Over IPX Networks With Fixed Path MTU

    Experimental
  • RFC 1347: TCP and UDP with Bigger Addresses (TUBA), A Simple Proposal for Internet Addressing and Routing

    Historic
  • RFC 1240: OSI connectionless transport services on top of UDP: Version 1

    Historic
  • RFC 1001: STD 19: Protocol standard for a NetBIOS service on a TCP/UDP transport: Concepts and methods

    Internet Standard
  • RFC 1002: STD 19: Protocol standard for a NetBIOS service on a TCP/UDP transport: Detailed specifications

    Internet Standard
  • RFC 768: STD 6: User Datagram Protocol

    Internet Standard

Subscribe to UDP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.