transport mapping

Transport Mappings: carrying one protocol over another transport: X-over-TLS/TCP/UDP/QUIC bindings and transport models

transport mapping RFCs (52)

Display RFCs as
  • RFC 9952: Application-Layer Protocol Negotiation (ALPN) ID for CoAP over DTLS

    Informational
  • RFC 9887: Terminal Access Controller Access-Control System Plus (TACACS+) over TLS 1.3

    Proposed Standard
  • RFC 9715: IP Fragmentation Avoidance in DNS over UDP

    Informational
  • RFC 9566: Deterministic Networking (DetNet) Packet Replication, Elimination, and Ordering Functions (PREOF) via MPLS over UDP/IP

    Informational
  • RFC 9456: Updates to the TLS Transport Model for SNMP

    Proposed Standard
  • RFC 9250: DNS over Dedicated QUIC Connections

    Proposed Standard
  • RFC 9210: BCP 235: DNS Transport over TCP - Operational Requirements

    Best Current Practice
  • RFC 9103: DNS Zone Transfer over TLS

    Proposed Standard
  • RFC 9025: Deterministic Networking (DetNet) Data Plane: MPLS over UDP/IP

    Proposed Standard
  • RFC 8894: Simple Certificate Enrolment Protocol

    Informational
  • RFC 8473: Token Binding over HTTP

    Proposed Standard
  • RFC 8323: CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets

    Proposed Standard
  • RFC 7930: Larger Packets for RADIUS over TCP

    Experimental
  • RFC 7850: Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP Profiles

    Proposed Standard
  • RFC 7766: DNS Transport over TCP - Implementation Requirements

    Proposed Standard
  • RFC 7472: Internet Printing Protocol (IPP) over HTTPS Transport Binding and the 'ipps' URI Scheme

    Proposed Standard
  • RFC 6876: A Posture Transport Protocol over TLS (PT-TLS)

    Proposed Standard
  • RFC 6679: Explicit Congestion Notification (ECN) for RTP over UDP

    Proposed Standard
  • RFC 6613: RADIUS over TCP

    Experimental
  • RFC 6546: Transport of Real-time Inter-network Defense (RID) Messages over HTTP/TLS

    Proposed Standard
  • RFC 6587: Transmission of Syslog Messages over TCP

    Historic
  • RFC 6353: STD 78: Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 6053: Implementation Report for Forwarding and Control Element Separation (ForCES)

    Informational
  • RFC 6012: Datagram Transport Layer Security (DTLS) Transport Mapping for Syslog

    Proposed Standard
  • RFC 5966: DNS Transport over TCP - Implementation Requirements

    Proposed Standard

    Obsoleted by RFC 7766

  • RFC 5953: Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 6353

  • RFC 5810: Forwarding and Control Element Separation (ForCES) Protocol Specification

    Proposed Standard
  • RFC 5811: SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol

    Proposed Standard
  • RFC 5734: STD 69: Extensible Provisioning Protocol (EPP) Transport over TCP

    Internet Standard
  • RFC 5608: Remote Authentication Dial-In User Service (RADIUS) Usage for Simple Network Management Protocol (SNMP) Transport Models

    Proposed Standard
  • RFC 5590: STD 78: Transport Subsystem for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 5592: Secure Shell Transport Model for the Simple Network Management Protocol (SNMP)

    Proposed Standard
  • RFC 5425: Transport Layer Security (TLS) Transport Mapping for Syslog

    Proposed Standard
  • RFC 5426: Transmission of Syslog Messages over UDP

    Proposed Standard
  • RFC 5166: Metrics for the Evaluation of Congestion Control Mechanisms

    Informational
  • RFC 5021: Extended Kerberos Version 5 Key Distribution Center (KDC) Exchanges over TCP

    Proposed Standard
  • RFC 4934: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Draft Standard

    Obsoleted by RFC 5734

  • RFC 4712: Transport Mappings for Real-time Application Quality-of-Service Monitoring (RAQMON) Protocol Data Unit (PDU)

    Proposed Standard
  • RFC 4404: Definitions of Managed Objects for Fibre Channel Over TCP/IP (FCIP)

    Proposed Standard
  • RFC 4380: Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)

    Proposed Standard
  • RFC 3821: Fibre Channel Over TCP/IP (FCIP)

    Proposed Standard
  • RFC 3822: Finding Fibre Channel over TCP/IP (FCIP) Entities Using Service Location Protocol version 2 (SLPv2)

    Proposed Standard
  • RFC 3734: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Proposed Standard

    Obsoleted by RFC 4934

  • RFC 3417: STD 62: Transport Mappings for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 3430: Simple Network Management Protocol Over Transmission Control Protocol Transport Mapping

    Experimental
  • RFC 2818: HTTP Over TLS

    Informational

    Obsoleted by RFC 9110

  • RFC 2487: SMTP Service Extension for Secure SMTP over TLS

    Proposed Standard

    Obsoleted by RFC 3207

  • RFC 1906: Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)

    Draft Standard

    Obsoleted by RFC 3417

  • RFC 1859: ISO Transport Class 2 Non-use of Explicit Flow Control over TCP RFC1006 extension

    Informational
  • RFC 1613: cisco Systems X.25 over TCP (XOT)

    Informational
  • RFC 1449: Transport Mappings for version 2 of the Simple Network Management Protocol (SNMPv2)

    Proposed Standard

    Obsoleted by RFC 1906

  • RFC 1095: Common Management Information Services and Protocol over TCP/IP (CMOT)

    Unknown

    Obsoleted by RFC 1189

Subscribe to transport mapping

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.