traffic engineering

Traffic engineering of packet and transport networks

traffic engineering subjects:

traffic engineering RFCs (91)

Display RFCs as
  • RFC 9889: A Realization of Network Slices for 5G Networks Using Current IP/MPLS Technologies

    Informational
  • Proposed Standard
  • RFC 9731: A YANG Data Model for Virtual Network (VN) Operations

    Proposed Standard
  • RFC 9732: A Framework for NRP-Based Enhanced Virtual Private Networks

    Informational
  • RFC 9730: Interworking of GMPLS Control and Centralized Controller Systems

    Informational
  • RFC 9543: A Framework for Network Slices in Networks Built from IETF Technologies

    Informational
  • RFC 9522: Overview and Principles of Internet Traffic Engineering

    Informational
  • Proposed Standard
  • RFC 9346: IS-IS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 9270: GMPLS Signaling Extensions for Shared Mesh Protection

    Proposed Standard
  • RFC 9256: Segment Routing Policy Architecture

    Proposed Standard
  • RFC 9145: Integrity Protection for the Network Service Header (NSH) and Encryption of Sensitive Context Headers

    Proposed Standard
  • Proposed Standard
  • RFC 8795: YANG Data Model for Traffic Engineering (TE) Topologies

    Proposed Standard
  • RFC 8776: Common YANG Data Types for Traffic Engineering

    Proposed Standard
  • RFC 8687: OSPF Routing with Cross-Address Family Traffic Engineering Tunnels

    Proposed Standard
  • RFC 8570: IS-IS Traffic Engineering (TE) Metric Extensions

    Proposed Standard
  • Proposed Standard
  • RFC 8454: Information Model for Abstraction and Control of TE Networks (ACTN)

    Informational
  • RFC 8453: Framework for Abstraction and Control of TE Networks (ACTN)

    Informational
  • RFC 8359: Network-Assigned Upstream Label

    Proposed Standard
  • Proposed Standard
  • RFC 8271: Updates to the Resource Reservation Protocol for Fast Reroute of Traffic Engineering GMPLS Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8258: Generalized SCSI: A Generic Structure for Interface Switching Capability Descriptor (ISCD) Switching Capability Specific Information (SCSI)

    Proposed Standard
  • RFC 8149: RSVP Extensions for Reoptimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 7926: BCP 206: Problem Statement and Architecture for Information Exchange between Interconnected Traffic-Engineered Networks

    Best Current Practice
  • RFC 7917: Advertising Node Administrative Tags in IS-IS

    Proposed Standard
  • RFC 7810: IS-IS Traffic Engineering (TE) Metric Extensions

    Proposed Standard

    Obsoleted by RFC 8570

  • RFC 7823: Performance-Based Path Selection for Explicitly Routed Label Switched Paths (LSPs) Using TE Metric Extensions

    Informational
  • RFC 7789: Impact of BGP Filtering on Inter-Domain Routing Policies

    Informational
  • Proposed Standard

    Obsoleted by RFC 9552

  • RFC 7709: Requirements for Very Fast Setup of GMPLS Label Switched Paths (LSPs)

    Informational
  • RFC 7471: OSPF Traffic Engineering (TE) Metric Extensions

    Proposed Standard
  • RFC 7453: MPLS Transport Profile (MPLS-TP) Traffic Engineering (TE) Management Information Base (MIB)

    Proposed Standard
  • RFC 7308: Extended Administrative Groups in MPLS Traffic Engineering (MPLS-TE)

    Proposed Standard
  • RFC 7297: IP Connectivity Provisioning Profile (CPP)

    Informational
  • RFC 7138: Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

    Proposed Standard
  • RFC 6875: The P2P Network Experiment Council's Activities and Experiments with Application-Layer Traffic Optimization (ALTO) in Japan

    Informational
  • RFC 6825: Traffic Engineering Database Management Information Base in Support of MPLS-TE/GMPLS

    Proposed Standard
  • RFC 6777: Label Switched Path (LSP) Data Path Delay Metrics in Generalized MPLS and MPLS Traffic Engineering (MPLS-TE) Networks

    Proposed Standard
  • RFC 6445: Multiprotocol Label Switching (MPLS) Traffic Engineering Management Information Base for Fast Reroute

    Proposed Standard
  • RFC 6060: Generalized Multiprotocol Label Switching (GMPLS) Control of Ethernet Provider Backbone Traffic Engineering (PBB-TE)

    Proposed Standard
  • RFC 6119: IPv6 Traffic Engineering in IS-IS

    Proposed Standard
  • RFC 5817: Graceful Shutdown in MPLS and Generalized MPLS Traffic Engineering Networks

    Informational
  • RFC 5786: Advertising a Router's Local Addresses in OSPF Traffic Engineering (TE) Extensions

    Proposed Standard
  • RFC 5712: MPLS Traffic Engineering Soft Preemption

    Proposed Standard
  • RFC 5543: BGP Traffic Engineering Attribute

    Proposed Standard
  • RFC 5392: OSPF Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 5316: ISIS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard

    Obsoleted by RFC 9346

  • Proposed Standard
  • RFC 5305: IS-IS Extensions for Traffic Engineering

    Proposed Standard
  • RFC 5329: Traffic Engineering Extensions to OSPF Version 3

    Proposed Standard
  • RFC 5298: Analysis of Inter-Domain Label Switched Path (LSP) Recovery

    Informational
  • RFC 5145: Framework for MPLS-TE to GMPLS Migration

    Informational
  • RFC 5146: Interworking Requirements to Support Operation of MPLS-TE over GMPLS Networks

    Informational
  • RFC 5150: Label Switched Path Stitching with Generalized Multiprotocol Label Switching Traffic Engineering (GMPLS TE)

    Proposed Standard
  • RFC 5152: A Per-Domain Path Computation Method for Establishing Inter-Domain Traffic Engineering (TE) Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 5073: IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node Capabilities

    Proposed Standard
  • RFC 4972: Routing Extensions for Discovery of Multiprotocol (MPLS) Label Switch Router (LSR) Traffic Engineering (TE) Mesh Membership

    Proposed Standard
  • RFC 4973: OSPF-xTE: Experimental Extension to OSPF for Traffic Engineering

    Experimental
  • RFC 4829: Label Switched Path (LSP) Preemption Policies for MPLS Traffic Engineering

    Informational
  • RFC 4802: Generalized Multiprotocol Label Switching (GMPLS) Traffic Engineering Management Information Base

    Proposed Standard
  • RFC 4804: Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE Tunnels

    Proposed Standard
  • RFC 4726: A Framework for Inter-Domain Multiprotocol Label Switching Traffic Engineering

    Informational
  • RFC 4561: Definition of a Record Route Object (RRO) Node-Id Sub-Object

    Proposed Standard
  • Proposed Standard
  • RFC 4216: MPLS Inter-Autonomous System (AS) Traffic Engineering (TE) Requirements

    Informational
  • Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 4206: Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)

    Proposed Standard
  • Proposed Standard
  • RFC 4124: Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering

    Proposed Standard
  • RFC 4125: Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4126: Max Allocation with Reservation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering & Performance Comparisons

    Experimental
  • RFC 4127: Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering

    Experimental
  • RFC 4128: Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance Evaluation

    Informational
  • RFC 4105: Requirements for Inter-Area MPLS Traffic Engineering

    Informational
  • RFC 3970: A Traffic Engineering (TE) MIB

    Proposed Standard
  • RFC 3906: Calculating Interior Gateway Protocol (IGP) Routes Over Traffic Engineering Tunnels

    Informational
  • RFC 3784: Intermediate System to Intermediate System (IS-IS) Extensions for Traffic Engineering (TE)

    Informational

    Obsoleted by RFC 5305

  • RFC 3812: Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB)

    Proposed Standard
  • RFC 3785: BCP 87: Use of Interior Gateway Protocol (IGP) Metric as a second MPLS Traffic Engineering (TE) Metric

    Best Current Practice
  • RFC 3630: Traffic Engineering (TE) Extensions to OSPF Version 2

    Proposed Standard
  • RFC 3564: Requirements for Support of Differentiated Services-aware MPLS Traffic Engineering

    Informational
  • Proposed Standard
  • RFC 3386: Network Hierarchy and Multilayer Survivability

    Informational
  • RFC 3346: Applicability Statement for Traffic Engineering with MPLS

    Informational
  • RFC 3272: Overview and Principles of Internet Traffic Engineering

    Informational

    Obsoleted by RFC 9522

  • RFC 2702: Requirements for Traffic Engineering Over MPLS

    Informational
  • RFC 2430: A Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

    Informational

Subscribe to traffic engineering

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.