TCP

TCP (Transmission Control Protocol): protocol, extensions, implementation

TCP subjects:

TCP RFCs (228)

Display RFCs as
  • RFC 9768: More Accurate Explicit Congestion Notification (AccECN) Feedback in TCP

    Proposed Standard
  • RFC 9937: Proportional Rate Reduction (PRR)

    Proposed Standard
  • RFC 9840: rLEDBAT: Receiver-Driven Low Extra Delay Background Transport for TCP

    Experimental
  • RFC 9740: New IPFIX Information Elements for TCP Options and IPv6 Extension Headers

    Proposed Standard
  • RFC 9687: Border Gateway Protocol 4 (BGP-4) Send Hold Timer

    Proposed Standard
  • RFC 9643: YANG Groupings for TCP Clients and TCP Servers

    Proposed Standard
  • RFC 9648: YANG Data Model for TCP

    Proposed Standard
  • RFC 9565: An Update to the tcpControlBits IP Flow Information Export (IPFIX) Information Element

    Proposed Standard
  • RFC 9406: HyStart++: Modified Slow Start for TCP

    Proposed Standard
  • RFC 9329: TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec Packets

    Proposed Standard
  • RFC 9314: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9293: STD 7: Transmission Control Protocol (TCP)

    Internet Standard
  • RFC 9235: TCP Authentication Option (TCP-AO) Test Vectors

    Informational
  • RFC 9210: BCP 235: DNS Transport over TCP - Operational Requirements

    Best Current Practice
  • RFC 9174: Delay-Tolerant Networking TCP Convergence-Layer Protocol Version 4

    Proposed Standard
  • RFC 9127: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9040: TCP Control Block Interdependence

    Informational
  • RFC 9006: TCP Usage Guidance in the Internet of Things (IoT)

    Informational
  • RFC 8985: The RACK-TLP Loss Detection Algorithm for TCP

    Proposed Standard
  • RFC 8961: BCP 233: Requirements for Time-Based Loss Detection

    Best Current Practice
  • RFC 8699: Coupled Congestion Control for RTP Media

    Experimental
  • RFC 8511: TCP Alternative Backoff with ECN (ABE)

    Experimental
  • RFC 8323: CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets

    Proposed Standard
  • RFC 8305: Happy Eyeballs Version 2: Better Connectivity Using Concurrency

    Proposed Standard
  • RFC 8257: Data Center TCP (DCTCP): TCP Congestion Control for Data Centers

    Informational
  • RFC 8229: TCP Encapsulation of IKE and IPsec Packets

    Proposed Standard

    Obsoleted by RFC 9329

  • RFC 8087: The Benefits of Using Explicit Congestion Notification (ECN)

    Informational
  • RFC 7974: An Experimental TCP Option for Host Identification

    Experimental
  • RFC 7930: Larger Packets for RADIUS over TCP

    Experimental
  • RFC 7893: Pseudowire Congestion Considerations

    Informational
  • RFC 7786: TCP Modifications for Congestion Exposure (ConEx)

    Experimental
  • RFC 7850: Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP Profiles

    Proposed Standard
  • Informational
  • RFC 7828: The edns-tcp-keepalive EDNS0 Option

    Proposed Standard
  • RFC 7766: DNS Transport over TCP - Implementation Requirements

    Proposed Standard
  • RFC 7765: TCP and Stream Control Transmission Protocol (SCTP) RTO Restart

    Experimental
  • RFC 7661: Updating TCP to Support Rate-Limited Traffic

    Experimental
  • RFC 7663: Report from the IAB Workshop on Stack Evolution in a Middlebox Internet (SEMI)

    Informational
  • RFC 7560: Problem Statement and Requirements for Increased Accuracy in Explicit Congestion Notification (ECN) Feedback

    Informational
  • RFC 7605: BCP 165: Recommendations on Using Assigned Transport Port Numbers

    Best Current Practice
  • RFC 7414: A Roadmap for Transmission Control Protocol (TCP) Specification Documents

    Informational
  • RFC 7413: TCP Fast Open

    Experimental
  • RFC 7323: TCP Extensions for High Performance

    Proposed Standard
  • RFC 7242: Delay-Tolerant Networking TCP Convergence-Layer Protocol

    Experimental
  • RFC 6994: Shared Use of Experimental TCP Options

    Proposed Standard
  • RFC 6978: A TCP Authentication Option Extension for NAT Traversal

    Experimental
  • RFC 6937: Proportional Rate Reduction for TCP

    Experimental

    Obsoleted by RFC 9937

  • RFC 6928: Increasing TCP's Initial Window

    Experimental
  • RFC 6846: RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)

    Proposed Standard
  • RFC 6675: A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCP

    Proposed Standard
  • RFC 6703: Reporting IP Network Performance Metrics: Different Points of View

    Informational
  • RFC 6691: TCP Options and Maximum Segment Size (MSS)

    Informational

    Obsoleted by RFC 9293

  • RFC 6613: RADIUS over TCP

    Experimental
  • RFC 6633: Deprecation of ICMP Source Quench Messages

    Proposed Standard
  • RFC 6587: Transmission of Syslog Messages over TCP

    Historic
  • RFC 6582: The NewReno Modification to TCP's Fast Recovery Algorithm

    Proposed Standard
  • RFC 6544: TCP Candidates with Interactive Connectivity Establishment (ICE)

    Proposed Standard
  • RFC 6528: Defending against Sequence Number Attacks

    Proposed Standard

    Obsoleted by RFC 9293

  • RFC 6429: TCP Sender Clarification for Persist Condition

    Informational

    Obsoleted by RFC 9293

  • RFC 6349: Framework for TCP Throughput Testing

    Informational
  • RFC 6298: Computing TCP's Retransmission Timer

    Proposed Standard
  • RFC 6247: Moving the Undeployed TCP Extensions RFC 1072, RFC 1106, RFC 1110, RFC 1145, RFC 1146, RFC 1379, RFC 1644, and RFC 1693 to Historic Status

    Informational
  • RFC 6191: BCP 159: Reducing the TIME-WAIT State Using TCP Timestamps

    Best Current Practice
  • Historic

    Obsoleted by RFC 7805

  • RFC 6056: BCP 156: Recommendations for Transport-Protocol Port Randomization

    Best Current Practice
  • RFC 6093: On the Implementation of the TCP Urgent Mechanism

    Proposed Standard

    Obsoleted by RFC 9293

  • RFC 6069: Making TCP More Robust to Long Connectivity Disruptions (TCP-LCD)

    Experimental
  • RFC 6062: Traversal Using Relays around NAT (TURN) Extensions for TCP Allocations

    Proposed Standard
  • RFC 5961: Improving TCP's Robustness to Blind In-Window Attacks

    Proposed Standard
  • RFC 5966: DNS Transport over TCP - Implementation Requirements

    Proposed Standard

    Obsoleted by RFC 7766

  • RFC 5927: ICMP Attacks against TCP

    Informational
  • RFC 5923: Connection Reuse in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5925: The TCP Authentication Option

    Proposed Standard
  • RFC 5926: Cryptographic Algorithms for the TCP Authentication Option (TCP-AO)

    Proposed Standard
  • RFC 5827: Early Retransmit for TCP and Stream Control Transmission Protocol (SCTP)

    Experimental
  • RFC 5690: Adding Acknowledgement Congestion Control to TCP

    Informational
  • RFC 5682: Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP

    Proposed Standard
  • RFC 5681: TCP Congestion Control

    Draft Standard
  • RFC 5734: STD 69: Extensible Provisioning Protocol (EPP) Transport over TCP

    Internet Standard
  • RFC 5622: Profile for Datagram Congestion Control Protocol (DCCP) Congestion ID 4: TCP-Friendly Rate Control for Small Packets (TFRC-SP)

    Experimental
  • RFC 5562: Adding Explicit Congestion Notification (ECN) Capability to TCP's SYN/ACK Packets

    Experimental
  • RFC 5482: TCP User Timeout Option

    Proposed Standard
  • RFC 5461: TCP's Reaction to Soft Errors

    Informational
  • RFC 5382: BCP 142: NAT Behavioral Requirements for TCP

    Best Current Practice
  • RFC 5348: TCP Friendly Rate Control (TFRC): Protocol Specification

    Proposed Standard
  • RFC 5273: Certificate Management over CMS (CMC): Transport Protocols

    Proposed Standard

    Obsoleted by RFC 10003

  • RFC 5044: Marker PDU Aligned Framing for TCP Specification

    Proposed Standard
  • RFC 4987: TCP SYN Flooding Attacks and Common Mitigations

    Informational
  • RFC 5021: Extended Kerberos Version 5 Key Distribution Center (KDC) Exchanges over TCP

    Proposed Standard
  • RFC 4992: XML Pipelining with Chunks for the Internet Registry Information Service

    Proposed Standard
  • RFC 4953: Defending TCP Against Spoofing Attacks

    Informational
  • RFC 4996: RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)

    Proposed Standard

    Obsoleted by RFC 6846

  • RFC 4898: TCP Extended Statistics MIB

    Proposed Standard
  • RFC 4934: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Draft Standard

    Obsoleted by RFC 5734

  • RFC 4850: Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node Architecture

    Proposed Standard

    Obsoleted by RFC 7143

  • RFC 4828: TCP Friendly Rate Control (TFRC): The Small-Packet (SP) Variant

    Experimental
  • RFC 4808: Key Change Strategies for TCP-MD5

    Informational
  • RFC 4782: Quick-Start for TCP and IP

    Experimental
  • RFC 4727: Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers

    Proposed Standard
  • RFC 4614: A Roadmap for Transmission Control Protocol (TCP) Specification Documents

    Informational

    Obsoleted by RFC 7414

  • RFC 4653: Improving the Robustness of TCP to Non-Congestion Events

    Experimental
  • RFC 4654: TCP-Friendly Multicast Congestion Control (TFMCC): Protocol Specification

    Experimental
  • RFC 4571: Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP) Packets over Connection-Oriented Transport

    Proposed Standard
  • RFC 4342: Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 3: TCP-Friendly Rate Control (TFRC)

    Proposed Standard
  • RFC 4341: Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion Control

    Proposed Standard
  • RFC 4413: TCP/IP Field Behavior

    Informational
  • RFC 4278: Standards Maturity Variance Regarding the TCP MD5 Signature Option (RFC 2385) and the BGP-4 Specification

    Informational
  • RFC 4172: iFCP - A Protocol for Internet Fibre Channel Storage Networking

    Proposed Standard
  • RFC 4173: Bootstrapping Clients using the Internet Small Computer System Interface (iSCSI) Protocol

    Proposed Standard
  • RFC 4145: TCP-Based Media Transport in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 4163: RObust Header Compression (ROHC): Requirements on TCP/IP Header Compression

    Informational
  • RFC 4138: Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP and the Stream Control Transmission Protocol (SCTP)

    Experimental
  • RFC 4022: Management Information Base for the Transmission Control Protocol (TCP)

    Proposed Standard
  • RFC 4015: The Eifel Response Algorithm for TCP

    Proposed Standard
  • RFC 3720: Internet Small Computer Systems Interface (iSCSI)

    Proposed Standard

    Obsoleted by RFC 7143

  • RFC 3782: The NewReno Modification to TCP's Fast Recovery Algorithm

    Proposed Standard

    Obsoleted by RFC 6582

  • RFC 3742: Limited Slow-Start for TCP with Large Congestion Windows

    Experimental
  • RFC 3734: Extensible Provisioning Protocol (EPP) Transport Over TCP

    Proposed Standard

    Obsoleted by RFC 4934

  • RFC 3708: Using TCP Duplicate Selective Acknowledgement (DSACKs) and Stream Control Transmission Protocol (SCTP) Duplicate Transmission Sequence Numbers (TSNs) to Detect Spurious Retransmissions

    Experimental
  • RFC 3649: HighSpeed TCP for Large Congestion Windows

    Experimental
  • RFC 3639: Considerations on the use of a Service Identifier in Packet Headers

    Informational
  • RFC 3562: Key Management Considerations for the TCP MD5 Signature Option

    Informational
  • RFC 3540: Robust Explicit Congestion Notification (ECN) Signaling with Nonces

    Historic
  • RFC 3522: The Eifel Detection Algorithm for TCP

    Experimental
  • RFC 3517: A Conservative Selective Acknowledgment (SACK)-based Loss Recovery Algorithm for TCP

    Proposed Standard

    Obsoleted by RFC 6675

  • RFC 3493: Basic Socket Interface Extensions for IPv6

    Informational
  • RFC 3498: Definitions of Managed Objects for Synchronous Optical Network (SONET) Linear Automatic Protection Switching (APS) Architectures

    Proposed Standard
  • RFC 3481: BCP 71: TCP over Second (2.5G) and Third (3G) Generation Wireless Networks

    Best Current Practice
  • RFC 3465: TCP Congestion Control with Appropriate Byte Counting (ABC)

    Experimental
  • RFC 3448: TCP Friendly Rate Control (TFRC): Protocol Specification

    Proposed Standard

    Obsoleted by RFC 5348

  • RFC 3449: BCP 69: TCP Performance Implications of Network Path Asymmetry

    Best Current Practice
  • RFC 3430: Simple Network Management Protocol Over Transmission Control Protocol Transport Mapping

    Experimental
  • RFC 3390: Increasing TCP's Initial Window

    Proposed Standard
  • RFC 3360: BCP 60: Inappropriate TCP Resets Considered Harmful

    Best Current Practice
  • RFC 3347: Small Computer Systems Interface protocol over the Internet (iSCSI) Requirements and Design Considerations

    Proposed Standard
  • RFC 3293: General Switch Management Protocol (GSMP) Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

    Proposed Standard
  • RFC 3257: Stream Control Transmission Protocol Applicability Statement

    Informational
  • Best Current Practice
  • Informational
  • RFC 3081: Mapping the BEEP Core onto TCP

    Proposed Standard
  • RFC 3042: Enhancing TCP's Loss Recovery Using Limited Transmit

    Proposed Standard
  • RFC 2988: Computing TCP's Retransmission Timer

    Proposed Standard

    Obsoleted by RFC 6298

  • RFC 2963: A Rate Adaptive Shaper for Differentiated Services

    Informational
  • RFC 2920: STD 60: SMTP Service Extension for Command Pipelining

    Internet Standard
  • RFC 2923: TCP Problems with Path MTU Discovery

    Informational
  • RFC 2883: An Extension to the Selective Acknowledgement (SACK) Option for TCP

    Proposed Standard
  • RFC 2884: Performance Evaluation of Explicit Congestion Notification (ECN) in IP Networks

    Informational
  • RFC 2861: TCP Congestion Window Validation

    Historic

    Obsoleted by RFC 7661

  • RFC 2873: TCP Processing of the IPv4 Precedence Field

    Proposed Standard

    Obsoleted by RFC 9293

  • Informational
  • RFC 2757: Long Thin Networks

    Informational
  • RFC 2581: TCP Congestion Control

    Proposed Standard

    Obsoleted by RFC 5681

  • RFC 2582: The NewReno Modification to TCP's Fast Recovery Algorithm

    Experimental

    Obsoleted by RFC 3782

  • RFC 2525: Known TCP Implementation Problems

    Informational
  • RFC 2553: Basic Socket Interface Extensions for IPv6

    Informational

    Obsoleted by RFC 3493

  • RFC 2507: IP Header Compression

    Proposed Standard
  • RFC 2481: A Proposal to add Explicit Congestion Notification (ECN) to IP

    Experimental

    Obsoleted by RFC 3168

  • RFC 2488: BCP 28: Enhancing TCP Over Satellite Channels using Standard Mechanisms

    Best Current Practice
  • RFC 2452: IP Version 6 Management Information Base for the Transmission Control Protocol

    Historic

    Obsoleted by RFC 4022, RFC 8096

  • RFC 2414: Increasing TCP's Initial Window

    Experimental

    Obsoleted by RFC 3390

  • RFC 2415: Simulation Studies of Increased Initial TCP Window Size

    Informational
  • RFC 2416: When TCP Starts Up With Four Packets Into Only Three Buffers

    Informational
  • RFC 2385: Protection of BGP Sessions via the TCP MD5 Signature Option

    Proposed Standard

    Obsoleted by RFC 5925

  • RFC 2398: FYI 33: Some Testing Tools for TCP Implementors

    Informational
  • RFC 2229: A Dictionary Server Protocol

    Informational
  • RFC 2197: SMTP Service Extension for Command Pipelining

    Draft Standard

    Obsoleted by RFC 2920

  • RFC 2147: TCP and UDP over IPv6 Jumbograms

    Proposed Standard

    Obsoleted by RFC 2675

  • RFC 2140: TCP Control Block Interdependence

    Informational

    Obsoleted by RFC 9040

  • RFC 2126: ISO Transport Service on top of TCP (ITOT)

    Proposed Standard
  • RFC 2001: TCP Slow Start, Congestion Avoidance, Fast Retransmit, and Fast Recovery Algorithms

    Proposed Standard

    Obsoleted by RFC 2581

  • RFC 2012: SNMPv2 Management Information Base for the Transmission Control Protocol using SMIv2

    Proposed Standard

    Obsoleted by RFC 4022

  • RFC 2018: TCP Selective Acknowledgment Options

    Proposed Standard
  • RFC 1936: Implementing the Internet Checksum in Hardware

    Informational
  • RFC 1858: Security Considerations for IP Fragment Filtering

    Informational
  • RFC 1859: ISO Transport Class 2 Non-use of Explicit Flow Control over TCP RFC1006 extension

    Informational
  • RFC 1834: Whois and Network Information Lookup Service, Whois++

    Informational
  • RFC 1835: Architecture of the WHOIS++ service

    Historic
  • RFC 1791: TCP And UDP Over IPX Networks With Fixed Path MTU

    Experimental
  • RFC 1693: An Extension to TCP : Partial Order Service

    Historic

    Obsoleted by RFC 6247

  • RFC 1644: T/TCP -- TCP Extensions for Transactions Functional Specification

    Historic

    Obsoleted by RFC 6247

  • RFC 1613: cisco Systems X.25 over TCP (XOT)

    Informational
  • RFC 1379: Extending TCP for Transactions -- Concepts

    Historic

    Obsoleted by RFC 6247

  • RFC 1347: TCP and UDP with Bigger Addresses (TUBA), A Simple Proposal for Internet Addressing and Routing

    Historic
  • RFC 1323: TCP Extensions for High Performance

    Proposed Standard

    Obsoleted by RFC 7323

  • RFC 1337: TIME-WAIT Assassination Hazards in TCP

    Informational
  • RFC 1263: TCP Extensions Considered Harmful

    Informational
  • RFC 1254: Gateway Congestion Control Survey

    Informational
  • RFC 1180: TCP/IP tutorial

    Informational
  • RFC 1185: TCP Extension for High-Speed Paths

    Experimental

    Obsoleted by RFC 1323

  • RFC 1146: TCP alternate checksum options

    Historic

    Obsoleted by RFC 6247

  • RFC 1145: TCP alternate checksum options

    Historic

    Obsoleted by RFC 1146, RFC 6247

  • RFC 1110: Problem with the TCP big window option

    Historic

    Obsoleted by RFC 6247

  • RFC 1106: TCP big window and NAK options

    Historic

    Obsoleted by RFC 6247

  • RFC 1085: ISO presentation services on top of TCP/IP based internets

    Unknown
  • RFC 1086: ISO-TP0 bridge between TCP and X.25

    Unknown
  • RFC 1078: TCP port service Multiplexer (TCPMUX)

    Historic

    Obsoleted by RFC 7805

  • RFC 1072: TCP extensions for long-delay paths

    Historic

    Obsoleted by RFC 1323, RFC 2018, RFC 6247

  • RFC 1025: TCP and IP bake off

    Unknown
  • RFC 1006: STD 35: ISO Transport Service on top of the TCP Version: 3

    Internet Standard
  • RFC 1001: STD 19: Protocol standard for a NetBIOS service on a TCP/UDP transport: Concepts and methods

    Internet Standard
  • RFC 1002: STD 19: Protocol standard for a NetBIOS service on a TCP/UDP transport: Detailed specifications

    Internet Standard
  • RFC 983: ISO transport arrives on top of the TCP

    Unknown

    Obsoleted by RFC 1006

  • RFC 962: TCP-4 prime

    Unknown
  • RFC 964: Some problems with the specification of the Military Standard Transmission Control Protocol

    Informational
  • RFC 915: Network mail path service

    Unknown
  • RFC 896: Congestion Control in IP/TCP Internetworks

    Historic

    Obsoleted by RFC 7805

  • RFC 889: Internet Delay Experiments

    Informational
  • Historic

    Obsoleted by RFC 7805, RFC 9293

  • RFC 848: Who provides the "little" TCP services?

    Unknown
  • RFC 842: Who talks TCP? - survey of 1 February 83

    Unknown

    Obsoleted by RFC 843

  • RFC 843: Who talks TCP? - survey of 8 February 83

    Unknown

    Obsoleted by RFC 845

  • RFC 845: Who talks TCP? - survey of 15 February 1983

    Unknown

    Obsoleted by RFC 846

  • RFC 846: Who talks TCP? - survey of 22 February 1983

    Unknown

    Obsoleted by RFC 847

  • RFC 836: Who talks TCP?

    Unknown

    Obsoleted by RFC 837

  • RFC 837: Who talks TCP?

    Unknown

    Obsoleted by RFC 838

  • RFC 838: Who talks TCP?

    Unknown

    Obsoleted by RFC 839

  • RFC 839: Who talks TCP?

    Unknown

    Obsoleted by RFC 842

  • RFC 832: Who talks TCP?

    Unknown

    Obsoleted by RFC 833

  • RFC 833: Who talks TCP?

    Unknown

    Obsoleted by RFC 834

  • RFC 834: Who talks TCP?

    Unknown

    Obsoleted by RFC 835

  • RFC 835: Who talks TCP?

    Unknown

    Obsoleted by RFC 836

  • RFC 872: TCP-on-a-LAN

    Informational
  • RFC 813: Window and Acknowledgement Strategy in TCP

    Historic

    Obsoleted by RFC 7805

  • RFC 801: NCP/TCP transition plan

    Unknown
  • RFC 793: Transmission Control Protocol

    Internet Standard

    Obsoleted by RFC 9293

  • RFC 773: Comments on NCP/TCP mail service transition strategy

    Unknown
  • RFC 761: DoD standard Transmission Control Protocol

    Historic

    Obsoleted by RFC 793, RFC 7805

  • RFC 675: Specification of Internet Transmission Control Program

    Historic

    Obsoleted by RFC 7805

Subscribe to TCP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.