STUN

STUN (Session Traversal Utilities for NAT)

STUN RFCs (22)

Display RFCs as
  • RFC 9443: Multiplexing Scheme Updates for QUIC

    Proposed Standard
  • RFC 8489: Session Traversal Utilities for NAT (STUN)

    Proposed Standard
  • RFC 8656: Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)

    Proposed Standard
  • RFC 8155: Traversal Using Relays around NAT (TURN) Server Auto Discovery

    Proposed Standard
  • RFC 8016: Mobility with Traversal Using Relays around NAT (TURN)

    Proposed Standard
  • RFC 7983: Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7982: Measurement of Round-Trip Time and Fractional Loss Using Session Traversal Utilities for NAT (STUN)

    Proposed Standard
  • Proposed Standard
  • RFC 7635: Session Traversal Utilities for NAT (STUN) Extension for Third-Party Authorization

    Proposed Standard
  • RFC 7584: Session Traversal Utilities for NAT (STUN) Message Handling for SIP Back-to-Back User Agents (B2BUAs)

    Proposed Standard
  • RFC 7443: Application-Layer Protocol Negotiation (ALPN) Labels for Session Traversal Utilities for NAT (STUN) Usages

    Informational
  • RFC 7376: Problems with Session Traversal Utilities for NAT (STUN) Long-Term Authentication for Traversal Using Relays around NAT (TURN)

    Informational
  • RFC 7350: Datagram Transport Layer Security (DTLS) as Transport for Session Traversal Utilities for NAT (STUN)

    Proposed Standard
  • RFC 7064: URI Scheme for the Session Traversal Utilities for NAT (STUN) Protocol

    Proposed Standard
  • RFC 6156: Traversal Using Relays around NAT (TURN) Extension for IPv6

    Proposed Standard

    Obsoleted by RFC 8656

  • RFC 6223: Indication of Support for Keep-Alive

    Proposed Standard
  • RFC 6062: Traversal Using Relays around NAT (TURN) Extensions for TCP Allocations

    Proposed Standard
  • RFC 5780: NAT Behavior Discovery Using Session Traversal Utilities for NAT (STUN)

    Experimental
  • RFC 5766: Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)

    Proposed Standard

    Obsoleted by RFC 8656

  • RFC 5769: Test Vectors for Session Traversal Utilities for NAT (STUN)

    Informational
  • RFC 5389: Session Traversal Utilities for NAT (STUN)

    Proposed Standard

    Obsoleted by RFC 8489

  • RFC 3489: STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)

    Proposed Standard

    Obsoleted by RFC 5389

Subscribe to STUN

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.