SLAAC

IPv6 SLAAC (Stateless Address Autoconfiguration)

SLAAC RFCs (17)

Display RFCs as
  • RFC 9762: Using Router Advertisements to Signal the Availability of DHCPv6 Prefix Delegation to Clients

    Proposed Standard
  • RFC 9686: Registering Self-Generated IPv6 Addresses Using DHCPv6

    Proposed Standard
  • RFC 9663: Using DHCPv6 Prefix Delegation (DHCPv6-PD) to Allocate Unique IPv6 Prefixes per Client in Large Broadcast Networks

    Informational
  • RFC 9131: Gratuitous Neighbor Discovery: Creating Neighbor Cache Entries on First-Hop Routers

    Proposed Standard
  • RFC 8978: Reaction of IPv6 Stateless Address Autoconfiguration (SLAAC) to Flash-Renumbering Events

    Informational
  • RFC 8981: Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6

    Proposed Standard
  • RFC 7934: BCP 204: Host Address Availability Recommendations

    Best Current Practice
  • RFC 7217: A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)

    Proposed Standard
  • RFC 6957: Duplicate Address Detection Proxy

    Proposed Standard
  • RFC 6105: IPv6 Router Advertisement Guard

    Informational
  • RFC 4862: IPv6 Stateless Address Autoconfiguration

    Draft Standard
  • RFC 4941: Privacy Extensions for Stateless Address Autoconfiguration in IPv6

    Draft Standard

    Obsoleted by RFC 8981

  • RFC 4429: Optimistic Duplicate Address Detection (DAD) for IPv6

    Proposed Standard
  • RFC 4076: Renumbering Requirements for Stateless Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Informational
  • RFC 3041: Privacy Extensions for Stateless Address Autoconfiguration in IPv6

    Proposed Standard

    Obsoleted by RFC 4941

  • RFC 2462: IPv6 Stateless Address Autoconfiguration

    Draft Standard

    Obsoleted by RFC 4862

  • RFC 1971: IPv6 Stateless Address Autoconfiguration

    Proposed Standard

    Obsoleted by RFC 2462

Subscribe to SLAAC

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.