SHA

The SHA (Secure Hash Algorithm) family of hash functions

SHA RFCs (40)

Display RFCs as
  • RFC 9941: Secure Shell (SSH) Key Exchange Method Using Hybrid Streamlined NTRU Prime sntrup761 and X25519 with SHA-512: sntrup761x25519-sha512

    Informational
  • RFC 9905: Deprecating the Use of SHA-1 in DNSSEC Signature Algorithms

    Proposed Standard
  • RFC 9709: Encryption Key Derivation in the Cryptographic Message Syntax (CMS) Using HKDF with SHA-256

    Proposed Standard
  • RFC 9688: Use of the SHA3 One-Way Hash Functions in the Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 9054: CBOR Object Signing and Encryption (COSE): Hash Algorithms

    Informational
  • RFC 9142: Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (SSH)

    Proposed Standard
  • RFC 9155: Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 8732: Generic Security Service Application Program Interface (GSS-API) Key Exchange with SHA-2

    Proposed Standard
  • RFC 8332: Use of RSA Keys with SHA-256 and SHA-512 in the Secure Shell (SSH) Protocol

    Proposed Standard
  • RFC 8009: AES Encryption with HMAC-SHA2 for Kerberos 5

    Informational
  • RFC 7860: HMAC-SHA-2 Authentication Protocols in User-Based Security Model (USM) for SNMPv3

    Proposed Standard
  • RFC 7677: SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) Mechanisms

    Proposed Standard
  • RFC 7630: HMAC-SHA-2 Authentication Protocols in the User-based Security Model (USM) for SNMPv3

    Proposed Standard

    Obsoleted by RFC 7860

  • RFC 6668: SHA-2 Data Integrity Verification for the Secure Shell (SSH) Transport Layer Protocol

    Proposed Standard
  • RFC 6605: Elliptic Curve Digital Signature Algorithm (DSA) for DNSSEC

    Proposed Standard
  • RFC 6594: Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource Records

    Proposed Standard
  • RFC 6234: US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)

    Informational
  • RFC 6194: Security Considerations for the SHA-0 and SHA-1 Message-Digest Algorithms

    Informational
  • RFC 5932: Camellia Cipher Suites for TLS

    Proposed Standard
  • RFC 5816: ESSCertIDv2 Update for RFC 3161

    Proposed Standard
  • RFC 5754: Using SHA2 Algorithms with Cryptographic Message Syntax

    Proposed Standard
  • RFC 5702: Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSEC

    Proposed Standard
  • RFC 5709: OSPFv2 HMAC-SHA Cryptographic Authentication

    Proposed Standard
  • RFC 5487: Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter Mode

    Proposed Standard
  • RFC 5310: IS-IS Generic Cryptographic Authentication

    Proposed Standard
  • RFC 5289: TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)

    Proposed Standard
  • RFC 4868: Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsec

    Proposed Standard
  • RFC 4635: HMAC SHA (Hashed Message Authentication Code, Secure Hash Algorithm) TSIG Algorithm Identifiers

    Proposed Standard

    Obsoleted by RFC 8945

  • RFC 4634: US Secure Hash Algorithms (SHA and HMAC-SHA)

    Informational

    Obsoleted by RFC 6234

  • RFC 4509: Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)

    Proposed Standard
  • RFC 4359: The Use of RSA/SHA-1 Signatures within Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard
  • RFC 4231: Identifiers and Test Vectors for HMAC-SHA-224, HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512

    Proposed Standard
  • RFC 4194: The S Hexdump Format

    Proposed Standard
  • RFC 3874: A 224-bit One-way Hash Function: SHA-224

    Informational
  • RFC 3174: US Secure Hash Algorithm 1 (SHA1)

    Informational
  • RFC 3110: RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)

    Proposed Standard
  • RFC 2841: IP Authentication using Keyed SHA1 with Interleaved Padding (IP-MAC)

    Historic
  • RFC 2404: The Use of HMAC-SHA-1-96 within ESP and AH

    Proposed Standard
  • RFC 2202: Test Cases for HMAC-MD5 and HMAC-SHA-1

    Informational
  • RFC 1852: IP Authentication using Keyed SHA

    Experimental

    Obsoleted by RFC 2841

Subscribe to SHA

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.