SDP

SDP (Session Description Protocol) and offer/answer

SDP RFCs (99)

Display RFCs as
  • RFC 9429: JavaScript Session Establishment Protocol (JSEP)

    Proposed Standard
  • RFC 9143: Negotiating Media Multiplexing Using the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8829: JavaScript Session Establishment Protocol (JSEP)

    Proposed Standard

    Obsoleted by RFC 9429

  • RFC 8843: Negotiating Media Multiplexing Using the Session Description Protocol (SDP)

    Proposed Standard

    Obsoleted by RFC 9143

  • RFC 8851: RTP Payload Format Restrictions

    Proposed Standard
  • RFC 8853: Using Simulcast in Session Description Protocol (SDP) and RTP Sessions

    Proposed Standard
  • RFC 8856: Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams

    Proposed Standard
  • RFC 8864: Negotiation Data Channels Using the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8865: T.140 Real-Time Text Conversation over WebRTC Data Channels

    Proposed Standard
  • RFC 8866: SDP: Session Description Protocol

    Proposed Standard
  • RFC 8830: WebRTC MediaStream Identification in the Session Description Protocol

    Proposed Standard
  • RFC 8839: Session Description Protocol (SDP) Offer/Answer Procedures for Interactive Connectivity Establishment (ICE)

    Proposed Standard
  • RFC 8840: A Session Initiation Protocol (SIP) Usage for Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (Trickle ICE)

    Proposed Standard
  • RFC 8841: Session Description Protocol (SDP) Offer/Answer Procedures for Stream Control Transmission Protocol (SCTP) over Datagram Transport Layer Security (DTLS) Transport

    Proposed Standard
  • RFC 8842: Session Description Protocol (SDP) Offer/Answer Considerations for Datagram Transport Layer Security (DTLS) and Transport Layer Security (TLS)

    Proposed Standard
  • RFC 8844: Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8850: Controlling Multiple Streams for Telepresence (CLUE) Protocol Data Channel

    Experimental
  • RFC 8858: Indicating Exclusive Support of RTP and RTP Control Protocol (RTCP) Multiplexing Using the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8859: A Framework for Session Description Protocol (SDP) Attributes When Multiplexing

    Proposed Standard
  • RFC 8873: Message Session Relay Protocol (MSRP) over Data Channels

    Proposed Standard
  • RFC 8759: RTP Payload for Timed Text Markup Language (TTML)

    Proposed Standard
  • RFC 8373: Negotiating Human Language in Real-Time Communications

    Proposed Standard
  • RFC 8124: The Session Description Protocol (SDP) WebSocket Connection URI Attribute

    Proposed Standard
  • RFC 8122: Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 7825: A Network Address Translator (NAT) Traversal Mechanism for Media Controlled by the Real-Time Streaming Protocol (RTSP)

    Proposed Standard
  • RFC 7826: Real-Time Streaming Protocol Version 2.0

    Proposed Standard
  • RFC 8035: Session Description Protocol (SDP) Offer/Answer Clarifications for RTP/RTCP Multiplexing

    Proposed Standard
  • RFC 7850: Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP Profiles

    Proposed Standard
  • RFC 7604: Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)

    Informational
  • RFC 7362: Latching: Hosted NAT Traversal (HNT) for Media in Real-Time Communication

    Informational
  • RFC 7345: UDP Transport Layer (UDPTL) over Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7261: Offer/Answer Considerations for G723 Annex A and G729 Annex B

    Proposed Standard
  • RFC 7195: Session Description Protocol (SDP) Extension for Setting Audio and Video Media Streams over Circuit-Switched Bearers in the Public Switched Telephone Network (PSTN)

    Proposed Standard
  • RFC 7197: Duplication Delay Attribute in the Session Description Protocol

    Proposed Standard
  • RFC 7104: Duplication Grouping Semantics in the Session Description Protocol

    Proposed Standard
  • RFC 7006: Miscellaneous Capabilities Negotiation in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 6947: The Session Description Protocol (SDP) Alternate Connectivity (ALTC) Attribute

    Informational
  • RFC 6871: Session Description Protocol (SDP) Media Capabilities Negotiation

    Proposed Standard
  • RFC 6849: An Extension to the Session Description Protocol (SDP) and Real-time Transport Protocol (RTP) for Media Loopback

    Proposed Standard
  • RFC 6544: TCP Candidates with Interactive Connectivity Establishment (ICE)

    Proposed Standard
  • RFC 6466: IANA Registration of the 'image' Media Type for the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 6364: Session Description Protocol Elements for the Forward Error Correction (FEC) Framework

    Proposed Standard
  • RFC 6337: Session Initiation Protocol (SIP) Usage of the Offer/Answer Model

    Informational
  • RFC 6336: IANA Registry for Interactive Connectivity Establishment (ICE) Options

    Proposed Standard

    Obsoleted by RFC 8839

  • RFC 6263: Application Mechanism for Keeping Alive the NAT Mappings Associated with RTP / RTP Control Protocol (RTCP) Flows

    Proposed Standard
  • RFC 6236: Negotiation of Generic Image Attributes in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 6185: RTP Payload Format for H.264 Reduced-Complexity Decoding Operation (RCDO) Video

    Proposed Standard
  • RFC 6193: Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)

    Informational
  • RFC 6064: SDP and RTSP Extensions Defined for 3GPP Packet-Switched Streaming Service and Multimedia Broadcast/Multicast Service

    Informational
  • RFC 5956: Forward Error Correction Grouping Semantics in the Session Description Protocol

    Proposed Standard
  • RFC 5939: Session Description Protocol (SDP) Capability Negotiation

    Proposed Standard
  • RFC 5898: Connectivity Preconditions for Session Description Protocol (SDP) Media Streams

    Proposed Standard
  • RFC 5888: The Session Description Protocol (SDP) Grouping Framework

    Proposed Standard
  • RFC 5245: Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols

    Proposed Standard

    Obsoleted by RFC 8445, RFC 8839

  • RFC 5583: Signaling Media Decoding Dependency in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 5576: Source-Specific Media Attributes in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 5574: RTP Payload Format for the Speex Codec

    Proposed Standard
  • RFC 5547: A Session Description Protocol (SDP) Offer/Answer Mechanism to Enable File Transfer

    Proposed Standard
  • RFC 5432: Quality of Service (QoS) Mechanism Selection in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 5159: Session Description Protocol (SDP) Attributes for Open Mobile Alliance (OMA) Broadcast (BCAST) Service and Content Protection

    Informational
  • RFC 5027: Security Preconditions for Session Description Protocol (SDP) Media Streams

    Proposed Standard
  • RFC 4796: The Session Description Protocol (SDP) Content Attribute

    Proposed Standard
  • RFC 4629: RTP Payload Format for ITU-T Rec. H.263 Video

    Proposed Standard
  • RFC 4756: Forward Error Correction Grouping Semantics in Session Description Protocol

    Proposed Standard

    Obsoleted by RFC 5956

  • RFC 4583: Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams

    Proposed Standard

    Obsoleted by RFC 8856

  • RFC 4574: The Session Description Protocol (SDP) Label Attribute

    Proposed Standard
  • RFC 4587: RTP Payload Format for H.261 Video Streams

    Proposed Standard
  • RFC 4612: Real-Time Facsimile (T.38) - audio/t38 MIME Sub-type Registration

    Historic
  • RFC 4566: SDP: Session Description Protocol

    Proposed Standard

    Obsoleted by RFC 8866

  • RFC 4567: Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP)

    Proposed Standard
  • RFC 4568: Session Description Protocol (SDP) Security Descriptions for Media Streams

    Proposed Standard
  • RFC 4570: Session Description Protocol (SDP) Source Filters

    Proposed Standard
  • RFC 4572: Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)

    Proposed Standard

    Obsoleted by RFC 8122

  • RFC 4473: Requirements for Internet Media Guides (IMGs)

    Informational
  • RFC 4435: A Framework for the Usage of Internet Media Guides (IMGs)

    Informational
  • RFC 4317: Session Description Protocol (SDP) Offer/Answer Examples

    Informational
  • RFC 4298: RTP Payload Format for BroadVoice Speech Codecs

    Proposed Standard
  • RFC 4145: TCP-Based Media Transport in the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 4091: The Alternative Network Address Types (ANAT) Semantics for the Session Description Protocol (SDP) Grouping Framework

    Proposed Standard

    Obsoleted by RFC 5245

  • RFC 4092: Usage of the Session Description Protocol (SDP) Alternative Network Address Types (ANAT) Semantics in the Session Initiation Protocol (SIP)

    Proposed Standard

    Obsoleted by RFC 5245

  • RFC 3890: A Transport Independent Bandwidth Modifier for the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 3611: RTP Control Protocol Extended Reports (RTCP XR)

    Proposed Standard
  • RFC 3605: Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)

    Proposed Standard
  • RFC 3556: Session Description Protocol (SDP) Bandwidth Modifiers for RTP Control Protocol (RTCP) Bandwidth

    Proposed Standard
  • RFC 3524: Mapping of Media Streams to Resource Reservation Flows

    Proposed Standard
  • RFC 3485: The Session Initiation Protocol (SIP) and Session Description Protocol (SDP) Static Dictionary for Signaling Compression (SigComp)

    Proposed Standard
  • RFC 3322: Signaling Compression (SigComp) Requirements & Assumptions

    Informational
  • RFC 3388: Grouping of Media Lines in the Session Description Protocol (SDP)

    Proposed Standard

    Obsoleted by RFC 5888

  • RFC 3407: Session Description Protocol (SDP) Simple Capability Declaration

    Proposed Standard
  • RFC 3264: An Offer/Answer Model with Session Description Protocol (SDP)

    Proposed Standard
  • RFC 3266: Support for IPv6 in Session Description Protocol (SDP)

    Proposed Standard

    Obsoleted by RFC 4566

  • RFC 3259: A Message Bus for Local Coordination

    Informational
  • RFC 3107: Carrying Label Information in BGP-4

    Proposed Standard

    Obsoleted by RFC 8277

  • RFC 3108: Conventions for the use of the Session Description Protocol (SDP) for ATM Bearer Connections

    Proposed Standard
  • RFC 2974: Session Announcement Protocol

    Experimental
  • RFC 2848: The PINT Service Protocol: Extensions to SIP and SDP for IP Access to Telephone Call Services

    Proposed Standard
  • RFC 2543: SIP: Session Initiation Protocol

    Proposed Standard

    Obsoleted by RFC 3261, RFC 3262, RFC 3263, RFC 3264, RFC 3265

  • RFC 2326: Real Time Streaming Protocol (RTSP)

    Proposed Standard

    Obsoleted by RFC 7826

  • RFC 2327: SDP: Session Description Protocol

    Proposed Standard

    Obsoleted by RFC 4566

Subscribe to SDP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.