SCTP

SCTP (Stream Control Transmission Protocol)

SCTP RFCs (52)

Display RFCs as
  • RFC 9653: Zero Checksum for the Stream Control Transmission Protocol

    Proposed Standard
  • RFC 9260: Stream Control Transmission Protocol

    Proposed Standard
  • RFC 8841: Session Description Protocol (SDP) Offer/Answer Procedures for Stream Control Transmission Protocol (SCTP) over Datagram Transport Layer Security (DTLS) Transport

    Proposed Standard
  • RFC 8850: Controlling Multiple Streams for Telepresence (CLUE) Protocol Data Channel

    Experimental
  • RFC 8899: Packetization Layer Path MTU Discovery for Datagram Transports

    Proposed Standard
  • RFC 8540: Stream Control Transmission Protocol: Errata and Issues in RFC 4960

    Informational

    Obsoleted by RFC 9260

  • RFC 8260: Stream Schedulers and User Message Interleaving for the Stream Control Transmission Protocol

    Proposed Standard
  • RFC 8261: Datagram Transport Layer Security (DTLS) Encapsulation of SCTP Packets

    Proposed Standard
  • RFC 8087: The Benefits of Using Explicit Congestion Notification (ECN)

    Informational
  • RFC 7829: SCTP-PF: A Quick Failover Algorithm for the Stream Control Transmission Protocol

    Proposed Standard
  • RFC 7765: TCP and Stream Control Transmission Protocol (SCTP) RTO Restart

    Experimental
  • RFC 7605: BCP 165: Recommendations on Using Assigned Transport Port Numbers

    Best Current Practice
  • RFC 7496: Additional Policies for the Partially Reliable Stream Control Transmission Protocol Extension

    Proposed Standard
  • RFC 7053: SACK-IMMEDIATELY Extension for the Stream Control Transmission Protocol

    Proposed Standard

    Obsoleted by RFC 9260

  • RFC 6951: UDP Encapsulation of Stream Control Transmission Protocol (SCTP) Packets for End-Host to End-Host Communication

    Proposed Standard
  • RFC 6633: Deprecation of ICMP Source Quench Messages

    Proposed Standard
  • RFC 6526: IP Flow Information Export (IPFIX) Per Stream Control Transmission Protocol (SCTP) Stream

    Proposed Standard
  • RFC 6525: Stream Control Transmission Protocol (SCTP) Stream Reconfiguration

    Proposed Standard
  • RFC 6458: Sockets API Extensions for the Stream Control Transmission Protocol (SCTP)

    Informational
  • RFC 6096: Stream Control Transmission Protocol (SCTP) Chunk Flags Registration

    Proposed Standard

    Obsoleted by RFC 9260

  • RFC 6083: Datagram Transport Layer Security (DTLS) for Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 6084: General Internet Signaling Transport (GIST) over Stream Control Transmission Protocol (SCTP) and Datagram Transport Layer Security (DTLS)

    Experimental
  • RFC 6053: Implementation Report for Forwarding and Control Element Separation (ForCES)

    Informational
  • RFC 5923: Connection Reuse in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5827: Early Retransmit for TCP and Stream Control Transmission Protocol (SCTP)

    Experimental
  • RFC 5811: SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol

    Proposed Standard
  • RFC 5043: Stream Control Transmission Protocol (SCTP) Direct Data Placement (DDP) Adaptation

    Proposed Standard
  • RFC 4960: Stream Control Transmission Protocol

    Proposed Standard

    Obsoleted by RFC 9260

  • RFC 5061: Stream Control Transmission Protocol (SCTP) Dynamic Address Reconfiguration

    Proposed Standard
  • RFC 5062: Security Attacks Found Against the Stream Control Transmission Protocol (SCTP) and Current Countermeasures

    Informational
  • RFC 4895: Authenticated Chunks for the Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 4820: Padding Chunk and Parameter for the Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 4666: Signaling System 7 (SS7) Message Transfer Part 3 (MTP3) - User Adaptation Layer (M3UA)

    Proposed Standard
  • RFC 4460: Stream Control Transmission Protocol (SCTP) Specification Errata and Issues

    Informational

    Obsoleted by RFC 9260

  • RFC 4166: Telephony Signalling Transport over Stream Control Transmission Protocol (SCTP) Applicability Statement

    Informational
  • RFC 4233: Integrated Services Digital Network (ISDN) Q.921-User Adaptation Layer

    Proposed Standard
  • RFC 4168: The Stream Control Transmission Protocol (SCTP) as a Transport for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 4138: Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP and the Stream Control Transmission Protocol (SCTP)

    Experimental
  • RFC 3868: Signalling Connection Control Part User Adaptation Layer (SUA)

    Proposed Standard
  • RFC 3873: Stream Control Transmission Protocol (SCTP) Management Information Base (MIB)

    Proposed Standard
  • RFC 3807: V5.2-User Adaptation Layer (V5UA)

    Proposed Standard
  • RFC 3758: Stream Control Transmission Protocol (SCTP) Partial Reliability Extension

    Proposed Standard
  • RFC 3708: Using TCP Duplicate Selective Acknowledgement (DSACKs) and Stream Control Transmission Protocol (SCTP) Duplicate Transmission Sequence Numbers (TSNs) to Detect Spurious Retransmissions

    Experimental
  • RFC 3554: On the Use of Stream Control Transmission Protocol (SCTP) with IPsec

    Proposed Standard
  • RFC 3436: Transport Layer Security over Stream Control Transmission Protocol

    Proposed Standard
  • RFC 3309: Stream Control Transmission Protocol (SCTP) Checksum Change

    Proposed Standard

    Obsoleted by RFC 4960

  • RFC 3331: Signaling System 7 (SS7) Message Transfer Part 2 (MTP2) - User Adaptation Layer

    Proposed Standard
  • RFC 3332: Signaling System 7 (SS7) Message Transfer Part 3 (MTP3) - User Adaptation Layer (M3UA)

    Proposed Standard

    Obsoleted by RFC 4666

  • RFC 3286: An Introduction to the Stream Control Transmission Protocol (SCTP)

    Informational
  • RFC 3257: Stream Control Transmission Protocol Applicability Statement

    Informational
  • RFC 3057: ISDN Q.921-User Adaptation Layer

    Proposed Standard

    Obsoleted by RFC 4233

  • RFC 2960: Stream Control Transmission Protocol

    Proposed Standard

    Obsoleted by RFC 4960

Subscribe to SCTP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.