SASL

SASL (Simple Authentication and Security Layer)

SASL RFCs (26)

Display RFCs as
  • RFC 8437: IMAP UNAUTHENTICATE Extension for Connection Reuse

    Proposed Standard
  • RFC 7832: Application Bridging for Federated Access Beyond Web (ABFAB) Use Cases

    Informational
  • RFC 7804: Salted Challenge Response HTTP Authentication Mechanism

    Experimental
  • RFC 7677: SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) Mechanisms

    Proposed Standard
  • RFC 7628: A Set of Simple Authentication and Security Layer (SASL) Mechanisms for OAuth

    Proposed Standard
  • RFC 6616: A Simple Authentication and Security Layer (SASL) and Generic Security Service Application Program Interface (GSS-API) Mechanism for OpenID

    Proposed Standard
  • RFC 6595: A Simple Authentication and Security Layer (SASL) and GSS-API Mechanism for the Security Assertion Markup Language (SAML)

    Proposed Standard
  • RFC 5801: Using Generic Security Service Application Program Interface (GSS-API) Mechanisms in Simple Authentication and Security Layer (SASL): The GS2 Mechanism Family

    Proposed Standard
  • RFC 5802: Salted Challenge Response Authentication Mechanism (SCRAM) SASL and GSS-API Mechanisms

    Proposed Standard
  • RFC 5803: Lightweight Directory Access Protocol (LDAP) Schema for Storing Salted Challenge Response Authentication Mechanism (SCRAM) Secrets

    Informational
  • RFC 4959: IMAP Extension for Simple Authentication and Security Layer (SASL) Initial Client Response

    Proposed Standard
  • RFC 5034: The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication Mechanism

    Proposed Standard
  • RFC 4954: SMTP Service Extension for Authentication

    Proposed Standard
  • RFC 4752: The Kerberos V5 ("GSSAPI") Simple Authentication and Security Layer (SASL) Mechanism

    Proposed Standard
  • RFC 4643: Network News Transfer Protocol (NNTP) Extension for Authentication

    Proposed Standard
  • RFC 4616: The PLAIN Simple Authentication and Security Layer (SASL) Mechanism

    Proposed Standard
  • RFC 4422: Simple Authentication and Security Layer (SASL)

    Proposed Standard
  • RFC 4505: Anonymous Simple Authentication and Security Layer (SASL) Mechanism

    Proposed Standard
  • RFC 4013: SASLprep: Stringprep Profile for User Names and Passwords

    Proposed Standard

    Obsoleted by RFC 7613

  • RFC 3163: ISO/IEC 9798-3 Authentication SASL Mechanism

    Experimental
  • RFC 2831: Using Digest Authentication as a SASL Mechanism

    Historic

    Obsoleted by RFC 6331

  • RFC 2808: The SecurID(r) SASL Mechanism

    Informational
  • RFC 2554: SMTP Service Extension for Authentication

    Proposed Standard

    Obsoleted by RFC 4954

  • RFC 2444: The One-Time-Password SASL Mechanism

    Proposed Standard
  • RFC 2245: Anonymous SASL Mechanism

    Proposed Standard

    Obsoleted by RFC 4505

  • RFC 2222: Simple Authentication and Security Layer (SASL)

    Proposed Standard

    Obsoleted by RFC 4422, RFC 4752

Subscribe to SASL

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.