RSA

RSA (Rivest-Shamir-Adleman) encryption and signatures

RSA RFCs (29)

Display RFCs as
  • RFC 10015: Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 9690: Use of the RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 9474: RSA Blind Signatures

    Informational
  • RFC 9142: Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (SSH)

    Proposed Standard
  • RFC 8332: Use of RSA Keys with SHA-256 and SHA-512 in the Secure Shell (SSH) Protocol

    Proposed Standard
  • RFC 8230: Using RSA Algorithms with CBOR Object Signing and Encryption (COSE) Messages

    Proposed Standard
  • RFC 8017: PKCS #1: RSA Cryptography Specifications Version 2.2

    Informational
  • RFC 7427: Signature Authentication in the Internet Key Exchange Version 2 (IKEv2)

    Proposed Standard
  • RFC 6594: Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource Records

    Proposed Standard
  • RFC 5990: Use of the RSA-KEM Key Transport Algorithm in the Cryptographic Message Syntax (CMS)

    Proposed Standard

    Obsoleted by RFC 9690

  • RFC 5958: Asymmetric Key Packages

    Proposed Standard
  • RFC 5754: Using SHA2 Algorithms with Cryptographic Message Syntax

    Proposed Standard
  • RFC 5756: Updates for RSAES-OAEP and RSASSA-PSS Algorithm Parameters

    Proposed Standard
  • RFC 5702: Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSEC

    Proposed Standard
  • RFC 5208: Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification Version 1.2

    Informational

    Obsoleted by RFC 5958

  • RFC 4758: Cryptographic Token Key Initialization Protocol (CT-KIP) Version 1.0 Revision 1

    Informational
  • RFC 4738: MIKEY-RSA-R: An Additional Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)

    Proposed Standard
  • RFC 4432: RSA Key Exchange for the Secure Shell (SSH) Transport Layer Protocol

    Proposed Standard
  • RFC 4359: The Use of RSA/SHA-1 Signatures within Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard
  • RFC 4055: Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile

    Proposed Standard
  • RFC 4056: Use of the RSASSA-PSS Signature Algorithm in Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 3447: Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1

    Informational

    Obsoleted by RFC 8017

  • RFC 3110: RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)

    Proposed Standard
  • RFC 3090: DNS Security Extension Clarification on Zone Status

    Proposed Standard

    Obsoleted by RFC 4033, RFC 4034, RFC 4035

  • RFC 2792: DSA and RSA Key and Signature Encoding for the KeyNote Trust Management System

    Informational
  • RFC 2537: RSA/MD5 KEYs and SIGs in the Domain Name System (DNS)

    Proposed Standard

    Obsoleted by RFC 3110

  • RFC 2437: PKCS #1: RSA Cryptography Specifications Version 2.0

    Informational

    Obsoleted by RFC 3447

  • RFC 2268: A Description of the RC2(r) Encryption Algorithm

    Informational
  • RFC 2313: PKCS #1: RSA Encryption Version 1.5

    Informational

    Obsoleted by RFC 2437

Subscribe to RSA

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.