RIP
Routing Information Protocol (RIP, RIPv2, RIPng)
Within this page
RIP RFCs (19)
RFC 8695: A YANG Data Model for the Routing Information Protocol (RIP)
Proposed Standard- X. Liu
- P. Sarda
- V. Choudhary
- February 2020
- IETF publication
- Routing Area
Abstract
This document describes a data model for the management of the Routing Information Protocol (RIP). Both RIP version 2 and RIPng are covered. The data model includes definitions for configuration, operational state, and Remote Procedure Calls (RPCs).
The YANG data model in this document conforms to the Network Management Datastore Architecture (NMDA).
Abstract
This document describes a data model for the management of the Routing Information Protocol (RIP). Both RIP version 2 and RIPng are covered. The data model includes definitions for configuration, operational state, and Remote Procedure Calls (RPCs).
The YANG data model in this document conforms to the Network Management Datastore Architecture (NMDA).
RFC 4822: RIPv2 Cryptographic Authentication
Proposed Standard- R. Atkinson
- M. Fanto
- February 2007
- IETF publication
Abstract
This note describes a revision to the RIPv2 Cryptographic Authentication mechanism originally specified in RFC 2082. This document obsoletes RFC 2082 and updates RFC 2453. This document adds details of how the SHA family of hash algorithms can be used with RIPv2 Cryptographic Authentication, whereas the original document only specified the use of Keyed-MD5. Also, this document clarifies a potential issue with an active attack on this mechanism and adds significant text to the Security Considerations section. [STANDARDS-TRACK]
Abstract
This note describes a revision to the RIPv2 Cryptographic Authentication mechanism originally specified in RFC 2082. This document obsoletes RFC 2082 and updates RFC 2453. This document adds details of how the SHA family of hash algorithms can be used with RIPv2 Cryptographic Authentication, whereas the original document only specified the use of Keyed-MD5. Also, this document clarifies a potential issue with an active attack on this mechanism and adds significant text to the Security Considerations section. [STANDARDS-TRACK]
RFC 2453: STD 56: RIP Version 2
Internet Standard- G. Malkin
- November 1998
- IETF publication
- Routing Area
Abstract
This document specifies an extension of the Routing Information Protocol (RIP) to expand the amount of useful information carried in RIP messages and to add a measure of security. [STANDARDS-TRACK]
Abstract
This document specifies an extension of the Routing Information Protocol (RIP) to expand the amount of useful information carried in RIP messages and to add a measure of security. [STANDARDS-TRACK]
RFC 2080: RIPng for IPv6
Proposed Standard- G. Malkin
- R. Minnear
- January 1997
- IETF publication
- Routing Area
Abstract
This document specifies a routing protocol for an IPv6 internet. It is based on protocols and algorithms currently in wide use in the IPv4 Internet [STANDARDS-TRACK]
Abstract
This document specifies a routing protocol for an IPv6 internet. It is based on protocols and algorithms currently in wide use in the IPv4 Internet [STANDARDS-TRACK]
RFC 2081: RIPng Protocol Applicability Statement
Informational- G. Malkin
- January 1997
- IETF publication
- Routing Area
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report defines the applicability of the RIPng protocol within the Internet. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report defines the applicability of the RIPng protocol within the Internet. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 2082: RIP-2 MD5 Authentication
Proposed Standard- F. Baker
- R. Atkinson
- January 1997
- IETF publication
- Routing Area
Abstract
Growth in the Internet has made us aware of the need for improved authentication of routing information. RIP-2 provides for unauthenticated service (as in classical RIP), or password authentication. [STANDARDS-TRACK]
Obsoleted by RFC 4822
Abstract
Growth in the Internet has made us aware of the need for improved authentication of routing information. RIP-2 provides for unauthenticated service (as in classical RIP), or password authentication. [STANDARDS-TRACK]
RFC 2091: Triggered Extensions to RIP to Support Demand Circuits
Proposed Standard- G. Meyer
- S. Sherry
- January 1997
- IETF publication
- Routing Area
Abstract
This document defines a modification which can be applied to Bellman- Ford (distance vector) algorithm information broadcasting protocols. [STANDARDS-TRACK]
Abstract
This document defines a modification which can be applied to Bellman- Ford (distance vector) algorithm information broadcasting protocols. [STANDARDS-TRACK]
RFC 2092: Protocol Analysis for Triggered RIP
Informational- S. Sherry
- G. Meyer
- January 1997
- IETF publication
- Routing Area
Abstract
As required by Routing Protocol Criteria [1], this report documents the key features of Triggered Extensions to RIP to Support Demand Circuits [2] and the current implementation experience. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
As required by Routing Protocol Criteria [1], this report documents the key features of Triggered Extensions to RIP to Support Demand Circuits [2] and the current implementation experience. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1923: RIPv1 Applicability Statement for Historic Status
Informational- J. Halpern
- S. Bradner
- March 1996
- IETF publication
- Routing Area
Abstract
RIP Version 1 [RFC-1058] has been declared an historic document. This Applicability statement provides the supporting motivation for that declaration. The primary reason, as described below, is the Classful nature of RIPv1. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
RIP Version 1 [RFC-1058] has been declared an historic document. This Applicability statement provides the supporting motivation for that declaration. The primary reason, as described below, is the Classful nature of RIPv1. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1721: RIP Version 2 Protocol Analysis
Informational- G. Malkin
- November 1994
- IETF publication
- Routing Area
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report documents the key features of the RIP-2 protocol and the current implementation experience. This report is a prerequisite to advancing RIP-2 on the standards track. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report documents the key features of the RIP-2 protocol and the current implementation experience. This report is a prerequisite to advancing RIP-2 on the standards track. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1722: STD 57: RIP Version 2 Protocol Applicability Statement
Internet Standard- G. Malkin
- November 1994
- IETF publication
- Routing Area
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report defines the applicability of the RIP-2 protocol within the Internet. This report is a prerequisite to advancing RIP-2 on the standards track. [STANDARDS-TRACK]
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report defines the applicability of the RIP-2 protocol within the Internet. This report is a prerequisite to advancing RIP-2 on the standards track. [STANDARDS-TRACK]
RFC 1723: RIP Version 2 - Carrying Additional Information
Internet Standard- G. Malkin
- November 1994
- IETF publication
- Routing Area
Abstract
This document specifies an extension of the Routing Information Protocol (RIP), o expand the amount of useful information carried in RIP messages and to add a measure of security. This memo obsoletes RFC 1388, which specifies an update to the "Routing Information Protocol" STD 34, RFC 1058. [STANDARDS-TRACK]
Obsoleted by RFC 2453
Abstract
This document specifies an extension of the Routing Information Protocol (RIP), o expand the amount of useful information carried in RIP messages and to add a measure of security. This memo obsoletes RFC 1388, which specifies an update to the "Routing Information Protocol" STD 34, RFC 1058. [STANDARDS-TRACK]
RFC 1724: RIP Version 2 MIB Extension
Draft Standard- G. Malkin
- F. Baker
- November 1994
- IETF publication
- Routing Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP-based internets. In particular, it defines objects for managing RIP Version 2. [STANDARDS-TRACK]
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP-based internets. In particular, it defines objects for managing RIP Version 2. [STANDARDS-TRACK]
RFC 1581: Protocol Analysis for Extensions to RIP to Support Demand Circuits
Informational- G. Meyer
- February 1994
- Legacy publication
Abstract
As required by Routing Protocol Criteria, this report documents the key features of Routing over Demand Circuits on Wide Area Networks - RIP and the current implementation experience. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
As required by Routing Protocol Criteria, this report documents the key features of Routing over Demand Circuits on Wide Area Networks - RIP and the current implementation experience. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1582: Extensions to RIP to Support Demand Circuits
Proposed Standard- G. Meyer
- February 1994
- Legacy publication
Abstract
This memo defines a generalized modification which can be applied to Bellman-Ford (or distance vector) algorithm information broadcasting protocols. [STANDARDS-TRACK]
Abstract
This memo defines a generalized modification which can be applied to Bellman-Ford (or distance vector) algorithm information broadcasting protocols. [STANDARDS-TRACK]
RFC 1387: RIP Version 2 Protocol Analysis
Informational- G. Malkin
- January 1993
- IETF publication
- Routing Area
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report documents the key features of the RIP-2 protocol and the current implementation experience. This memo provides information for the Internet community. It does not specify an Internet standard.
Obsoleted by RFC 1721
Abstract
As required by Routing Protocol Criteria (RFC 1264), this report documents the key features of the RIP-2 protocol and the current implementation experience. This memo provides information for the Internet community. It does not specify an Internet standard.
RFC 1388: RIP Version 2 Carrying Additional Information
Proposed Standard- G. Malkin
- January 1993
- IETF publication
- Routing Area
Abstract
This document specifies an extension of the Routing Information Protocol (RIP), as defined in [STANDARDS-TRACK]
Obsoleted by RFC 1723
Abstract
This document specifies an extension of the Routing Information Protocol (RIP), as defined in [STANDARDS-TRACK]
RFC 1389: RIP Version 2 MIB Extensions
Proposed Standard- G. Malkin
- F. Baker
- January 1993
- IETF publication
- Routing Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP-based internets. [STANDARDS-TRACK]
Obsoleted by RFC 1724
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP-based internets. [STANDARDS-TRACK]
RFC 1058: Routing Information Protocol
Historic- C.L. Hedrick
- June 1988
- Legacy publication
Abstract
This RFC describes an existing protocol for exchanging routing information among gateways and other hosts. It is intended to be used as a basis for developing gateway software for use in the Internet community.
Abstract
This RFC describes an existing protocol for exchanging routing information among gateways and other hosts. It is intended to be used as a basis for developing gateway software for use in the Internet community.
Subscribe to RIP
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.