RADIUS

The RADIUS (Remote Authentication Dial-In User Service) protocol

RADIUS RFCs (83)

Display RFCs as
  • RFC 9813: BCP 243: Operational Considerations for Using TLS Pre-Shared Keys (TLS-PSKs) with RADIUS

    Best Current Practice
  • RFC 9765: RADIUS/1.1: Leveraging Application-Layer Protocol Negotiation (ALPN) to Remove MD5

    Experimental
  • RFC 9445: RADIUS Extensions for DHCP-Configured Services

    Proposed Standard
  • RFC 8658: RADIUS Attributes for Softwire Mechanisms Based on Address plus Port (A+P)

    Proposed Standard
  • RFC 8559: Dynamic Authorization Proxying in the Remote Authentication Dial-In User Service (RADIUS) Protocol

    Proposed Standard
  • RFC 8044: Data Types in RADIUS

    Proposed Standard
  • RFC 8045: RADIUS Extensions for IP Port Configuration and Reporting

    Proposed Standard
  • RFC 7930: Larger Packets for RADIUS over TCP

    Experimental
  • RFC 7831: Application Bridging for Federated Access Beyond Web (ABFAB) Architecture

    Informational
  • RFC 7832: Application Bridging for Federated Access Beyond Web (ABFAB) Use Cases

    Informational
  • RFC 7833: A RADIUS Attribute, Binding, Profiles, Name Identifier Format, and Confirmation Methods for the Security Assertion Markup Language (SAML)

    Proposed Standard
  • RFC 7585: Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)

    Experimental
  • RFC 7593: The eduroam Architecture for Network Roaming

    Informational
  • RFC 7542: The Network Access Identifier

    Proposed Standard
  • RFC 7499: Support of Fragmentation of RADIUS Packets

    Experimental
  • RFC 7360: Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUS

    Experimental
  • RFC 7268: RADIUS Attributes for IEEE 802 Networks

    Proposed Standard
  • RFC 7037: RADIUS Option for the DHCPv6 Relay Agent

    Proposed Standard
  • RFC 6929: Remote Authentication Dial In User Service (RADIUS) Protocol Extensions

    Proposed Standard
  • RFC 6930: RADIUS Attribute for IPv6 Rapid Deployment on IPv4 Infrastructures (6rd)

    Proposed Standard
  • RFC 6911: RADIUS Attributes for IPv6 Access Networks

    Proposed Standard
  • RFC 6572: RADIUS Support for Proxy Mobile IPv6

    Proposed Standard
  • RFC 6613: RADIUS over TCP

    Experimental
  • RFC 6614: Transport Layer Security (TLS) Encryption for RADIUS

    Experimental
  • RFC 6519: RADIUS Extensions for Dual-Stack Lite

    Proposed Standard
  • RFC 6421: Crypto-Agility Requirements for Remote Authentication Dial-In User Service (RADIUS)

    Informational
  • RFC 6218: Cisco Vendor-Specific RADIUS Attributes for the Delivery of Keying Material

    Informational
  • RFC 6158: BCP 158: RADIUS Design Guidelines

    Best Current Practice
  • RFC 6065: Using Authentication, Authorization, and Accounting Services to Dynamically Provision View-Based Access Control Model User-to-Group Mappings

    Proposed Standard
  • RFC 5997: Use of Status-Server Packets in the Remote Authentication Dial In User Service (RADIUS) Protocol

    Informational
  • RFC 5904: RADIUS Attributes for IEEE 802.16 Privacy Key Management Version 1 (PKMv1) Protocol Support

    Informational
  • RFC 5608: Remote Authentication Dial-In User Service (RADIUS) Usage for Simple Network Management Protocol (SNMP) Transport Models

    Proposed Standard
  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

    Proposed Standard
  • RFC 5607: Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) Management

    Proposed Standard
  • RFC 5090: RADIUS Extension for Digest Authentication

    Proposed Standard
  • RFC 5176: Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)

    Informational
  • RFC 5080: Common Remote Authentication Dial In User Service (RADIUS) Implementation Issues and Suggested Fixes

    Proposed Standard
  • RFC 5030: Mobile IPv4 RADIUS Requirements

    Informational
  • RFC 4849: RADIUS Filter Rule Attribute

    Proposed Standard
  • RFC 4818: RADIUS Delegated-IPv6-Prefix Attribute

    Proposed Standard
  • RFC 4672: RADIUS Dynamic Authorization Client MIB

    Informational
  • RFC 4673: RADIUS Dynamic Authorization Server MIB

    Informational
  • RFC 4675: RADIUS Attributes for Virtual LAN and Priority Support

    Proposed Standard
  • RFC 4679: DSL Forum Vendor-Specific RADIUS Attributes

    Informational
  • RFC 4668: RADIUS Authentication Client MIB for IPv6

    Proposed Standard
  • RFC 4669: RADIUS Authentication Server MIB for IPv6

    Proposed Standard
  • RFC 4670: RADIUS Accounting Client MIB for IPv6

    Informational
  • RFC 4671: RADIUS Accounting Server MIB for IPv6

    Informational
  • RFC 4603: Additional Values for the NAS-Port-Type Attribute

    Informational
  • RFC 4590: RADIUS Extension for Digest Authentication

    Proposed Standard

    Obsoleted by RFC 5090

  • RFC 4372: Chargeable User Identity

    Proposed Standard
  • RFC 4282: The Network Access Identifier

    Proposed Standard

    Obsoleted by RFC 7542

  • RFC 4005: Diameter Network Access Server Application

    Proposed Standard

    Obsoleted by RFC 7155

  • RFC 4014: Remote Authentication Dial-In User Service (RADIUS) Attributes Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Information Option

    Proposed Standard
  • RFC 3579: RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)

    Informational
  • RFC 3580: IEEE 802.1X Remote Authentication Dial In User Service (RADIUS) Usage Guidelines

    Informational
  • RFC 3575: IANA Considerations for RADIUS (Remote Authentication Dial In User Service)

    Proposed Standard
  • RFC 3576: Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)

    Informational

    Obsoleted by RFC 5176

  • RFC 3169: Criteria for Evaluating Network Access Server Protocols

    Informational
  • RFC 3162: RADIUS and IPv6

    Proposed Standard
  • RFC 3017: XML DTD for Roaming Access Phone Book

    Proposed Standard
  • RFC 2881: Network Access Server Requirements Next Generation (NASREQNG) NAS Model

    Informational
  • RFC 2882: Network Access Servers Requirements: Extended RADIUS Practices

    Informational
  • RFC 2865: Remote Authentication Dial In User Service (RADIUS)

    Draft Standard
  • RFC 2866: RADIUS Accounting

    Informational
  • RFC 2867: RADIUS Accounting Modifications for Tunnel Protocol Support

    Informational
  • RFC 2868: RADIUS Attributes for Tunnel Protocol Support

    Informational
  • RFC 2869: RADIUS Extensions

    Informational
  • RFC 2809: Implementation of L2TP Compulsory Tunneling via RADIUS

    Informational
  • RFC 2607: Proxy Chaining and Policy Implementation in Roaming

    Informational
  • RFC 2618: RADIUS Authentication Client MIB

    Proposed Standard

    Obsoleted by RFC 4668

  • RFC 2619: RADIUS Authentication Server MIB

    Proposed Standard

    Obsoleted by RFC 4669

  • RFC 2620: RADIUS Accounting Client MIB

    Informational

    Obsoleted by RFC 4670

  • RFC 2621: RADIUS Accounting Server MIB

    Informational

    Obsoleted by RFC 4671

  • RFC 2548: Microsoft Vendor-specific RADIUS Attributes

    Informational
  • RFC 2477: Criteria for Evaluating Roaming Protocols

    Informational
  • RFC 2486: The Network Access Identifier

    Proposed Standard

    Obsoleted by RFC 4282

  • RFC 2194: Review of Roaming Implementations

    Informational
  • RFC 2138: Remote Authentication Dial In User Service (RADIUS)

    Proposed Standard

    Obsoleted by RFC 2865

  • RFC 2139: RADIUS Accounting

    Informational

    Obsoleted by RFC 2866

  • RFC 2107: Ascend Tunnel Management Protocol - ATMP

    Informational
  • RFC 2058: Remote Authentication Dial In User Service (RADIUS)

    Proposed Standard

    Obsoleted by RFC 2138

  • RFC 2059: RADIUS Accounting

    Informational

    Obsoleted by RFC 2139

Subscribe to RADIUS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.