privacy

Privacy threat models and protocol privacy considerations

privacy RFCs (108)

Display RFCs as
  • RFC 9788: Header Protection for Cryptographically Protected Email

    Proposed Standard
  • RFC 9797: Randomized and Changing Media Access Control (MAC) Addresses: Context, Network Impacts, and Use Cases

    Informational
  • RFC 9781: A Concise Binary Object Representation (CBOR) Tag for Unprotected CBOR Web Token Claims Sets (UCCS)

    Proposed Standard
  • RFC 9724: State of Affairs for Randomized and Changing Media Access Control (MAC) Addresses

    Informational
  • RFC 9620: Guidelines for Human Rights Protocol and Architecture Considerations

    Informational
  • RFC 9498: The GNU Name System

    Informational
  • RFC 9505: A Survey of Worldwide Censorship Techniques

    Informational
  • RFC 9415: On the Generation of Transient Numeric Identifiers

    Informational
  • RFC 9446: Reflections on Ten Years Past the Snowden Revelations

    Informational
  • RFC 9156: DNS Query Name Minimisation to Improve Privacy

    Proposed Standard
  • RFC 9076: DNS Privacy Considerations

    Informational
  • RFC 8981: Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6

    Proposed Standard
  • RFC 8828: WebRTC IP Address Handling Requirements

    Proposed Standard
  • RFC 8871: A Solution Framework for Private Media in Privacy-Enhanced RTP Conferencing (PERC)

    Proposed Standard
  • RFC 8932: BCP 232: Recommendations for DNS Privacy Service Operators

    Best Current Practice
  • RFC 8882: DNS-Based Service Discovery (DNS-SD) Privacy and Security Requirements

    Informational
  • RFC 8576: Internet of Things (IoT) Security: State of the Art and Challenges

    Informational
  • RFC 8568: Network Virtualization Research Challenges

    Informational
  • RFC 8386: Privacy Considerations for Protocols Relying on IP Broadcast or Multicast

    Informational
  • RFC 8324: DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?

    Informational
  • RFC 8280: Research into Human Rights Protocol Considerations

    Informational
  • RFC 8065: Privacy Considerations for IPv6 Adaptation-Layer Mechanisms

    Informational
  • RFC 7861: Remote Procedure Call (RPC) Security Version 3

    Proposed Standard
  • RFC 7943: A Method for Generating Semantically Opaque Interface Identifiers (IIDs) with the Dynamic Host Configuration Protocol for IPv6 (DHCPv6)

    Informational
  • RFC 7871: Client Subnet in DNS Queries

    Informational
  • RFC 7824: Privacy Considerations for DHCPv6

    Informational
  • RFC 7844: Anonymity Profiles for DHCP Clients

    Proposed Standard
  • RFC 7819: Privacy Considerations for DHCP

    Informational
  • RFC 7816: DNS Query Name Minimisation to Improve Privacy

    Experimental

    Obsoleted by RFC 9156

  • RFC 7721: Security and Privacy Considerations for IPv6 Address Generation Mechanisms

    Informational
  • RFC 7785: Recommendations for Prefix Binding in the Context of Softwire Dual-Stack Lite

    Informational
  • RFC 7687: Report from the Strengthening the Internet (STRINT) Workshop

    Informational
  • RFC 7626: DNS Privacy Considerations

    Informational

    Obsoleted by RFC 9076

  • RFC 7624: Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem Statement

    Informational
  • RFC 7459: Representation of Uncertainty and Confidence in the Presence Information Data Format Location Object (PIDF-LO)

    Proposed Standard
  • RFC 7293: The Require-Recipient-Valid-Since Header Field and SMTP Service Extension

    Proposed Standard
  • RFC 7258: BCP 188: Pervasive Monitoring Is an Attack

    Best Current Practice
  • RFC 7216: Location Information Server (LIS) Discovery Using IP Addresses and Reverse DNS

    Proposed Standard
  • RFC 7199: Location Configuration Extensions for Policy Management

    Proposed Standard
  • Proposed Standard
  • RFC 7035: Relative Location Representation

    Proposed Standard
  • RFC 6973: Privacy Considerations for Internet Protocols

    Informational
  • RFC 6915: Flow Identity Extension for HTTP-Enabled Location Delivery (HELD)

    Proposed Standard
  • RFC 6848: Specifying Civic Address Extensions in the Presence Information Data Format Location Object (PIDF-LO)

    Proposed Standard
  • RFC 6772: Geolocation Policy: A Document Format for Expressing Privacy Preferences for Location Information

    Proposed Standard
  • RFC 6753: A Location Dereference Protocol Using HTTP-Enabled Location Delivery (HELD)

    Proposed Standard
  • RFC 6447: Filtering Location Notifications in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 6462: Report from the Internet Privacy Workshop

    Informational
  • RFC 6444: Location Hiding: Problem Statement and Requirements

    Informational
  • RFC 6225: Dynamic Host Configuration Protocol Options for Coordinate-Based Location Configuration Information

    Proposed Standard
  • RFC 6280: BCP 160: An Architecture for Location and Location Privacy in Internet Applications

    Best Current Practice
  • RFC 6235: IP Flow Anonymization Support

    Experimental
  • RFC 6155: Use of Device Identity in HTTP-Enabled Location Delivery (HELD)

    Proposed Standard
  • RFC 5985: HTTP-Enabled Location Delivery (HELD)

    Proposed Standard
  • RFC 5986: Discovering the Local Location Information Server (LIS)

    Proposed Standard
  • RFC 5902: IAB Thoughts on IPv6 Network Address Translation

    Informational
  • RFC 5904: RADIUS Attributes for IEEE 802.16 Privacy Key Management Version 1 (PKMv1) Protocol Support

    Informational
  • RFC 5870: A Uniform Resource Identifier for Geographic Locations ('geo' URI)

    Proposed Standard
  • RFC 5808: Requirements for a Location-by-Reference Mechanism

    Informational
  • RFC 5767: User-Agent-Driven Privacy Mechanism for SIP

    Informational
  • RFC 5687: GEOPRIV Layer 7 Location Configuration Protocol: Problem Statement and Requirements

    Informational
  • RFC 5774: BCP 154: Considerations for Civic Addresses in the Presence Information Data Format Location Object (PIDF-LO): Guidelines and IANA Registry Definition

    Best Current Practice
  • RFC 5726: Mobile IPv6 Location Privacy Solutions

    Experimental
  • RFC 5379: Guidelines for Using the Privacy Mechanism for SIP

    Informational
  • RFC 5606: Implications of 'retransmission-allowed' for SIP Location Conveyance

    Informational
  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

    Proposed Standard
  • RFC 5491: GEOPRIV Presence Information Data Format Location Object (PIDF-LO) Usage Clarification, Considerations, and Recommendations

    Proposed Standard
  • RFC 5403: RPCSEC_GSS Version 2

    Proposed Standard
  • RFC 5209: Network Endpoint Assessment (NEA): Overview and Requirements

    Informational
  • RFC 5139: Revised Civic Location Format for Presence Information Data Format Location Object (PIDF-LO)

    Proposed Standard
  • RFC 4941: Privacy Extensions for Stateless Address Autoconfiguration in IPv6

    Draft Standard

    Obsoleted by RFC 8981

  • RFC 4882: IP Address Location Privacy and Mobile IPv6: Problem Statement

    Informational
  • RFC 4902: Integrity, Privacy, and Security in Open Pluggable Edge Services (OPES) for SMTP

    Informational
  • RFC 4745: Common Policy: A Document Format for Expressing Privacy Preferences

    Proposed Standard
  • RFC 4651: A Taxonomy and Analysis of Enhancements to Mobile IPv6 Route Optimization

    Informational
  • RFC 4776: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Option for Civic Addresses Configuration Information

    Proposed Standard
  • RFC 4676: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Option for Civic Addresses Configuration Information

    Proposed Standard

    Obsoleted by RFC 4776

  • RFC 4683: Internet X.509 Public Key Infrastructure Subject Identification Method (SIM)

    Proposed Standard
  • RFC 4589: Location Types Registry

    Proposed Standard
  • RFC 4119: A Presence-based GEOPRIV Location Object Format

    Proposed Standard
  • RFC 4131: Management Information Base for Data Over Cable Service Interface Specification (DOCSIS) Cable Modems and Cable Modem Termination Systems for Baseline Privacy Plus

    Proposed Standard
  • RFC 4079: A Presence Architecture for the Distribution of GEOPRIV Location Objects

    Informational
  • RFC 3924: Cisco Architecture for Lawful Intercept in IP Networks

    Informational
  • RFC 3825: Dynamic Host Configuration Protocol Option for Coordinate-based Location Configuration Information

    Proposed Standard

    Obsoleted by RFC 6225

  • RFC 3693: Geopriv Requirements

    Informational
  • RFC 3694: Threat Analysis of the Geopriv Protocol

    Informational
  • RFC 3323: A Privacy Mechanism for the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 3156: MIME Security with OpenPGP

    Proposed Standard
  • RFC 3083: Baseline Privacy Interface Management Information Base for DOCSIS Compliant Cable Modems and Cable Modem Termination Systems

    Informational
  • RFC 3041: Privacy Extensions for Stateless Address Autoconfiguration in IPv6

    Proposed Standard

    Obsoleted by RFC 4941

  • RFC 2804: IETF Policy on Wiretapping

    Informational
  • RFC 2726: PGP Authentication for RIPE Database Updates

    Proposed Standard
  • RFC 2440: OpenPGP Message Format

    Proposed Standard

    Obsoleted by RFC 4880

  • RFC 2315: PKCS #7: Cryptographic Message Syntax Version 1.5

    Informational
  • RFC 2015: MIME Security with Pretty Good Privacy (PGP)

    Proposed Standard
  • RFC 1984: BCP 200: IAB and IESG Statement on Cryptographic Technology and the Internet

    Best Current Practice
  • RFC 1991: PGP Message Exchange Formats

    Informational

    Obsoleted by RFC 4880

  • RFC 1421: Privacy Enhancement for Internet Electronic Mail: Part I: Message Encryption and Authentication Procedures

    Historic
  • RFC 1422: Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key Management

    Historic
  • RFC 1423: Privacy Enhancement for Internet Electronic Mail: Part III: Algorithms, Modes, and Identifiers

    Historic
  • Historic
  • RFC 1355: FYI 15: Privacy and Accuracy Issues in Network Information Center Databases

    Informational
  • RFC 1281: Guidelines for the Secure Operation of the Internet

    Informational
  • RFC 1113: Privacy enhancement for Internet electronic mail: Part I - message encipherment and authentication procedures

    Historic

    Obsoleted by RFC 1421

  • RFC 1114: Privacy enhancement for Internet electronic mail: Part II - certificate-based key management

    Historic

    Obsoleted by RFC 1422

  • RFC 1115: Privacy enhancement for Internet electronic mail: Part III - algorithms, modes, and identifiers

    Historic

    Obsoleted by RFC 1423

  • RFC 1040: Privacy enhancement for Internet electronic mail: Part I: Message encipherment and authentication procedures

    Unknown

    Obsoleted by RFC 1113

  • RFC 989: Privacy enhancement for Internet electronic mail: Part I: Message encipherment and authentication procedures

    Unknown

    Obsoleted by RFC 1040, RFC 1113

Subscribe to privacy

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.