OSPF

OSPF (Open Shortest Path First)

OSPF subjects:

OSPF RFCs (118)

Display RFCs as
  • Proposed Standard
  • RFC 9933: Carrying SR-Algorithm in Path Computation Element Communication Protocol (PCEP)

    Proposed Standard
  • RFC 9917: IGP Flexible Algorithms Reverse Affinity Constraint

    Proposed Standard
  • RFC 9903: A YANG Data Model for OSPF Segment Routing over the MPLS Data Plane

    Proposed Standard
  • RFC 9843: IGP Flexible Algorithms: Bandwidth, Delay, Metrics, and Constraints

    Proposed Standard
  • RFC 9825: Extensions to OSPF for Advertising Prefix Administrative Tags

    Proposed Standard
  • RFC 9655: Egress Validation in Label Switched Path Ping and Traceroute Mechanisms

    Proposed Standard
  • RFC 9502: IGP Flexible Algorithm in IP Networks

    Proposed Standard
  • Proposed Standard
  • RFC 9454: Update to OSPF Terminology

    Proposed Standard
  • RFC 9350: IGP Flexible Algorithm

    Proposed Standard
  • RFC 9355: OSPF Bidirectional Forwarding Detection (BFD) Strict-Mode

    Proposed Standard
  • Proposed Standard
  • RFC 9339: OSPF Reverse Metric

    Proposed Standard
  • RFC 9129: YANG Data Model for the OSPF Protocol

    Proposed Standard
  • RFC 9314: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9160: Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 9127: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9089: Signaling Entropy Label Capability and Entropy Readable Label Depth Using OSPF

    Proposed Standard
  • RFC 9084: OSPF Prefix Originator Extensions

    Proposed Standard
  • RFC 9013: OSPF Advertisement of Tunnel Encapsulations

    Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 9492

  • RFC 8770: Host Router Support for OSPFv2

    Proposed Standard
  • RFC 8665: OSPF Extensions for Segment Routing

    Proposed Standard
  • RFC 8687: OSPF Routing with Cross-Address Family Traffic Engineering Tunnels

    Proposed Standard
  • RFC 8541: Impact of Shortest Path First (SPF) Trigger and Delay Strategies on IGP Micro-loops

    Informational
  • Proposed Standard
  • RFC 8476: Signaling Maximum SID Depth (MSD) Using OSPF

    Proposed Standard
  • RFC 8363: GMPLS OSPF-TE Extensions in Support of Flexi-Grid Dense Wavelength Division Multiplexing (DWDM) Networks

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 8258: Generalized SCSI: A Generic Structure for Interface Switching Capability Descriptor (ISCD) Switching Capability Specific Information (SCSI)

    Proposed Standard
  • RFC 8099: OSPF Topology-Transparent Zone

    Experimental
  • RFC 8042: OSPF Two-Part Metric

    Proposed Standard
  • RFC 7884: OSPF Extensions to Advertise Seamless Bidirectional Forwarding Detection (S-BFD) Target Discriminators

    Proposed Standard
  • RFC 7777: Advertising Node Administrative Tags in OSPF

    Proposed Standard
  • Proposed Standard
  • RFC 7688: GMPLS OSPF Enhancement for Signal and Network Element Compatibility for Wavelength Switched Optical Networks

    Proposed Standard
  • RFC 7580: OSPF-TE Extensions for General Network Element Constraints

    Proposed Standard
  • RFC 7474: Security Extension for OSPFv2 When Using Manual Key Management

    Proposed Standard
  • RFC 7471: OSPF Traffic Engineering (TE) Metric Extensions

    Proposed Standard
  • RFC 7138: Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

    Proposed Standard
  • RFC 7137: Use of the OSPF-MANET Interface in Single-Hop Broadcast Networks

    Experimental
  • RFC 7096: Evaluation of Existing GMPLS Encoding against G.709v3 Optical Transport Networks (OTNs)

    Informational
  • RFC 7038: Use of OSPF-MDR in Single-Hop Broadcast Networks

    Experimental
  • RFC 6987: OSPF Stub Router Advertisement

    Informational
  • RFC 6992: Routing for IPv4-Embedded IPv6 Packets

    Informational
  • RFC 6863: Analysis of OSPF Security According to the Keying and Authentication for Routing Protocols (KARP) Design Guide

    Informational
  • RFC 6860: Hiding Transit-Only Networks in OSPF

    Proposed Standard
  • RFC 6845: OSPF Hybrid Broadcast and Point-to-Multipoint Interface Type

    Proposed Standard
  • RFC 6571: Loop-Free Alternate (LFA) Applicability in Service Provider (SP) Networks

    Informational
  • RFC 6549: OSPFv2 Multi-Instance Extensions

    Proposed Standard
  • RFC 5820: Extensions to OSPF to Support Mobile Ad Hoc Networking

    Experimental
  • RFC 5786: Advertising a Router's Local Addresses in OSPF Traffic Engineering (TE) Extensions

    Proposed Standard
  • RFC 5709: OSPFv2 HMAC-SHA Cryptographic Authentication

    Proposed Standard
  • RFC 5642: Dynamic Hostname Exchange Mechanism for OSPF

    Proposed Standard
  • Proposed Standard
  • RFC 5614: Mobile Ad Hoc Network (MANET) Extension of OSPF Using Connected Dominating Set (CDS) Flooding

    Experimental
  • RFC 5449: OSPF Multipoint Relay (MPR) Extension for Ad Hoc Networks

    Experimental
  • RFC 5392: OSPF Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic Engineering

    Proposed Standard
  • RFC 5250: The OSPF Opaque LSA Option

    Proposed Standard
  • RFC 5252: OSPF-Based Layer 1 VPN Auto-Discovery

    Proposed Standard
  • RFC 5243: OSPF Database Exchange Summary List Optimization

    Informational
  • RFC 5185: OSPF Multi-Area Adjacency

    Proposed Standard
  • RFC 5088: OSPF Protocol Extensions for Path Computation Element (PCE) Discovery

    Proposed Standard
  • RFC 4972: Routing Extensions for Discovery of Multiprotocol (MPLS) Label Switch Router (LSR) Traffic Engineering (TE) Mesh Membership

    Proposed Standard
  • RFC 4973: OSPF-xTE: Experimental Extension to OSPF for Traffic Engineering

    Experimental
  • RFC 4940: BCP 130: IANA Considerations for OSPF

    Best Current Practice
  • RFC 4915: Multi-Topology (MT) Routing in OSPF

    Proposed Standard
  • Informational
  • RFC 4812: OSPF Restart Signaling

    Informational
  • Experimental

    Obsoleted by RFC 5613

  • RFC 4750: OSPF Version 2 Management Information Base

    Proposed Standard
  • Proposed Standard
  • RFC 4577: OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4202: Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • RFC 4203: OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)

    Proposed Standard
  • RFC 4222: BCP 112: Prioritized Treatment of Specific OSPF Version 2 Packets and Congestion Avoidance

    Best Current Practice
  • RFC 4167: Graceful OSPF Restart Implementation Report

    Informational
  • RFC 4136: OSPF Refresh and Flooding Reduction in Stable Topologies

    Informational
  • RFC 4061: Benchmarking Basic OSPF Single Router Control Plane Convergence

    Informational
  • RFC 4062: OSPF Benchmarking Terminology and Concepts

    Informational
  • RFC 4063: Considerations When Using Basic OSPF Convergence Benchmarks

    Informational
  • RFC 3883: Detecting Inactive Neighbors over OSPF Demand Circuits (DC)

    Proposed Standard
  • RFC 3623: Graceful OSPF Restart

    Proposed Standard
  • RFC 3630: Traffic Engineering (TE) Extensions to OSPF Version 2

    Proposed Standard
  • RFC 3509: Alternative Implementations of OSPF Area Border Routers

    Informational
  • RFC 3101: The OSPF Not-So-Stubby Area (NSSA) Option

    Proposed Standard
  • RFC 3166: Request to Move RFC 1403 to Historic Status

    Informational
  • RFC 3137: OSPF Stub Router Advertisement

    Informational

    Obsoleted by RFC 6987

  • RFC 2844: OSPF over ATM and Proxy-PAR

    Experimental
  • RFC 2740: OSPF for IPv6

    Proposed Standard

    Obsoleted by RFC 5340

  • RFC 2676: QoS Routing Mechanisms and OSPF Extensions

    Experimental
  • RFC 2370: The OSPF Opaque LSA Option

    Proposed Standard

    Obsoleted by RFC 5250

  • RFC 2328: STD 54: OSPF Version 2

    Internet Standard
  • RFC 2329: OSPF Standardization Report

    Informational
  • RFC 2178: OSPF Version 2

    Draft Standard

    Obsoleted by RFC 2328

  • RFC 2154: OSPF with Digital Signatures

    Experimental
  • RFC 2096: IP Forwarding Table MIB

    Proposed Standard

    Obsoleted by RFC 4292

  • RFC 1850: OSPF Version 2 Management Information Base

    Draft Standard

    Obsoleted by RFC 4750

  • RFC 1793: Extending OSPF to Support Demand Circuits

    Proposed Standard
  • RFC 1765: OSPF Database Overflow

    Experimental
  • RFC 1745: BGP4/IDRP for IP---OSPF Interaction

    Historic
  • RFC 1583: OSPF Version 2

    Draft Standard

    Obsoleted by RFC 2178

  • RFC 1584: Multicast Extensions to OSPF

    Historic
  • RFC 1585: MOSPF: Analysis and Experience

    Informational
  • RFC 1586: Guidelines for Running OSPF Over Frame Relay Networks

    Informational
  • RFC 1587: The OSPF NSSA Option

    Proposed Standard

    Obsoleted by RFC 3101

  • RFC 1403: BGP OSPF Interaction

    Historic
  • RFC 1370: Applicability Statement for OSPF

    Historic
  • RFC 1364: BGP OSPF Interaction

    Proposed Standard

    Obsoleted by RFC 1403

  • RFC 1252: OSPF Version 2 Management Information Base

    Proposed Standard

    Obsoleted by RFC 1253

  • RFC 1253: OSPF Version 2 Management Information Base

    Proposed Standard

    Obsoleted by RFC 1850

  • RFC 1245: OSPF Protocol Analysis

    Informational
  • RFC 1246: Experience with the OSPF Protocol

    Informational
  • RFC 1247: OSPF Version 2

    Draft Standard

    Obsoleted by RFC 1583

  • RFC 1248: OSPF Version 2 Management Information Base

    Proposed Standard

    Obsoleted by RFC 1252

  • RFC 1131: OSPF specification

    Proposed Standard

    Obsoleted by RFC 1247

Subscribe to OSPF

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.