NomCom

IETF NomCom (Nominating Committee) procedures

NomCom RFCs (12)

Display RFCs as
  • RFC 9389: BCP 10: Nominating Committee Eligibility

    Best Current Practice
  • RFC 8989: Additional Criteria for Nominating Committee Eligibility

    Experimental

    Obsoleted by RFC 9389

  • RFC 8788: Eligibility for the 2020-2021 Nominating Committee

    Best Current Practice

    Obsoleted by RFC 9389

  • RFC 8318: IAB, IESG, and IAOC Selection, Confirmation, and Recall Process: IAOC Advisor for the Nominating Committee

    Best Current Practice

    Obsoleted by RFC 8713

  • RFC 7437: IAB, IESG, and IAOC Selection, Confirmation, and Recall Process: Operation of the Nominating and Recall Committees

    Best Current Practice

    Obsoleted by RFC 8713

  • RFC 6859: Update to RFC 3777 to Clarify Nominating Committee Eligibility of IETF Leadership

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 5680: The Nominating Committee Process: Open Disclosure of Willing Nominees

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 5633: Nominating Committee Process: Earlier Announcement of Open Positions and Solicitation of Volunteers

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 5078: IAB and IESG Selection, Confirmation, and Recall Process: Revision of the Nominating and Recall Committees Timeline

    Informational

    Obsoleted by RFC 7437

  • RFC 3797: Publicly Verifiable Nominations Committee (NomCom) Random Selection

    Informational
  • RFC 3777: IAB and IESG Selection, Confirmation, and Recall Process: Operation of the Nominating and Recall Committees

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 2777: Publicly Verifiable Nomcom Random Selection

    Informational

    Obsoleted by RFC 3797

Subscribe to NomCom

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.