NFS

NFS (Network File System)

NFS RFCs (56)

Display RFCs as
  • RFC 9766: Extensions for Weak Cache Consistency in NFSv4.2's Flexible File Layout

    Proposed Standard
  • RFC 9754: Extensions for Opening and Delegating Files in NFSv4.2

    Proposed Standard
  • RFC 9737: Reporting Errors in NFSv4.2 via LAYOUTRETURN

    Proposed Standard
  • RFC 9561: Using the Parallel NFS (pNFS) SCSI Layout to Access Non-Volatile Memory Express (NVMe) Storage Devices

    Proposed Standard
  • RFC 9289: Towards Remote Procedure Call Encryption by Default

    Proposed Standard
  • RFC 8881: Network File System (NFS) Version 4 Minor Version 1 Protocol

    Proposed Standard
  • RFC 8797: Remote Direct Memory Access - Connection Manager (RDMA-CM) Private Data for RPC-over-RDMA Version 1

    Proposed Standard
  • RFC 8587: NFS Version 4.0 Trunking Update

    Proposed Standard
  • RFC 8434: Requirements for Parallel NFS (pNFS) Layout Types

    Proposed Standard
  • RFC 8435: Parallel NFS (pNFS) Flexible File Layout

    Proposed Standard
  • RFC 8275: Allowing Inheritable NFSv4 Access Control Entries to Override the Umask

    Proposed Standard
  • RFC 8276: File System Extended Attributes in NFSv4

    Proposed Standard
  • RFC 8267: Network File System (NFS) Upper-Layer Binding to RPC-over-RDMA Version 1

    Proposed Standard
  • RFC 8178: Rules for NFSv4 Extensions and Minor Versions

    Proposed Standard
  • RFC 8166: Remote Direct Memory Access Transport for Remote Procedure Call Version 1

    Proposed Standard
  • RFC 8167: Bidirectional Remote Procedure Call on RPC-over-RDMA Transports

    Proposed Standard
  • RFC 8154: Parallel NFS (pNFS) Small Computer System Interface (SCSI) Layout

    Proposed Standard
  • RFC 8000: Requirements for NFSv4 Multi-Domain Namespace Deployment

    Proposed Standard
  • RFC 7861: Remote Procedure Call (RPC) Security Version 3

    Proposed Standard
  • RFC 7862: Network File System (NFS) Version 4 Minor Version 2 Protocol

    Proposed Standard
  • RFC 7863: Network File System (NFS) Version 4 Minor Version 2 External Data Representation Standard (XDR) Description

    Proposed Standard
  • RFC 7931: NFSv4.0 Migration: Specification Update

    Proposed Standard
  • RFC 7569: Registry Specification for Mandatory Access Control (MAC) Security Label Formats

    Proposed Standard
  • RFC 7530: Network File System (NFS) Version 4 Protocol

    Proposed Standard
  • RFC 7531: Network File System (NFS) Version 4 External Data Representation Standard (XDR) Description

    Proposed Standard
  • RFC 7532: Namespace Database (NSDB) Protocol for Federated File Systems

    Proposed Standard
  • RFC 7533: Administration Protocol for Federated File Systems

    Proposed Standard
  • RFC 7204: Requirements for Labeled NFS

    Informational
  • RFC 6688: Parallel NFS (pNFS) Block Disk Protection

    Proposed Standard
  • RFC 6641: Using DNS SRV to Specify a Global File Namespace with NFS Version 4

    Proposed Standard
  • RFC 5661: Network File System (NFS) Version 4 Minor Version 1 Protocol

    Proposed Standard

    Obsoleted by RFC 8881

  • RFC 5662: Network File System (NFS) Version 4 Minor Version 1 External Data Representation Standard (XDR) Description

    Proposed Standard
  • RFC 5663: Parallel NFS (pNFS) Block/Volume Layout

    Proposed Standard
  • RFC 5664: Object-Based Parallel NFS (pNFS) Operations

    Proposed Standard
  • RFC 5665: IANA Considerations for Remote Procedure Call (RPC) Network Identifiers and Universal Address Formats

    Proposed Standard
  • RFC 5666: Remote Direct Memory Access Transport for Remote Procedure Call

    Proposed Standard

    Obsoleted by RFC 8166

  • RFC 5667: Network File System (NFS) Direct Data Placement

    Proposed Standard

    Obsoleted by RFC 8267

  • RFC 5716: Requirements for Federated File Systems

    Informational
  • RFC 5532: Network File System (NFS) Remote Direct Memory Access (RDMA) Problem Statement

    Informational
  • RFC 5531: RPC: Remote Procedure Call Protocol Specification Version 2

    Draft Standard
  • RFC 5403: RPCSEC_GSS Version 2

    Proposed Standard
  • RFC 4506: STD 67: XDR: External Data Representation Standard

    Internet Standard
  • RFC 3530: Network File System (NFS) version 4 Protocol

    Proposed Standard

    Obsoleted by RFC 7530

  • RFC 3010: NFS version 4 Protocol

    Proposed Standard

    Obsoleted by RFC 3530

  • RFC 2755: Security Negotiation for WebNFS

    Informational
  • RFC 2623: NFS Version 2 and Version 3 Security Issues and the NFS Protocol's Use of RPCSEC_GSS and Kerberos V5

    Proposed Standard
  • RFC 2624: NFS Version 4 Design Considerations

    Informational
  • RFC 2339: An Agreement Between the Internet Society, the IETF, and Sun Microsystems, Inc. in the matter of NFS V.4 Protocols

    Informational
  • RFC 2224: NFS URL Scheme

    Informational
  • RFC 2054: WebNFS Client Specification

    Informational
  • RFC 2055: WebNFS Server Specification

    Informational
  • RFC 1813: NFS Version 3 Protocol Specification

    Informational
  • RFC 1094: NFS: Network File System Protocol specification

    Informational
  • RFC 1037: NFILE - a file access protocol

    Historic
  • RFC 535: Comments on File Access Protocol

    Unknown
  • RFC 520: Memo to FTP group: Proposal for File Access Protocol

    Unknown

Subscribe to NFS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.