NAT

NAT (Network Address Translation): behaviour, requirements, deployment

NAT subjects:

NAT RFCs (72)

Display RFCs as
  • RFC 9146: Connection Identifier for DTLS 1.2

    Proposed Standard
  • RFC 8517: An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator Perspective

    Informational
  • RFC 8512: A YANG Module for Network Address Translation (NAT) and Network Prefix Translation (NPT)

    Proposed Standard
  • RFC 8158: IP Flow Information Export (IPFIX) Information Elements for Logging NAT Events

    Proposed Standard
  • RFC 7825: A Network Address Translator (NAT) Traversal Mechanism for Media Controlled by the Real-Time Streaming Protocol (RTSP)

    Proposed Standard
  • RFC 7974: An Experimental TCP Option for Host Identification

    Experimental
  • RFC 7934: BCP 204: Host Address Availability Recommendations

    Best Current Practice
  • RFC 7768: Port Management to Reduce Logging in Large-Scale NATs

    Informational
  • RFC 7658: Deprecation of MIB Module NAT-MIB: Managed Objects for Network Address Translators (NATs)

    Proposed Standard
  • RFC 7383: Internet Key Exchange Protocol Version 2 (IKEv2) Message Fragmentation

    Proposed Standard
  • RFC 7216: Location Information Server (LIS) Discovery Using IP Addresses and Reverse DNS

    Proposed Standard
  • RFC 7157: IPv6 Multihoming without Network Address Translation

    Informational
  • RFC 7050: Discovery of the IPv6 Prefix Used for IPv6 Address Synthesis

    Proposed Standard
  • RFC 7051: Analysis of Solution Proposals for Hosts to Learn NAT64 Prefix

    Informational
  • RFC 6967: Analysis of Potential Solutions for Revealing a Host Identifier (HOST_ID) in Shared Address Deployments

    Informational
  • RFC 6751: Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)

    Experimental
  • RFC 6619: Scalable Operation of Address Translators with Per-Interface Bindings

    Proposed Standard
  • RFC 6535: Dual-Stack Hosts Using "Bump-in-the-Host" (BIH)

    Proposed Standard
  • RFC 6384: An FTP Application Layer Gateway (ALG) for IPv6-to-IPv4 Translation

    Proposed Standard
  • RFC 6333: Dual-Stack Lite Broadband Deployments Following IPv4 Exhaustion

    Proposed Standard
  • RFC 6281: Understanding Apple's Back to My Mac (BTMM) Service

    Informational
  • RFC 6284: Port Mapping between Unicast and Multicast RTP Sessions

    Proposed Standard
  • RFC 6263: Application Mechanism for Keeping Alive the NAT Mappings Associated with RTP / RTP Control Protocol (RTCP) Flows

    Proposed Standard
  • RFC 6127: IPv4 Run-Out and IPv4-IPv6 Co-Existence Scenarios

    Informational
  • RFC 6144: Framework for IPv4/IPv6 Translation

    Informational
  • RFC 6145: IP/ICMP Translation Algorithm

    Proposed Standard

    Obsoleted by RFC 7915

  • RFC 6146: Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 Servers

    Proposed Standard
  • RFC 6147: DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 Servers

    Proposed Standard
  • RFC 6081: Teredo Extensions

    Proposed Standard
  • RFC 6052: IPv6 Addressing of IPv4/IPv6 Translators

    Proposed Standard
  • RFC 5973: NAT/Firewall NSIS Signaling Layer Protocol (NSLP)

    Experimental
  • RFC 5978: Using and Extending the NSIS Protocol Family

    Informational
  • RFC 5902: IAB Thoughts on IPv6 Network Address Translation

    Informational
  • RFC 5770: Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address Translators

    Experimental
  • RFC 5456: IAX: Inter-Asterisk eXchange Version 2

    Informational
  • RFC 5684: Unintended Consequences of NAT Deployments with Overlapping Address Space

    Informational
  • RFC 5627: Obtaining and Using Globally Routable User Agent URIs (GRUUs) in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5597: BCP 150: Network Address Translation (NAT) Behavioral Requirements for the Datagram Congestion Control Protocol

    Best Current Practice
  • RFC 5508: BCP 148: NAT Behavioral Requirements for ICMP

    Best Current Practice
  • RFC 5382: BCP 142: NAT Behavioral Requirements for TCP

    Best Current Practice
  • RFC 5128: State of Peer-to-Peer (P2P) Communication across Network Address Translators (NATs)

    Informational
  • RFC 5189: Middlebox Communication (MIDCOM) Protocol Semantics

    Proposed Standard
  • RFC 5135: BCP 135: IP Multicast Requirements for a Network Address Translator (NAT) and a Network Address Port Translator (NAPT)

    Best Current Practice
  • RFC 4966: Reasons to Move the Network Address Translator - Protocol Translator (NAT-PT) to Historic Status

    Informational
  • RFC 4864: Local Network Protection for IPv6

    Informational
  • RFC 4787: BCP 127: Network Address Translation (NAT) Behavioral Requirements for Unicast UDP

    Best Current Practice
  • RFC 4380: Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)

    Proposed Standard
  • RFC 4008: Definitions of Managed Objects for Network Address Translators (NAT)

    Proposed Standard

    Obsoleted by RFC 7658

  • RFC 3989: Middlebox Communications (MIDCOM) Protocol Semantics

    Informational

    Obsoleted by RFC 5189

  • RFC 3947: Negotiation of NAT-Traversal in the IKE

    Proposed Standard
  • RFC 3715: IPsec-Network Address Translation (NAT) Compatibility Requirements

    Informational
  • RFC 3605: Real Time Control Protocol (RTCP) attribute in Session Description Protocol (SDP)

    Proposed Standard
  • RFC 3519: Mobile IP Traversal of Network Address Translation (NAT) Devices

    Proposed Standard
  • RFC 3424: IAB Considerations for UNilateral Self-Address Fixing (UNSAF) Across Network Address Translation

    Informational
  • RFC 3304: Middlebox Communications (midcom) Protocol Requirements

    Informational
  • RFC 3257: Stream Control Transmission Protocol Applicability Statement

    Informational
  • RFC 3235: Network Address Translator (NAT)-Friendly Application Design Guidelines

    Informational
  • RFC 3102: Realm Specific IP: Framework

    Experimental
  • RFC 3103: Realm Specific IP: Protocol Specification

    Experimental
  • RFC 3104: RSIP Support for End-to-end IPsec

    Experimental
  • RFC 3105: Finding an RSIP Server with SLP

    Experimental
  • RFC 3022: Traditional IP Network Address Translator (Traditional NAT)

    Informational
  • RFC 3027: Protocol Complications with the IP Network Address Translator

    Informational
  • RFC 2993: Architectural Implications of NAT

    Informational
  • RFC 2962: An SNMP Application Level Gateway for Payload Address Translation

    Informational
  • RFC 2766: Network Address Translation - Protocol Translation (NAT-PT)

    Historic

    Obsoleted by RFC 4966

  • RFC 2709: Security Model with Tunnel-mode IPsec for NAT Domains

    Informational
  • RFC 2694: DNS extensions to Network Address Translators (DNS_ALG)

    Informational
  • RFC 2663: IP Network Address Translator (NAT) Terminology and Considerations

    Informational
  • RFC 2428: FTP Extensions for IPv6 and NATs

    Proposed Standard
  • RFC 2391: Load Sharing using IP Network Address Translation (LSNAT)

    Informational
  • RFC 1631: The IP Network Address Translator (NAT)

    Informational

    Obsoleted by RFC 3022

Subscribe to NAT

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.