media types

Media (MIME) type registrations and registry rules

media types RFCs (99)

Display RFCs as
  • RFC 9996: Media Types for Protocol Buffers

    Informational
  • RFC 9806: Updates to SIP-Based Media Recording (SIPREC) to Correct Metadata Media Type

    Proposed Standard
  • RFC 9782: Entity Attestation Token (EAT) Media Types

    Proposed Standard
  • RFC 9751: Closing the RTP Payload Format Media Types Registry

    Proposed Standard
  • RFC 9694: BCP 13: Guidelines for the Definition of New Top-Level Media Types

    Best Current Practice
  • RFC 9695: The 'haptics' Top-Level Media Type

    Proposed Standard
  • RFC 9512: YAML Media Type

    Informational
  • Proposed Standard
  • RFC 9193: Sensor Measurement Lists (SenML) Fields for Indicating Data Value Content-Format

    Proposed Standard
  • RFC 9239: Updates to ECMAScript Media Types

    Informational
  • RFC 8878: Zstandard Compression and the 'application/zstd' Media Type

    Informational
  • RFC 8478: Zstandard Compression and the application/zstd Media Type

    Informational

    Obsoleted by RFC 8878

  • RFC 8351: The PKCS #8 EncryptedPrivateKeyInfo Media Type

    Informational
  • RFC 8118: The application/pdf Media Type

    Informational
  • RFC 8081: The "font" Top-Level Media Type

    Proposed Standard
  • RFC 8098: STD 85: Message Disposition Notification

    Internet Standard
  • RFC 8072: YANG Patch Media Type

    Proposed Standard
  • RFC 8091: A Media Type Structured Syntax Suffix for JSON Text Sequences

    Informational
  • RFC 7903: Windows Image Media Types

    Informational
  • RFC 7763: The text/markdown Media Type

    Informational
  • RFC 7736: Content Delivery Network Interconnection (CDNI) Media Type Registration

    Informational
  • RFC 7578: Returning Values from Forms: multipart/form-data

    Proposed Standard
  • RFC 7351: A Media Type for XML Patch Operations

    Informational
  • RFC 7303: XML Media Types

    Proposed Standard
  • RFC 7193: The application/cms Media Type

    Informational
  • RFC 7111: URI Fragment Identifiers for the text/csv Media Type

    Informational
  • RFC 7071: A Media Type for Reputation Interchange

    Proposed Standard
  • RFC 7061: eXtensible Access Control Markup Language (XACML) XML Media Type

    Informational
  • RFC 6922: The application/sql Media Type

    Informational
  • RFC 6838: BCP 13: Media Type Specifications and Registration Procedures

    Best Current Practice
  • RFC 6839: Additional Media Type Structured Syntax Suffixes

    Informational
  • RFC 6713: The 'application/zlib' and 'application/gzip' Media Types

    Informational
  • RFC 6657: Update to MIME regarding "charset" Parameter Handling in Textual Media Types

    Proposed Standard
  • RFC 6522: STD 73: The Multipart/Report Media Type for the Reporting of Mail System Administrative Messages

    Internet Standard
  • RFC 6466: IANA Registration of the 'image' Media Type for the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 6381: The 'Codecs' and 'Profiles' Parameters for "Bucket" Media Types

    Proposed Standard
  • RFC 6207: The Media Types application/mods+xml, application/mads+xml, application/mets+xml, application/marcxml+xml, and application/sru+xml

    Informational
  • RFC 6208: Cloud Data Management Interface (CDMI) Media Types

    Informational
  • RFC 6129: The 'application/tei+xml' Media Type

    Informational
  • RFC 5967: The application/pkcs10 Media Type

    Informational
  • RFC 5955: The application/timestamped-data Media Type

    Informational
  • RFC 5877: The application/pkix-attr-cert Media Type for Attribute Certificates

    Informational
  • RFC 5791: RFC 2731 ("Encoding Dublin Core Metadata in HTML") Is Obsolete

    Informational
  • RFC 5334: Ogg Media Types

    Proposed Standard
  • RFC 5147: URI Fragment Identifiers for the text/plain Media Type

    Proposed Standard
  • RFC 5013: The Dublin Core Metadata Element Set

    Informational
  • RFC 4839: Media Type Registrations for the Open eBook Publication Structure (OEBPS) Package File (OPF)

    Informational
  • RFC 4855: Media Type Registration of RTP Payload Formats

    Proposed Standard
  • RFC 4856: Media Type Registration of Payload Formats in the RTP Profile for Audio and Video Conferences

    Proposed Standard
  • RFC 4723: Registration of Media Type audio/mobile-xmf

    Informational
  • RFC 4735: Example Media Types for Use in Documentation

    Proposed Standard
  • RFC 4708: CellML Media Type

    Informational
  • RFC 4613: Media Type Registrations for Downloadable Sounds for Musical Instrument Digital Interface (MIDI)

    Informational
  • RFC 4627: The application/json Media Type for JavaScript Object Notation (JSON)

    Informational

    Obsoleted by RFC 7159

  • RFC 4536: The application/smil and application/smil+xml Media Types

    Informational
  • RFC 4539: Media Type Registration for the Society of Motion Picture and Television Engineers (SMPTE) Material Exchange Format (MXF)

    Informational
  • RFC 4329: Scripting Media Types

    Informational

    Obsoleted by RFC 9239

  • RFC 4374: The application/xv+xml Media Type

    Informational
  • RFC 4263: Media Subtype Registration for Media Type text/troff

    Informational
  • RFC 4288: Media Type Specifications and Registration Procedures

    Best Current Practice

    Obsoleted by RFC 6838

  • RFC 4281: The Codecs Parameter for "Bucket" Media Types

    Proposed Standard

    Obsoleted by RFC 6381

  • RFC 4267: The W3C Speech Interface Framework Media Types: application/voicexml+xml, application/ssml+xml, application/srgs, application/srgs+xml, application/ccxml+xml, and application/pls+xml

    Informational
  • RFC 4155: The application/mbox Media Type

    Informational
  • RFC 4027: Domain Name System Media Types

    Informational
  • RFC 3902: The "application/soap+xml" media type

    Informational
  • RFC 3870: application/rdf+xml Media Type Registration

    Informational
  • RFC 3823: MIME Media Type for the Systems Biology Markup Language (SBML)

    Informational
  • RFC 3778: The application/pdf Media Type

    Informational

    Obsoleted by RFC 8118

  • RFC 3676: The Text/Plain Format and DelSp Parameters

    Proposed Standard
  • RFC 3625: The QCP File Format and Media Types for Speech Data

    Informational
  • RFC 3534: The application/ogg Media Type

    Proposed Standard

    Obsoleted by RFC 5334

  • RFC 3510: Internet Printing Protocol/1.1: IPP URL Scheme

    Proposed Standard
  • RFC 3391: The MIME Application/Vnd.pwg-multiplexed Content-Type

    Informational
  • RFC 3420: Internet Media Type message/sipfrag

    Proposed Standard
  • RFC 3381: Internet Printing Protocol (IPP): Job Progress Attributes

    Proposed Standard

    Obsoleted by RFC 8011

  • RFC 3382: Internet Printing Protocol (IPP): The 'collection' attribute syntax

    Proposed Standard

    Obsoleted by RFC 8010, RFC 8011

  • RFC 3380: Internet Printing Protocol (IPP): Job and Printer Set Operations

    Proposed Standard
  • RFC 3236: The 'application/xhtml+xml' Media Type

    Informational
  • RFC 3204: MIME media types for ISUP and QSIG Objects

    Proposed Standard
  • RFC 3023: XML Media Types

    Proposed Standard

    Obsoleted by RFC 7303

  • RFC 3003: The audio/mpeg Media Type

    Proposed Standard
  • RFC 3009: Registration of parityfec MIME types

    Proposed Standard

    Obsoleted by RFC 5109

  • RFC 3016: RTP Payload Format for MPEG-4 Audio/Visual Streams

    Proposed Standard

    Obsoleted by RFC 6416

  • RFC 2910: Internet Printing Protocol/1.1: Encoding and Transport

    Proposed Standard

    Obsoleted by RFC 8010

  • RFC 2911: Internet Printing Protocol/1.1: Model and Semantics

    Proposed Standard

    Obsoleted by RFC 8011

  • RFC 2854: The 'text/html' Media Type

    Informational
  • RFC 2731: Encoding Dublin Core Metadata in HTML

    Informational

    Obsoleted by RFC 5791

  • RFC 2646: The Text/Plain Format Parameter

    Proposed Standard

    Obsoleted by RFC 3676

  • RFC 2567: Design Goals for an Internet Printing Protocol

    Experimental
  • RFC 2568: Rationale for the Structure of the Model and Protocol for the Internet Printing Protocol

    Experimental
  • RFC 2569: Mapping between LPD and IPP Protocols

    Experimental
  • RFC 2442: The Batch SMTP Media Type

    Informational
  • RFC 2413: Dublin Core Metadata for Resource Discovery

    Informational

    Obsoleted by RFC 5013

  • RFC 2397: The "data" URL scheme

    Proposed Standard
  • RFC 2376: XML Media Types

    Informational

    Obsoleted by RFC 3023

  • RFC 2318: The text/css Media Type

    Informational
  • RFC 2046: Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types

    Draft Standard
  • RFC 1874: SGML Media Types

    Experimental
  • RFC 1590: Media Type Registration Procedure

    Informational

    Obsoleted by RFC 2045, RFC 2046, RFC 2047, RFC 2048, RFC 2049

Subscribe to media types

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.