LDAP

LDAP (Lightweight Directory Access Protocol)

LDAP RFCs (119)

Display RFCs as
  • RFC 8284: Lightweight Directory Access Protocol (LDAP) Schema for Supporting the Extensible Messaging and Presence Protocol (XMPP) in White Pages

    Informational
  • RFC 7612: Lightweight Directory Access Protocol (LDAP): Schema for Printer Services

    Informational
  • RFC 6880: An Information Model for Kerberos Version 5

    Proposed Standard
  • RFC 6171: The Lightweight Directory Access Protocol (LDAP) Don't Use Copy Control

    Proposed Standard
  • RFC 5803: Lightweight Directory Access Protocol (LDAP) Schema for Storing Salted Challenge Response Authentication Mechanism (SCRAM) Secrets

    Informational
  • RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions

    Experimental
  • RFC 5020: The Lightweight Directory Access Protocol (LDAP) entryDN Operational Attribute

    Proposed Standard
  • RFC 4876: A Configuration Profile Schema for Lightweight Directory Access Protocol (LDAP)-Based Agents

    Informational
  • RFC 4510: Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map

    Proposed Standard
  • RFC 4511: Lightweight Directory Access Protocol (LDAP): The Protocol

    Proposed Standard
  • RFC 4512: Lightweight Directory Access Protocol (LDAP): Directory Information Models

    Proposed Standard
  • RFC 4513: Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security Mechanisms

    Proposed Standard
  • RFC 4514: Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished Names

    Proposed Standard
  • RFC 4515: Lightweight Directory Access Protocol (LDAP): String Representation of Search Filters

    Proposed Standard
  • RFC 4516: Lightweight Directory Access Protocol (LDAP): Uniform Resource Locator

    Proposed Standard
  • RFC 4517: Lightweight Directory Access Protocol (LDAP): Syntaxes and Matching Rules

    Proposed Standard
  • RFC 4518: Lightweight Directory Access Protocol (LDAP): Internationalized String Preparation

    Proposed Standard
  • RFC 4519: Lightweight Directory Access Protocol (LDAP): Schema for User Applications

    Proposed Standard
  • RFC 4520: BCP 64: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

    Best Current Practice
  • RFC 4521: BCP 118: Considerations for Lightweight Directory Access Protocol (LDAP) Extensions

    Best Current Practice
  • RFC 4522: Lightweight Directory Access Protocol (LDAP): The Binary Encoding Option

    Proposed Standard
  • RFC 4523: Lightweight Directory Access Protocol (LDAP) Schema Definitions for X.509 Certificates

    Proposed Standard
  • RFC 4524: COSINE LDAP/X.500 Schema

    Proposed Standard
  • RFC 4525: Lightweight Directory Access Protocol (LDAP) Modify-Increment Extension

    Informational
  • RFC 4526: Lightweight Directory Access Protocol (LDAP) Absolute True and False Filters

    Proposed Standard
  • RFC 4527: Lightweight Directory Access Protocol (LDAP) Read Entry Controls

    Proposed Standard
  • RFC 4528: Lightweight Directory Access Protocol (LDAP) Assertion Control

    Proposed Standard
  • RFC 4529: Requesting Attributes by Object Class in the Lightweight Directory Access Protocol

    Informational
  • RFC 4530: Lightweight Directory Access Protocol (LDAP) entryUUID Operational Attribute

    Proposed Standard
  • RFC 4531: Lightweight Directory Access Protocol (LDAP) Turn Operation

    Experimental
  • RFC 4532: Lightweight Directory Access Protocol (LDAP) "Who am I?" Operation

    Proposed Standard
  • RFC 4533: The Lightweight Directory Access Protocol (LDAP) Content Synchronization Operation

    Experimental
  • RFC 4403: Lightweight Directory Access Protocol (LDAP) Schema for Universal Description, Discovery, and Integration version 3 (UDDIv3)

    Informational
  • RFC 4370: Lightweight Directory Access Protocol (LDAP) Proxied Authorization Control

    Proposed Standard
  • RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)

    Informational
  • RFC 4104: Policy Core Extension Lightweight Directory Access Protocol Schema (PCELS)

    Proposed Standard
  • RFC 3944: H.350 Directory Services

    Informational
  • RFC 3928: Lightweight Directory Access Protocol (LDAP) Client Update Protocol (LCUP)

    Proposed Standard
  • RFC 3909: Lightweight Directory Access Protocol (LDAP) Cancel Operation

    Proposed Standard
  • RFC 3876: Returning Matched Values with the Lightweight Directory Access Protocol version 3 (LDAPv3)

    Proposed Standard
  • RFC 3866: Language Tags and Ranges in the Lightweight Directory Access Protocol (LDAP)

    Proposed Standard
  • RFC 3829: Lightweight Directory Access Protocol (LDAP) Authorization Identity Request and Response Controls

    Informational
  • RFC 3771: The Lightweight Directory Access Protocol (LDAP) Intermediate Response Message

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4511

  • RFC 3698: Lightweight Directory Access Protocol (LDAP): Additional Matching Rules

    Proposed Standard
  • RFC 3703: Policy Core Lightweight Directory Access Protocol (LDAP) Schema

    Proposed Standard
  • RFC 3712: Lightweight Directory Access Protocol (LDAP): Schema for Printer Services

    Informational

    Obsoleted by RFC 7612

  • RFC 3727: ASN.1 Module Definition for the LDAP and X.500 Component Matching Rules

    Proposed Standard
  • RFC 3687: Lightweight Directory Access Protocol (LDAP) and X.500 Component Matching Rules

    Proposed Standard
  • RFC 3671: Collective Attributes in the Lightweight Directory Access Protocol (LDAP)

    Proposed Standard
  • RFC 3672: Subentries in the Lightweight Directory Access Protocol (LDAP)

    Proposed Standard
  • RFC 3663: Domain Administrative Data in Lightweight Directory Access Protocol (LDAP)

    Experimental
  • RFC 3673: Lightweight Directory Access Protocol version 3 (LDAPv3): All Operational Attributes

    Proposed Standard
  • RFC 3674: Feature Discovery in Lightweight Directory Access Protocol (LDAP)

    Proposed Standard

    Obsoleted by RFC 4512

  • RFC 3352: Connection-less Lightweight Directory Access Protocol (CLDAP) to Historic Status

    Informational
  • RFC 3494: Lightweight Directory Access Protocol version 2 (LDAPv2) to Historic Status

    Informational
  • RFC 3384: Lightweight Directory Access Protocol (version 3) Replication Requirements

    Informational
  • RFC 3383: Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP)

    Best Current Practice

    Obsoleted by RFC 4520

  • RFC 3377: Lightweight Directory Access Protocol (v3): Technical Specification

    Proposed Standard

    Obsoleted by RFC 4510

  • RFC 3296: Named Subordinate References in Lightweight Directory Access Protocol (LDAP) Directories

    Proposed Standard
  • RFC 3254: Definitions for talking about directories

    Informational
  • RFC 3112: LDAP Authentication Password Schema

    Informational
  • RFC 3088: OpenLDAP Root Service An experimental LDAP referral service

    Experimental
  • RFC 3062: LDAP Password Modify Extended Operation

    Proposed Standard
  • RFC 3045: Storing Vendor Information in the LDAP root DSE

    Informational
  • RFC 2985: PKCS #9: Selected Object Classes and Attribute Types Version 2.0

    Informational
  • RFC 2926: Conversion of LDAP Schemas to and from SLP Templates

    Informational
  • RFC 2927: MIME Directory Profile for LDAP Schema

    Informational
  • RFC 2891: LDAP Control Extension for Server Side Sorting of Search Results

    Proposed Standard
  • RFC 2849: The LDAP Data Interchange Format (LDIF) - Technical Specification

    Proposed Standard
  • RFC 2820: Access Control Requirements for LDAP

    Informational
  • RFC 2829: Authentication Methods for LDAP

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4513

  • RFC 2830: Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4511, RFC 4513

  • RFC 2798: Definition of the inetOrgPerson LDAP Object Class

    Informational
  • RFC 2739: Calendar Attributes for vCard and LDAP

    Proposed Standard
  • RFC 2713: Schema for Representing Java(tm) Objects in an LDAP Directory

    Informational
  • RFC 2714: Schema for Representing CORBA Object References in an LDAP Directory

    Informational
  • RFC 2696: LDAP Control Extension for Simple Paged Results Manipulation

    Informational
  • RFC 2649: An LDAP Control and Schema for Holding Operation Signatures

    Experimental
  • RFC 2657: LDAPv2 Client vs. the Index Mesh

    Experimental
  • RFC 2587: Internet X.509 Public Key Infrastructure LDAPv2 Schema

    Proposed Standard

    Obsoleted by RFC 4523

  • RFC 2589: Lightweight Directory Access Protocol (v3): Extensions for Dynamic Directory Services

    Proposed Standard
  • RFC 2596: Use of Language Codes in LDAP

    Proposed Standard

    Obsoleted by RFC 3866

  • RFC 2559: Internet X.509 Public Key Infrastructure Operational Protocols - LDAPv2

    Historic

    Obsoleted by RFC 3494

  • RFC 2377: Naming Plan for Internet Directory-Enabled Applications

    Informational
  • RFC 2378: The CCSO Nameserver (Ph) Architecture

    Informational
  • RFC 2425: A MIME Content-Type for Directory Information

    Proposed Standard

    Obsoleted by RFC 6350

  • RFC 2426: vCard MIME Directory Profile

    Proposed Standard

    Obsoleted by RFC 6350

  • RFC 2307: An Approach for Using LDAP as a Network Information Service

    Experimental
  • RFC 2164: Use of an X.500/LDAP directory to support MIXER address mapping

    Proposed Standard
  • RFC 2247: Using Domains in LDAP/X.500 Distinguished Names

    Proposed Standard
  • RFC 2258: Internet Nomenclator Project

    Informational
  • RFC 2259: Simple Nomenclator Query Protocol (SNQP)

    Informational
  • RFC 2251: Lightweight Directory Access Protocol (v3)

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4511, RFC 4512, RFC 4513

  • RFC 2252: Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4523

  • RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4514

  • RFC 2254: The String Representation of LDAP Search Filters

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4515

  • RFC 2255: The LDAP URL Format

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4516

  • RFC 2256: A Summary of the X.500(96) User Schema for use with LDAPv3

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4519, RFC 4523

  • RFC 2218: A Common Schema for the Internet White Pages Service

    Proposed Standard
  • RFC 2219: BCP 17: Use of DNS Aliases for Network Services

    Best Current Practice
  • RFC 2148: BCP 15: Deployment of the Internet White Pages Service

    Best Current Practice
  • RFC 2116: FYI 11: X.500 Implementations Catalog-96

    Informational
  • RFC 2120: Managing the X.500 Root Naming Context

    Experimental
  • RFC 2079: Definition of an X.500 Attribute Type and an Object Class to Hold Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 1959: An LDAP URL Format

    Proposed Standard

    Obsoleted by RFC 2255

  • RFC 1960: A String Representation of LDAP Search Filters

    Proposed Standard

    Obsoleted by RFC 2254

  • RFC 1943: Building an X.500 Directory Service in the US

    Informational
  • RFC 1823: The LDAP Application Program Interface

    Informational
  • RFC 1803: Recommendations for an X.500 Production Directory Service

    Informational
  • RFC 1804: Schema Publishing in X.500 Directory

    Experimental
  • RFC 1777: Lightweight Directory Access Protocol

    Historic

    Obsoleted by RFC 3494

  • RFC 1778: The String Representation of Standard Attribute Syntaxes

    Historic

    Obsoleted by RFC 3494

  • RFC 1779: A String Representation of Distinguished Names

    Historic

    Obsoleted by RFC 2253, RFC 3494

  • RFC 1781: Using the OSI Directory to Achieve User Friendly Naming

    Historic

    Obsoleted by RFC 3494

  • RFC 1632: A Revised Catalog of Available X.500 Implementations

    Informational

    Obsoleted by RFC 2116

  • RFC 1558: A String Representation of LDAP Search Filters

    Informational

    Obsoleted by RFC 1960

  • RFC 1487: X.500 Lightweight Directory Access Protocol

    Historic

    Obsoleted by RFC 1777, RFC 3494

  • RFC 1488: The X.500 String Representation of Standard Attribute Syntaxes

    Proposed Standard

    Obsoleted by RFC 1778

  • RFC 1491: FYI 21: A Survey of Advanced Usages of X.500

    Informational

Subscribe to LDAP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.