IPv6 transition

IPv6/IPv4 coexistence and transition mechanisms

IPv6 transition subjects:

IPv6 transition RFCs (34)

Display RFCs as
  • RFC 9229: IPv4 Routes with an IPv6 Next Hop in the Babel Routing Protocol

    Experimental
  • RFC 8983: Internet Key Exchange Protocol Version 2 (IKEv2) Notification Status Types for IPv4/IPv6 Coexistence

    Proposed Standard
  • RFC 8585: Requirements for IPv6 Customer Edge Routers to Support IPv4-as-a-Service

    Informational
  • RFC 8468: IPv4, IPv6, and IPv4-IPv6 Coexistence: Updates for the IP Performance Metrics (IPPM) Framework

    Informational
  • RFC 7949: OSPFv3 over IPv4 for IPv6 Transition

    Proposed Standard
  • RFC 7849: An IPv6 Profile for 3GPP Mobile Devices

    Informational
  • RFC 7381: Enterprise IPv6 Deployment Guidelines

    Informational
  • RFC 6782: Wireline Incremental IPv6

    Informational
  • RFC 6264: An Incremental Carrier-Grade NAT (CGN) for IPv6 Transition

    Informational
  • RFC 6180: Guidelines for Using IPv6 Transition Mechanisms during IPv6 Deployment

    Informational
  • RFC 6144: Framework for IPv4/IPv6 Translation

    Informational
  • RFC 6157: IPv6 Transition in the Session Initiation Protocol (SIP)

    Proposed Standard
  • RFC 5572: IPv6 Tunnel Broker with the Tunnel Setup Protocol (TSP)

    Experimental
  • RFC 4942: IPv6 Transition/Co-existence Security Considerations

    Informational
  • RFC 4554: Use of VLANs for IPv4-IPv6 Coexistence in Enterprise Networks

    Informational
  • RFC 4215: Analysis on IPv6 Transition in Third Generation Partnership Project (3GPP) Networks

    Informational
  • RFC 4213: Basic Transition Mechanisms for IPv6 Hosts and Routers

    Proposed Standard
  • RFC 4038: Application Aspects of IPv6 Transition

    Informational
  • RFC 3904: Evaluation of IPv6 Transition Mechanisms for Unmanaged Networks

    Informational
  • RFC 3750: Unmanaged Networks IPv6 Transition Scenarios

    Informational
  • RFC 3338: Dual Stack Hosts Using "Bump-in-the-API" (BIA)

    Experimental

    Obsoleted by RFC 6535

  • RFC 3142: An IPv6-to-IPv4 Transport Relay Translator

    Informational
  • RFC 3089: A SOCKS-based IPv6/IPv4 Gateway Mechanism

    Informational
  • RFC 3056: Connection of IPv6 Domains via IPv4 Clouds

    Proposed Standard
  • RFC 3053: IPv6 Tunnel Broker

    Informational
  • RFC 2921: 6BONE pTLA and pNLA Formats (pTLA)

    Informational
  • RFC 2893: Transition Mechanisms for IPv6 Hosts and Routers

    Proposed Standard

    Obsoleted by RFC 4213

  • RFC 2766: Network Address Translation - Protocol Translation (NAT-PT)

    Historic

    Obsoleted by RFC 4966

  • RFC 2767: Dual Stack Hosts using the "Bump-In-the-Stack" Technique (BIS)

    Informational

    Obsoleted by RFC 6535

  • RFC 2772: 6Bone Backbone Routing Guidelines

    Informational
  • RFC 2546: 6Bone Routing Practice

    Informational

    Obsoleted by RFC 2772

  • RFC 2185: Routing Aspects of IPv6 Transition

    Informational
  • RFC 1933: Transition Mechanisms for IPv6 Hosts and Routers

    Proposed Standard

    Obsoleted by RFC 2893

  • RFC 1671: IPng White Paper on Transition and Other Considerations

    Informational

Subscribe to IPv6 transition

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.