internet architecture

Internet Architecture: architectural principles of the Internet

internet architecture RFCs (122)

Display RFCs as
  • RFC 9962: A Decentralized Locator/ID Separation Protocol Mapping System (LISP-Decent)

    Informational
  • RFC 9817: Use Cases for In-Network Computing

    Informational
  • RFC 9730: Interworking of GMPLS Control and Centralized Controller Systems

    Informational
  • RFC 9556: Internet of Things (IoT) Edge Challenges and Functions

    Informational
  • Proposed Standard
  • Proposed Standard
  • RFC 9518: Centralization, Decentralization, and Internet Standards

    Informational
  • RFC 9473: A Vocabulary of Path Properties

    Informational
  • RFC 9340: Architectural Principles for a Quantum Internet

    Informational
  • RFC 9305: Locator/ID Separation Protocol (LISP) Generic Protocol Extension

    Proposed Standard
  • RFC 9236: Architectural Considerations of Information-Centric Networking (ICN) Using a Name Resolution Service

    Informational
  • RFC 9217: Current Open Questions in Path-Aware Networking

    Informational
  • RFC 9170: Long-Term Viability of Protocol Extension Mechanisms

    Informational
  • RFC 9138: Design Considerations for Name Resolution Service in Information-Centric Networking (ICN)

    Informational
  • RFC 9087: Segment Routing Centralized BGP Egress Peer Engineering

    Informational
  • RFC 9049: Path Aware Networking: Obstacles to Deployment (A Bestiary of Roads Not Taken)

    Informational
  • RFC 8821: PCE-Based Traffic Engineering (TE) in Native IP Networks

    Informational
  • RFC 8890: The Internet is for End Users

    Informational
  • RFC 8799: Limited Domains and Internet Protocols

    Informational
  • RFC 8623: Stateful Path Computation Element (PCE) Protocol Extensions for Usage with Point-to-Multipoint TE Label Switched Paths (LSPs)

    Proposed Standard
  • RFC 8517: An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator Perspective

    Informational
  • RFC 8467: Padding Policies for Extension Mechanisms for DNS (EDNS(0))

    Experimental
  • Proposed Standard
  • RFC 8165: Design Considerations for Metadata Insertion

    Informational
  • RFC 8117: Current Hostname Practice Considered Harmful

    Informational
  • RFC 8021: Generation of IPv6 Atomic Fragments Considered Harmful

    Informational
  • RFC 7980: A Framework for Defining Network Complexity

    Informational
  • RFC 7962: Alternative Network Deployments: Taxonomy, Characterization, Technologies, and Architectures

    Informational
  • RFC 7720: BCP 40: DNS Root Name Service Protocol and Deployment Requirements

    Best Current Practice
  • RFC 7557: Extension Mechanism for the Babel Routing Protocol

    Experimental

    Obsoleted by RFC 8966

  • RFC 7496: Additional Policies for the Partially Reliable Stream Control Transmission Protocol Extension

    Proposed Standard
  • RFC 7452: Architectural Considerations in Smart Object Networking

    Informational
  • RFC 7437: IAB, IESG, and IAOC Selection, Confirmation, and Recall Process: Operation of the Nominating and Recall Committees

    Best Current Practice

    Obsoleted by RFC 8713

  • RFC 7391: Forwarding and Control Element Separation (ForCES) Protocol Extensions

    Proposed Standard
  • RFC 7314: Extension Mechanisms for DNS (EDNS) EXPIRE Option

    Experimental
  • RFC 7304: A Method for Mitigating Namespace Collisions

    Informational
  • RFC 7306: Remote Direct Memory Access (RDMA) Protocol Extensions

    Proposed Standard
  • RFC 7094: Architectural Considerations of IP Anycast

    Informational
  • RFC 7054: Addressing Requirements and Design Considerations for Per-Interface Maintenance Entity Group Intermediate Points (MIPs)

    Informational
  • RFC 6950: Architectural Considerations on Application Features in the DNS

    Informational
  • RFC 6929: Remote Authentication Dial In User Service (RADIUS) Protocol Extensions

    Proposed Standard
  • RFC 6891: STD 75: Extension Mechanisms for DNS (EDNS(0))

    Internet Standard
  • RFC 6815: Applicability Statement for RFC 2544: Use on Production Networks Considered Harmful

    Informational
  • RFC 6709: Design Considerations for Protocol Extensions

    Informational
  • RFC 6710: Simple Mail Transfer Protocol Extension for Message Transfer Priorities

    Proposed Standard
  • RFC 6648: BCP 178: Deprecating the "X-" Prefix and Similar Constructs in Application Protocols

    Best Current Practice
  • RFC 6630: EAP Re-authentication Protocol Extensions for Authenticated Anticipatory Keying (ERP/AAK)

    Proposed Standard
  • RFC 6451: Location-to-Service Translation (LoST) Protocol Extensions

    Experimental
  • RFC 6388: Label Distribution Protocol Extensions for Point-to-Multipoint and Multipoint-to-Multipoint Label Switched Paths

    Proposed Standard
  • RFC 6357: Design Considerations for Session Initiation Protocol (SIP) Overload Control

    Informational
  • RFC 6177: BCP 157: IPv6 Address Assignment to End Sites

    Best Current Practice
  • RFC 6182: Architectural Guidelines for Multipath TCP Development

    Informational
  • RFC 6001: Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)

    Proposed Standard
  • RFC 5694: Peer-to-Peer (P2P) Architecture: Definition, Taxonomies, Examples, and Applicability

    Informational
  • RFC 5704: Uncoordinated Protocol Development Considered Harmful

    Informational
  • RFC 5706: Guidelines for Considering Operations and Management of New Protocols and Protocol Extensions

    Informational
  • RFC 5633: Nominating Committee Process: Earlier Announcement of Open Positions and Solicitation of Volunteers

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 5557: Path Computation Element Communication Protocol (PCEP) Requirements and Protocol Extensions in Support of Global Concurrent Optimization

    Proposed Standard
  • RFC 5317: Joint Working Team (JWT) Report on MPLS Architectural Considerations for a Transport Profile

    Informational
  • RFC 5287: Control Protocol Extensions for the Setup of Time-Division Multiplexing (TDM) Pseudowires in MPLS Networks

    Proposed Standard
  • RFC 5088: OSPF Protocol Extensions for Path Computation Element (PCE) Discovery

    Proposed Standard
  • RFC 5089: IS-IS Protocol Extensions for Path Computation Element (PCE) Discovery

    Proposed Standard
  • RFC 5073: IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node Capabilities

    Proposed Standard
  • RFC 5078: IAB and IESG Selection, Confirmation, and Recall Process: Revision of the Nominating and Recall Committees Timeline

    Informational

    Obsoleted by RFC 7437

  • Informational
  • RFC 4924: Reflections on Internet Transparency

    Informational
  • RFC 4845: Process for Publication of IAB RFCs

    Informational
  • RFC 4901: Protocol Extensions for Header Compression over MPLS

    Proposed Standard
  • Informational
  • RFC 4840: Multiple Encapsulation Methods Considered Harmful

    Informational
  • RFC 4760: Multiprotocol Extensions for BGP-4

    Draft Standard
  • RFC 4775: BCP 125: Procedures for Protocol Extensions and Variations

    Best Current Practice
  • RFC 4440: IAB Thoughts on the Role of the Internet Research Task Force (IRTF)

    Informational
  • RFC 4416: Goals for Internet Messaging to Support Diverse Service Environments

    Informational
  • RFC 4417: Report of the 2004 IAB Messaging Workshop

    Informational
  • RFC 4124: Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering

    Proposed Standard
  • RFC 4085: BCP 105: Embedding Globally-Routable Internet Addresses Considered Harmful

    Best Current Practice
  • RFC 4091: The Alternative Network Address Types (ANAT) Semantics for the Session Description Protocol (SDP) Grouping Framework

    Proposed Standard

    Obsoleted by RFC 5245

  • RFC 4092: Usage of the Session Description Protocol (SDP) Alternative Network Address Types (ANAT) Semantics in the Session Initiation Protocol (SIP)

    Proposed Standard

    Obsoleted by RFC 5245

  • RFC 4089: IAB and IESG Recommendation for IETF Administrative Restructuring

    Informational
  • RFC 4052: BCP 102: IAB Processes for Management of IETF Liaison Relationships

    Best Current Practice
  • RFC 3869: IAB Concerns and Recommendations Regarding Internet Research and Evolution

    Informational
  • RFC 3819: BCP 89: Advice for Internet Subnetwork Designers

    Best Current Practice
  • RFC 3777: IAB and IESG Selection, Confirmation, and Recall Process: Operation of the Nominating and Recall Committees

    Best Current Practice

    Obsoleted by RFC 7437

  • RFC 3724: The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet Architecture

    Informational
  • RFC 3675: .sex Considered Dangerous

    Informational
  • RFC 3627: Use of /127 Prefix Length Between Routers Considered Harmful

    Historic

    Obsoleted by RFC 6547

  • RFC 3535: Overview of the 2002 IAB Network Management Workshop

    Informational
  • RFC 3496: Protocol Extension for Support of Asynchronous Transfer Mode (ATM) Service Class-aware Multiprotocol Label Switching (MPLS) Traffic Engineering

    Informational
  • Proposed Standard
  • RFC 3439: Some Internet Architectural Guidelines and Philosophy

    Informational
  • RFC 3426: General Architectural and Policy Considerations

    Informational
  • RFC 3360: BCP 60: Inappropriate TCP Resets Considered Harmful

    Best Current Practice
  • RFC 3347: Small Computer Systems Interface protocol over the Internet (iSCSI) Requirements and Design Considerations

    Proposed Standard
  • RFC 3226: DNSSEC and IPv6 A6 aware server/resolver message size requirements

    Proposed Standard
  • RFC 2858: Multiprotocol Extensions for BGP-4

    Proposed Standard

    Obsoleted by RFC 4760

  • RFC 2826: IAB Technical Comment on the Unique DNS Root

    Informational
  • RFC 2850: BCP 39: Charter of the Internet Architecture Board (IAB)

    Best Current Practice
  • RFC 2775: Internet Transparency

    Informational
  • RFC 2671: Extension Mechanisms for DNS (EDNS0)

    Proposed Standard

    Obsoleted by RFC 6891

  • RFC 2624: NFS Version 4 Design Considerations

    Informational
  • RFC 2545: Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing

    Proposed Standard
  • RFC 2449: POP3 Extension Mechanism

    Proposed Standard
  • RFC 2283: Multiprotocol Extensions for BGP-4

    Proposed Standard

    Obsoleted by RFC 2858

  • RFC 2276: Architectural Principles of Uniform Resource Name Resolution

    Informational
  • RFC 1958: Architectural Principles of the Internet

    Informational
  • RFC 1877: PPP Internet Protocol Control Protocol Extensions for Name Server Addresses

    Informational
  • RFC 1627: Network 10 Considered Harmful (Some Practices Shouldn't be Codified)

    Informational

    Obsoleted by RFC 1918

  • RFC 1633: Integrated Services in the Internet Architecture: an Overview

    Informational
  • RFC 1636: Report of IAB Workshop on Security in the Internet Architecture - February 8-10, 1994

    Informational
  • RFC 1620: Internet Architecture Extensions for Shared Media

    Informational
  • RFC 1601: Charter of the Internet Architecture Board (IAB)

    Informational

    Obsoleted by RFC 2850

  • RFC 1498: On the Naming and Binding of Network Destinations

    Informational
  • RFC 1358: Charter of the Internet Architecture Board (IAB)

    Informational

    Obsoleted by RFC 1601

  • RFC 1326: Mutual Encapsulation Considered Dangerous

    Informational
  • RFC 1287: Towards the Future Internet Architecture

    Informational
  • RFC 1263: TCP Extensions Considered Harmful

    Informational
  • RFC 1220: Point-to-Point Protocol extensions for bridging

    Proposed Standard

    Obsoleted by RFC 1638

  • RFC 1122: STD 3: Requirements for Internet Hosts - Communication Layers

    Internet Standard
  • RFC 1123: STD 3: Requirements for Internet Hosts - Application and Support

    Internet Standard
  • RFC 1127: Perspective on the Host Requirements RFCs

    Informational
  • RFC 642: Ready line philosophy and implementation

    Unknown

Subscribe to internet architecture

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.