iCalendar

iCalendar calendar data format

iCalendar RFCs (24)

Display RFCs as
  • RFC 9253: Support for iCalendar Relationships

    Proposed Standard
  • RFC 9073: Event Publishing Extensions to iCalendar

    Proposed Standard
  • RFC 9074: "VALARM" Extensions for iCalendar

    Proposed Standard
  • RFC 8984: JSCalendar: A JSON Representation of Calendar Data

    Proposed Standard
  • RFC 7986: New Properties for iCalendar

    Proposed Standard
  • RFC 7953: Calendar Availability

    Proposed Standard
  • RFC 7809: Calendaring Extensions to WebDAV (CalDAV): Time Zones by Reference

    Proposed Standard
  • RFC 7529: Non-Gregorian Recurrence Rules in the Internet Calendaring and Scheduling Core Object Specification (iCalendar)

    Proposed Standard
  • RFC 7265: jCal: The JSON Format for iCalendar

    Proposed Standard
  • RFC 7095: jCard: The JSON Format for vCard

    Proposed Standard
  • RFC 6764: Locating Services for Calendaring Extensions to WebDAV (CalDAV) and vCard Extensions to WebDAV (CardDAV)

    Proposed Standard
  • RFC 6868: Parameter Value Encoding in iCalendar and vCard

    Proposed Standard
  • RFC 6638: Scheduling Extensions to CalDAV

    Proposed Standard
  • RFC 6321: xCal: The XML Format for iCalendar

    Proposed Standard
  • RFC 6047: iCalendar Message-Based Interoperability Protocol (iMIP)

    Proposed Standard
  • RFC 5546: iCalendar Transport-Independent Interoperability Protocol (iTIP)

    Proposed Standard
  • RFC 5545: Internet Calendaring and Scheduling Core Object Specification (iCalendar)

    Proposed Standard
  • RFC 4791: Calendaring Extensions to WebDAV (CalDAV)

    Proposed Standard
  • RFC 4324: Calendar Access Protocol (CAP)

    Experimental
  • RFC 3283: Guide to Internet Calendaring

    Informational
  • RFC 2739: Calendar Attributes for vCard and LDAP

    Proposed Standard
  • RFC 2445: Internet Calendaring and Scheduling Core Object Specification (iCalendar)

    Proposed Standard

    Obsoleted by RFC 5545

  • RFC 2446: iCalendar Transport-Independent Interoperability Protocol (iTIP) Scheduling Events, BusyTime, To-dos and Journal Entries

    Proposed Standard

    Obsoleted by RFC 5546

  • RFC 2447: iCalendar Message-Based Interoperability Protocol (iMIP)

    Proposed Standard

    Obsoleted by RFC 6047

Subscribe to iCalendar

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.