HIP

HIP (Host Identity Protocol)

HIP RFCs (31)

Display RFCs as
  • RFC 9028: Native NAT Traversal Mode for the Host Identity Protocol

    Experimental
  • RFC 9063: Host Identity Protocol Architecture

    Informational
  • RFC 8046: Host Mobility with the Host Identity Protocol

    Proposed Standard
  • RFC 8047: Host Multihoming with the Host Identity Protocol

    Proposed Standard
  • RFC 8002: Host Identity Protocol Certificates

    Proposed Standard
  • RFC 8003: Host Identity Protocol (HIP) Registration Extension

    Proposed Standard
  • RFC 8004: Host Identity Protocol (HIP) Rendezvous Extension

    Proposed Standard
  • RFC 8005: Host Identity Protocol (HIP) Domain Name System (DNS) Extension

    Proposed Standard
  • RFC 7401: Host Identity Protocol Version 2 (HIPv2)

    Proposed Standard
  • RFC 7402: Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)

    Proposed Standard
  • RFC 7343: An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers Version 2 (ORCHIDv2)

    Proposed Standard
  • RFC 7086: Host Identity Protocol-Based Overlay Networking Environment (HIP BONE) Instance Specification for REsource LOcation And Discovery (RELOAD)

    Experimental
  • RFC 6538: The Host Identity Protocol (HIP) Experiment Report

    Informational
  • RFC 6537: Host Identity Protocol Distributed Hash Table Interface

    Experimental
  • RFC 6316: Sockets Application Program Interface (API) for Multihoming Shim

    Informational
  • RFC 6317: Basic Socket Interface Extensions for the Host Identity Protocol (HIP)

    Experimental
  • RFC 6253: Host Identity Protocol Certificates

    Experimental

    Obsoleted by RFC 8002

  • RFC 6261: Encrypted Signaling Transport Modes for the Host Identity Protocol

    Experimental
  • RFC 6078: Host Identity Protocol (HIP) Immediate Carriage and Conveyance of Upper-Layer Protocol Signaling (HICCUPS)

    Experimental
  • RFC 6079: HIP BONE: Host Identity Protocol (HIP) Based Overlay Networking Environment (BONE)

    Experimental
  • RFC 6028: Host Identity Protocol (HIP) Multi-Hop Routing Extension

    Experimental
  • RFC 5770: Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address Translators

    Experimental
  • RFC 5338: Using the Host Identity Protocol with Legacy Applications

    Experimental
  • RFC 5201: Host Identity Protocol

    Experimental

    Obsoleted by RFC 7401

  • RFC 5202: Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)

    Experimental

    Obsoleted by RFC 7402

  • RFC 5203: Host Identity Protocol (HIP) Registration Extension

    Experimental

    Obsoleted by RFC 8003

  • RFC 5204: Host Identity Protocol (HIP) Rendezvous Extension

    Experimental

    Obsoleted by RFC 8004

  • RFC 5205: Host Identity Protocol (HIP) Domain Name System (DNS) Extensions

    Experimental

    Obsoleted by RFC 8005

  • RFC 5206: End-Host Mobility and Multihoming with the Host Identity Protocol

    Experimental

    Obsoleted by RFC 8046

  • RFC 5207: NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) Communication

    Informational
  • RFC 4423: Host Identity Protocol (HIP) Architecture

    Informational

    Obsoleted by RFC 9063

Subscribe to HIP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.